Автоматизация процесса обработки информации для сотрудников приёмной комиссии техникума

Разработка сайта для хранения и обработки информации об абитуриентах в среде программирования Delphi 7. Архитектура базы данных. Функциональная схема программы. Даталогическая модель данных. Сущности БД и архива. Элементы пользовательского интерфейса.

Рубрика Программирование, компьютеры и кибернетика
Вид дипломная работа
Язык русский
Дата добавления 30.03.2015
Размер файла 4,2 M

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

  • Image1: TImage;
  • sProgressBar1: TsProgressBar;
  • sGauge1: TsGauge;
  • Timer1: TTimer;
  • Timer2: TTimer;
  • sLabelFX1: TsLabelFX;
  • и т.д.
  • Приложение 2
  • Руководство пользователя
  • Аннотация
  • Программа «Абитуриент» предназначена для использования сотрудниками приёмной комиссии техникума с целью автоматизации процесса приёма абитуриентов. Данная система разрабатывалась коллективом программистом.
  • Совместными функциями были:
  • 1) Наличие авторизации для ограничения доступа к программе,
  • 2) Хранение и обработку основной базы данных на сервере.
  • Индивидуальными функциями были:
  • 1) Архивацию данных с возможностью их последующего восстановления,
  • 2) Формирование статистики за указанный период времени,
  • 3) Защиту информации,
  • 4) Настройки программы,
  • 5) Блок администрирования,
  • 6) Формирование документов по шаблонам.
  • 1. Условия работы программы
  • 1.1. Техническое обеспечение
  • Минимальные системные требования

    1.

    Процессор

    Pentium 1 GHz или выше

    2.

    Видеокарта

    VGA совместимая

    3.

    Оперативная память

    256 MB

    4.

    Место на жёстком диске

    2 GB

    5.

    Мышь

    Совместимая с ПК

    6.

    Клавиатура

    Совместимая с ПК

    7.

    Принтер

    Совместимый с ПК

    • 1.2. Программное обеспечение
    • Название

      Функция

      1.

      Операционная система

      Windows XP/Vista/7

      2.

      Microsoft Office 2003/2007

      Текстовый редактор для обработки шаблонов документов

      • 1.3. Состав эксплуатационного пакета
      • В состав эксплуатационного пакета входит диск со следующей информацией:
      • - Инсталлятор - файл «Setup.exe»,
      • - Файл «Readme.txt» с инструкцией по установке программы,
      • 2. Установка и вызов программы
      • 2.1. Установка
      • Чтобы установить автоматизированную систему «Абитуриент», необходимо запустить файл «Setup.exe». Инсталлятор самостоятельно установит программу, пошагово согласовываясь с пользователем. Директория по умолчанию: «C:\Abiturient 2010\...».
      • 2.2. Вызов
      • Для работы с программой, пользователю необходимо запустить файл «ABITURIENT 2010.exe», который находится в корневой папке на диске или его ярлык на Рабочем столе.
      • 3. Описание работы программы
      • При запуске файла «ABITURIENT.exe» открывается заставка программы (Рис.1), где можно видеть процентное состояние загрузки программы.
      • 3.1. Окно авторизации
      • При открытии окна авторизации (Рис.2) программы пользователю предоставляется возможность ввода логина и пароля для входа в программу. Для дешифрации данных базы и возможности работы с функциями программы пользователю прелагается ввести ключ. При входе в программу без ключа вся функциональная часть программы недоступна, а данные отображаеются в зашифрованном виде (Рис.3).
      • Рис.1. - Заставка программы
      • Рис.2. - Окно авторизации
      • Рис.3. - Шифрация данных
      • 3.2. Главное окно программы
      • В зависимости от скина, закреплённого за авторизованным пользователем, открывается главное окно программы (Рис.4) в определённой цветовой гамме. Также при авторизации определяется доступность и недоступность имеющихся функций.
      • Рис.4. - Главное окно программы
      • Главное окно программы содержит два вида панели инструментов: слева и сверху (Рис.5):
      • Рис.5. - Панель инструментов
      • На главном окне программы имеется полный список абитуриентов (Рис.6)
      • Рис.6. - Список абитуриентов
      • Воспользоваться основными функциями обработки базы данных можно на представленной выше панели инструментов. Просмотр, добавление и изменение информации представлено в режиме вкладок.
      • - Основная информация (Рис.7)
      • Рис.7. - Основная информация
      • - Паспортные данные (Рис.8)
      • Рис.8. - Паспортные данные
      • - Адрес (Рис.9)
      • Рис.9. - Адрес
      • - Поступление (Рис.10)
      • Рис.10. - Поступление
      • - Родители (Рис.11)
      • Рис.11. - Родители
      • - Образование (Рис.12)
      • Рис.12. - Образование
      • - Наличие документов (Рис.13)
      • Рис.13. - Наличие документов
      • - Вступительные испытания (Рис.14)
      • Рис.14. - Вступительные испытания
      • Чтобы добавить абитуриента или изменить о нём информацию, необходимо на нижней панели функций (Рис.15) нажать кнопку «Сохранить». Кнопка «Отмена» возвращает пользователя обратно к списку всех абитуриентов.
      • Рис.15. - Панель функций
      • При удалении или архивировании абитуриента в программе появляется диалоговое окно с соответствующим запросом (Рис.16)
      • Рис.16. - Диалоговое окно удаления
      • Главное окно программы включает в себя также такие функции, как: поиск, статистика поступлений, формирование документов, защита информации, настройки программы, а также панель с калькулятором и календарём для облегчения работы с данными.
      • Правая часть окна делится на четыре части:
      • 1) Поиск (Рис.17). Выполняется при указании основного параметра и при желании дополнительных параметров.
      • Рис.17. - Панель поиска
      • 2) Сортировка (Рис.18). Выполняется при указании параметра сортировки, а также вида сортировки: по возрастанию или по убыванию.
      • Рис.18. - Панель сортировки
      • 3) Статистика поступлений (Рис.19)
      • Рис.19. - Панель статистики поступлений
      • 4) Формирование документов (Рис.20)
      • Рис.20. - Панель формирования документов
      • При выборе определённой даты производится расчёт по различным показателям и по шаблону документа Excel (Рис.21) формируется документ «Статистика поступлений» (Рис.22).
      • Рис.21. - Шаблон документа «Статистика поступлений»
      • Рис.22. - Готовый документ «Статистика поступлений»
      • 3) Формирование документов
      • Формирование документов происходит по готовым шаблонам Word. Всего имеется 5 видов документов:
      • - Заявление (Рис.23)
      • Рис.23. - Пример готового документа «Заявление»
      • - Расписка о приёме документов (Рис.24)
      • Рис.24. - Пример готового документа «Расписка»
      • - Экзаменационный лист (Рис.25)
      • Рис.25. - Пример готового документа «Экзаменационный лист»
      • - Справка об оценках (Рис.26)
      • Рис.26. - Пример готового документа «Справка об оценках»
      • - Титульный лист (Рис.27)
      • Рис.27. - Пример готового титульного листа
      • Все документы автоматически сохраняются в папку Documents, находящуюся в папке с программой.
      • В качестве удобства пользования программой имеются дополнительные функции - календарь и калькулятор (Рис.28).
      • Рис.28. - Календарь и калькулятор
      • В программе также имеются настройки. Они делятся на три блока:
      • - Общие настройки (Рис.29)
      • Рис.29. - Общие настройки
      • - Настройки интерфейса (Рис.30)
      • Рис.30. - Настройки интерфейса
      • - Настройки безопасности (Рис.31)
      • Рис.31. - Настройки безопасности
      • Главное окно программы содержит главное меню (Рис.32)
      • Рис.32. - Главное меню программы
      • Всего в главном меню содержится 7 пунктов:
      • - Функция (Рис.33). Включает в себя функции: смена пользователя, добавление, изменение, архивирование и удаление данных.
      • Рис.33. - Меню «Функция»
      • - Настройки (Рис.34). Включает в себя переход на панели настроек: общие, интерфейс, безопасность.
      • Рис.34. - Меню «Настройки»
      • - Вид (Рис.35). Включает в себя смену пользовательского интерфейса. Можно выбрать режим отображения функций: вкладки, панели или окна, а также вид отображения панели инструментов: сбоку или сверху.
      • Рис.35. - Меню «Вид»
      • - Данные (Рис.36). Включает в себя возможность шифрования и дешифрования информации, а также смену ключа.
      • Рис.36. - Меню «Данные»
      • - Сервис (Рис.37). Подразумевает под собой переход на дополнительные окна, имеющиеся в программе: информация о группах, администраторская, архив.
      • Рис.37 - Меню «Сервис»
      • - Справка. Содержит инструкцию по пользованию программой.
      • - Выход из программы, при котором появляется диалоговое окно (Рис.38).
      • Рис.38. - Диалоговое окно выхода из программы
      • 3.3. Окно информации о группах
      • Окно информации о группах (Рис.39) содержит список всех групп и экзаменов, закреплённых за определёнными группами, которые можно добавлять, изменять или удалять.
      • Рис.39. - Окно информации о группах
      • Также при выборе определённой группы доступны следующие функции:
      • - Генерация шифра,
      • - Формирование документов «Экзаменационная ведомость» по выбранной дисциплине,
      • - Формирование документа «Результаты вступительных испытаний»,
      • - Статистика абитуриентов,
      • - Архивация абитуриентов.
      • Чтобы добавить группу, необходимо нажать на кнопку «Добавить» на панели инструментов. Панель добавления (Рис.40) помимо информации о группе содержит информацию об экзаменах.
      • Рис.40. - Панель добавления группы
      • Чтобы вызвать панель изменения информации о группе (Рис.41), необходимо нажать на кнопку «Изменить информацию» на панели инструментов.
      • Рис.41. - Панель изменения информации о группе
      • Генерация шифра происходит при формировании двух документов и заносится в базу данных:
      • 1) Документ «Экзаменационная ведомость» (Рис.42) представляет собой сводную таблицу по выбранной группе и дисциплине, содержащую список абитуриентов, отсортированных по возрастанию, а также номера экзаменационных листов соответственно на каждого человека.
      • Рис.42. - Пример готовой экзаменационной ведомости
      • 2) Документ «Результаты вступительных испытаний» (Рис.43) представляет собой сводную таблицу по выбранной группе, содержащую список абитуриентов, отсортированных по возрастанию, а также номера экзаменационных листов и общего балла соответственно на каждого человека.
      • Рис.43. - Пример готового документа «Результаты вступительных испытаний»
      • Статистика абитуриентов по выбранной группе (Рис.44) представляет собой текстовую информацию с соответствующими расчётами: количество человек, льготников, иногородних и иностранцев, а также средний общий балл по группе.
      • Рис.44. - Статистика по группе
      • Чтобы добавить абитуриентов выбранной группы в архив, необходимо нажать на кнопку «Удалить группу» и в диалоговом окне (Рис.45) нажать «Да».
      • Рис.45. - Диалоговое окно архивации абитуриентов группы
      • 3.4. Администраторская
      • Администраторская (Рис.46) представляет собой окно со списком всех пользователей. Можно пользоваться функциями регистрации нового пользователя, изменения информации о пользователе, удаление пользователя. Необходимо учитывать, что при добавлении и изменении нужно также указывать доступность функций. Также администратор может просмотреть все действия выбранного пользователя за время пользования программой.
      • Рис.46. - Администраторская
      • Чтобы зарегистрировать нового пользователя, необходимо нажать на кнопку «Регистрация нового пользователя», заполнить все необходимые поля на панели регистрации (Рис.47) и нажать на кнопку «Сохранить».
      • Рис.47. - Панель регистрации нового пользователя
      • Чтобы изменить информацию о пользователе, необходимо нажать на кнопку «Изменить информацию о пользователе» и выполнить соответствующие корректировки (Рис.48).
      • Рис.48. - Панель изменения информации о пользователе
      • 3.5. Архив
      • Архив (Рис.49) представляет собой окно, где вся информация о заархивированных абитуриентах расположена в таблице и на вкладках по аналогии с главным окном программы. Пользователь может воспользоваться функцией восстановления записи, а также абсолютного удаления. В том числе доступен поиск и сортировка в архиве.
      • Рис.49. - Архив
      • Поиск представляет собой отдельную панель ниже таблицы (Рис.50). В качестве параметра указывается ФИО абитуриента, год занесения в архив, а также группа, в которой абитуриент сдавал вступительные испытания.
      • Рис.50. - Поиск по архиву
      • Сортировка происходит путём выбора параметра для сортировки и нажатия на заголовок таблицы (Рис.51). Первый щелчок означает сортировку по возрастанию, второй - по убыванию. Параметрами для сортировки являются: ФИО, общий балл, возраст и дата занесения в архив.
      • Рис.51. - Сортировка данных в архиве
      • 4. Входные / выходные данные
      • 4.1. Входные данные
      • Данная информация вводится пользователем при работе с программой.
      • Табл.1. - Входные данные
      • № п/п

        Наименование поля

        Ограничение в символах

        Способ ввода

        Основная информация

        1

        ФИО

        50

        Клавиатура

        2

        Пол

        -

        Выбор из списка

        3

        Дата рождения

        10

        Клавиатура

        4

        Форма обучения

        -

        Выбор из списка

        5

        Шифр

        Автоматическая генерация

        6

        Изучаемый язык

        15

        Клавиатура / выбор из списка

        7

        Мобильный телефон

        Клавиатура

        8

        Электронная почта

        50

        9

        Льгота

        -

        Выбор из списка

        10

        Общий балл

        Автоматическая генерация

        11

        Дата подачи заявления

        12

        Возраст

        Поступление

        1

        Название специальности

        -

        Выбор из списка

        2

        Код специальности

        3

        Вид обучения

        4

        Приоритет

        Автоматическая генерация

        Адрес

        1

        Вид адреса

        -

        Выбор из списка

        2

        Город, округ

        40

        Клавиатура / выбор из списка

        3

        Индекс

        6

        Клавиатура

        4

        Улица

        30

        5

        Дом

        3

        6

        Корпус

        5

        7

        Квартира

        3

        8

        Домашний телефон

        15

        Паспортные данные

        1

        Серия

        4

        Клавиатура

        2

        Номер

        6

        3

        Место рождения

        40

        Клавиатура / выбор из списка

        4

        Гражданство

        5

        Место выдачи

        100

        Клавиатура

        6

        Дата выдачи

        10

        7

        Код подразделения

        Группа

        1

        Название группы

        5

        Выбор из списка

        2

        Поток

        -

        Вступительные экзамены

        1

        Дисциплина

        -

        Автоматическая генерация

        2

        Экзаменатор

        25

        Клавиатура

        3

        Дата экзамена

        10

        4

        Время экзамена

        8

        5

        Аудитория

        4

        Образование

        1

        Вид образования

        -

        Выбор из списка

        2

        Название учебного заведения

        150

        Клавиатура

        3

        Серия документа об образовании

        5

        4

        Номер документа

        7

        5

        Дата выдачи документа

        10

        ЕГЭ / ГИА

        1

        Номер свидетельства ЕГЭ / ГИА

        20

        Клавиатура

        2

        Дата получения свидетельства ЕГЭ/ГИА

        10

        3

        Место выдачи ЕГЭ / ГИА

        100

        Предметы ЕГЭ / ГИА

        1

        Предмет ЕГЭ / ГИА

        -

        Автоматическая генерация

        2

        Балл ЕГЭ / ГИА

        3

        Клавиатура

        Родители

        1

        Вид родства

        -

        Автоматическая генерация

        2

        ФИО родителя

        50

        Клавиатура

        3

        Рабочий телефон

        15

        4

        Мобильный телефон

        5

        Место работы

        100

        6

        Должность

        50

        Результаты вступительных экзаменов

        1

        Дисциплина

        -

        Автоматическая генерация

        2

        Балл

        3

        Клавиатура

        3

        Явка

        -

        Выбор

        Наличие документов

        1

        Фото

        -

        Выбор

        2

        Заявление

        -

        Выбор

        3

        Справка 086-у

        -

        Выбор

        4

        Копия паспорта

        -

        Выбор

        5

        Справка о прописке

        -

        Выбор

        6

        Документ об образовании

        -

        Выбор

        7

        Документ по льготе

        -

        Выбор

        • 4.2. Выходные данные
        • Данная информация выводится для просмотра при работе с программой.
        • Табл.2. - Выходные данные
        • № п/п

          Наименование поля

          Способ вывода

          1

          Документ «Заявление»

          Microsoft Word

          2

          Документ «Расписка о приёме документов»

          3

          Документ «Экзаменационный лист»

          4

          Документ «Справка»

          5

          Титульный лист

          6

          Документ «Экзаменационная ведомость»

          7

          Документ «Результаты вступительных испытаний»

          8

          Документ «Статистика поступлений»

          Microsoft Excel

          9

          Статистика по группе

          Вывод на экран в программе

          • 5. Сообщения
          • При возникновении в программе действий, приводящих к потере информации или другим неординарным ситуациям, пользователю предоставляется сообщение с запросом на подтверждение или предупреждением.
          • Табл.3. - Сообщения
          • Ситуация

            Сообщение

            Примечание

            1

            Введён неверный пароль

            Введён неверный пароль!

            Проверьте правильность пароля

            2

            Удаление выбранной записи

            Вы точно хотите удалить запись?

            Подтвердите удаление

            3

            Удаление выбранной группы

            Вы хотите добавить всех абитуриентов данной группы в архив?

            Подтвердите архивирование

            • Приложение 3
            • Результаты работы программы
            • Функция подсчёта статистики подразумевает обработку шаблона (Рис.1), который хранится в папке с программой на диске в готовый документ «Статистика поступлений» (Рис.2), представляющий собой таблицу. В данной таблице по каждой специальности рассчитываются следующие показатели:
            • - Количество подавших заявление за указанный период
            • - Количество забравших заявление за указанный период
            • - Количество абитуриентов за всё время
            • - Количество поданных заявлений за всё время
            • Рис.1. - Шаблон документа «Статистика поступлений»
            • Рис.2. - Пример готового документа «Статистика поступлений»
            • Размещено на Allbest.ru

    Подобные документы

    • Процесс разработки базы данных для хранения и обработки информации. Ключи, индексы, триггеры, хранимые процедуры. Разработка пользовательского интерфейса и базы данных. Основные инструментальные средства для разработки клиентской и серверной частей.

      дипломная работа [225,0 K], добавлен 18.05.2013

    • Создание реляционной базы данных приёмной комиссии в Borland Delphi 7: отчеты по абитуриентам, не сдавшие документы, посещающие курсы и прочее. Домены атомарных значений и степени их отношения в основе структур SQL-запросов и интерфейса программы.

      дипломная работа [82,9 K], добавлен 22.06.2009

    • Описание входной и выходной информации, структура базы данных. Разработка программа автоматизации обработки сведений в отделе Государственной статистики Аскинского района по животноводству в среде Delphi 7. Расчет затрат на создание программного продукта.

      курсовая работа [1,2 M], добавлен 10.07.2012

    • Информационно-логическая модель предметной области по нотациям Ричарда Баркера. Даталогическая модель реляционной базы данных в виде диаграммы схемы отношений. Приложение интерфейса для базы данных на языке программирования С# в среде Visual Studio.

      курсовая работа [3,6 M], добавлен 23.12.2014

    • Разработка автоматизированной информационной системы для обеспечения учета образовательных учреждений в среде Delphi на языке программирования Pascal. Создание базы данных и интерфейса для работы с АИС. Сущности и атрибуты логической модели данных.

      курсовая работа [429,3 K], добавлен 15.05.2014

    • Разработка программы на языке Си++ и осуществление постановки и выбора алгоритмов решения задач обработки экономической информации, создание и редактирование базы данных, сортировка записей по определенному запросу, анализ эффективности обработки данных.

      контрольная работа [316,8 K], добавлен 28.08.2012

    • Создание программы, осуществляющей хранение информации о Ресторане. Структура предприятия, нормализация отношений. Разработка пользовательского интерфейса базы данных "АРМ администратора ресторана" в Borland Delphi 7. Характеристики для поиска данных.

      курсовая работа [835,5 K], добавлен 18.06.2015

    • Исследование значения информации и информационных услуг в современном мире. Изучение истории хранения и обработки информации. Проектирование инфологической модели базы данных. Реляционная модель баз данных. Домены и отношения. Реляционное исчисление.

      курсовая работа [47,9 K], добавлен 13.07.2015

    • Этапы проектирования базы данных, определение целей и содержание таблиц. Добавление данных и создание других объектов базы данных. Даталогическая модель: структуризация, нормализация, схемы данных. Порядок, принципы создания пользовательского интерфейса.

      курсовая работа [1,3 M], добавлен 26.03.2013

    • Borland Delphi 7 как универсальный инструмент разработки, применяемый во многих областях программирования, функции: добавление информации об абитуриентах в базу данных, формирование отчетов. Рассмотрение и характеристика основных компонентов Delphi.

      контрольная работа [3,6 M], добавлен 18.10.2012

    Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
    PPT, PPTX и PDF-файлы представлены только в архивах.
    Рекомендуем скачать работу.