Редактирование графических объектов в GIMP

Разработка факультативного курса по редактированию графических объектов в программе GIMP. Основные понятия растровой графики, интерфейс программы, окна, диалоги и панели. Добавление отсутствующих элементов, Создание из фотографии "карандашного рисунка".

Рубрика Программирование, компьютеры и кибернетика
Вид дипломная работа
Язык русский
Дата добавления 17.12.2012
Размер файла 5,5 M

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru/

Содержание

Введение

Глава 1. Основы редактирования графических объектов в программе GIMP

1.1 Особенности растровых изображений

1.2 Основные понятия растровой графики

1.3 Интерфейс программы GIMP

1.4 Основные принципы GIMP

1.5 Окна, диалоги и панели

1.6 Загрузка изображений в GIMP

Глава 2. Лабораторный практикум

2.1 Лабораторная работа 1. Добавление отсутствующих элементов

2.2 Лабораторная работа 2. Создание «клонов»

2.3 Лабораторная работа 3. Создание из фотографии «карандашного рисунка»

2.4 Лабораторная работа 4. Редактирование внешнего вида автомобиля в GIMP

2.5 Лабораторная работа 5. Эффект шарма для фотографии

2.6 Лабораторная работа 6. Изменение человека на фотографии в Аватар (из фильма Аватар)

2.7 Лабораторная работа 7. Удаление эффекта «красных глаз»

2.8 Лабораторная работа 8. Сделать фотографию на листе бумаги

Заключение

Список литературы

Введение

Графический объект - это изображение, которое можно выделить, переместить, изменить или удалить. В данной работе графический объект будет рассматриваться как фотография, которые будем учиться редактировать.

С помощью редактирования можно исправить огромное количество недостатков фотографии. Например, снимки с красными или закрытыми глазами. Корректируя уже готовое фото можно добиться лучшего освещения, что сделает тон более ровным, улучшит цвет лица и скроет возможные недостатки. Таким образом, оказывается, что редактирование фотографий встречается на каждом шагу. Оставаясь незаметным, оно украшает нашу жизнь, делает ярче воспоминания и улучшает будущее.

Для редактирования фотографий используется множество программ, таких как Photoshop, CorelDraw, GIMP, и множество других. А в это время большинство школ перешли на бесплатное программное обеспечение Linux, и теперь они используют для редактирования фотографий программу GIMP, при этом она русифицирована, обладает легким и доступным интерфейсом, поэтому лучше всего подходит для обучения школьников.

Область использования GIMP довольно широка и включает в себя множество возможностей, которые может предоставить не каждый графический редактор. Вот некоторые из них:

работа со слоями и каналами изображения;

поддержка кроме собственного формата файлов XCF еще более трех десятков известных форматов, включая форматы Photoshop (PSD), GIF, PNG, TIFF, JPEG, EPS, BMP, ICO и др;

работа с кистями формата .gbr, .vbr, поддержка анимированных кистей .gih, возможность использовать кисти Adobe Photoshop. abr;

работа с фильтрами, масками и разными режимами смешивания слоев;

расширяемость за счет установки дополнений;

настройка работы с дисками и памятью компьютера;

очень гибкая настройка интерфейса программы, возможность выбора между однооконным и многооконным интерфейсом;

возможность полной перенастройки клавиатурных комбинаций.

Всё это делает GIMP незаменимым помощником в редактировании графических объектов.

Цель: разработать факультативный курс по редактированию графических объектов в программе Gimp для 9 классов.

Задачи:

· изучить литературу, и источники в Интернете по основам редактирования графических объектов в программе GIMP;

· проанализировать, отобрать и систематизировать теоретический материал, сопроводив их примерами;

· разработать лабораторные работы по редактированию графических объектов.

Программное и аппаратное обеспечение

Процессор Turion x2 2.2 Ghz, видеокарта Radeon Hd4570, оперативная память 4 GB RAM, жесткий диск 320 GB HDD, операционная система Linux, программа GIMP 2.6.

Начальные знания и умения

Запускать и закрывать программу, пользоваться клавиатурой и мышкой.

Факультативный курс предназначен для 9 классов общеобразовательных школ и рассчитан на 16 часов.

Выпускная квалификационная работа состоит из введения, тематического планирования, двух глав, заключения и списка литературы. В первой главе рассмотрены основы редактирования графических объектов в программе GIMP, глава включает особенности растровых изображений и основные понятия растровой графики, интерфейс, основные принципы программы, окна, диалоги и панели, загрузка изображений в программе. Во второй главе приведен комплекс лабораторных работ по редактированию графических объектов. В приложении на CD-диске находится библиотека с файлами-заготовками для успешного выполнения лабораторных работ.

Тематическое планирование

Таблица 1. Тематическое планирование

Особенности растровых изображений

Лекция

1 час

Основные понятия растровой графики

Лекция

1 час

Интерфейс программы GIMP

Лекция

1 час

Основные принципы GIMP

Лекция

1 час

Окна, диалоги и панели

Лекция

1 час

Загрузка изображений в GIMP

Лекция

1 час

Добавление отсутствующих элементов (Задание 1)

(Задание 2)

Практика

Практика

30 мин

30 мин

Создание «клонов» (Задание 1)

(Задание 2)

Практика

Практика

30 мин

30 мин

Создание из фотографии «карандашного рисунка» (Задание 1)

(Задание 2)

Практика

Практика

30 мин

30 мин

Редактирование внешнего вида автомобиля в GIMP

(Задание 1)

(Задание 2)

Практика

Практика

1 час

1 час

Эффект шарма для фотографии (Задание 1)

(Задание 2)

Практика

Практика

30 мин

30 мин

Изменение человека на фотографии в Аватар (из фильма Аватар) (Задание 1)

(Задание 2)

Практика

Практика

1 час

1 час

Удаление эффекта «красных глаз» (Задание 1)

(Задание 2)

Практика

Практика

30 мин

30 мин

Сделать фотографию на листе бумаги (Задание 1)

(Задание 2)

Практика

Практика

30 мин

30 мин

Всего

16 часов

Глава 1. Основы редактирования графических объектов в программе GIMP

1.1 Особенности растровых изображений

Основным элементом растрового изображения является точка.

Если изображение экранное, то эта точка называется пикселем. В зависимости от того, на какое графическое разрешение экрана настроена операционная система компьютера, на экране могут размещаться изображения, имеющие 640x480, 800x600, 1024 и более пикселей.

С размером изображения непосредственно связано его разрешение. Этот параметр измеряется в точках на дюйм (dots per inch -- dpi). У монитора с диагональю 15 дюймов размер изображения на экране составляет примерно 28x21 см. Зная, что в одном дюйме 25,4 мм, можно рассчитать, что при работе монитора в режиме 800x600 пикселей разрешение экранного изображения равно 72 dpi.

При печати разрешение должно быть намного выше. Полиграфическая печать полноцветного изображения требует разрешения не менее 300 dpi. Стандартный фотоснимок размером 10x15 см должен содержать примерно 1000x1500 пикселей.

Нетрудно также установить, что такое изображение будет иметь 1,5 млн. точек, а если изображение цветное и на кодирование каждой точки использованы три байта, то обычной цветной фотографии соответствует массив данных размером свыше 4 Мбит.

Большие объемы данных -- это основная проблема при использовании растровых изображений. Для активных работ с большеразмерными иллюстрациями типа журнальной потребуются компьютеры с большим размером оперативной памяти и хорошей видеокартой. Разумеется, такие компьютеры должны иметь и высоко производительные процессоры.

Второй недостаток растровых изображений связан с невозможностью их увеличения для рассмотрения деталей. Поскольку изображение состоит из точек, то увеличение изображения приводит только к тому, что эти точки становятся крупнее. Никаких дополнительных деталей при увеличении растрового изображения рассмотреть не удается. Более того, увеличение точек растра визуально искажает иллюстрацию и делает грубой. Этот эффект называется пикселизацией.

Сравнение векторной и растровой графики

Говоря о растровой графике, укажем на два ее существенных недостатка: значительный объем массивов данных, которые надо хранить и обрабатывать, а также невозможность масштабирования изображения без потери качества.

Рисунок 1. Сравнение векторной и растровой графики

Векторная графика устраняет оба эти недостатка, но, в свою очередь, значительно усложняет работу по созданию художественных ил люстраций. На практике средства векторной графики используют не для создания художественных композиций, а для оформительских, чертежных и проектно-конструкторских работ.

Для хранения информации о простейшем объекте, каковым является линия третьего порядка, в векторной графике необходимо всего восемь параметров. Добавив к ним параметры, выражающие такие свойства линии, как ее ширина, цвет, характер и прочие, получается, что для хранения одного объекта достаточно 20-30 байтов оперативной памяти. Достаточно сложные композиции, насчитывающие тысячи объектов, расходуют лишь десятки и сотни кбайт.

В векторной графике легко решаются вопросы масштабирования. Если для линии задана толщина, равная 0,15мм, то, сколько бы ни увеличивали или ни уменьшали рисунок, эта линия все равно будет иметь только такую толщину, поскольку это одно из свойств объекта, жестко за ним закрепленное. Распечатав чертеж на малом или на большом листе бумаги, всегда получим линии одной и той же толщины. Это свойство векторной графики широко используется в картографии и в конструкторских системах автоматизированного проектирования (САПР).

Получив на экране изображение дома, мы можем его увеличить и подробно рассмотреть изображение квартиры. При дальнейшем увеличении можно подробно рассмотреть способ крепления дверной коробки, дверной петли и далее увеличивать изображение до тех пор, пока шурупы, которыми крепятся дверные петли, не займут полный экран.

Если бы была необходимость, изображение можно было бы увеличивать и далее.

GIMP - пакет для создания и редактирования растровых изображений (растровый графический редактор), разрабатываемый сообществом разработчиков по технологии разработки с открытым исходным кодом (Open Source) и распространяемый на условиях свободной лицензии GNU (GNU Public License - GPL).

GIMP прекрасно подходит для любительской и полупрофессиональной работы с изображениями - обработки фотографий, создания графических композиций и коллажей, создания элементов дизайна web-страниц. Возможности GIMP позволяют обойтись без дорогостоящих коммерческих пакетов растровой графики или их пиратских версий, что особенно актуально в связи с ужесточением защиты авторских прав в России.

Проект GIMP (GNU Image Manipulation Program) был основан в 1995 году Спенсером Кимбеллом и Питером Маттисом как дипломный проект, в настоящий момент поддерживается группой добровольцев. Распространяется на условиях GNU General Public License. Т.е., проще говоря, бесплатно. Изначально сокращение "GIMP" означало англ. General Image Manipulation Program, a в 1997 году полное название было изменено на "GNU Image Manipulation Program", и программа официально стала частью проекта GNU. Проект поддерживает следующие платформы: GNU/Linux, MS Windows, FreeBSD. В редактор встроена поддержка нескольких десятков языков. Есть portable-версия.

С помощью GIMP можно создавать графические изображения, логотипы, масштабировать и кадрировать фотографии, раскрашивать, комбинировать картинки с использованием слоев, преобразовывать изображения в различные форматы.

Первое время GIMP разрабатывался исходя из личных предпочтений разработчиков, дизайн и удобство пользования оставляли желать лучшего. Последние пять лет была проделана большая работа в этом направлении. Но ввиду того, что проект некоммерческий, изменения появляются не так быстро, как хотелось бы пользователям.

Традиционно GIMP считается свободным аналогом Adobe Photoshop, хотя сами разработчики часто возражают против такой формулировки. И они правы: по мощности и удобству GIMP сильно уступает продукту корпорации Adobe. Но на базе Linux и FreeBSD, по сути, нет равных. Существующие другие бесплатные растровые редакторы Krita, Paint.NET, Tux Paint не могут сравниться с GIMP.

Особенности программы

В GIMP последних версий включена следующая особенность: GIMP поддерживается графическими планшетами и другими устройствами ввода.

Динамика кистей. Любой кисти можно задать степень дрожания, кисти могут реагировать на степень надавливания, скорость движения и изменять свой цвет, размер, жесткость и непрозрачность в произвольном порядке.

Собственный формат файлов XCF хранит совершенно всю информацию о файле. Включая историю отмен. В любой момент можно начать редактировать файл и отменить любые предыдущие действия.

Удобная работа с буфером обмена. Содержимое буфера обмена сразу можно превратить либо в новое изображение, либо можно использовать как кисть или текстуру для заливки.

GIMP может перетаскивать практически все, что видно на экране. Можно даже перетащить цвет с панели инструментов на изображение и в результате все изображение или выделенная его часть будут заполнены выбранным цветом.

GIMP умеет архивировать изображения "на лету". Нужно только добавить к имени файла gz или bz2, и изображение будет сжато. В дальнейшем, GIMP сможет открыть такое изображение как обычное.

Интуитивный инструмент свободного выделения. Одним инструментом можно создавать как многоугольное выделение, так и выделение "от руки". Все точки соединения выделения можно редактировать перед применением выделения.

Поддержка формата файлов PSD обеспечивает хорошую интеграцию с программами, которые не поддерживают формат файлов GIMP.

При кадрировании изображения сразу можно выбрать правила, которые помогут хорошо кадрировать изображение. Например, "Правило третьей", "Золотое сечение", "Линии по центру".

Редактирование выделения. После создания прямоугольного или эллиптического выделения размеры и параметры можно отредактировать. Можно изменить размеры выделенной области или, например, закруглить края выделения (рис. 2).

Рисунок 2. Редактирование выделения

Инструмент выравнивания. На рисунке 3 изображен инструмент выравнивания. Слои можно выровнять по определенным параметрам. Правилом выравнивания может быть направляющая, активный слой или контур выделения.

Рисунок 3. Выравнивание

Локализация. GIMP переведен на множество языков. GIMP самостоятельно определит язык операционной системы при установке, и сразу же начнет общаться с вами на вашем родном языке.

Изменяемые комбинации клавиш. В GIMP можно переназначить большинство горячих клавиш. При включенной функции динамического изменения, горячие клавиши можно поменять просто наведя курсор на пункт меню и нажав нужное сочетание клавиш.

Простое создание собственных плагинов. Любой программист может создать расширение на одном из трех распространенных языков программирования, который сможет расширить возможности редактора. Поэтому таких плагинов создано большое количество.

Карта изображения. В GIMP стандартной сборки добавлен плагин, который может создавать HTML-разметку и саму карту изображения (image map).

Интеллектуальное обесцвечивание. При обесцвечивании изображения можно выбрать один из предложенных вариантов обесцвечивания.

Параметр "Ослабить". Возможно не полная отмена предыдущего действия, а его частичное ослабление за счет изменения режима смешивания и непрозрачности.

Инструмент "Контуры". На рисунке 4 изображен инструмент контуры. Инструмент служит для создания псевдовекторных кривых. Реализован, пожалуй, гораздо удобней чем в большинстве платных векторных редакторов.

Рисунок 4. Контуры

Передвижение холста. В холсте изображение можно передвигать за пределы окна, что помогает рисованию по краям изображений. Изображение можно передвигать, пока в каком-либо углу холста не окажется центра изображения. Это очень помогает при рисовании по краям рисунка.

Реальный размер слоя. При активации одного из слоев, можно увидеть его края, если он даже находится за пределами рабочего холста. Опционально эту функцию можно отключить.

Выделение переднего плана. Очень быстрый и удобный инструмент, который сопоставляет цвета, которые есть на переднем плане, а потом создает выделение только переднего плана. В любой момент границы переднего плана можно переопределить кистью.

1.2 Основные понятия растровой графики

Разрешение изображения и его размер

В компьютерной графике с понятием разрешения обычно происходит больше всего путаницы, поскольку приходится иметь дело сразу с несколькими свойствами разных объектов.

Следует четко различать: разрешение экрана, разрешение печатающего устройства и разрешение изображения. Все эти понятия относятся к разным объектам. Друг с другом эти виды разрешения никак не связаны, пока не потребуется узнать, какой физический размер будет иметь картинка на экране монитора, отпечаток на бумаге или файл на жестком диске.

Разрешение экрана -- это свойство компьютерной системы (зависит от монитора и видеокарты) и операционной системы. Разрешение экрана измеряется в пикселях и определяет размер изображения, которое может поместиться на экране целиком.

Разрешение принтера -- это свойство принтера, выражающее количество отдельных точек, которые могут быть напечатаны на участке единичной длины. Оно измеряется в единицах dpi (точки на дюйм) и определяет размер изображения при заданном качестве или, наоборот, качество изображения при заданном размере.

Разрешение изображения -- это свойство самого изображения. Оно тоже измеряется в точках на дюйм и задается при создании изображения в графическом редакторе или с помощью сканера. Значение разрешения изображения хранится в файле изображения и неразрывно связано с другим свойством изображения -- его физическим размером.

Физический размер изображения может измеряться как в пикселях, так и в единицах длины (миллиметрах, сантиметрах, дюймах). Он задается при создании изображения и хранится вместе с файлом.

Если изображение готовят для демонстрации на экране, то его ширину и высоту задают в пикселях, чтобы знать, какую часть экрана оно занимает.

Если изображение готовят для печати, то его размер задают в единицах длины, чтобы знать, какую часть листа бумаги оно займет. Не трудно пересчитать размер изображения из пикселей в единицы длины или наоборот, если известно разрешение изображения.

Цветовое разрешение и цветовые модели

При работе с цветом используются понятия цветовое разрешение (еще называют глубиной цвета) и цветовая модель. Цветовое разрешение определяет метод кодирования цветовой информации, и от него зависит то, сколько цветов на экране может отображаться одновременно. Для кодирования двухцветного (черно-белого) изображения достаточно выделить по одному биту на представление цвета каждого пикселя. Выделение одного байта позволяет закодировать 256 различных цветовых оттенков. Два байта (16 битов) позволяют определить 65 536 различных цветом. Этот режим называется High Color. Если для кодирования цвета используются три байта (24 бита), возможно одновременное отображение 16,5 млн цветов. Этот режим называется True Color.

Цвета в природе редко являются простыми. Большинство цветовых оттенков образуется смешением основных цветов. Способ разделения цветового оттенка на составляющие компоненты называется цветовой моделью. Существует много различных типов цветовых моделей, но в компьютерной графике, как правило, применяется не более трех. Эти модели известны под названиями: RGB, CMYK и HSB.

Цветовая модель RGB наиболее проста для понимания и очевидна. В этой модели работают мониторы и бытовые телевизоры. Любой цвет считается состоящим из трех основных компонентов: красного (Red), зеленого (Green) и синего (Blue). Эти цвета называются основными. Считается также, что при наложении одного компонента на другой яркость суммарного цвета увеличивается. Совмещение трех компонентов дает нейтральный цвет (серый), который при большой яркости стремится к белому цвету.

Это соответствует тому, что наблюдаем на экране монитора, поэтому данную модель применяют всегда, когда готовится изображение, предназначенное для воспроизведения на экране. Если изображение проходит компьютерную обработку в графическом редакторе, то его тоже следует представить в этой модели. В графических редакторах имеются средства для преобразования изображений из одной цветовой модели в другую.

Метод получения нового оттенка суммированием яркостей составляющих компонентов называют аддитивным методом. Он применяется всюду, где цветное изображение рассматривается в проходящем свете («на просвет»): в мониторах, слайд-проекторах и т. п.

Нетрудно догадаться, что чем меньше яркость, тем темнее оттенок. Поэтому в аддитивной модели центральная точка, имеющая нулевые значения компонентов (0, 0, 0), имеет черный цвет (отсутствие свечения экрана монитора). Белому цвету соответствуют максимальные значения составляющих (255, 255, 255). Модель RGB является аддитивной, а ее компоненты -- красный, зеленый и синий -- называют основными цветами.

Цветовую модель CMYK используют для подготовки не экранных, а печатных изображений. Они отличаются тем, что их видят не в проходящем, а в отраженном свете. Чем больше краски положено на бумагу, тем больше света она поглощает и меньше отражает. Совмещение трех основных красок поглощает почти весь падающий свет, и со стороны изображение выглядит почти черным. В отличие от модели RGB увеличение количества краски приводит не к увеличению визуальной яркости, а наоборот к ее уменьшению. Поэтому для подготовки печатных изображений используется не аддитивная (суммирующая) модель, а субтрактивная (вычитающая) модель. Цветовыми компонентами этой модели являются не основные цвета, а те, которые получаются в результате вычитания основных цветов из белого:

* голубой (cyan)=белый?красный=зеленый+синий;

* пурпурный (magenta)=белый?зеленый=красный+синий;

* желтый (yellow)=белый?синий=красный+зеленый.

Эти три цвета называются дополнительными, потому что дополняют основные цвета до белого.

Существенную трудность в полиграфии представляет черный цвет. Теоретически можно получить совмещением трех основных или дополнительных красок, но на практике результат оказывается негодным. Поэтому в цветовую модель CMYK добавлен четвертый компонент -- черный.

Ему эта система обязана буквой «К» в названии (blacK). В типографиях цветные изображения печатают в несколько приемов. Накладывая на бумагу по очереди голубой, пурпурный, желтый и черный отпечатки, получают полноцветную иллюстрацию. Поэтому готовое изображение, полученное на компьютере, перед печатью разделяют на четыре составляющих одноцветных изображения. Этот процесс называется цветоделением. Современные графические редакторы имеют средства для выполнения этой операции. В отличие от модели RGB, центральная точка имеет белый цвет (отсутствие красителей на белой бумаге). К трем цветовым координатам добавлена четвертая -- интенсивность черной краски. Ось черного цвета выглядит обособленной, но в этом есть смысл: при сложении цветных составляющих с черным цветом все равно получится черный цвет.

Сложение цветов в модели CMYK каждый может проверить, взяв в руки голубой, розовый и желтый карандаши или фломастеры. Смесь голубого и желтого на бумаге дает зеленый цвет, розового с желтым -- красный и т. д. При смешении всех трех цветов получается неопределенный темный цвет. Поэтому в этой модели черный цвет и понадобился дополнительно.

Некоторые графические редакторы позволяют работать с цветовой моделью HSB. Если модель RGB наиболее удобна для компьютера, а модель CMYK -- для типографий, то модель HSB наиболее удобна для человека. Она проста и интуитивно понятна.

В модели HSB тоже три компонента: оттенок цвета (Hue), насыщенность цвета (Saturation) и яркость цвета (Brightness). Регулируя эти три компонента, можно получить столь же много произвольных цветов, как и при работе с другими моделями.

Цветовая модель HSB удобна для применения в тех графических редакторах, которые ориентированы не на обработку готовых изображений, а на их создание своими руками. Существуют такие программы, которые позволяют имитировать различные инструменты художника (кисти, перья, фломастеры, карандаши), материалы красок (акварель, гуашь, масло, тушь, уголь, пастель) и материалы полотна (холст, картон, рисовая бумага и пр.). Создавая собственное художественное произведение, удобно работать в модели HSB, а по окончании работы его можно преобразовать в модель RGB или CMYK, в зависимости от того, будет ли оно использоваться как экранная или печатная иллюстрация.

Цветовая палитра -- это таблица данных, в которой хранится информация о том, каким кодом закодирован тот или иной цвет.

Эта таблица создается и хранится вместе с графическим файлом.

Рисунок 5. Цветовая палитра

Самый удобный для компьютера способ кодирования цвета -- 24-разрядный, True Color. В этом режиме на кодирование каждой цветовой составляющей R (красной), G (зеленой) и В (синей) отводится по одному байту (8 битов). Яркость каждой составляющей выражается числом от 0 до 255, и любой цвет из 16,5 миллионов компьютер может воспроизвести по трем кодам. В этом случае цветовая палитра не нужна, поскольку в трех байтах и так достаточно информации о цвете конкретного пик селя.

Существенно сложнее обстоит дело, когда изображение имеет только 256 цветов, кодируемых одним байтом. В этом случае каждый цветовой оттенок представлен одним числом, причем это число выражает не цвет пикселя, а индекс цвета (номер). Сам же цвет разыскивается по этому номеру в сопроводительной цветовой палитре, приложенной к файлу. Такие цветовые палитры еще называют индексными палитрами. Разные изображения могут иметь разные цветовые палитры. Например, в одном изображении зеленый цвет может кодироваться индексом 64, а в другом изображении этот индекс может быть отдан розовому цвету. Если воспроизвести изображение с «чужой» цветовой палитрой, то зеленая елка на экране может оказаться розовой.

В тех случаях, когда цвет изображения закодирован двумя байтами (режим High Color), на экране возможно изображение 65 тысяч цветов. Разумеется, это не все возможные цвета, а лишь одна двести пятьдесят шестая доля общего непрерывного спектра красок, доступного в режиме True Color. В таком изображении каждый двухбайтный код тоже выражает какой-то цвет из общего спектра. Но в данном случае нельзя приложить к файлу индексную палитру, в которой было бы записано, какой код какому цвету соответствует, поскольку в этой таблице было бы 65 тысяч записей и ее размер составил бы сотни тысяч байтов.

Вряд ли есть смысл прикладывать к файлу таблицу, которая может быть по размеру больше самого файла. В этом случае используют понятие фиксированной палитры. Ее не надо прикладывать к файлу, поскольку в любом графическом файле, имеющем шестнадцатиразрядное кодирование цвета, один и тот же код всегда выражает один и тот же цвет.

1.3 Интерфейс программы GIMP

редактирование растровый графика интерфейс

Интерфейс редактора кажется, мягко говоря, необычным. Организация рабочего пространства в GIMP несколько непривычна, потому что каждое окно программы является почти независимым приложением.

Рисунок 6. Интерфейс программы GIMP

Диалоговые окна открытия и сохранения файлов выполнены в стандартных традициях приложений GTK+, что привычно для пользователей Linux, но может показаться неудобным для приверженцев Windows.

Рисунок 7. Панель инструментов

На рисунке 6, изображены рабочие окна программы: панель инструментов (рис. 7), главное окно где будет находиться изображение и окно слоев и каналов (рис. 8). Каждое окно находится независимо друг от друга, их можно перемещать как удобно.

Рисунок 8. Окно слоев и каналов

Дальше в работе будет подробно рассмотрено, окно изображения, панель инструментов и окно слоев и каналов. Работа в редакторе осуществляется при помощи инструментов. Инструменты выборки, т.е. средства, необходимые для определения областей обработки изображения. GIMP обеспечивает выделение прямоугольника (rectangle), круга или эллипса (ellipse), а также области, ограниченной произвольной линией (free).

Инструменты рисования

Они представлены карандашом (pencil), кистью (paintbrush) с настраиваемыми параметрами, режимами и матрицами, ластиком (eraser) и распылителем (airbrush). Помимо этого имеются Clone -- аналог резинового штампа (rubber stamp) из Photoshop, позволяющий путем копирования переносить с места на место участки изображения, и Convolver -- средство сглаживания или, наоборот, повышения резкости изображения.

Рисунок 9. Инструменты рисования

Инструменты корректировки цвета. В GIMP эти функции весьма близки к соответствующим средствам Photoshop. Найти здесь можно регулировку цветового баланса (Color Balance), оттенка и насыщенности (Hue-Saturation), яркости и контрастности (Brightness-Contrast), за задние порога (Threshold), уровней (Levels), кривых (Curves), операции уменьшения насыщенности (Desaturate), инверсии цвета (Invert), «постеризации» (Posterize), «поворота» таблицы цветов (Colormap Rotation) и имитации светофильтров (Filter Pack Simulation), а также автоматические режимы.

В GIMP есть средства работы со слоями (layers), контурами (pathes) и каналами (channels) с полным набором команд редактирования, локализованными в отдельном диалоговом окне. Детальное сравнение встроенных функций GIMP и Adobe Photoshop приводит к следующим выводам. Основные функции двух редакторов очень похожи: практически каждый инструмент Photoshop, предназначен ли для рисования, выборки, работы с цветом, слоями, масками или контурами, имеет аналог в GIMP, хотя реализации отдельных инструментов могут отличаться или иметь индивидуальные особенности.

В области же подключаемых модулей GIMP не имеет себе равных. Почему? Во-первых, потому, что он предоставляет превосходную базу для разработки модулей: к услугам программиста - консоль макрокоманд (можно наблюдать результат работы каждой строки макроса), два языка скриптов -- Scheme и Perl - в стандартной поставке, единый интерфейс для написания скриптов и программ на Си (скрипт легко преобразовать в программу на Си, поэтому очень удобно отладить модуль как скрипт, а затем перенести в Cи и откомпилировать). Доступна масса готовых исходных текстов, но главное достоинство GIMP -- особый механизм встраивания подключаемых модулей: как только вы регистрируете в программе свой модуль, будь-то скрипт или двоичный файл, он тут же становится доступным в виде функции для всех остальных модулей.

Значит, для создания довольно мощного и интересного подключаемого модуля зачастую достаточно написать лишь несколько строк исходного текста.

Во-вторых, все перечисленные средства давно и активно используются, так что накопилось множество готовых модулей, причем огромное число (около 140 двоичных и более 100 скриптовых) включено в стандартный комплект GIMP. Некоторые, возможно, не имеют аналогов среди коммерческих модулей для других программ (кроме того, они уже под рукой и их не надо искать).

1.4 Основные принципы GIMP

В этом разделе речь пойдет об основных принципах GIMP и терминологии, которая необходима для понимания смысла последующей документации.

Изображение -- основной объект, с которым работает GIMP. Под словом изображение подразумевается один файл с расширением TIFF или JPEG. Можно отождествлять изображение и окно, которое его содержит, но это будет не совсем правильно: можно открыть несколько окон с одним и тем же изображением. В то же время нельзя открыть в одном окне более одного изображения, и нельзя работать с изображением без отображающего его окна.

Изображение в GIMP может быть достаточно сложным. Наиболее правильной аналогией будет не лист бумаги, а, скорее, книга, страницы которой называются слоями.

Слои

Если изображение подобно книге, то слой можно сравнить со страницей внутри книги. Простейшее изображение содержит только один слой и, продолжая аналогию, является листом бумаги. Слои могут быть прозрачными и могут покрывать не все пространство изображения.

Рисунок 10. Панель слоев

Каналы

В GIMP каналы являются наименьшей единицей подразделения стека слоев, из которых создается изображение. Каждый канал имеет тот же размер, что и слой, и состоит из тех же пикселей. Смысл этого значения зависит от типа канала, например, в цветовой модели RGB значение канала R означает количество красного цвета, добавляемого к другим цветам пикселей.

Выделения

Часто при работе возникает необходимость изменить только часть изображения. Для этого существует механизм выделения областей. В каждом изображении можно создать выделенную область, которая, как правило, отображается в виде движущейся пунктирной линии (она также называется «муравьиной дорожкой»).

История правки

Ошибки при редактировании изображений неизбежны, однако почти всегда можно отменить свои действия: GIMP записывает историю действий пользователя, позволяя при необходимости вернуться на несколько шагов назад. Однако история занимает память, поэтому возможности отмены не безграничны.

Основные приемы использования GIMP

Для того чтобы открыть программу GIMP, нужно открыть меню KDE и в меню Графика найти Редактор растровой графики (GIMP). На рисунке 11 показано стандартное расположение окон GIMP. Элементами окон являются:

1. Панель инструментов: это самое сердце GIMP. Содержится главное меню, кнопки с пиктограммами, с помощью которых производится выбор инструментов, и некоторые другие полезные вещи.

2. Параметры инструментов: под панелью инструментов прикреплен диалог Параметры инструментов, который отображает параметры выбранного инструмента (в данном случае это инструмент Выделение прямоугольных областей)

3. Окно изображения: каждое изображение в GIMP отображается в отдельном окне. Можно открыть одновременно достаточно большое количество изображений, столько, сколько позволяют системные ресурсы.

Рисунок 11. Стандартное расположение окон

4. Диалог Слои-Каналы-Контуры-Отменить: этот диалог отображает структуру слоев активного изображения и позволяет управлять ими.

5. Кисти-Текстуры-Градиенты: панель, расположенная ниже диалога слоев, показывает диалоги управления кистями, текстурами и градиентами.

Приведенный набор -- это минимальный набор окон. В GIMP используется более дюжины различных диалогов, которые можно открыть при необходимости.

При работе с многослойным изображением диалог Слои необходим всегда. В отличие от многих других программ, в GIMP нет возможности разместить все содержимое -- панели и диалоги -- в одном цельном окне.

1.5 Окна, диалоги и панели

Каждое открытое вами изображение в GIMP отображается в своем собственном отдельном окне. Элементы окна показаны на рисунке 12.

Рисунок 12. Элементы окна

1. С помощью этого меню можно получить доступ ко всем операциям, применимым к изображению. Также можно вызвать меню изображения щелчком правой кнопкой мыши на изображении, или щелчком левой кнопкой мыши по небольшому значку -- «стрелке» в левом верхнем углу.

2. Прямо под заголовком находится меню изображения. С помощью этого меню можно получить доступ ко всем операциям, применимым к изображению (некоторые «глобальные» действия, которые доступны только через меню Панели инструментов.) Также можете вызвать меню изображения щелчком правой кнопкой мыши на изображении, или щелчком левой кнопкой мыши по небольшому значку -- «стрелке» в левом верхнем углу, если считаете один из этих методов более удобным.

3. Щелчок по этой небольшой кнопке вызывает меню изображения, расположенное в столбец вместо строки.

4. В схеме по умолчанию линейки показаны сверху и слева от изображения, отображая координаты внутри изображения. Если желаете, можете выбрать, в каких единицах измерения отображаются координаты. По умолчанию используются пиксели. Одно из основных действий для использования линеек -- это создание направляющих. Если щелкните на линейке и перетащите на окно изображения, будет создана направляющая линия, которая поможет аккуратно располагать предметы.

5. В левом нижнем углу окна изображения расположена небольшая кнопка, которая включает или выключает быструю маску, которая является альтернативным и часто полезным методом просмотра выделенной области внутри изображения.

6. В левом нижнем углу окна расположена прямоугольная область, используемая для отображения текущих координат указателя (положение мыши, если вы используете мышь).

7. Используемыми по умолчанию единицами измерения для линеек и некоторых других целей являются пиксели. Можете заменить их на дюймы, сантиметры или другие единицы, доступные с помощью этого меню.

8. Есть несколько методов увеличения или уменьшения масштаба изображения, но это меню является наиболее простым.

9. Область статуса расположена под изображением. Она отображает активный слой изображения, и количество занятой изображением системной памяти.

10. Панель навигации -- небольшая кнопка крестовидной формы расположена справа внизу под изображением. Можете перемещаться к другим частям изображения двигая мышь при нажатой кнопке.

11. Неактивная область заполнения: эта область заполнения отделяет активное отображаемое изображение и неактивную область, поэтому видно различие между ними.

12. Наиболее важная часть окна изображения это конечно, само изображение. Оно занимает центральную область окна и окружено желтой пунктирной линией, в отличие от нейтрального серого цвета фона.

13. Кнопка Изменение размера изображения. Если эта кнопка нажата, при изменении размера окна изображение будет изменять размер.

Диалоги и панели

В GIMP версии 2.6. пользователь получил больше удобства в плане размещения диалоговых окон на экране. Вместо размещения каждого диалога в своем собственном окне, можете группировать вместе с помощью панелей. Панель -- это окно контейнер, которое может содержать собрание постоянных диалогов, таких, как Параметры инструментов, Кисти, Палитры и др.

Панель инструментов

Панель инструментов -- единственная часть интерфейса программы, которую нельзя продублировать или закрыть. Внешний вид Панели инструментов представлен на рисунке 13.

Рисунок 13. Панель инструментов

1. Меню панели инструментов: это меню особое, содержит некоторые команды, которые не найти в прикрепляемых к изображению меню. Здесь включены команды для настроек, создания определенных типов диалогов и т.д.

2. Пиктограммы инструментов: эти пиктограммы являются кнопками, которые активируют инструменты для разнообразных действий: выделение частей изображений, рисования, преобразования и т.п.

3. Цвета фона-переднего плана: область выбора цвета показывает текущий выбранный вами цвет переднего плана и фона, который применяется во многих операциях. Щелчок по одному из них вызовет выборщик цветов, который позволяет вам установить другой цвет.

Состав панели инструментов

- прямоугольное выделение: выделение прямоугольной области (кнопка R).

- эллиптическое выделение: выделение эллиптической области (кнопка E).

- свободное выделение: выделение области произвольными линиями или отрезками (кнопка F).

- выделение смежных областей: выделение соседних областей области по схожести цвета (кнопка U).

- выделение по цвету: выделение областей с заливкой схожего цвета (Shift+O).

- умные ножницы: выделение фигур при помощи распознавания краев (кнопка I).

- выделение переднего плана: выделение области, содержащей объекты на переднем плане.

- контуры: создание и правка контуров (кнопка B).

- пипетка: получение цвета из изображения (кнопка O).

- лупа: изменение масштаба отображения (кнопка Z).

- измеритель: изменение расстояния и углов (Shift+M).

- перемещение: перемещение слоев, выделений и прочих объектов (кнопка M).

- выравнивание: выравнивание или расстановка слоев и прочих объектов (кнопка Q).

- кадрирование: удаление областей с края изображения или слоя (Shift+C).

- вращение: поворот слоев, выделений или контуров (Shift+R).

- масштаб: масштабирование слоев, выделенных областей или контуров (Shift+T).

- искривление: искривление слоев, выделенных областей или контуров (Shift+S).

- перспектива: изменение перспективы слоя, выделения или контура (Shift+P).

- зеркало: горизонтальное или вертикальное отображение слоя, выделения или контура (Shift+F).

- текст: создание и редактирование текстовых слоев (кнопка T).

- плоская заливка: заливка цветом или текстурой (Shift+B).

- градиент: заливка цветным градиентом (кнопка L).

- карандаш: рисование резкими штрихами (кнопка N).

- кисть: рисование плавных штрихов кистью (кнопка P).

- ластик: стирание кистью до фона или прозрачности (Shift+E).

- аэрограф: рисование кистью с переменным давлением (кнопка A).

- перо: каллиграфическое рисование (кнопка K).

- штамп: выборочное копирование из изображения или текстуры при помощи кисти (кнопка C).

- лечебная кисть: излечение дефектов в изображении (кнопка H).

- штамп по перспективе: применение инструмента «штамп» с учетом перспективы изображения.

- резкость или размывание: выборочное размывание или увеличение резкости кистью (Shift+U).

- размывание: выборочное размывание кистью (кнопка S).

- осветление/затемнение: выборочное осветление или затемнение кистью (Shift+D).

Область перетаскивания диалогов

Каждая панель имеет область перетаскивания. При наведении указателя на область перетаскивания курсор изменит вид на форму ладони. Для присоединения диалога просто щелкните по области перетаскивания и перетащите его на одну из соединительных планок в панели.

Можете перетащить более одного диалога в одну панель. Если хотите, они будут чередоваться в виде закладок, отображаемых в виде значков вверху диалога. Щелчок по закладке выдвигает диалог на передний план, следовательно, можете взаимодействовать с ним.

Отмена

Почти все, что делается с изображением, может быть отменено. Можете отменить последнее действие, выбрав в меню изображения Правка > Отменить, но эта операция применяется так часто, что лучше запомнить сочетание клавиш Ctrl+Z.

Сама отмена также может быть отменена. После отмены действия можете вернуть его, выбрав в меню изображения пункт Правка > Повторить или с использованием клавиши быстрого доступа Ctrl+Y. Часто это полезно при оценке эффекта какого-либо действия, с помощью его неоднократной отмены и повтора. Если часто используете отмену и возврат на множество шагов за раз, возможно будет более удобно работать с диалогом Истории отмен -- прикрепляемой панелью, которая показывает небольшие эскизы каждой точки в истории отмены, позволяя перемещаться назад или вперед к точке, по которой щелкаете.

1.6 Загрузка изображений в GIMP

В этой части узнаете о загрузке изображений в GIMP для редактирования и о создании новых изображений. Но первым делом мы хотим познакомить вас с общей структурой изображений в GIMP.

Типы изображений

Изображение в GIMP -- это сложная структура, которая содержит множество составляющих: слои, маски выделения, набор каналов, набор контуров, историю «отмен» и т.д.

Основное свойство изображения -- это режим. Существует три доступных режима: RGB, градации серого и индексированное. Режим RGB был рассмотрен выше. В изображении в режиме градаций серого, каждая точка представлена уровнем яркости в диапазоне от 0 (черный) до 255 (белый), с набором промежуточных значений, которые представляют различные оттенки серого цвета.

На самом деле, и RGB и серые изображения имеют дополнительный цветовой канал, называемый альфа каналом, представляющий непрозрачность. Когда значение альфа в данной точке равно нулю, слой совершенно прозрачен и цвет в том месте определяется цветом слоя, лежащего ниже. Когда значение альфа максимально, слой непрозрачен и цвет определяется цветом слоя. Промежуточные значения альфа соответствуют разным степеням полупрозрачности: цвет в выбранной точке изображения -- пропорциональная смесь цветов данного слоя и слоя, расположенного ниже.

Третий тип изображений -- это индексированные изображения. В индексированном изображении используется ограниченный набор цветов, обычно не более 256. Эти цвета формируют цветовую карту изображения, и каждой точке в изображении назначается цвет из цветовой карты.

Некоторые наиболее используемые типы файлов (включая GIF и PNG) при открытии их в GIMP выводят индексированные изображения. Многие инструменты GIMP работают с индексированными изображениями некорректно, поэтому перед работой с изображением лучше преобразовать его в режим RGB. Если необходимо, можете преобразовать его обратно в индексированный режим перед сохранением.

Создание новых файлов

В GIMP можете создать новое изображение при помощи пункта меню: Файл > Новый. При этом откроется диалог «Создать» новое изображение (рис. 14), где можно установить начальные ширину и высоту файла.

Рисунок 14. Создание нового изображения

Открытие файлов

Доступно несколько способов открыть существующее изображение в GIMP. Наиболее очевидный -- это открыть его с помощью меню Файл - Открыть в меню Окна Изображения (рис. 15). При этом появится диалог выбор файла. Этот метод годен, когда название и место файла известны, но не подходит для нахождения файла с помощью просмотра.

Рисунок 15. Открытие файла

Другой способ -- перетащить и бросить. После того, как необходимый файл найден в файловой системе, можно нажать на пиктограмму и перетащить на панель инструментов GIMP. Если пиктограмму перетащить на существующее изображение в GIMP, то файл добавится как новый слой или слои этого изображения.

Некоторые приложения позволяют делать копию экрана в буфер обмена, подобно клавише Print Screen. Тогда это изображение можно открыть в GIMP через меню Окна Изображения Правка - Вставить как - Новое изображение (рис. 16). Поддержка этого поведения непостоянна, поэтому необходимо проверить, работает ли она.

Рисунок 16. Открытие файла как нового изображения

Глава 2. Лабораторный практикум

2.1 Лабораторная работа 1. Добавление отсутствующих элементов

Задание 1. В фотографию из файла Работа 1.jpg добавить небо.

Ход выполнения

Откройте изображение без неба из файла Работа 1.jpg (рис. 17).

Рисунок 17. Изображение без неба

Выделите часть изображения где у нас будет небо, как показано на рисунке 18.

Рисунок 18. Выделение изображения без неба

Чтобы добавить облака используйте инструмент Фильтры - Визуализация - Облака - Разностные облака (рис. 19).

Рисунок 19. Фильтры - Визуализация - Облака - Разностные облака

4. Должно получиться как на рисунке 20.

Рисунок 20. Вставка неба

5. Теперь затонируйте небо, как показано на рисунке 21 (Цвет - Тонирование).

Рисунок 21. Тонировка неба

6. Результат показан на рисунке 22.

Рисунок 22. Изображение с небом

Задание 2. Самостоятельно, по аналогии, добавьте на небо облака в изображение.

2.2 Лабораторная работа 2. Создание «клонов»

Задание 1. Из фотографий Работа 21.jpg, Работа 22.jpg сделайте фотографию с одинаковым фоном, на которой один и тот же человек должен находиться в разных местах.

Ход выполнения

1. Возьмите два фото как показано на рисунке 23.

Рисунок 23. Начальные изображения

2. Откройте все изображения как слои (рис. 24).

Рисунок 24. Открытие всех изображений как слои

3. На верхний слой добавьте маску Слой -- Маска -- Добавить маску слоя, и прорисовать кистью Circle Fuzzy место на котором человек находится в предыдущем слое (Цвет кисти должен быть черного цвета). Должно получиться как на рисунке 25.

Рисунок 25. Добавка маски

4. Дальше точно также докрасьте то место где находится человек и результат получится как на рисунке 26.

Рисунок 26. Изображение с клоном

Задание 2. Самостоятельно, по аналогии, создайте изображение в котором один и тот же человек будет находиться в разных местах

2.3 Лабораторная работа 3. Создание из фотографии «карандашного рисунка»

Задание 1. Создайте из фотографии Работа 3.png «карандашный рисунок».

Ход выполнения

1. Возьмите изображение (рис. 27).

Рисунок 27. Изображение изначальное

2. Используйте Фильтры - Выделение края - Край. Поставьте алгоритм Лаплас, величина 1. Получится рисунок, на котором видно, что края выделены белым (рис. 28).

Рисунок 28. Применение Фильтр - Выделение края - Край

3. Выберите Цвет - Инвертировать. Результат получится как на рисунке 29.

Рисунок 29. Применение Цвет - Инвертировать

Задание 2. Самостоятельно, по аналогии, сделайте карандашный рисунок из вашей личной фотографии.

2.4 Лабораторная работа 4. Редактирование внешнего вида автомобиля в GIMP

Задание 1. Из файла фотографии Работа 4.jpg из капота автомобиля сделать капот карбонового вида.

Ход выполнения

1. Откройте фото автомобиля, такое, чтобы с ним было удобно работать, например, такое как на рисунке 30.

Рисунок 30. Начальное изображение

2. Создайте образец самого «карбона». Создайте новое изображение размером 12Ч6 (или 6Ч3, если изображение авто небольшое), с белым цветом фона (рис. 31).

Рисунок 31. Создание нового изображения

3. Увеличьте изображение до удобных размеров. Затем, с помощью инструмента Прямоугольное выделение выделите верхнюю левую четверть изображения и залейте его Градиентом (из черного в белый). Далее снимите выделение (Выделение -- Снять) и проделайте предыдущую операцию с нижней правой четвертью. Градиент при этом должен идти из белого в черный (это изменяется галочкой около градиента как на рисунке 32).

Рисунок 32. Градиентная заливка

4. Должно получиться как на рисунке 33.

Рисунок 33. Пример карбона

5. Снимите выделение, скопируйте «карбон» (Ctrl+C) и закройте, больше он не пригодится. Перейдите к изображению с машиной и вставьте как текстуру (Правка -- Вставить как… -- Новая текстура). В появившемся окне введите название текстуры и нажмите ОК. В Диалоге текстур (Shift+Ctrl+P) новая текстура станет активной (рис. 34).

Рисунок 34. Вставка новой текстуры

6. Теперь выделите капот (рис. 35). Сделайте это инструментом Быстрая маска (Shift+Q).

Рисунок 35. Выделение капота

7. С помощью инструмента Тонирование (Цвет -- Тонирование) измените цвет капота (рис. 36).

Рисунок 36. Тонировка капота

8. Далее скопируйте (Ctrl+C) и вставьте (Ctrl+V). Во вкладке слоев появится Плавающее выделение с капотом. Вызовете его контекстное меню и в нем выберите Создать слой (рис. 37).

Рисунок 37. Создание нового слоя

9. Создайте новый слой (Shift+Ctrl+N) и залейте его созданной ранее «карбоновой» текстурой (откройте Диалог текстур и перетащите мышью нашу текстуру на изображение). Поменяйте непрозрачность залитого слоя до 60-70% как на рисунке 38.

Рисунок 38. Изменение непрозрачности слоя

10. Для придания реалистичности выберите Фильтры -- Искажения -- Вихрь и щипок. Поменяйте угол вихря примерно до 60 (рис. 39).

Рисунок 39. Окно фильтра «Вихрь и щиток»

11. Перейдите на слой с капотом, в контекстном меню и выберите Альфа-канал в выделение.

12. Вернитесь на слой с текстурой, инвертируйте выделение (Выделение -- Инвертировать) и удалите ненужное (Del). После этого поменяйте режим слоя на Умножение и снимите выделение, результат показан на рисунке 40.


Подобные документы

  • История создания GIMP и особенности программы. Сравнение векторной и растровой графики. Определение основных понятий: цветовые модели, разрешение изображения и его размер. Возможности использования GIMP для открытия файлов и загрузки изображений.

    курсовая работа [756,5 K], добавлен 10.11.2011

  • Этапы создания презентации: знакомство с программой, добавление графиков и диаграмм, рисование и вставка графических и анимационных объектов. Добавление графических клипов из Clip Gallery. Создание и запуск слайд-фильма. Настройка программы Power Point.

    контрольная работа [27,2 K], добавлен 07.12.2010

  • Рассмотрение истории создания, особенностей (интеллектуальное обесцвечивание, динамика кистей), преимуществ и недостатков бесплатного растрового графического редактора GIMP. Ознакомление с интерфейсом программы. Описание меню панели инструментов.

    реферат [62,6 K], добавлен 04.08.2010

  • Общие сведения о графических редакторах, понятия компьютерной растровой и векторной графики, форматов. Обзор и сравнительный анализ современных программ обработки и просмотра графических изображений: Paint, Corel Draw, Adobe Photoshop, MS PowerPoint.

    дипломная работа [283,9 K], добавлен 09.08.2010

  • Растровая графика, составление графических изображений из отдельных точек (пикселей). Растровые графические редакторы. Векторная графика - построение изображения из простых объектов. Достоинства, недостатки и применение растровой и векторной графики.

    презентация [7,8 K], добавлен 06.01.2014

  • Создание простейших рисунков, закраска объектов в CorelDraw. Работа с текстом в графических объектах в программе CorelDRAW. Использование кривых линий и ломаных. Упорядочивание, выравнивание и группировка объектов. Использование графических эффектов.

    практическая работа [1,5 M], добавлен 19.04.2012

  • Программы компьютерной графики для рисования. Основные инструменты для создания рисунка в графических редакторах. Выделение объектов в векторном редакторе. Описание этапов создания текстового граффити на кирпичной стене с помощью программы Photoshop.

    курсовая работа [2,1 M], добавлен 04.07.2014

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.