Проектирование сети OSPF

Рассмотрение конфигурации сети Frame-Relay. Особенности распределения адресного пространства. Способы определения IP адреса интерфейсов маршрутизаторов. Методы настройки средств суммирования адресов. Знакомство с этапами проектирования сети OSPF.

Рубрика Программирование, компьютеры и кибернетика
Вид курсовая работа
Язык русский
Дата добавления 23.04.2017
Размер файла 486,7 K

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru/

1.Техническое задание

Согласно варианту назначить сетям и интерфейсам маршрутизаторов IP адреса из диапазонов, указанных в таблице 1.1.

Таблица 1.1. Диапазоны IP адресов

Вариант

IP адреса для всей AS

IP адреса для интерфейсов между маршрутизаторов

2

30.0.0.0/14

192.168.2.0

Таблица 1.2 Количество пользовательских сетей и количество хостов в каждой сети

Вариант

Номер области

Количество сетей в области

Количество хостов для каждой сети

2

Area 1

3

1500

Area 2

7

1000

Area 3

5

2000

Область RIP

1

1000

Таблица 1.3 Конфигурация сети Frame-Relay

Вариант

Конфигурация сети Frame-Relay

2

Частично-связная, типы интерфейсов point-to-point и multipoint, тип сети OSPF на интерфейсах multipoint - широковещательная, протокол inARP включен, широковещательная рассылка разрешена.

Для каждой сети и области OSPF должны быть выделены диапазоны IP адресов. Желательно выделять непрерывный диапазон IP адресов, но если в таком блоке адресов окажется более 20% незадействованных IP адресов, то пользовательская сеть должна быть разбита на несколько подсетей, желательно со смежными диапазонами IP адресов.

Запрограммировать маршрутизаторы в сети. Сеть необходимо построить в программе GNS3. В качестве маршрутизаторов можно выбрать любой, главное чтобы в нем было необходимое количество интерфейсов. Топология сети представлена на рисунке 1.

Рисунок 1. Топология сети

2.Распределение адресного пространства

Для разбиения адресного диапазона 30.0.0.0/14 между всеми пользовательскими сетями всех областей, весь адресный диапазон разобьем на три части согласно количеству хостов в каждой области.

При этом Area 1 и область RIP будут считаться одной областью, такое объединение делается для лучшего суммирования адресов. Вначале определим, какое количество IP адресов необходимо для каждой сети в каждой области.

Область Area 1 и RIP в общем состоят из 3 сетей по 1500 хостов в каждой и одной 1000 хостов, для адресации такого количества хостов непрерывным блоком IP адресов необходимо выделить четыре блока адресов. Три блока по 11 бит, что составляет 2048 IP адреса, и один блок 10 бит, что составляет 1024 IP адреса. В блоке 2048 больше чем на 20% неиспользованных адресов от исходного количества хостов. Следовательно, для каждой из трёх сетей нужно выделить по 2 блока, первый для адресации 1024 хостов, а второй для адресации 512 хостов. Таким образом, для адресации всех сетей в этой области необходимо IP адресов. Поскольку вся область должна быть адресована одним непрерывным блоком IP адресов, то необходимо предусмотреть блок из 8192 IP адресов.

Область Area 2 состоит из 7 сетей по 1000 хостов в каждой, для адресации такого количества хостов непрерывным блоком IP адресов необходимо выделить 10 бит, что составляет 1024 IP адреса. Таким образом, для адресации всех сетей в этой области необходимо 7168 IP адресов. Поскольку вся область должна быть адресована одним непрерывным блоком IP адресов, то необходимо предусмотреть блок из 8192 IP адресов.

Область Area 3 состоит из 5 сетей по 2000 хостов в каждой, для адресации такого количества хостов непрерывным блоком IP адресов необходимо выделить 11 бит, что составляет 2048 IP адреса. Таким образом, для адресации всех сетей в этой области необходимо 10240 IP адресов. Поскольку вся область должна быть адресована одним непрерывным блоком IP адресов, то необходимо предусмотреть блок из 16384 IP адресов.

Суммарное количество хостов составит:

Следовательно, для адресации всей сети OSPF необходимо 15 бит.

По условию задания выдан диапазон адресов 30.0.0.0/14, поскольку для адресации необходимо 15 бит, то из адресного диапазона 30.0.0.0/14, выделим подсеть 30.0.0.0/17.

Для разбиения адресного диапазона 30.0.0.0/17

Для разбиения адресного диапазона 30.0.0.0/17 распишем его в двоичном виде, но поскольку первые 17 бит, фиксированы, то первые два октета, будут оставаться неизменными и их расписывать не обязательно.

Данный адресный диапазон разобьем следующим образом:

30.0.0.0/19 - Area 1

30.0.32.0/19 - Area 2

30.0.64.0/19 - Area 3

30.0.192.0/22 - RIP

30.0.196.0/20 - резерв

Тогда на каждую сеть в Area 1 будет приходиться следующие адресные диапазоны: 30.0.0.0/21, 30.0.8.0/21, 30.0.16.0/21.

Область RIP: 30.0.192.0/22

В area 2: 30.0.32.0/22, 30.0.36.0/22, 30.0.40.0/22, 30.0.44.0/22, 30.0.48.0/22, 30.0.52.0/22, 30.0.56.0/22

Area 3: 30.0.60.0/21, 30.0.68.0/21, 30.0.76.0/21, 30.0.84.0/21, 30.0.92.0/21

Номера сетей для каждой области сведем в таблице 3.2.

Таблица 3.2 Распределение IP адресов по сетям

Area 1

Area 2

Area 3

RIP

Сеть 1

30.0.0.0/21

30.0.32.0/22

30.0.60.0/21

30.0.192.0/22

Сеть 2

30.0.8.0/21

30.0.36.0/22

30.0.68.0/21

Сеть 3

30.0.16.0/21

30.0.40.0/22

30.0.76.0/21

Сеть 4

30.0.44.0/22

30.0.84.0/21

Сеть 5

30.0.48.0/22

30.0.92.0/21

Сеть 6

30.0.52.0/22

Сеть 7

30.0.56.0/22

Определим IP адреса интерфейсов маршрутизаторов, не входящих ни в одну пользовательскую сеть. Количество не пользовательских сетей согласно исходной топологии равно пяти. В зависимости от типа сети Frame Relay количество таких сетей будет различным, в данном случае интерфейсы маршрутизаторов в сети Frame Relay будут принадлежать одной подсети, так как тип интерфейсов multipoint, а организация виртуальных каналов обеспечивает полносвязную топологию, а тип сети OSPF относится к широковещательной или NBMA сети с разрешенной или запрещенной широковещательной рассылкой. Поэтому в этом случае можно создать шесть подсетей с маской 29: 192.168.2.0/29, 192.168.2.8/29, 192.168.2.16/29, 192.168.2.24/29, 192.168.2.32/29,192.168.2.40/29. В таблицу 3.3 определим IP адреса для интерфейсов маршрутизаторов, не входящих в пользовательские сети.

Таблица 3.3 IP адреса для интерфейсов маршрутизаторов в случае частично-связной сети Frame Relay

Таблица 3.4Таблица коммутации FR1

3. Конфигурирование маршрутизаторов

Конфигурирование маршрутизаторов начнём с протоколов находящихся на нижних уровнях модели OSI и назначения IP адресов каждому интерфейсу. В качестве протоколов канального уровня в курсовом проекте будут использованы следующие протоколы: PPP, MPPP, Ethernet, Frame Relay.

R1

conf t

int f0/0

ip address 192.168.2.33 255.255.255.248

no shutd

exit

int f1/0

ip address 30.0.192.1 255.255.252.0

no shutd

exit

ASBR1

conf t

int f0/0

ip address 192.168.2.10 255.255.255.248

no shutd

exit

int f0/1

ip address 192.168.2.34 255.255.255.248

no shutd

exit

int f1/0

ip address 30.0.0.1 255.255.248.0

no shutd

exit

int f1/1

ip address 30.0.8.1 255.255.248.0

no shutd

router rip

version 2

network 192.168.2.0

no auto-summary

default-information originate

exit

ASBR 2

conf t

int f0/0

ip address 192.168.2.11 255.255.255.248

no shutd

exit

int f1/0

ip address 1.1.1.1 255.0.0.0

no shutd

exit

int f1/1

ip address 30.0.16.1 255.255.248.0

no shutd

exit

R2

conf t

int 0/0

ip address 192.168.2.17 255.255.255.248

no shutd

exit

int f1/1

ip address 30.0.32.1 255.255.252.0

no shutd

exit

int f1/0

ip address 30.0.36.1 255.255.252.0

no shutd

exit

int f0/1

ip address 30.0.40.1 255.255.252.0

no shutd

exit

R3

conf t

int f0/0

ip address 192.168.2.50 255.255.255.248

no shutd

exit

int f1/0

ip address 30.0.44.1 255.255.252.0

no shutd

exit

int f1/1

ip address 30.0.48.1 255.255.252.0

no shutd

exit

int f0/1

ip address 30.0.52.1 255.255.252.0

no shutd

exit

ABR 1

conf t

int f0/0

ip address 192.168.2.9 255.255.255.248

no shutd

exit

int s1/0

encapsulation frame-relay ietf

no shutd

int s1/0.1 multipoint

ip address 192.168.2.1 255.255.255.248

frame-relay interface-dlci 103

exit

frame-relay interface-dlci 104

exit

int s1/0.2 point-to-point

ip address 192.168.2.41 255.255.255.248

frame relay-dlci 102

exit

ABR 2

conf t

int f0/0

ip address 192.168.2.20 255.255.255.248

no shutd

exit

int f0/1

ip address 192.168.2.49 255.255.255.248

no shutd

exit

int f2/0

ip address 30.0.56.1 255.255.252.0

no shutd

exit

int s1/0

encapsulation frame-relay ietf

no shutd

int s1/0.2 point-to-point

ip address 192.168.2.42 255.255.255.248

frame-relay interface-dlci 101

exit

ABR 3

conf t

int f0/0

ip address 192.168.2.29 255.255.255.248

no shutd

exit

int f0/1

ip address 30.0.92.1 255.255.248.0

no shutd

exit

int s1/0

encapsulation frame-relay ietf

no shutd

int s1/0.1 multipoint

ip address 192.168.2.2 255.255.255.248

frame-relay interface-dlci 101

exit

frame-relay interface-dlci 104

exit

ABR 4

conf t

int f0/0

ip address 192.168.2.30 255.255.255.248

no shutd

exit

int s1/0

encapsulation frame-relay ietf

no shutd

int s1/0.1 multipoint

ip address 192.168.2.3 255.255.255.248

frame-relay interface-dlci 101

exit

frame-relay interface-dlci 103

exit

R4

conf t

int f0/0

ip address 192.168.2.25 255.255.255.248

no shutd

exit

int f0/1

ip address 192.168.2.57 255.255.255.248

no shut

exit

int f1/0

ip address 30.0.60.1 255.255.248.0

no shutd

exit

int f1/1

ip address 30.0.68.1 255.255.248.0

no shutd

exit

R5

conf t

int f0/0

ip address 192.168.2.27 255.255.255.248

no shutd

exit

int f0/1

ip address 192.168.2.58 255.255.255.248

no shutd

exit

int f1/0

ip address 30.0.76.1 255.255.248.0

no shutd

exit

int f1/1

ip address 30.0.84.1 255.255.248.0

no shutd

exit

4. Конфигурации протокола OSPF

После конфигурирования протоколов канального уровня и назначения IP адресов можно приступать к конфигурации протокола OSPF.

R2

conf t

router ospf 1

network 192.168.2.16 0.0.0.7 area 2

network 30.0.32.0 0.0.3.255 area 2

network 30.0.36.0 0.0.3.255 area 2

network 30.0.40.0 0.0.3.255 area 2

exit

R3

conf t

router ospf 1

network 192.168.2.16 0.0.0.7 area 2

network 192.168.2.48 0.0.0.7 area 2

network 30.0.44.0 0.0.3.255 area 2

network 30.0.48.0 0.0.3.255 area 2

network 30.0.52.0 0.0.3.255 area 2

exit

R4

conf t

router ospf 1

network 192.168.2.24 0.0.0.7 area 3

network 192.168.2.56 0.0.0.7 area 3

network 30.0.60.0 0.0.7.255 area 3

network 30.0.68.0 0.0.7.255 area 3

exit

R5

conf t

router ospf 1

network 192.168.2.56 0.0.0.7 area 3

network 192.168.2.24 0.0.0.7 area 3

network 192.168.2.64 0.0.0.7 area 2

network 30.0.76.0 0.0.7.255 area 3

network 30.0.84.0 0.0.7.255 area 3

exit

ABR1

conf t

int s1/0.1

ip ospf network broadcast

exit

int s1/0.2

ip ospf network broadcast

exit

router ospf 1

network 192.168.2.0 0.0.0.7 area 0

network 192.168.2.40 0.0.0.7 area 0

network 192.168.2.8 0.0.0.7 area 1

exit

ABR2

conf t

int s1/0.2

ip ospf network broadcast

exit

router ospf 1

network 192.168.2.64 0.0.0.7 area 2

network 192.168.2.48 0.0.0.7 area 2

network 192.168.2.40 0.0.0.7 area 0

network 192.168.2.16 0.0.0.7 area 2

network 30.0.56.0 0.0.3.255 area 2

exit

ABR3

conf t

int s1/0.1

ip ospf network broadcast

exit

router ospf 1

network 192.168.2.0 0.0.0.7 area 0

network 192.168.2.24 0.0.0.7 area 3

network 30.0.92.0 0.0.7.255 area 3

exit

ABR4

conf t

int s1/0.1

ip ospf network broadcast

exit

router ospf 1

network 192.168.2.0 0.0.0.7 area 0

network 192.168.2.24 0.0.0.7 area 3

exit

ASBR1

config t

int f0/0

router ospf 1

redistribute rip metric 30 metric-type 1 subnet

network 192.168.2.8 0.0.0.7 area 1

network 30.0.0.0 0.0.7.255 area 1

network 30.0.8.0 0.0.7.255 area 1

exit

ASBR2

conf t

router ospf 1

default-information originate always

network 192.168.2.8 0.0.0.7 area 1

network 30.0.16.0 0.0.7.255 area 1

exit

5. Настройка протокола MPPP

Данный протокол применяется в том случае, когда несколько физических каналов необходимо объединить в один логический. В нашем случае нужно соединить R3 и R5.

R3

config t

int multilink 1

encapsulation ppp00000000

ip address 192.168.2.65 255.255.255.248

no shutd

exit

int s2/0

encapsulation ppp

ppp multilink group 1

no shutd

exit

int s2/1

encapsulation ppp

ppp multilink group 1

no shutd

exit

exit

R5

config t

int multilink 1

encapsulation ppp

ip address 192.168.2.66 255.255.255.248

no shutd

exit

int s2/0

encapsulation ppp

ppp multilink group 1

no shutd

exit

int s2/1

encapsulation ppp

ppp multilink group 1

no shutd

exit

exit

После этого организуем виртуальный канал между ABR2 и R2.

ABR2

config t

router ospf 1

area 2 virtual-link 192.168.2.27

exit

exit

R5

config t

router ospf 1

area 2 virtual-link 192.168.2.49

exit

exit

6. Настройка средств суммирования адресов

сеть адресный интерфейс

Для того чтобы указать маршрутизатору ABR чтобы он суммировал подсети одной области, для анонсирования в опорную область необходимо ввести следующую команду на ABR: area [area-id] range [суммарный ip адрес] [маска] advertise.

Если же наоборот необходимо чтобы сети из заданного диапазона не анонсировались в опорную область, вместо ключевого слова advertise необходимо ввести not-advertise. Данную команду следует применять в случае фильтрации анонсов о сетях с частными IP адресами.

ABR1

conf t

router ospf 1

area 1 range 192.168.2.0 255.255.255.248 not-advertise

area 1 range 30.0.0.0 255.255.224.0 advertise

exit

ABR2

conf t

router ospf 1

area 2 range 192.168.2.16 255.255.255.248 not-advertise

area 2 range 192.168.2.48 255.255.255.248 not-advertise

area 2 range 192.168.2.64 255.255.255.248 not-advertise

area 2 range 30.0.32.0 255.255.224.0 advertise

exit

ABR3

conf t

router ospf 1

area 3 range 192.168.2.24 255.255.255.248 not-advertise

area 3 range 192.168.2.8 255.255.255.248 not-advertise

area 3 range 30.0.64.0 255.255.224.0 advertise

exit

ABR4

conf t

router ospf 1

area 3 range 192.168.2.24 255.255.255.248 not-advertise

area 3 range 192.168.2.32 255.255.255.248 not-advertise

area 3 range 30.0.64.0 255.255.224.0 advertise

exit

R3

conf t

router ospf 1

area 3 range 192.168.2.24 255.255.255.248 not-advertise

area 3 range 192.168.2.32 255.255.255.248 not-advertise

area 3 range 192.168.2.8 255.255.255.248 not-advertise

area 3 range 192.168.2.48 255.255.255.248 not-advertise

area 3 range 192.168.2.64 255.255.255.248 not-advertise

area 3 range 30.0.64.0 255.255.224.0 advertise

exit

R5

conf t

router ospf 1

area 2 range 192.168.2.16 255.255.255.248 not-advertise

area 2 range 192.168.2.8 255.255.255.248 not-advertise

area 2 range 192.168.2.56 255.255.255.248 not-advertise

area 2 range 192.168.2.64 255.255.255.248 not-advertise

area 2 range 30.0.32.0 255.255.224.0 advertise

exit

7. Защита сети OSPF

В качестве средств защиты предполагается использование пассивных интерфейсов и механизмов аутентификации OSPF. Аутентификация маршрутов необходима для того, чтобы маршрутизатор принимал анонсы только от авторизированных маршрутизаторов. Настройку средств аутентификации необходимо провести для каждого интерфейса маршрутизатора, те интерфейсы маршрутизаторов, которые подсоединены к пользовательским сетям, должны быть переведены в пассивный режим. Аутентификацию также необходимо проводить и для виртуального канала.

ASBR1

conf t

router ospf 1

area 1 authentication message-digest

exit

int f0/0

ip ospf message-digest-key 1 md5 eternity

exit

ASBR2

conf t

router ospf 1

area 1 authentication message-digest

exit

int f0/0

ip ospf message-digest-key 1 md5 eternity

exit

ABR1

conf t

router ospf 1

area 1 authentication message-digest

area 0 authentication message-digest

exit

int f0/0

ip ospf message-digest-key 1 md5 eternity

exit

int s1/0.1

ip ospf message-digest-key 2 md5 eternity

exit

int s1/0.2

ip ospf message-digest-key 2 md5 eternity

exit

ABR2

conf t

router ospf 1

area 0 authentication message-digest

area 2 authentication message-digest

exit

int s1/0.2

ip ospf message-digest-key 2 md5 eternity

exit

int f0/0

ip ospf message-digest-key 3 md5 eternity

exit

int f0/1

ip ospf message-digest-key 3 md5 eternity

exit

R2

conf t

router ospf 1

area 2 authentication message-digest

exit

int f0/0

ip ospf message-digest-key 3 md5 eternity

exit

R3

conf t

router ospf 1

area 2 authentication message-digest

exit

int f0/0

ip ospf message-digest-key 3 md5 eternity

exit

ABR3

conf t

router ospf 1

area 0 authentication message-digest

area 3 authentication message-digest

exit

int s1/0.1

ip ospf message-digest-key 2 md5 eternity

exit

int f0/0

ip ospf message-digest-key 4 md5 eternity

exit

ABR4

conf t

router ospf 1

area 0 authentication message-digest

area 3 authentication message-digest

exit

int s1/0.1

ip ospf message-digest-key 2 md5 eternity

exit

int f0/0

ip ospf message-digest-key 4 md5 eternity

exit

R4

conf t

router ospf 1

area 3 authentication message-digest

exit

int f0/0

ip ospf message-digest-key 4 md5 eternity

exit

int f0/1

ip ospf message-digest-key 4 md5 eternity

exit

R5

conf t

router ospf 1

area 3 authentication message-digest

area 0 authentication message-digest

exit

int f0/0

ip ospf message-digest-key 4 md5 eternity

exit

int f0/1

ip ospf message-digest-key 4 md5 eternity

exit

Для аутентификации виртуального канала между маршрутизатором ASBR2 и R2 необходимо разрешить аутентификацию в области 1 и 2 , так как интерфейсы виртуального канала лежат именно в этих областях, после разрешения средств аутентификации в области 1 и 2 необходимо задать пароль для виртуального канала с помощью команды area [area-id] virtual-link [router id] authentication-key [encryption type] [password], предварительно удалить существующий виртуальный канал.

ABR2

conf t

router ospf 1

area 2 authentication message-digest

no area 2 virtual-link 192.168.2.27

area 2 virtual-link 192.168.2.27 authentication-key 5 eternity

exit

exit

R5

conf t

router ospf 1

area 2 authentication message-digest

no area 2 virtual-link 192.168.2.49

area 2 virtual-link 192.168.2.49 authentication-key 5 eternity

exit

exit

После настройки средств аутентификации в режиме конфигурации протокола OSPF необходимо перевести все пользовательские интерфейсы в пассивный режим, тем самым прекратится передача анонсов OSPF в пользовательские сети, с помощью команды passive-interface [interface].

R1

conf t

router ospf 1

passive-interface fastEthernet 1/0

exit

exit

ASBR1

conf t

router ospf 1

passive-interface fastEthernet 1/0

passive-interface fastEthernet 1/1

exit

exit

ASBR2

conf t

router ospf 1

passive-interface fastEthernet 1/0

passive-interface fastEthernet 1/1

exit

exit

ABR2

conf t

router ospf 1

passive-interface fastEthernet 2/0

exit

exit

R2

conf t

router ospf 1

passive-interface fastEthernet 1/1

passive-interface fastEthernet 1/0

passive-interface fastEthernet 0/1

exit

exit

R3

conf t

router ospf 1

passive-interface fastEthernet 1/1

passive-interface fastEthernet 1/0

passive-interface fastEthernet 0/1

exit

exit

ABR3

conf t

router ospf 1

passive-interface fastEthernet 0/1

exit

exit

R4

conf t

router ospf 1

passive-interface fastEthernet 1/0

passive-interface fastEthernet 1/1

exit

exit

R5

conf t

router ospf 1

passive-interface fastEthernet 1/0

passive-interface fastEthernet 1/1

exit

exit

8.Анализ сообщений протокола OSPF

После настройки маршрутизаторов необходимо осуществить захват следующих типов сообщений протокола OSPF:

- приветственный пакет (Hello Packet);

- пакет с описанием базы данных (DataBase Description);

- пакет с запросом о состоянии канала (Link-State Request);

- пакет с обновлениями о состоянии канала (Link-State Update);

- пакет тип 4 с LSA1;

- пакет тип 4 с LSA2;

- пакет тип 4 с LSA3;

- пакет тип 4 с LSA4;

- пакет тип 4 с LSA5;

- пакет тип 4 с LSA7;

- пакет с подтверждением о состоянии канала (Link-State Ack).

Для расшифровки пакетов воспользуемся рекомендацией RFC 2328.

Разберем приветственный пакет (Hello Packet).

Hello-пакет используется для таких целей:

- с помощью него каждый маршрутизатор обнаруживает своих соседей;

- он передает параметры о которых маршрутизаторы должны договориться прежде чем они станут соседями;

- hello-пакеты выполняют роль keepalive-пакетов (интервал между проверочными пакетами) между соседями;

- отвечает за установление двухсторонних коммуникаций между соседними маршрутизаторами (двухсторонняя коммуникация установлена тогда, когда маршрутизатор увидит себя в списке соседей hello-пакета полученного от соседнего маршрутизатора);

- он выбирает DR и BDR в широковещательных и не широковещательных сетях со множественным доступом.

Open Shortest Path First

OSPF Header

Version: 2

Message Type: Hello Packet (1)

Packet Length: 48

Source OSPF Router: 192.168.2.41

Area ID: 0.0.0.0 (Backbone)

Checksum: 0x0000 (None)

Auth Type: Cryptographic (2)

Auth Crypt Key id: 2

Auth Crypt Data Length: 16

Auth Crypt Sequence Number: 1492704629

Auth Crypt Data: 578b3492b406ec00e75afc7d3c91f839

OSPF Hello Packet

Network Mask: 255.255.255.248

Hello Interval [sec]: 10

Options: 0x12 ((L) LLS Data block, (E) External Routing)

0... .... = DN: Not set

.0.. .... = O: Not set

..0. .... = (DC) Demand Circuits: Not supported

...1 .... = (L) LLS Data block: Present

.... 0... = (N) NSSA: Not supported

.... .0.. = (MC) Multicast: Not capable

.... ..1. = (E) External Routing: Capable

.... ...0 = (MT) Multi-Topology Routing: No

Router Priority: 1

Router Dead Interval [sec]: 40

Designated Router: 192.168.2.41

Backup Designated Router: 192.168.2.42

Active Neighbor: 192.168.2.42

OSPF LLS Data Block

Checksum: 0x0000

LLS Data Length: 36 bytes

Extended options TLV

TLV Type: 1

TLV Length: 4

Options: 0x00000001 ((LR) LSDB Resynchronization)

.... .... .... .... .... .... .... ..0. = (RS) Restart Signal: Not set

.... .... .... .... .... .... .... ...1 = (LR) LSDB Resynchronization: Set

Crypto Authentication TLV

TLV Type: 2

TLV Length: 20

Sequence number: 0x58f8dd75

Auth Data: 759b06baffa05979d26a2578ebb8a097

Пакет с описанием базы данных (DataBase Description). Пакеты DD относятся в OSPF к типу 2. Обмен этими пакетами происходит при инициализации отношений смежности. Пакеты описывают содержимое базы данных о каналах. Для описания базы данных может использоваться множество пакетов с использованием процедуры poll-response (опрос-отклик). Один из маршрутизаторов является ведущим (master), а второй - ведомым (slave). Ведущий маршрутизатор передает пакеты DD, которые подтверждаются пакетами DD от ведомого маршрутизатора. Отклики связываются с опросом через порядковые номера пакетов DD.

Open Shortest Path First

OSPF Header

Version: 2

Message Type: DB Description (2)

Packet Length: 32

Source OSPF Router: 192.168.2.41

Area ID: 0.0.0.0 (Backbone)

Checksum: 0x0000 (None)

Auth Type: Cryptographic (2)

Auth Crypt Key id: 2

Auth Crypt Data Length: 16

Auth Crypt Sequence Number: 1492704748

Auth Crypt Data: d6868ab99c863f490ea34c3316a920aa

OSPF DB Description

Interface MTU: 1500

Options: 0x52 (O, (L) LLS Data block, (E) External Routing)

0... .... = DN: Not set

.1.. .... = O: Set

..0. .... = (DC) Demand Circuits: Not supported

...1 .... = (L) LLS Data block: Present

.... 0... = (N) NSSA: Not supported

.... .0.. = (MC) Multicast: Not capable

.... ..1. = (E) External Routing: Capable

.... ...0 = (MT) Multi-Topology Routing: No

DB Description: 0x07 ((I) Init, (M) More, (MS) Master)

.... 0... = (R) OOBResync: Not set

.... .1.. = (I) Init: Set

.... ..1. = (M) More: Set

.... ...1 = (MS) Master: Yes

DD Sequence: 700

OSPF LLS Data Block

Checksum: 0x0000

LLS Data Length: 36 bytes

Extended options TLV

TLV Type: 1

TLV Length: 4

Options: 0x00000001 ((LR) LSDB Resynchronization)

.... .... .... .... .... .... .... ..0. = (RS) Restart Signal: Not set

.... .... .... .... .... .... .... ...1 = (LR) LSDB Resynchronization: Set

Crypto Authentication TLV

TLV Type: 2

TLV Length: 20

Sequence number: 0x58f8ddec

Auth Data: 6902d64489b3f3ebb6f76d804375a27b

Пакет с запросом о состоянии канала (Link-State Request). Пакеты LSR относятся в OSPF к типу 3. После обмена пакетами DD с соседом маршрутизатор может понять, что часть его базы данных устарела. Пакеты LSR служат для запроса более современных фрагментов базы данных у соседа. При обновлении может использоваться множество пакетов LSR. Маршрутизатор, передающий запрос LSR, должен помнить конкретный экземпляр запрашиваемого фрагмента базы данных. Экземпляры идентифицируются порядковым номером, возрастом и контрольной суммой, но эти поля не указываются в самом пакете LSR. Маршрутизатор в ответ на запрос может получить даже более свежий (по сравнению с запрошенным) экземпляр.

Frame 96: 160 bytes on wire (1280 bits), 160 bytes captured (1280 bits)

Frame Relay

Internet Protocol Version 4, Src: 192.168.2.1, Dst: 192.168.2.2

Open Shortest Path First

OSPF Header

Version: 2

Message Type: LS Request (3)

Packet Length: 120

Source OSPF Router: 192.168.2.41

Area ID: 0.0.0.0 (Backbone)

Checksum: 0x0000 (None)

Auth Type: Cryptographic (2)

Auth Crypt Key id: 2

Auth Crypt Data Length: 16

Auth Crypt Sequence Number: 1492704748

Auth Crypt Data: 661fc718cdc7438ce935dd5a558fc5cf

Link State Request

LS Type: Router-LSA (1)

Link State ID: 192.168.2.29

Advertising Router: 192.168.2.29

Link State Request

LS Type: Summary-LSA (IP network) (3)

Link State ID: 192.168.2.56

Advertising Router: 192.168.2.29

Link State Request

LS Type: Summary-LSA (IP network) (3)

Link State ID: 192.168.2.24

Advertising Router: 192.168.2.29

Link State Request

LS Type: Summary-LSA (IP network) (3)

Link State ID: 30.0.88.0

Advertising Router: 192.168.2.29

Link State Request

LS Type: Summary-LSA (IP network) (3)

Link State ID: 30.0.80.0

Advertising Router: 192.168.2.29

Link State Request

LS Type: Summary-LSA (IP network) (3)

Link State ID: 30.0.72.0

Advertising Router: 192.168.2.29

Link State Request

LS Type: Summary-LSA (IP network) (3)

Link State ID: 30.0.71.255

Advertising Router: 192.168.2.29

Link State Request

LS Type: Summary-LSA (IP network) (3)

Link State ID: 30.0.56.0

Advertising Router: 192.168.2.29

Пакет с обновлениями о состоянии канала (Link-State Update). Пакеты LSU относятся в OSPF к типу 4 и используются для лавинной рассылки LSA. Каждый пакет LSU передает набор LSA на один интервал от точки их происхождения. В одном пакете может содержаться множество LSA. Пакеты LSU являются групповыми для сетей поддерживающих широковещательную и групповую адресацию. Для обеспечения надежности процедуры лавинной рассылки отправленные LSA подтверждаются в пакетах LSAck. Если требуется повтор передачи некоторых LSA, они всегда передаются соседу напрямую.

Open Shortest Path First

OSPF Header

Version: 2

Message Type: LS Update (4)

Packet Length: 260

Source OSPF Router: 192.168.2.29

Area ID: 0.0.0.0 (Backbone)

Checksum: 0x0000 (None)

Auth Type: Cryptographic (2)

Auth Crypt Key id: 2

Auth Crypt Data Length: 16

Auth Crypt Sequence Number: 1492704748

Auth Crypt Data: 79d0a7d42900761d6bd92780eaaf1f5b

LS Update Packet

Number of LSAs: 8

LSA-type 1

LSA-type 2

LSA-type 3

LSA-type 4

LSA-type 5

Пакет тип 4 с LSA1. Router-LSA относятся к типу 1 и порождаются каждым маршрутизатором области. Эти LSA описывают состояние и стоимость каналов (интерфейсов) маршрутизатора в область. Все каналы маршрутизатора в область должны описываться в одном анонсе router LSA.

LSA-type 1 (Router-LSA), len 36

.000 0000 0000 0001 = LS Age (seconds): 1

0... .... .... .... = Do Not Age Flag: 0

Options: 0x22 ((DC) Demand Circuits, (E) External Routing)

0... .... = DN: Not set

.0.. .... = O: Not set

..1. .... = (DC) Demand Circuits: Supported

...0 .... = (L) LLS Data block: Not Present

.... 0... = (N) NSSA: Not supported

.... .0.. = (MC) Multicast: Not capable

.... ..1. = (E) External Routing: Capable

.... ...0 = (MT) Multi-Topology Routing: No

LS Type: Router-LSA (1)

Link State ID: 192.168.2.41

Advertising Router: 192.168.2.41

Sequence Number: 0x80000013

Checksum: 0x8b03

Length: 36

Flags: 0x01 ((B) Area border router)

.... .0.. = (V) Virtual link endpoint: No

.... ..0. = (E) AS boundary router: No

.... ...1 = (B) Area border router: Yes

Number of Links: 1

Type: Transit ID: 192.168.2.41 Data: 192.168.2.41 Metric: 64

Link ID: 192.168.2.41 - IP address of Designated Router

Link Data: 192.168.2.41

Link Type: 2 - Connection to a transit network

Number of Metrics: 0 - TOS

0 Metric: 64

Пакет тип 4 с LSA2. Network-LSA относятся к типу 2 и генерируются для каждой широковещательной и NBMA-сети в области, поддерживающей более 1 маршрутизатора. Анонсы network-LSA порождаются выделенным маршрутизатором DR и описывают все подключенные к сети маршрутизаторы, включая DR. Поле Link State ID содержит IP-адрес интерфейса DR. Дистанция от сети до всех подключенных маршрутизаторов равна 0, поэтому поле метрики не включается в network-LSA.

LSA-type 2 (Network-LSA), len 32

.000 0000 0000 0001 = LS Age (seconds): 1

0... .... .... .... = Do Not Age Flag: 0

Options: 0x22 ((DC) Demand Circuits, (E) External Routing)

0... .... = DN: Not set

.0.. .... = O: Not set

..1. .... = (DC) Demand Circuits: Supported

...0 .... = (L) LLS Data block: Not Present

.... 0... = (N) NSSA: Not supported

.... .0.. = (MC) Multicast: Not capable

.... ..1. = (E) External Routing: Capable

.... ...0 = (MT) Multi-Topology Routing: No

LS Type: Network-LSA (2)

Link State ID: 192.168.2.41

Advertising Router: 192.168.2.41

Sequence Number: 0x80000004

Checksum: 0xcb1f

Length: 32

Netmask: 255.255.255.248

Attached Router: 192.168.2.41

Attached Router: 192.168.2.42

Пакет тип 4 с LSA3. Summary-LSA относятся к типам 3 и 4 и генерируются граничными маршрутизаторами областей. Анонсы Summary-LSA описывают междоменные маршруты. Анонсы summary-LSA типа 3 используются в тех случаях, когда адресатом является сеть IP. В этом случае поле Link State ID содержит IP-номер сети (при необходимости Link State ID может включать также биты адреса хоста. Когда адресатом является граничный маршрутизатор AS, используется summary-LSA типа 4 и поле Link State ID содержит OSPF Router ID граничного маршрутизатора AS. За исключением различий в использовании поля Link State ID анонсы summary-LSA типов 3 и 4 идентичны. Для тупиковых областей summary-LSA типа 3 могут также использоваться для описания принятых по умолчанию маршрутов (по областям). Такие маршруты используются в тупиковых областях взамен лавинной рассылки полного набора внешних маршрутов. При описании используемого по умолчанию маршрута поле Link State ID в summaryLSA всегда содержит значение DefaultDestination (0.0.0.0), а Network Mask = 0.0.0.0.

LSA-type 3 (Summary-LSA (IP network)), len 28

.000 0000 1110 0001 = LS Age (seconds): 225

0... .... .... .... = Do Not Age Flag: 0

Options: 0x22 ((DC) Demand Circuits, (E) External Routing)

0... .... = DN: Not set

.0.. .... = O: Not set

..1. .... = (DC) Demand Circuits: Supported

...0 .... = (L) LLS Data block: Not Present

.... 0... = (N) NSSA: Not supported

.... .0.. = (MC) Multicast: Not capable

.... ..1. = (E) External Routing: Capable

.... ...0 = (MT) Multi-Topology Routing: No

LS Type: Summary-LSA (IP network) (3)

Link State ID: 192.168.2.56

Advertising Router: 192.168.2.29

Sequence Number: 0x8000000f

Checksum: 0x9473

Length: 28

Netmask: 255.255.255.248

TOS: 0

Metric: 2

Пакет тип 4 LSA5. AS-external-LSA относятся к типу 5 и генерируются граничными маршрутизаторами AS для описания внешних маршрутов из AS Анонсы AS-external-LSA обычно описывают маршрут к отдельному адресату (сети). Для таких LSA поле Link State ID содержит IP-номер сети (при необходимости в него могут также включаться некоторые биты адреса хоста). Анонсы AS-external-LSA также используются для описания принятых по умолчанию маршрутов (эти маршруты применяются в случае отсутствия другого пути к адресату). В таких случаях поле Link State ID всегда содержит значение Default Destination (0.0.0.0), а поле Network Mask имеет значение 0.0.0.0.

LSA-type 5 (AS-External-LSA (ASBR)), len 36

.000 0000 0000 0010 = LS Age (seconds): 2

0... .... .... .... = Do Not Age Flag: 0

Options: 0x20 ((DC) Demand Circuits)

0... .... = DN: Not set

.0.. .... = O: Not set

..1. .... = (DC) Demand Circuits: Supported

...0 .... = (L) LLS Data block: Not Present

.... 0... = (N) NSSA: Not supported

.... .0.. = (MC) Multicast: Not capable

.... ..0. = (E) External Routing: Not capable

.... ...0 = (MT) Multi-Topology Routing: No

LS Type: AS-External-LSA (ASBR) (5)

Link State ID: 192.168.2.32

Advertising Router: 192.168.2.34

Sequence Number: 0x8000000a

Checksum: 0x9c5f

Length: 36

Netmask: 255.255.255.248

0... .... = External Type: Type 1 (metric is specified in the same units as interface cost)

.000 0000 = TOS: 0

Metric: 30

Forwarding Address: 0.0.0.0

External Route Tag: 0

Пакет Link State Acknowledgment. Пакеты LSAck относятся в OSPF к типу 5. Для обеспечения надежности лавинной рассылки LSA, все анонсы должны подтверждаться в явной форме. Подтверждения обеспечиваются с помощью пакетов LSAck, каждый из которых может подтверждать прием множества LSA. В зависимости от состояния передающего интерфейса и отправителя соответствующего пакета LSU, пакеты LSAck передаются по групповым (AllSPFRouters или AllDRouters) или индивидуальным адресам. Формат пакетов подтверждения поход на формат пакетов DD. Тело пакета просто содержит список заголовков подтверждаемых LSA. Каждый подтверждаемый анонс LSA описывается заголовком LSA, содержащим все сведения для идентификации LSA и текущего экземпляра.

Open Shortest Path First

OSPF Header

LSA-type 1 (Router-LSA), len 48

.000 0000 0000 0001 = LS Age (seconds): 1

0... .... .... .... = Do Not Age Flag: 0

Options: 0x22 ((DC) Demand Circuits, (E) External Routing)

0... .... = DN: Not set

.0.. .... = O: Not set

..1. .... = (DC) Demand Circuits: Supported

...0 .... = (L) LLS Data block: Not Present

.... 0... = (N) NSSA: Not supported

.... .0.. = (MC) Multicast: Not capable

.... ..1. = (E) External Routing: Capable

.... ...0 = (MT) Multi-Topology Routing: No

LS Type: Router-LSA (1)

Link State ID: 192.168.2.41

Advertising Router: 192.168.2.41

Sequence Number: 0x80000014

Checksum: 0x9c3c

Length: 48

Заключение

Internet состоит из сетей, управляемых разными организациями. Каждая такая сеть использует внутри свои алгоритмы маршрутизации и управления. И называется Автономной системой. Наличие стандартов позволяет преодолеть различия во внутренней организации автономных систем и обеспечить их совместное функционирование. Алгоритм маршрутизации OSPF, относиться к протоколам внутренних шлюзов, но может принимать и передавать данные о путях другим автономным системам. Протокол OSPF опубликован в открытой литературе поэтому не является собственностью какой-либо компании, что делает его применяемым в сетях построенных на сетевом оборудовании различных фирм производителей. Алгоритм маршрутизации OSPF умеет работать с разными метриками расстояния, пропускной способностью, задержками , является динамическим, т.е. реагирует на изменении в топологии сети автоматически и быстро, поддерживает разные виды сервиса, поддерживает маршрутизацию в реальном времени для одних потоков и другую для других, обеспечивает балансировку нагрузки и при необходимости разделять потоки по разным каналам.

Из вышесказанного можно сделать вывод, что использования алгоритма динамической маршрутизации OSPF придаёт автоматизированной системе значительно большую гибкость и оптимизирует её работу.

Список использованных источников

1. Амато Вито. Основы организации сетей Cisco, том 1. М.: Издательский дом "Вильяме", 2004. - 512с.

2. Амато Вито. Основы организации сетей Cisco, том 2. М.: Издательский дом "Вильяме", 2004. - 464с.

3. Системы документальной электросвязи: учебно-методическое пособие для выполнения курсового проекта [Электронный ресурс] / сост. К. Э. Гаипов, А.Ю.Турбов. - Электрон. дан. - Красноярск: Сиб. федер. ун-т, 2013.

4. Маршрутизаторы: учебное пособие / М.В. Дибров. - Красноярск 2008.

Размещено на Allbest.ru


Подобные документы

  • Классическая технология коммутации пакетов. Взаимоотношения между объектами сети Х.25. Сквозная передача между устройствами DTE. Первые предложения по стандартам протокола Frame Relay. Процесс передачи данных через коммутируемые виртуальные каналы.

    доклад [2,0 M], добавлен 12.01.2011

  • Ключевые особенности и принципы работы Frame Relay (FR). Виртуальные каналы, их виды. Преимущества реализации технологии FR. Дополнение традиционных мультиплексоров интерфейсами FR для информационных устройств как обычный способ реализации частной сети.

    курсовая работа [884,7 K], добавлен 20.12.2015

  • Особенности проектирования и анализ современных информационных локальных и глобальных вычислительных сетей. Проведение настройки виртуальной локальной вычислительной сети (VLAN), HTTP и DNS серверов, сетевых протоколов OSPF, RIP, STP, технологий NAT.

    курсовая работа [182,1 K], добавлен 16.01.2014

  • Разработка структурной схемы компьютерной сети на базе технологии канального уровня Ethernet, содержащую 3 подсети, 53 компьютера, сервера NTP и DNS. Установка ip-адресов сетевых интерфейсов. Соединение отдельных частей сети с помощью маршрутизаторов.

    курсовая работа [2,0 M], добавлен 23.12.2015

  • Локальные вычислительные сети. Пропускная способность сети. Определение загруженности сети. Выбор физической среды передачи данных. Распределение адресного пространства. Проверочный расчет времени двойного оборота. Пассивное сетевое оборудование.

    курсовая работа [2,9 M], добавлен 17.02.2012

  • Применение компьютерных сетей для организации сетевого взаимодействия. Планирование адресного пространства для сети, управление коммутатором. Физическая структура сети, подбор аппаратного и программного обеспечения. Топология сети и сетевых протоколов.

    курсовая работа [1,3 M], добавлен 12.07.2012

  • Особенности проектирования локальной сети для учебного учреждения на основе технологии Ethernet, с помощью одного сервера. Описание технологии работы сети и режимов работы оборудования. Этапы монтажа сети, установки и настройки программного обеспечения.

    курсовая работа [1,9 M], добавлен 16.02.2010

  • Принцип деятельности ООО "МАГМА Компьютер". Особенности предметной области. Цели создания компьютерной сети. Разработка конфигурации сети. Выбор сетевых компонентов. Перечень функций пользователей сети. Планирование информационной безопасности сети.

    курсовая работа [2,3 M], добавлен 17.09.2010

  • Разработка структурной схемы компьютерной сети. Планирование топологии сети, настройка серверов. Принципы распределения IP-адресов. Расчет удвоенной задержки распространения сигнала. Моделирование потоков трафика в сети. Сетевые протоколы, их особенности.

    курсовая работа [1,2 M], добавлен 23.12.2015

  • Формирование подсетей для сети с IP-адресом. Объединение 60 станций в составную сеть. Использование протокола ARP для определения MAC-адреса по IP-адресу. IP-маршрутизация в операционной системе Windows IP-адреса отдельных сетей составной сети.

    курсовая работа [64,6 K], добавлен 16.01.2011

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.