Основы работы в системах Turbo Pascal и Visual C++6.0

Программирование и структура программы на языке Turbo Pascal и MS Visual C++6.0. Вычисление площади круга. Реализация программы в системе Turbo Pascal и MS VISUAL C++6.0 для Windows. Структура окна ТРW. Сохранение текста программы в файле на диске.

Рубрика Программирование, компьютеры и кибернетика
Вид лабораторная работа
Язык русский
Дата добавления 22.03.2012
Размер файла 3,7 M

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru/

МОСКОВСКИЙЙ ГОСУДАРСТВЕННЫЙ ИСТИТУТ ЭЛЕКТРОННОЙ ТЕХНИКИ

(ТЕХНИЧЕСКИЙ УНИВЕРСИТЕТ)

Кафедра “Информатика и программное обеспечение вычислительных систем”

Дисциплина “Информатика”

ЛАБОРАТОРНАЯ РАБОТА

Основы работы в системах Turbo Pascal и Visual C++ 6.0

Разработали:

доц. Голова С.Ю.

доц. Кемарская Е.Б.

МОСКВА - 2006 г.

Лабораторная работа

Основы программирования в системах Turbo Pascal и VISUAL C++6.0

Цель работы: 1) получить первые навыки работы в среде системы Turbo Pascal и системы VISUAL C++6.0; 2) на учиться создавать, редактировать и выполнять простые программы, написанные на языке Pascal и языке C++.

Теоретические сведения

Основные этапы решения задач на компьютере

Для решения любой задачи с помощью компьютера необходимо выполнить 6 этапов.

Рассмотрим эти этапы на конкретном примере.

Задача: вычислить площадь круга при заданном радиусе.

I этап - математическая постановка задачи. Формула вычисления площади круга имеет вид: , где R - радиус круга, р - константа, S - площадь круга.

II этап - определение входных и выходных данных: в нашем случае R и р - входные данные; S - выходное данное.

III этап - описание алгоритма решения задачи: рассмотрим графический способ описания алгоритма в виде схемы. На рис.1 представлены два варианта схемы алгоритма: Схемы различаются способом задания значения радиуса R: в Варианте1 значение радиуса R вычисляется, а в Варианте2 значение радиуса R вводится с клавиатуры.

Рис.1. Два варианта схем алгоритма вычисления площади круга.

IV этап - кодирование алгоритма, т.е. составление программы на выбранном языке программирования (например, языки программирования Pascal, С++ и т.д.)

V этап - ввод, отладка и тестирование программы.

VI этап - выполнение и сопровождение программы.

Замечание. I, II и III этапы не зависят от конкретной марки компьютера и конкретного языка программирования; реализация IV, V и VI этапов связана с конкретно выбранным языком и системой программирования.

Системы программирования

Системы программирования - это особый вид программного обеспечения. В основу каждой системы программирования положен свой язык программирования, что и отражено в названии системы.

Система программирования представляет собой интегрированную среду разработки программ, которая содержит:

- редактор текста - для создания и редактирования текста программы на языке высокого уровня, т.е. формирования исходного модуля (при сохранении текста программы в файле каждая система программирования по умолчанию дает свое стандартное расширение имени файла, например, системы на основе языка Pascal дают расширение .pas , системы на основе языка С++ - расширение .cpp).

- компилятор - для перевода текста программы с языка высокого уровня в машинные коды, т.е. формирование объектного модуля (например, в системе TurboPascal - файл с расширением tpu; в системе на основе языка С++ - файл с расширением obj);

- компоновщик - для подключение объектных кодов стандартных команд и формирования загрузочного модуля (файл с расширением .exe)

- загрузчик - для выполнение загрузочного модуля программы.

Интегрированная среда разработки программ позволяет:

- создавать и редактировать исходные тексты программ;

- сохранять исходные тексты программ в файлах;

- считывать файлы с диска;

- осуществлять поиск и исправление ошибок (отладка);

- выполнять программу и просматривать результаты выполнения.

В данной работе рассмотрим реализацию IV, V, VI этапов в двух системах программирования: TurboPascal для Windows и Microsoft VISUAL C++6.0.

Программирование в системе TurboPascal

Структура программы на языке Pascal

Программа на языке Pascal состоит из заголовка, раздела подключения модулей, раздела описаний и раздела операторов:

Program имя;

Uses < список модулей >;

раздел описаний

Begin

раздел операторов

End.

Заголовок программы начинается с зарезервированного слова Program и содержит имя программы, которое дает сам программист.

Подключение модулей начинается с зарезервированного слова Uses и содержит список модулей (библиотек внешних процедур и функций).

Раздел описаний состоит из подразделов, в которых объявляются все встречающиеся в программе объекты: метки (Label), константы (Const), типы (Type), переменные (Var), внутренние процедуры (Procedure), внутренние функции (Function). Описания отделяются друг от друга точкой с запятой.

Раздел операторов заключается в операторные скобки Begin и End, при этом после End ставится точка. Операторы отделяются друг от друга точкой с запятой.

Примеры программ на языке Pascal

Рассмотрим два примера программ соответственно двум вариантам схем алгоритма (рис. 1).

Пример 1. Программа вычисления площади круга (схема алгоритма Варианта1) ( значение радиуса задается оператором присваивания)

{ Вариант 1: Вычисление площади круга }

Program PRIM1; {заголовок программы}

Uses WinСrt; {подключение модуля управления экраном в текстовом режиме}

Const {подраздел объявления констант}

Pi=3.14; {задание константы Pi}

Var {подраздел объявления переменных}

R,S: Real; {переменные вещественного типа - радиус и площадь круга}

Begin {начало раздела операторов}

Clrscr; {очистка экрана}

R:=1.5; {оператор присваивания переменной R значения 1.5}

S:=Pi*R*R; {оператор присваивания для вычисления S }

Writeln(`S=',S:7:3); {вывод на экран значения S}

End. {конец программы}

Пояснения к программе:

1. Программа начинается с комментария, который заключается в фигурные скобки. Комментарии могут располагаться как вне, так и внутри программы. В комментариях разрешается указывать все символы клавиатуры.

2. После комментария идет заголовок программы, содержащий ее имя PRIM1.

3. В разделе Uses указывается подключаемый к программе модуль WinCrt, содержащий средства работы с экраном (например, очистка экрана процедурой ClrScr).

4. В разделе описаний - два подраздела:

4.1. подраздел констант (Const), где определена константа Pi;

4.2. подраздел переменных (Var), где объявляются все переменные, используемые в разделе операторов и резервируются ячейки оперативной памяти; в нашем случае это переменные действительного типа - R и S.

5. Раздел операторов заключается в операторные скобки (Begin и End.) и содержит:

5.1. вызов процедуры ClrScr для очистки экрана во время выполнения программы;

5.2. два оператора присваивания:

- задание переменной R значения 1.5;

- вычисление площади круга S (операция присваивания имеет вид “:=”);

5.3. оператор вывода значения переменной S на экран: Writeln(`S=',S:7:3)

Пояснения к оператору вывода:

а) для оператора вывода есть два ключевых слова Write или Writeln

б) оператор Writeln(параметры) означает вывод параметров и последующий переход на новую строку (параметры записываются через запятую);

б) оператор Write(параметры) означает вывод параметров без перехода на новую строку

в) оператор Writeln без параметров означает переход на новую строку;

г) в списке параметров могут быть строки символов и имена переменных:

· для вывода строки символов используются ограничивающие апострофы, например, `S=' или `Результаты вычислений'

· при выводе значение действительной переменной может иметь два представления:

1-е - с фиксированной точкой: в этом случае указывается имя переменной, за которой через двоеточие стоят форматы (S:7:3), где первое число (7) обозначает общее поле выводимого значения, второе число (3) - поле дробной части. Общее поле включает:

- отрицательный знак числа или пробел для положительного числа,

- количество цифр в целой части,

- десятичную точку,

- количество цифр в дробной части.

Так в нашем случае вывод значения S в соответствии с форматом S:7:3 означает, что на изображение всего числа отведено 7 позиций, из них 3 позиции справа на дробную часть, 4-я позиция справа на десятичную точку, остальные - на целую часть. Результат будет иметь вид: S= 7.065

2-е - с плавающей точкой: в этом случае указывается только имя переменной без форматов, например, Write(`S=',S). Результат будет иметь вид: S= 7.0650000000Е+00

Пример 2. Программа вычисления площади круга (схема алгоритма Варианта2) ввод значения радиуса с клавиатуры)

{ Вариант 2: Вычисление площади круга }

Program PRIM2;

Uses WinСrt;

Const

Pi=3.14;

Var

R,S: Real;

Begin

Clrscr;

Write(`Введите радиус `); {вывод на экран текста запроса}

Readln(R); {ввод с клавиатуры значения R}

S:=Pi*R*R;

Writeln(`S=',S:7:3);

End.

Пояснения к программе:

1. Эта программа отличается от предыдущей только тем, что значение радиуса вводится с клавиатуры, а не присваивается в операторе присваивания. Операторы Write и Readln используются для организации диалога пользователя с компьютером:

- оператор Write(` Введите радиус `) выводит на экран текст: Введите радиус

- оператор Readln(R) служит для ввода с клавиатуры численного значения переменной R во время выполнения программы.

2. Все остальные части программы работают так же, как и в предыдущей программе.

Реализация программы в системе Turbo Pascal для Windows

Cистема Turbo Pascal для Windows (TPW) включает в себя:

- встроенный редактор текста;

- компилятор с языка Pascal;

- компоновщик;

- загрузчик;

- отладчик.

Cистема Turbo Pascal хранится на жестком диске в общей папке TPW и занимает около 7,5Мб на диске.

Загрузочный файл системы Turbo Pascal имеет имя TPW.exe

1. Запуск системы Turbo Pascal (TPW)

Запуск системы TPW можно осуществить несколькими способами:

1-й способ: найти и запустить загрузочный файл TPW.exe (D:\ TPW);

2-й способ: запуск ярлыка загрузочного файла TPW.exe

Задание 1. Создайте на Рабочем столе ярлык для запуска ТРW.

Задание 2. Запустите систему ТРW.

После запуска появится окно программы (рис.2):

Рис.2. Главное окно системы Turbo Pascal.

Ознакомьтесь со структурой окна ТРW

Структура окна программы Turbo Pascal (TPW).

Окно программы TPW - типичное окно программы в среде ОС Windows и содержит следующие элементы:

1-я (верхняя) строка - заголовок окна программы.

2-я строка - меню ТРW:

File - операции с файлами,

Edit - редактирование текста программы,

Search - поиск текста и ошибок,

Compile - компиляция программы,

Run - выполнение и отладка программы,

Options - выбор режимов,

Window - операции с окнами документов,

Help - вызов справки.

В центре окна программы - рабочее поле, в котором находятся одно или несколько окон документов (для создания исходных текстов программ).

Нижняя строка окна программы - статусная строка.

Структура окна документа:

1-я строка - заголовок окна документа (по умолчанию окна называются noname00.pas, noname01.pas и т.д.).

В центре окна документа - поле для набора текста программы. Текст каждой программы создается в отдельном окне документа и сохраняется в отдельном файле.

Справа и внизу окна документа - соответственно вертикальная и горизонтальная полосы прокрутки текста.

Замечание. После запуска ТРW мы находимся в режиме встроенного редактора текста: текстовый курсор находится в левом верхнем углу окна документа.

Создание текста программы на языке Pascal.

Наберите текст программы Варианта1.

Рекомендации по набору текста программы:

1) С целью рационального размещения текста не следует операторы программы писать сплошным текстом.

2) Для чёткого выявления вложенности управляющих структур требуется особым образом располагать операторы в тексте, так что служебные слова, которыми начинается и заканчивается тот или иной оператор, записываются на одной вертикали, а все вложенные в него операторы записываются с некоторым отступом вправо.

3) При записи конструкций языка более глубоких уровней вложенности следует сдвигать их от начала строки вправо.

4) Каждое описание и каждый оператор следует писать с новой строки. Продолжение описаний или операторов на новой строке надо сдвигать вправо. Следует избегать длинных строк. Допускается пропуск пустых строк.

5) В тексте программы заглавные и строчные буквы не различаются.

Сохранение текста программы в файле на диске

Сохраните текст программы на диске (например, D:) с именем Prim1p.pas.

Для этого:

· выполните команду меню File Save as...

· в диалоговом окне введите полное имя файла, например, D:\prim1p (расширение .pas присваивается по умолчанию)

· сделайте щелчок на кн. ОК или нажмите кл. Enter.

После закрытия диалогового окна имя файла появится в заголовке окна документа.

Вид окна программы с сохраненным текстом программы представлен на рис.3.

Рис.3. Окно системы ТРW вместе с сохраненным текстом программы Варианта1.

Компиляция и компоновка программы

Назначение компилятора:

1) проверка текста программы на наличие синтаксических ошибок;

2) в случае отсутствия ошибок перевод исходного текста программы с языка Pascal на язык машинных кодов, т.е. создание объектного кода программы.

Назначение компоновщика:

1) подключение к объектному коду программы объектных кодов внешних программных модулей (библиотек процедур и функций);

2) создание загрузочного кода программы (имя файла с расширением exe).

Откомпилируйте программу Prim1p

Для этого:

· установите текущий каталог D:\, чтобы загрузочный файл сохранился там же, где находится исходный файл, для этого:

o выполните команду меню Options Directories…

o в поле EXE and TPU Directories введите с клавиатуры D:\

· выполните команду меню Compile Compile или нажмите клавиши Alt+F9

( если в программе имеются ошибки, то строка с первой ошибкой закрашивается черным цветом, место ошибки отмечается курсором, сообщение об ошибке появляется в статусной строке окна программы);

· исправьте ошибки и повторите компиляцию и так до тех пор, пока не появится диалоговое окно с сообщением Successfully completed (компиляция завершена):

· сохраните исправленный текст программы (команда меню File Save).

Замечание. Команда Compile выполняет две функции - компилятора и компоновщика. В результате сформируется программный файл (в нашем случае Prim1p.exe).

· проверьте местонахождение загрузочного файла.

Выполнение программы.

Выполните программу Prim1p.

Для этого:

· выполните команду меню Run Run или нажмите клавиши Ctrl+F9 (появится окно с результатами выполнения, см. рис.4.).

· запишите результат и закройте окно выполнения.

Рис.4. Результат выполнения программы Варианта1.

Создание и выполнение новой версии программы

Создайте и выполните программу Варианта2.

Для этого:

· создайте новое окно документа в окне ТРW (команда меню File New);

· скопируйте текст программы Prim1p.pas в новое окно, для этого:

- активизируйте окно с файлом Prim1p.pas (кл. F6)

- выделите весь текст и скопируйте его в Буфер обмена (команда Edit Copy)

- активизируйте новое окно (кл. F6)

- вставьте текст из Буфера обмена (команда Edit Paste)

· в новом окне измените текст программы в соответствии с Вариантом2

· сохраните текст программы в своей папке в файле с именем Prim2p.pas ( команда меню File Save as…) (см. рис.5 )

Рис.5. Окно системы ТРW вместе с сохраненным текстом программы Варианта2.

· откомпилируйте программу Prim2p до успешного завершения;

· зафиксируйте правильный текст программы (команда File Save);

· выполните программу Prim2p (команда Run Run или клавиши Ctrl+F9). Автоматически появится окно выполнения программы с приглашением к вводу значения радиуса круга (рис.6.);

Рис.6. Окно выполнения с приглашением ввода радиуса

· в ответ на это приглашение наберите с клавиатуры число 1.5 и нажмите кл.Enter (в окне выполнения появится результат, см. рис.7);

· запишите результат в тетрадь;

· для продолжения работы закройте окно выполнения.

Рис.7. Окно выполнения с результатами работы программы Варианта2.

Закройте все окна на рабочем столе

Откройте программу Проводник и свою папку. Убедитесь в наличие исходных и программных файлов для каждого варианта.

Из окна Проводника запустите программный файл для Варианта1, затем для Варианта2. (Обратите внимание, что каждая программа выполняется в отдельном окне). Не закрывайте окна!

Запустите систему Turbo Рascal и откройте исходные файлы для Варианта1, затем для Варианта2 (команда меню File Open).

В окне Turbo Рascal расположите окна мозаикой (команда Window Tyle).

На Рабочем столе расположите каскадом все открытые окна.

Предъявите результаты работы преподавателю - окно Проводника, окно ТРW, два окна выполнения программ.

Часть2. Программирование в системе MS VISUAL C++6.0

программа pascal visual текст

Структура программы на языке С++

Программа на языке С++ состоит из директив препроцессора, описания глобальных объектов, функций написанных программистом и функции main() :

директивы препроцессора

описания глобальных объектов

функции, написанные программистом

void main()

{

операторы функции main

}

Директивы препроцессора включают в себя необходимые заголовочные файлы библиотек С++, определения констант, типов и макроопределений, используемых в программе.

Глобальные объекты - константы, типы, переменные используются во всех функциях программы, обеспечивая соответствие типов, значений констант и переменных во всей программе.

Функции - это особым образом оформленные части программы, которая выполняют действия необходимые программисту.

Функция main() - главная функция программы. Любая программа на С++ обязательно включает в себя функцию main(), с которой и начинает свое выполнение. Функция main() запускается операционной системой. Слово void перед именем функции main() означает, что функция main() не возвращает операционной системе никакой информации.

Тело функции заключено в фигурные скобки ` { } ' . Фигурные скобки ` { } ' обозначают начало и конец составного оператора (аналогично begin и end в TurboPascal). Точка с запятой ` ; ` завершает каждый оператор и каждое описание.

Программа может содержать комментарии, их можно вставлять в любое место программы, где допускаются пробелы или в конце строки. В С++ используются два вида комментариев:

/* многострочный

комментарий */

// однострочный комментарий до конца текущей строки

Примеры программ на языке С++

Рассмотрим два примера программ соответственно двум вариантам схемы алгоритма (рис. 1).

Пример 1. Программа вычисления площади круга (по схеме алгоритма Варианта1)

( значение радиуса задается оператором присваивания)

/* Вариант1: Вычисление площади круга */

#include <stdio.h> //директива препроцессора для подключения стандартной библиотеки

// ввода - вывода

void main() // заголовок функции main()

{

const float Pi=3.14; // определение вещественной константы Pi равной 3.14

float R,S; // оператор описания вещественных переменных R и S

R=1.5; // оператор присваивания переменной R значения 1.5

S=Pi*R*R; // оператор присваивания S вычисленного значения

printf(“S=%f\n”,S); // оператор вывода на экран значения S

}

Пояснения к программе

1. Первая строка - комментарий, который заключается в символы: /* комментарий */

Комментарии могут располагаться как вне, так и внутри программ. В комментариях разрешается указывать все символы клавиатуры.

2. Следующая директива препроцессора #include <stdio.h> подключает к программе стандартную библиотеку ввода-вывода. Директивы препроцессора располагаются строго на одной строке и начинаются с символа `#'.

3. Далее идет заголовок функции main(): отсутствие параметров в круглых скобках означает, что функция main() не возвращает никаких значений операционной системе и не получает от нее никакой информации. В теле функции внутри фигурных скобок:

3.1. Объявление и задание константы Pi .

3.2. Оператор описаний - float R,S резервирует ячейки оперативной памяти под переменные - R (радиус круга) и S (площадь круга).

3.3. Два оператора присваивания:

- задание переменной R значения 1.5;

- вычисление площади круга S (операция присваивания имеет вид “=”).

3.4. Оператор вывода значения S и соответствующих пояснений на экран

printf(“S=%f\n”,S);

Для вывода действительной переменной S указывается форматная спецификация - %f - соответствующая выводу вещественного значения с фиксированной точкой. Управляющий символ `\n' используется для перевода курсора на начало следующей строки экрана.

Пример 2. Программа вычисления площади круга (по схеме алгоритма Варианта2)

( ввод значения радиуса с клавиатуры)

/* Вариант2: Вычисление площади круга */

#include <stdio.h>

void main()

{

const float Pi=3.14;

float R,S;

printf(“R= “); //оператор вывода текста приглашения к вводу значения радиуса

scanf(%f”.&R); // оператор ввода с клавиатуры значения переменной R

S=Pi*R*R;

printf(“S=%f\n”,S);

}

Пояснения к программе:

1. Эта программа отличается от предыдущей только тем, что значение радиуса R вводится с клавиатуры, а не присваивается в операторе присваивания. Операторы printf и scanf используются для организации диалога пользователя с компьютером:

- оператор printf(“R= “) выводит на экран текст: R=

- оператор scanf(“%f”,&R) служит для ввода в соответствии с форматной спецификацией %f численного значения переменной R во время выполнения программы. Символ & (амперсанд) используется для того, чтобы введенное значение было записано по адресу переменной R.

2. Все остальные части программы работают так же, как и в предыдущей программе.

Реализация программы в системе Microsoft VISUAL C++6.0

Cистема Microsoft VISUAL C++6.0 (MVC++) включает в себя:

- встроенный редактор текста;

- компилятор с языка С++;

- компоновщик;

- загрузчик

- отладчик.

Cистема MVC++ хранится на жестком диске в общей папке MS Visual Studio и занимает около 50 Мб на диске.

Загрузочный файл системы MVC++ имеет имя MSDEV.exe

Понятие проекта

1. Основным объектом в системе MVC++ является проект.

2. Проект (project) - это набор файлов, которые совместно используются для создания одной программы. Обычно для каждой отдельной программы создается свой проект.

3. Проекты размещаются в рабочих областях. MVC++ автоматически создает рабочую область для каждого нового проекта.

4. В среде MVC++ можно строить различные типы проектов. Проекты создаются с помощью специальных средств - мастеров проектов. В данной работе рассмотрим создание проекта с помощью мастера Win32 Console Application.

Запуск системы MVC++

Запуск системы MVC++ можно осуществить несколькими способами:

1-й способ: кн. Пуск Программы MS Visual C++ 6.0 MS Visual C++ 6.0

2-й способ: найти и запустить загрузочный файл MSDEV.exe;

3-й способ запуск ярлыка MVC++ на Рабочем столе

На Рабочем столе создайте ярлык MVC++.

Запустите систему MVC++.

После запуска появится первое окно системы MVC++ (рис.8)

Рис.8. Главное окно VISUAL C++ 6.0

Структура окна программы MVC++

Окно программы MVC++ - типичное окно программы в среде Windows и содержит следующие элементы:

1-я (верхняя) строка - заголовок окна программы MVC++.

2-я строка - меню MVC++:

File - операции с файлами

Edit - редактирование текста программы

View

Insert -

Project -

Bield - компиляция, выполнение и отладка программы из текущего окна;

Tools - выбор режимов

Window - операции с окнами документов

Help - вызов справки.

3,4-е строки - панели инструментов.

В центре окна программы - рабочее поле, которое разделено на три .части

Слева от горизонтальной полосы прокрутки - закладки, где будут отображаться сообщения компилятора.

Нижняя строка окна программы - статусная строка.

Создание проекта

Создание проекта происходит в два этапа:

- сначала создается заготовка проекта,

- затем набирается текст конкретной программы, который компилируется и выполняется.

Создайте заготовку проекта с именем Pr1.

Для этого:

· выполните команду File New… (появится диалоговое окно New )

Рис.9. Диалоговое окно New среды VISUAL C++ 6.0

· в окне New активизируйте вкладку Projects :

- выберите тип проекта - Win32 Console Application;

- в поле Location установите нужную папку для расположения проекта, например, H:\

- в поле Project name введите имя проекта, например, Pr1 (имя проекта отобразится и в поле Location - H:\Pr1)

- щелкните на кнопке ОК (появится окно мастера проекта Win32 Console Application (рис.10)

Рис.10. Окно первого шага создания проекта в среде VISUAL C++ 6.0

· в окне Step1:

- выберите тип проекта: An empty application (пустой проект)

- нажмите кнопку Finish (проект в виде заготовки создан; появится информационное окно с характеристиками нового проекта (рис.11)

Рис.11. Информационное окно с характеристиками нового проекта

· в окне New Project Information для подтверждения характеристик щелкните на кн.ОК (появится окно нового проекта; см.рис.12)

Рис.12 Окно нового проекта PR1 в среде VISUAL C++

· выполните команду Project Add To Project New… (появится диалоговое окно New, рис.13):

· выберите режим С++ Source File

· в поле File Name введите с клавиатуры имя будущего исходного файла, например, 111 (файл получит стандартное расширение .cpp )

· щелкните на кнопке ОК.

Рис.13 Окно добавления исходного файла в проект PR1.

· в левой области окна среды VISUAL C++ активизируйте вкладку FileView, откройте последовательно папки Pr1 files, Source Files и активизируйте 111.cpp

Рис.14. Окно среды Visual C++, готовое к набору исходного текста программы.

· Распахните окно документа и наберите текст программы Варианта1 на языке С++ (рис.15)

Обратите внимание! В тексте программы на языке С++ (в отличие от языка Pascal) заглавные и строчные буквы различаются.

Рис.15. Окно среды VISUAL C++ c текстом программы Варианта1 на С++

Компиляция программы.

Назначение компилятора:

1) проверка текста программы на наличие синтаксических ошибок;

2) в случае отсутствия ошибок перевод исходного текста программы с языка С на язык машинных кодов, т.е. создание объектного кода программы.

Откомпилируйте программу 111.cpp

Для этого:

· выполните команду меню Build Compile или используйте клавиши Ctrl+F7

- если в программе нет ошибок, то в нижней части окна появится сообщение:

111.obj - 0 error (s), 0 warning (s) (см. рис.16);

- если есть ошибки:

- в нижней части окна появится сообщение о ошибках;

- для определения места в программе, где находится ошибка, щелкните мышью на соответствующей строке диагностики нижнего окна;

- исправьте ошибки и повторите компиляцию (типичные ошибки и их диагностику см. в Приложении1).

Рис.16. Окно среды VISUAL C++ c результатами успешной компиляции программы Варианта1.

Обратите внимание! В результате успешной компиляции в папке Pr1\Debug появится файл с расширением obj ( в нашем случае 111.obj, см. рис.17).

Рис.17. Окно программы Проводник с содержимым папки Debug.

Компоновка программы (или создание загрузочного модуля)

Назначение компоновщика:

1) подключение к объектному коду программы объектных кодов внешних программных модулей (библиотек процедур и функций);

2) создание загрузочного кода программы (имя файла с расширением exe).

Сформируйте загрузочный модуль для программы Варианта1.

Для этого:

· выполните команду меню Build Build Pr1.exe (или клавиша F7). Окно с результатами работы компоновщика представлено на рис.18.

Рис.18. Окно среды VISUAL C++ c результатами успешной компоновки программы Варианта1.

Обратите внимание! В результате успешной компиляции в папке Pr1\Debug появится файл с расширением exe ( в нашем случае Pr1.exe, см. рис.19).

Рис.19. Окно программы Проводник с содержимым папки Debug.

Выполнение программы

Выполните программу Варианта1.

Для этого:

· выполните команду меню Build Execute (или клавиши Ctrl+F5). В результате появится новое окно выполнения программы с результатами (см. рис.19)

· запишите результат и закройте окно выполнения.

Рис.19. Окно выполнения программы Варианта1.

Закрытие проекта

Закройте проект Pr1 вместе с Рабочей областью.

Для этого:

· выполните команду меню File Close Workspace

· ответьте Да на вопрос о закрытии всех окон проекта.

Создание и выполнение новой версии программы

Создайте и выполните программу Варианта2.

Для этого:

· создайте новый проект (команда меню File New); проекту дайте имя Pr2; исходному модулю программы - имя 222.cpp (см. Задание2);

· в пустое окно 222.cpp скопируйте текст программы 111.cpp, для этого:

o выполните команду File Open… и откройте файл 111.cpp

o скопируйте текст программы 111.cpp в окно 222.cpp

o закройте окно с текстом программы 111.cpp

· измените текст программы в окне 222.cpp в соответствии с Вариантом2 (см. рис. )

· откомпилируйте программу

· сформируйте загрузочный модуль

· выполните программу (окно выполнения на рис.20)

Рис.20. Окно выполнения программы Варианта1.

· введите с клавиатуры значение радиуса и нажмите кл.Enter(окно с результатами выполнения на рис.21)

Рис.21. Результат выполнения программы Варианта2.

Лабораторное задание

1. Изучить технологию создание программ на языках программирования.

2. Изучить структуру программы на языке Pascal

3. Изучить примеры программирования на языке Pascal, приведенные в разработке.

4. Изучить структуру программы на языке С++.

5. Изучить примеры программирования на языке С++, приведенные в разработке.

6. Изучить функции систем программирования.

7. Изучить процесс создания и выполнения программ в системе Тurbo Pascal и выполнить задания из разработки.

8. Изучить процесс создания и выполнения программ в среде VISUAL C++6.0

9. Выполнить в среде VISUAL C++6.0 программы, приведенные в разработке.

10. Написать на языках ТurboPascal и С++ программы, приведенные в вариантах заданий и выполнить их в соответствующих средах. Причем один вариант программы должен предусматривать задание исходных данных с помощью операторов присваивания, другой должен использовать операторы ввода данных с клавиатуры.

11. Подготовить отчет в редакторе Word по своему варианту, в который включить описание всех 6 этапов решения задачи (окна с результатами компиляции, формирования загрузочного модуля и выполнения программы вставить в виде рисунков).

Таблица вариантов заданий

Номер варианта

Задание

1 , 14

По заданной стороне квадрата вычислить его площадь

2 , 15

По заданной стороне квадрата вычислить его периметр

3 , 16

По заданной стороне куба вычислить его объем

4 , 17

По заданной стороне куба вычислить площадь его боковой поверхности

5 , 18

По заданной стороне куба вычислить площадь его поверхности

6 , 19

По заданным сторонам прямоугольника вычислить его площадь

7 , 20

По заданным сторонам прямоугольника вычислить его периметр

8 , 21

По заданной длине, ширине и высоте параллелепипеда вычислить площадь его боковой поверхности

9 , 22

По заданной длине, ширине и высоте параллелепипеда вычислить площадь его поверхности

10, 23

По заданной длине, ширине и высоте параллелепипеда вычислить его объем

11, 24

По заданному радиусу вычислить длину окружности 2*р*r

12, 25

По заданному радиусу вычислить объем шара 4/3*р*r3

13, 26

По заданному радиусу вычислить площадь поверхности сферы 4*р*r2

Приложение1. Примеры ошибок и их диагностика

1) Пример диагностики, когда отсутствует переменная R в операторе описаний, а в операторе присваивания переменная R присутствует, тогда в нижнем окне возникают сообщения об ошибках (рис.22)

Рис.22. Окно VISUAL C++ с ошибками отсутствия описания переменной

Здесь:

- в 10 строке программы предупреждение о том, что инициализирующее значение типа double приписывается константе типа float.

- в 14 строке программы ошибка -“неописанная переменная R”;

- в 14 строке программы предупреждение о том, что константу1.5 типа double пытаются присвоить необъявленной переменной R предположительно типа int.

Рис.23. Окно среды VISUAL C++ с диагностикой ошибок.

2) Пример диагностики, когда пропущено подключение библиотеки ввода-вывода (рис.24)

Рис.24. Окно с диагностикой отсутствия подключения библиотеки stdio.h

Приложение 2. Описание среды Visual C++ и пунктов меню

Интегрированная среда Visual C++ используется для разработки, изменения и сопровождения проектов разной сложности c использованием возможностей всех библиотек языка С++ , а также специализированных библиотек Visual C++.

С помощью Visual C++ можно работать со следующими типами проектов:

ATL COM Wizard ();

Cluster Resource Type Wizard ();

Custom APPWizard ();

Database Project ();

DevStudio Add-in Wizard ();

ISAPI Extension Wizard ();

Makefile ();

MFC ActiveX Control Wizard ();

MFC AppWizard (dll) ();

MFC AppWizard (exe) ();

Utility Project ();

Win32 Application ();

Win32 Console Application ();

Win 32 Dinamic-Link Library ();

Win 32 Static-Link Library ().

Каждый из проектов содержит разное количество файлов. Это могут быть файлы с исходным текстом программы, заголовочные файлы библиотек, файлы с характеристиками рабочей области проекта и другие.

Интегрированная среда Visual C++ позволяет создавать и использовать следующие виды файлов:

Active Server Page ();

Binary File ();

Bitmap File ();

C/C++ Header File ();

C++ Source File ();

Cursor File ();

HTML Page ();

Icon File ();

Macro File ();

Resource Script ();

Resource Template ();

SQL Script File ();

Text File ().

Кроме того, Visual C++ позволяет работать с другими видами документов;

CorelDRAW9.0 Graphic ();

Powersim Simulation Project ();

Trellix Document ();

VISIO 5 Drawing ();

Диаграмма Microsoft Excel;

Документ Microsoft Word;

Лист Microsoft Excel;

Презентация Microsoft PowerPoint.

Главное меню среды системы VISUAL C++6.0 содержит следующие команды

- File -

- Edit -

- View -

- Insert -

- Project -

- Build -

- Tools -

- Window -

- Help -

Пункт меню File предназначен для работы с файлами, проектами, рабочими областями и содержит следующие команды:

- New - создать проект/файл/документ других приложений;

- Open - открыть файл;

- Close - закрыть файл, содержимое которого находится в окне;

- Open Workspace - открыть рабочую область существующего проекта;

- Save Workspace - сохранить рабочую область активного проекта;

- Save - сохранить файл, содержимое которого находится в окне;

- Save As - сохранить файл под другим именем;

- Save All - сохранить все;

- Page setup - параметры страницы;

- Print - вызов диалогового окна печати;

- Recent Files - список последних пяти файлов, с которыми Visual C++ работал недавно;

- Recent Workspaces - список последних пяти рабочих областей, с которыми Visual C++ работал недавно;

- Exit - выход.

Пункт меню Edit предназначен для удобства редактирования текста файла (работы с проектом) и содержит следующие команды:

Undo - отменить действие;

Redo - повторить действие;

Cut - вырезать выделенный фрагмент и поместить его в буфер обмена;

Copy - копировать выделенный фрагмент в буфер обмена;

Paste - вставить содержимое буфера обмена в указанное место;

Delete - удалить выделенный фрагмент;

Select All - выделить все;

Find -искать (слово, текст, фрагмент);

Find in Files - искать в файлах, список которых находится в диалоговом окне;

Replace - заменить;

Go to - перейти к ;

Bookmarks -

Advanced -

Breakpoints -

ListMembers -

Type Info -

Parameter Info -

Complete Word -

Команды меню Edit полностью аналогичны соответствующим командам других приложений.

Пункт меню View используется для изменения способа отображения информации в окнах и содержит следующие команды:

- Class Wizard -

- Resource symbols ();

- Resource includes ();

- Full Screen ();

- Workspace ();

- Output ();

- Debug Windows ();

- Refresh ();

- Properties ()

Пункт меню Insert используется для и содержит следующие команды:

- New Class -

- New Form -

- Resource ()

- Resource Copy ()

- File As Text -

- New ATL Object -

Пункт меню Project используется для управления проектами и содержит следующие команды:

- Set Active Project -установить проект, с которым нужно работать в настоящее время;

- Add to Project - добавить файл в проект;

- Dependencies -

- Setting - настройки проекта;

- Export MakeFile -

- Insert Project into Workspace - вставить проект в рабочую область.

Пункт меню Build используется для компиляции проекта, т.е. проверки правильности текста файлов проекта, перевода текста проекта с языка высокого уровня (С++) в язык объектных кодов (последовательности нулей и единиц), компоновки файлов проекта с файлами используемых библиотек. Пункт меню Build содержит следующие команды:

- Compile - компиляция файла проекта (проверка правильности текста файлов проекта и перевод на язык объектных кодов). При этом производится компиляция текстов проекта, находящихся в оперативной памяти и если никаких изменений не проводилось, то компиляция не осуществляется.

- Build - компиляция содержимого файлов проекта (и если были изменения) текстов, находящихся в оперативной памяти. В случае отсутствия каких-либо изменений все равно производится компиляция файлов проекта;

- Rebuild All - принудительная компиляция всех файлов проекта;

- Batch Build -

- Clean -

- Start Debug - запуск режима отладки;

- Debugger Remote Connection -

- Execute - запуск проекта на выполнение;

- Set Active Configuration -

- Configuration -

- Profile -

Пункт меню Tools используется для задания режима работы Visual C++ и содержит следующие команды:

- Source Browser -

- Close Source Browser File

- Register Control

- Error Lookup

- ActiveX Control Test Container

- OLE/COM Object Viewer

- MFC Tracer

- Customize

- Options

- Macro

- Record Quick Macro

- Play Quick Macro

Пункт меню Window используется для работы с окнами Visual C++ и содержит следующие команды:

- New Window создание нового окна;

- Split

- Docking View

- Close - закрыть окно

- Close All - закрыть все окна

- Next - переход к следующему окну;

- Previous - переход к предыдущему окну;

- Cascade - размещение всех окон каскадом;

- Tile Horizontaly размещение окон горизонтальной мозаикой;

- Tile Vertically - размещение окон вертикальной мозаикой

- Windows

Размещено на Allbest.ru


Подобные документы

  • Основы работы на языке высокого уровня Turbo Pascal. Основное оборудование и программное обеспечение. Операторы, необходимы для работы в графической среде Turbo Pascal. Запуск графического режима. Текст программы в графической среде Turbo Pascal.

    лабораторная работа [12,7 K], добавлен 14.05.2011

  • История создания и развитие Pascal. Особенности пакета программирования Turbo. его возможности редактора текстов, компилятора и отладчика. Построения программы на языке Turbo Pascal, ее структура, типы алгоритмов, одномерные и многомерные массивы.

    курсовая работа [519,3 K], добавлен 25.06.2011

  • Структура и основные элементы языка Turbo Pascal. Алгоритм составления простейших программ на Turbo Pascal. Применение условного оператора и сильноветвящихся алгоритмов. Циклы с предусловием и постусловием, сочетание циклических и условных операторов.

    реферат [64,0 K], добавлен 20.03.2016

  • Характеристика используемой операционной системы, языка программирования. Структура программы на языке Turbo Pascal 7.1. Операторы языка Turbo Pascal. Проведение сортировки записей. Алгоритмы программы и подпрограмм. Причины возникновения ошибок.

    курсовая работа [454,1 K], добавлен 13.06.2014

  • Написание программы "телеграф", который принимает от пользователя сообщения и выводит его на экран в виде последовательности точек и тире. Их вывод сортируется звуковым сигналом соответствующей длительности. Программа написана на языке Turbo Pascal.

    курсовая работа [565,6 K], добавлен 18.08.2008

  • Разработка эскизного и технического проектов программы "Helpopr" (ввод, хранение и вывод данных на дисплей по запросу пользователя). Язык программирования Turbo Pascal. Описание алгоритма программы. Требования к компьютеру и программному обеспечению.

    курсовая работа [198,1 K], добавлен 03.02.2010

  • Этапы подготовки и решения задач на компьютере. Способы предоставления алгоритмов. Простые типы данных и их обработка. Основы работы с графикой и графическими операторами в Visual Basic. Организация линейной программы. Процедуры и функции в языке Паскаль.

    дипломная работа [1,9 M], добавлен 25.10.2015

  • Анализ эффективности методов сортировки данных в языке Turbo Pascal. Разработка эскизного и технического проекта программы. Сортировка без и с использованием дополнительной памяти, за исключением небольшого стека (массива). Сортировка связанных списков.

    курсовая работа [359,0 K], добавлен 23.05.2012

  • Изучение текстового режима языка программирования Turbo Pascal. Написание игры "Змейка" с помощью средств, процедур и функций языка программирование Turbo Pascal. Структурное и функциональное описание разработки. Листинг и общие примеры работы программы.

    контрольная работа [286,3 K], добавлен 10.04.2011

  • Особенности поиска среднеарифметического значения элементов массива. Общая характеристика проблем разработки в среде Turbo Pascal программы упорядочивания массива по возрастанию. Рассмотрение основных этапов разработки программы на языке PASCAL.

    курсовая работа [896,7 K], добавлен 18.05.2014

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.