Табличный процессор MS Excel. Язык программирования Visual Basic for Applications

Назначение и основные функции Ехсе1. Причины возникновения ошибок и способы их решения в Ехсе1. Язык программирования Visual Basic for Applications (VBA): общая характеристика языка. Основные понятия информационной безопасности, способы ее нарушения.

Рубрика Программирование, компьютеры и кибернетика
Вид шпаргалка
Язык русский
Дата добавления 26.02.2010
Размер файла 201,2 K

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

55

Вопросы к зачету для заочного отделения 1 курс 2 семестр 2007-2008 г.:

1. Электронные таблицы: обзор, назначение и основные функции. Основные понятия электронных таблиц (рабочая книга, лист, ячейка, блок ячеек; рабочая область, печатная страница; форматы листа и ячеек). Типы данных, используемых Ехсе1. Понятие абсолютной и относительной адресации.

2. Обзор, назначение и основные функции Ехсе1. Причины возникновения ошибок и способы их решения в Ехсе1.

3. Элементы экрана. Ввод данных и формул в таблицу. Организация ссылок.

4. Автоматическое вычисление сумм. Выделение фрагментов таблицы. Редактирование табличных данных.

5. Копирование данных и формул. Автозаполнение. Режимы вычислений в Ехсе1.

6. Оформление таблиц. Автоформатирование.

7. Операции над длинным текстом ячейки, выбор шрифта, изменение вида выравнивания по горизонтали и вертикали. Объединение ячеек.

8. Изменение формата вывода чисел. Операции над документами. Одновременная работа с несколькими табличными документами.

9. Работа с диаграммами: создание диаграмм, составные части диаграммы, форматирование объектов, изменение типа диаграмм, добавление к диаграмме новых данных.

10. Работа с большими таблицами: фиксация титулов на экране, создание нескольких окон для табличного документа, разбивка документа на страницы вручную, печать повторяющихся заголовков.

11. Сортировка данных таблицы. Работа с именами ячеек: создание имен, замена адресов ячеек их именами, вставка имен в формулы.

12. Встроенные функции Ехсе1. Операции над рабочими листами. Консолидация данных. Подведение промежуточных итогов в таблице.

13. Понятие алгоритма. Свойства алгоритмов. Элементы блок-схем алгоритмов.

14. Структуры алгоритмов: алгоритмы линейной и разветвляющейся структур, алгоритмы циклической структуры.

15. Понятие программы, программирования, программного продукта. Системы и языки программирования.

16. Язык программирования Visual Basic for Applications (VBA): Общая характеристика языка. Интерфейс редактора УВА. Типы данных УВА. Назначение кнопок стандартной панели инструментов. Встроенные элементы управления.

17. Язык программирования Visual Basic for Applications (VBA): Операторы, выражения и операции. Процедуры УВА.

18. Язык программирования Visual Basic for Applications (VBA): Управляющие конструкции языка. Встроенные функции. Функции ввода-вывода данных и сообщений.

19. Язык программирования Visual Basic for Applications (VBA): Обработка событий. Использование списков и полей со списками. Функции для работы со строками. Функции пользователя. Массивы данных.

20. Программное обеспечение ЭВМ и технологии программирования.

21. Основные понятия информационной безопасности.

22. Способы и средства нарушения конфиденциальности информации.

23. Классификация способов и средств защиты информации.

24. Организационно-административные и технические средства защиты информации.

25. Юридические основы защиты информации. Программные средства и методы защиты.

26. Средства опознания и разграничения доступа к информации.

27. Криптографические методы защиты информации.

1. Электронные таблицы: обзор, назначение и основные функции. Основные понятия электронных таблиц (рабочая книга, лист, ячейка, блок ячеек; рабочая область, печатная страница; форматы листа и ячеек). Типы данных, используемых Ехсе1. Понятие абсолютной и относительной адресации

Ехсеl - табличный процессор-комплекс взаимосвязыв. программ, предназначен для обработки электронных таблиц.

Электронная таблица - компьютерный эквивалент обычной таблицы, состоящий из строк и столбцов на пересечении которых находятся клетки (ячейки) в которых содержится числовая информация, формулы или текст.

Функции:

1. бухгалтерский и статистический расчет,

2. связывание таблицы между собой,

3. создание и редактирование электронов в базы данных,

4. автоматическое получение и распечатывание отчетов,

5. вычисление различного рода,

6. математическое моделирование.

Рабочая книга - документ, состоит из нескольких листов, на которых могут находиться таблицы диаграммой Макроса.

Рабочий лист - состоит из ячеек.

Ячейка - область, находящаяся на пересечении строки и столбца.

Блоком ячеек - является строка или часть строки, столбец или часть столбца, а также прямоугольник, задаваемый координатами противоположных углов.

Рабочая область - все пространство разделенная тонкими линиями по вертикали на столбцы, а по горизонтали на строки.

Типы данных используемых в Excel.

Текстовой тип данных. Форматы числовых данных:

1. общий - для отображения текстовых и числовых знач.

2. числовой - для чисел.

3. текстовой - текст.

4. денежн. формат,

5. дата, время,

6. процентный.

2. Обзор, назначение и основные функции Ехсе1. Причины возникновения ошибок и способы их решения в Ехсе1

Функции Ехсел - стандартные формулы, позволяющие производить расчеты: финансовой, статистической, математической, логической и др. областях.

Категории функции:

1. математ., арифмет., тригонометр. функции.

2. функции с датами и временем.

3. финансовые функции.

4. логические.

5. для работы с ссылками и массивами.

6. статистические.

7. текстовые и др.

Shift F3 или вставка/функция

имя функции (аргумент1, аргумент 2 и т.д.) СУММ (А1; В1; С1) СУММ (А1: В5)

Сообщение об ошибке. Причина возникновения и способ решения проблемы

Числовое значение состоит из многих символов. Есть два возможных решения: увеличить ширину ячейки или уплотнить число. Попытайтесь расширить столбец и посмотрите, что получится. Если это не то, что вам нужно, можете сократить количество символов в ячейке, выбрав команду Ячейки в меню Формат и указав новый формат на вкладке Число.

#ССЫЛ! Неверная ссылка на ячейку. Такое часто случается при перемещении ячеек. Те ячейки, которые вы перемещаете, уничтожают данные в тех, чье место они занимают. При этом ссылки на эти ячейки во всех формулах автоматически изменятся на неверные, и Excel будет не в состоянии вычислить результат этих формул.

#ЗНАЧ! Неправильные операнды или аргументы функции. Проверьте ссылки на ячейки, которые используются в этой формуле.

#ЧИСЛО! Проблема заключается в одном из чисел формулы. Возможно, результатом формулы является слишком большое или слишком малое число, которое Excel не может вывести на экран из-за его размера. Проверьте правильность аргументов функции.

#ИМЯ? В формуле используется имя, которое Excel не в состоянии найти. Проверьте правильность написания ссылок, формул и функций. Проверьте наличие кавычек, которые указывают, что заключенные в них символы являются строкой. Удостоверьтесь в том, что все перечисленные имена существуют, а не были удалены из книги. Проверьте наличие двоеточия в середине ссылок, определяющих область ячеек; если таковое отсутствует, Excel воспринимает ссылку как имя.

#ДЕЛ/0! Деление на нуль. Эта ошибка возникает из-за пустых ячеек, которые Excel воспринимает как нулевые. Убедитесь в том, что ни одна из ссылок в вашей формуле не указывает на пустую ячейку.

#ПУСТО! Ссылка на пересечение двух непересекающихся областей. Проверьте, правильно ли вы указали ссылки, убедитесь в том, что хотя бы одна ячейка принадлежит двум областям.

#Н/ДЗначение недоступно функции или формуле. Возможно, ячейка, на которую ссылается формула, содержит ошибку или же вы пропустили аргумент во встроенной функции Excel.

3. Элементы экрана. Ввод данных и формул в таблицу. Организация ссылок

Основы работы в Excel.

После запуска Excel на экране появляется окно, состоящее из нескольких элементов (рис 1):

строки меню, содержащей пункты главного и подчиненных меню (документы разных типов имеют разные строки меню, например, при работе над диаграммой, Вы увидите строку меню диаграммы). С помощью этой строки можно получить доступ практически ко всем командам Excel.

Примечание: Кроме главного меню Excel содержит так называемые контекстные меню, содержащие наиболее употребляемые команды для работы с ячейками, диаграммами или другими объектами.

Контекстные меню активизируются нажатием ПРАВОЙ кнопки мыши (или Shift + F10). Для выхода из контекстного меню нужно щелкнуть кнопкой мыши вне его или нажать Esc.

строки формул, в которой можно вводить и редактировать данные, находящиеся в выбранной ячейке активного рабочего листа или в этой строке отображается содержимое текущей ячейки.

пользовательская панель инструментов, в которой в качестве пиктограмм вынесены наиболее употребляемые пользователем команды. Использование кнопок панелей инструментов позволяет сэкономить время по сравнению с выбором команд меню. При помещении указателя мыши на пиктограммы в форме всплывающей подсказки будет отражена информация о функциональном предназначении кнопки. Настройка панелей инструментов зависит от задач пользователя и определяется пунктом меню Вид|Панели инструментов.

полосы прокрутки (вертикальной и горизонтальной), позволяющих просматривать и работать с большими таблицами;

строки состояния, отражающей информацию о текущем состоянии и результатах выполняемых операций Excel.

ярлычки рабочих листов, содержащих стандартные имена (Лист1, Лист2, Лист3 и т.д.), которые по желанию пользователя могут быть добавлены, удалены или переименованы под конкретную задачу.

Работа с электронными таблицами

В Excel можно работать с 4 основными типами документов:

электронная таблица;

диаграмма;

макротаблица;

рабочая книга.

Электронные таблицы в Excel располагаются на рабочих листах рабочих книг, представляющих собой электронный эквивалент папки-скоросшивателя, "складывающей" документы. Количество рабочих листов в книге может регулировать пользователь. В рабочие книги можно дополнительно "подшивать" диаграммы, сводные таблицы, различные отчеты и т.п.

Рабочий лист электронной книги состоит из ячеек, каждая из которых имеет свой адрес: сочетание имени столбца и строки. Столбцы идентифицируются буквами латинского алфавита (А. B, C, D…), а строки - арабскими цифрами (1,2,3…). Ячейка, в которой находится курсор, считается активной, то есть предназначенной для ввода данных.

Например, адрес F10 говорит о том, что вводимая информация при активной ячейке F10 попадет именно в эту ячейку, а содержимое этой ячейки отразится в строке формул.

Многие команды Excel позволяют работать с блоками ячеек. Блок ячеек - это прямоугольник, задаваемый координатами противоположных углов, обычно, верхней левой и нижней правой ячеек. Имена ячеек в блоках разделяются двоеточием (“: “). Например, блок А1: В4 включает в себя ячейки А1, А2, А3, А4, В1, В2, В3 и В4. Выделение блока ячеек осуществляется протаскиванием курсора мыши на нужный диапазон. При этом ячейка, начиная с которой выделяется блок, остается белого цвета, а остальные ячейки затемняются. Но блок ячеек не обязательно может включать смежные ячейки.

Ячейкам и блокам для удобства работы можно давать имена.

Рабочие листы также могут быть переименованы для лучшего отражения смыслового содержания решаемой задачи.

4. Автоматическое вычисление сумм. Выделение фрагментов таблицы. Редактирование табличных данных

Автоматическое вычисление сумм.

Многие операции в Ехсе1 производятся с использованием встроенных функций. Функции могут быть выбраны из списка функций с помощью меню Вставка | Функция или с помощью нажатия пиктограммы Гх на стандартной панели инструментов с соответствующим выбором необходимой функиии. Наиболее употребляемой функцией является функция суммирования - СУММ (). Она находится в упомянутом выше пункте меню Вставка|Функция, пиктограмме Гх, а также вынесена в качестве отдельной пиктограммы Автосумма, изображаемой как математический знак суммы - X.

Выделение фрагментов таблицы

Чтобы выделить:

1 - Текст в ячейке - Если режим редактирования в ячейке включен, выберите ячейку, дважды щелкните ее и выделите текст в ячейке. Если режим редактирования в ячейке выключен, выберите ячейку и выделите текст в строке формул.

2 - Отдельную ячейку - Щелкните ячейку или перейдите к ней, используя клавиши со стрелками.

З - Диапазон ячеек - Протащите указатель из одного угла диапазона в другой.

4 - Большой диапазон ячеек - Щелкните первую ячейку диапазона, а затем, удерживая нажатой клавишу 8Н1РТ, щелкните последнюю ячейку диапазона. Для перемещения к последней ячейке можно использовать полосы прокрутки.

5 - Все ячейки листа - Нажмите кнопку Выделить все

6 - Несмежные ячейки или диапазоны ячеек - Выделите первую ячейку или первый диапазон ячеек, а затем, удерживая нажатой клавишу СТЯЕ, последовательно выделите остальные ячейки или диапазоны.

7 - Всю строку или весь столбец - Щелкните заголовок строки или столбца

8 - Смежные строки или столбцы - Протащите указатель по заголовкам строк или столбцов. Либо выделите первую строку или первый столбец, а затем, удерживая нажатой клавишу 8Н1РТ, выделите последнюю строку или последний столбец.

9 - Несмежные строки или столбцы - Выделите первую строку или первый столбец, а затем, удерживая нажатой клавишу СТКЕ, последовательно выделите остальные строки или столбцы.

10 - Большее или меньшее количество ячеек по сравнению с текущим выделенным диапазоном - Удерживая нажатой клавишу 8Н1РТ, щелкните последнюю ячейку, которую необходимо включить в новый диапазон. Прямоугольная область между активной ячейкой и указанной ячейкой образует новый диапазон.

11 - Отмена выделения ячеек - Щелкните любую ячейку на листе.

Редактирование табличных данных

Если при просмотре таблицы были обнаружены ошибки, их необходимо отредактировать. Ехсе1 позволяет

редактировать содержимое ячеек несколькими способами: а) набором в активной ячейке новой информации

поверх ошибочной (используется, как правило, при полной замене информации); б) активизацией строки

формул щелчком мыши для перехода в режим редактирования; в) нажатием функциональной клавиши Р2 в

активной ячейке.

Удаление ошибочной информации осуществляется нажатием клавиши Ое1е*е в активной ячейке.

Для удобства ориентации среди электронных документов рекомендуется давать листам рабочей книги соответствующие названия.

5. Копирование данных и формул. Автозаполнение. Режимы вычислений в Ехсеl

Копирование данных и формул в электронных таблицах Экономические таблицы содержат в пределах одного столбца, как правило, однородные данные, то есть данные одного типа и структуры. Ехсе! предоставляет возможность один раз ввести формулу расчета в ячейку, а затем скопировать ее из одной ячейки в другие. Для этого существует несколько приемов копирования:

Использование пунктов меню Правка|Копировать и Правка|Вставить.

Использование пиктограмм Копировать и Вставить на стандартной панели инструментов.

Применение правой кнопки мыши, то есть вызов контекстного меню, и выбор соответствующих пунктов: Копировать и Вставить.

Протаскивание "маркера заполнения" через требуемые смежные ячейки. Маркером заполнения при этом называется черный квадратик, расположенный в правом нижнем углу активной ячейки.

Другие способы копирования в среде \\^пёо\У5 (например, сочетание "горячих клавиш" Сдх1+С, Сйт+У и т.п.).

При приеме копирования с использованием "протаскивания" маркера заполнения необходимо выполнить следующие действия: а) Поместить курсор мыши на маркер ячейки ВЗ в правом нижнем углу (при этом курсор должен приобрести конфигурацию знака "плюс" (+). Б) Удерживая нажатой левую кнопку мыши, "протащить" маркер через ячейки В4: В10. в) Щелкнуть левой кнопкой мыши в любой свободной ячейке листа, чтобы снять выделение с блока ВЗ: В10. В процессе копирования Ехсе1 автоматически корректирует адреса аргументов формул, изменяя их в соответствии с идентификатором столбца или строки. Это называется относительной адресацией ячеек.

Автозаполнение числами.

При работе с числами используется метод автозаполнения. В правом нижнем углу рамки текущей ячейки имеется черный квадратик - маркер заполнения. При наведении на него указатель мыши (он обычно имеет вид толстого белого креста) приобретает форму тонкого черного крестика. Перетаскивание маркера заполнения рассматривается как операция "размножения" содержимого ячейки в горизонтальном или вертикальном направлении. Если ячейка содержит число (в том числе дату, денежную сумму), то при перетаскивании маркера происходит копирование ячеек или их заполнение арифметической прогрессией. Для выбора способа автозаполнения следует производить специальное перетаскивание с использованием правой кнопки мыши. Пусть, например, ячейка А1 содержит число 1. Наведите указатель мыши на маркер заполнения, нажмите правую кнопку мыши, и перетащите маркер заполнения так, чтобы рамка охватила ячейки АI, В1 и С1, и отпустите кнопку мыши. Если теперь выбрать в открывшемся меню пункт "Копировать ячейки", все ячейки будут содержать число 1. Если же выбрать пункт "Заполнить", то в ячейках окажутся числа 1,2 и 3. Чтобы точно сформулировать условия заполнения ячеек, следует дать команду Правка > Заполнить > Прогрессия. В открывшемся диалоговом окне Прогрессия выбирается тип прогрессии, величина шага и предельное значение. После щелчка на кнопке ОК программа Ехсе! автоматически заполняет ячейки в соответствии с заданными правилами. Автозаполнение формулами. Эта операция выполняется так же, как автозаполнение чиагами. Ее особенность заключается в необходимости копирования ссылок на другие ячейки. В ходе автозаполнения во внимание принимается характер ссылок в формуле: относительные ссылки изменяются в соответствии с относительным расположением копии и оригинала, абсолютные остаются без изменений. Для примера предположим, что значения в третьем столбце рабочего листа (столбце С) вычисляются как суммы значений в соответствующих ячейках столбцов А и В. Введем в ячейку С1 формулу =А1 +В1. Теперь скопируем эту формулу методом автозаполнения во все ячейки третьего столбца таблицы. Благодаря относительной адресации формула будет правильной для всех ячеек данного столбца. В таблице 12.1 приведены правила обновления ссылок при автозаполнении вдоль строки или вдоль столбца. Правила обновления ссылок при автозаполнении.

6. Оформление таблиц. Автоформатирование

Автоформатирование. Вводимая в ячейки Ехсе1 информация может быть отображена на экране различными способами. Для изменения формы отображения и доступа к информации используются средства форматирования и защиты. Неправильный формат представления данных может вызвать значительные проблемы, особенно, если у пользователя отсутствует достаточный опыт. Например, если пользователь введет число 0.9, но в качестве десятичного разделителя в настройках компьютера используется запятая, то введенные данные будут восприниматься как текст. Опытный пользователь сразу это заметит, так как обычно по умолчанию текст выравнивается по левому краю, а числа - по правому краю ячейки. Форматирование в Ехсе1 включает в себя решение следующих вопросов:

1 - изменение шрифта, размеров, начертания и цвета символов,

2 - выравнивание и изменение ориентации текста и чисел в ячейках,

3 - форматирование чисел, дат и времени,

4 - форматирование строк и столбцов,

5 - создание и использование пользовательских форматов,

6 - условное форматирование,

7 - защита ячеек, листов и рабочих книг,

8 - использование стилей при форматировании,

9 - применение автоформатов

Большинство операций по форматированию таблиц сосредоточено в пункте меню Формат | Ячейки на соответствующих вкладках, но наиболее употребляемые операции (цвет заливки, цвет шрифта, выравнивание по различным признакам, границы, разрядность и т.п.) выведены в качестве пиктограмм панели инструментов Форматирование. Каждая электронная таблица требует своего оформления, то есть придания ей определенного эстетического вида. Как правило, заголовки таблиц, названия их граф, итоговая строка могут быть выделены отличающимся от общего текста размером шрифта, его цветом, фоном. Кроме того, в таблицах принято использовать разделители столбцов и строк (границы) и прочие графические эффекты.

7. Операции над длинным текстом ячейки, выбор шрифта, изменение вида выравнивания по горизонтали и вертикали. Объединение ячеек

Чтобы произвести какие-либо операции над текстом ячейки, необходимо выделить ее содержимое. Выделение ячейки выполняется щелчком мыши на ее содержимом. Текст в ячейке можно расположить различными способами. Для этого необходимо выполнить команду: Формат/Ячейки и на вкладке выравнивание выбрать расположение текста по вертикали или по горизонтали. Также здесь можно осуществить необходимое нам отображение - для этого необходимо поставить флажок в нужных пунктах (переносить по словам; автоподбор ширины; объединение ячеек). Кроме того, на данной вкладке можно выбрать направление текста, а также ориентировать текст на нужный угол, самостоятельно определив угол наклона. Длинный текст можно расположить в несколько строк. Для этого установите ширину столбца так, чтобы она удовлетворяла вас с точки зрения обозримости таблицы. Выберите команду меню Формат/Ячейки. В диалоговом окне Формат ячеек раскройте вкладку Выравнивание, установите флажок Переносить по словам.

"Чтобы выделить текст в ячейке - выполните следующее: если режим редактирования в ячейке включен, выберите ячейку, дважды щелкните ее и выделите текст в ячейке. Выберите нужный шрифт в списке Шрифт на панели инструментов Форматирование. В поле Размер выберите требуемый размер шрифта. Чтобы использовать последний выбранный цвет, выберите мышью элемент Цвет текста на панели инструментов Форматирование. Для использования другого цвета нажмите стрелку рядом с кнопкой Цвет шрифта, а затем выберите необходимый цвет.

Можно изменить начертание выделенного текста. Для этого - нажмите нужную кнопку на панели инструментов Форматирование. Начертание - Полужирный текст - Нажмите кнопку Полужирный; Выделение текста курсивом - Нажмите кнопку Курсив; Подчеркивание текста - Нажмите кнопку Подчеркнутый. Распределение содержимого одной ячейки на несколько ячеек - Текст распределяется по нескольким ячейкам и выравнивается в них по центру. Разбивка объединенных ячеек - Выберите объединенную ячейку. После объединения ячеек на панели инструментов Форматирование выделяется (Выделенный элемент управления). Вокруг выделенной кнопки панели инструментов всегда отображается граница, даже когда указатель мыши находится не на этой кнопке) кнопка Объединить и поместить в центре. Щелкните кнопку Объединить и поместить в центре на панели инструментов Форматирование. Выделите ячейки, которые необходимо объединить. Для объединения ячеек в одной строке или одном столбце и выравнивания по центру содержимого ячеек нажмите кнопку Объединить и поместить в центре на панели инструментов Форматирование.

8. Изменение формата вывода чисел. Операции над документами. Одновременная работа с несколькими табличными документами

Изменение формата вывода чисел.

1. Выделите ячейки, формат которых требуется изменить.

2. В меню Формат выберите команду Ячейки, а затем откройте вкладку Число.

З. В списке Числовые форматы выберите нужный формат и нажмите кнопку ОК. Если числа уже введены, их можно преобразовать в текстовый формат.

1. Выделите ячейки, содержащие числа, которые требуется отформатировать в виде текста.

2. В меню Формат выберите команду Ячейки, а затем откройте вкладку Число.

З. В списке Числовые форматы выберите Текстовый и нажмите кнопку ОК.

Операции над документами.

С помощью программы Ехсеl можно создавать самые различные документы, которые сохраняются на диске в виде файла. Файл может содержать несколько взаимосвязанных рабочих листов, образующих единый трехмерный документ (блокнот, рабочую книгу). С помощью трехмерных документов пользователь получает доступ одновременно к нескольким таблицам и диаграммам, что повышает эффективность их обработки. Создание нового документа. Для создания документа из меню нужно выбрать Файл/Создать. Новый документ можно создать также, щелкнув мышью по пиктограмме, которая находится на первой пиктографической панели (зеленый икс). Загрузка рабочего документа. Чтобы загрузить с диска расположенный там документ, нужно вызвать директиву открыть из меню Файл. Можно также щелкнуть мышью по пиктограмме, которая находится на основной панели. В любом случае откроется диалоговое окно загрузки файла. В этом окне в поле Диски нужно указать диск, а в поле директории, выбрать директории, где расположен файл. Если выбор был сделан правильно, то в левом поле появится список имен файлов, среди которых должен находиться искомый файл. Сохранение документа. При первом сохранении документа необходимо выполнить команду Файл/Сохранить как. После этого появится диалоговое окно, в котором нужно указать имя сохраняемого файла, а также диск и директорию, в которой его надо расположить. Если документ уже сохранялся ранее под определенным именем, при следующем сохранении следует выполнить Файл/Сохранить или щелкнуть по изображенной пиктограмме, которая находится на основной панели (дискетка). Автоматическое сохранение. Из меню нужно выбрать Сервис/Параметры и на вкладке сохранение нужно включить опцию Автоматическое сохранение, щелкнув по ней мышью, затем необходимо закрыть окно, щелкнув ок. Также во вкладке Сохранение пользователь может задать интервал времени между моментами сохранения. Кроме того, в этом окне можно определить, должна ли программа выдавать запрос на сохранение и нужно ли автоматически сохранять все документы или только активный документ. Также созданный документ можно защитить от использования другими лицами. Для этого необходимо зайти в Сервис, выбрать Защита и поставить свой пароль либо на рабочий лист, либо на всю книгу.

Одновременная работа с несколькими табличными документами.

Одновременный просмотр нескольких листов или книг. 1. Откройте книгу, которую нужно просмотреть. Чтобы вывести одновременно несколько листов текущей книги, выберите команду Новое в меню Окно. Перейдите к новому окну и выберите лист, который нужно просмотреть. Таким же образом выведите на экран все необходимые листы. 2. В меню Окно выберите команду Расположить. 3. В группе Расположить выберите требуемый параметр. Чтобы отобразить только те листы, которые находятся в текущей книге, установите флажок. Только окна текущей книги. Объединение книг. 1. Для выполнения данной процедуры копии общей книги должны храниться в одной папке. Чтобы поместить их в одну папку, дайте каждой копии уникальное имя. 2. Откройте копию, в которой планируется объединить изменения. 3. В меню Сервис выберите команду Сравнить и объединить книги.4. Если будет предложено, сохраните книгу.5. В диалоговом окне Выберите, какие файлы включить в книгу выберите копию, содержащую изменения, которые требуется объединить, а затем нажмите кнопку ОК. Сравнение двух рабочих книг рядом: 1 - Откройте рабочие книги, которые требуется сравнить.2 - В меню Окно выберите команду Сравнить рядом с.3 - С помощью панели инструментов Сравнить рядом выполните следующие действия. А. Для одновременной прокрутки рабочих книг нажмите кнопку Синхронная прокрутка. Чтобы восстановить то расположение окон рабочих книг, каким оно было в начале сравнения, нажмите кнопку Восстановить положение окна. 3 - Нажмите кнопку Закрыть открытые рядом документы, чтобы закончить сравнение книг. Примечание. Если открыты две рабочие книги, то в меню Окно в название команды будет включено имя файла одной из этих книг. Например, если открыты файлы "Книга1. х1з" и "Книга2. х1$", то при просмотре файла "Книга1. х1з" в меню Окно будет отображаться команда Сравнить рядом с Книга2. х1з. Если панель инструментов Сравнить рядом была закрыта, то для того чтобы снова ее отобразить, выберите в меню Сервис команду Настройка, перейдите на вкладку Панели инструментов и в списке Панели инструментов установите флажок Сравнить рядом.

9. Работа с диаграммами: создание диаграмм, составные части диаграммы, форматирование объектов, изменение типа диаграмм, добавление к диаграмме новых данных

Построение диаграмм в Excel/

Значительный набор возможностей предоставляет пользователю Excel для графического представления данных. Составлять диаграммы можно как на одном рабочем листе с таблицей, так и на отдельном листе рабочей книги, который называется листом диаграммы. Диаграмма, созданная на одном рабочем листе с таблицей, называется внедренной. Для построения диаграмм в Excel используется:

Мастер диаграмм;

Панель Диаграммы.

Мастер диаграмм позволяет строить несколько типов графиков, для каждого из которых можно выбрать модификацию основного варианта диаграммы.

Элементы диаграммы

Основные компоненты диаграммы представлены на следующей схеме:

55

Примечание: для объемной диаграммы составные части несколько отличаются.

Типы диаграмм/

В зависимости от выбранного типа диаграммы можно получить различное отображение данных:

линейчатые диаграммы и гистограммы могут быть использованы для иллюстрации соотношения отдельных значений или показа динамики изменения данных за определенный период времени;

график отражает тенденции изменения данных за определенные промежутки времени;

круговые диаграммы предназначены для наглядного отображения соотношения частей и целого

точечная диаграмма отображает взаимосвязь между числовыми значениями нескольких рядов данных и представляет две группы чисел в виде одного ряда точек, часто используется для представления данных научного характера;

диаграмма с областями подчеркивает величину изменения данных во времени, показывая сумму введенных значений, а также демонстрирует вклад отдельных значений в общую сумму;

кольцевая диаграмма показывает вклад каждого элемента в общую сумму, но, в отличие от круговой диаграммы, может содержать несколько рядов данных (каждое кольцо - отдельный ряд);

лепестковая диаграмма позволяет сравнивать общие значения из нескольких рядов данных;

поверхностная диаграмма используется для поиска наилучшего сочетания двух наборов данных;

пузырьковая диаграмма представляет разновидность точечной диаграммы, где два значения определяют положение пузырька, а третье - его размер;

биржевая диаграмма часто используется для демонстрации цен на акции, курсов валют, для определения изменения температуры, а также для научных данных

Кроме того, можно строить диаграммы так называемого нестандартного типа, позволяющие совмещать в одной диаграмме различные типы представления данных.

При работе с нестандартным типом диаграмм предусмотрена возможность быстрого просмотра диаграммы. Каждый нестандартный тип диаграммы основывается на стандартном типе и содержит дополнительные формат и параметры, такие как легенда, сетка, подписи данных, вспомогательная ось, цвета, шаблоны, заливки и места расположения различных элементов диаграммы.

Можно использовать либо один из встроенных нестандартных типов диаграмм, либо создать свой собственный. Нестандартные типы диаграмм находятся в книгах.

Построение диаграмм при помощи Мастера диаграмм.

Для создания диаграммы на рабочем листе необходимо выделить данные, которые будут в ней использованы, и вызвать Мастер диаграмм. Может быть выбран как один ряд данных (или отдельная строка в таблице, или отдельный столбец), так и несколько.

Примечание: данные, не входящие в прямоугольный блок, выделяются при нажатой клавише Ctrl.

Для вызова Мастера диаграмм используется:

пункт меню Вставка|Диаграмма;

кнопка Мастер диаграмм на стандартной панели инструментов

Вывод на экран панели Диаграммы осуществляется при помощи пункта меню Вид|Панели инструментов|Диаграммы:

55

Мастер диаграмм предполагает несколько шагов, которые должен сделать пользователь.

Созданные диаграммы в любое время могут редактироваться. Excel позволяет:

Изменять размеры диаграммы

Перемещать диаграммы на рабочем листе

Менять тип и подтип диаграммы, корректировать цвет рядов или точек данных, их местоположение, настраивать изображение рядов, добавлять подписи данных

Добавлять новые и удалять ненужные данные и т. п

Диаграмма может влиять на значения данных таблицы и наоборот, то есть при изменении значений в электронных таблицах происходит автоматическое обновление данных диаграммы, равно как и изменение данных в диаграмме мгновенно меняет данные в связанной с ней таблицей.

Внимание! Изменение значений данных на диаграмме будет оказывать влияние на изменение соответствующих данных только в тех ячейках таблицы, которые не содержат формул.

Добавление линии тренда к ряду данных

Для выявления общей тенденции изменения значений отдельного ряда на диаграмму выводится линия тренда.

Линия тренда - это линия регрессии, аппроксимирующая точки данных, или линия скользящего среднего. Линию тренда можно вывести за пределы, в которых данные уже известны, и показать тенденцию их изменения.

Линии тренда обычно используются в задачах прогнозирования, для сглаживания разброса цен, по линии тренда можно определить линейную корреляцию двух переменных и т.д.

Линии тренда различаются в зависимости от заданного математического соотношения между значениями ряда данных. Например, при сглаживании разброса цен на акции за определенный период может быть использован или линейный тип тренда, или скользящее среднее, при определении периода полураспада радиоактивного соединения понадобится экспоненциальный тип тренда и т.д. Выбор типа линии тренда всегда связан с предметной областью.

Линии тренда можно использовать не для всех типов диаграмм, а только для гистограмм, линейчатых диаграмм, графиков, XY-точечных диаграмм, диаграмм с областями.

Выведенная на диаграмму линия тренда сохраняет связь с исходным рядом, то есть при изменении данных соответственно изменяется линия тренда, а при удалении ряда линия тренда удаляется вместе с ним.

10. Работа с большими таблицами: фиксация титулов на экране, создание нескольких окон для табличного документа, разбивка документа на страницы вручную, печать повторяющихся заголовков

11. Сортировка данных таблицы. Работа с именами ячеек: создание имен, замена адресов ячеек их именами, вставка имен в формулы

Сортировка данных таблицы Сортировка предназначена для более удобного представления данных. Ехсе1 предоставляет разнообразные способы сортировки данных. Можно сортировать строки или столбцы в возрастающем или убывающем порядке данных, с учетом или без учета регистра букв. Можно задать и свой собственный пользовательский порядок сортировки. При сортировке строк изменяется порядок расположения строк, в то время как порядок столбцов остается прежним. При сортировке столбцов соответственно изменяется порядок расположения столбцов. Стандартные средства Ехсе1 по умолчанию позволяют сортировать данные по трем признакам (графам таблицы).

Внимание! Перед тем, как производить сортировку, необходимо установить курсор на любую ячейку сортируемой таблицы. Для сортировки списка наименований товаров в алфавитном порядке необходимо:

1. Выделить блок ячеек. Обратить внимание, что первая графа (№ п/п) таблицы не принимает участия в процессе сортировки, чтобы нумерация строк оставалась неизменной.

2. Активизировать пункт меню Данные.

З. Выбрать команду Сортировка.

4. В окне Сортировать по из выпадающего списка выбрать, например "Наименование товаров".

5. Установить переключатель, например, По возрастанию.

6. Установить переключатель Идентифицировать поля по в положение Подписям (первая строка диапазона).

7. Щелкнуть по кнопке Параметры.

8. Установить переключатель в положение Строки диапазона.

9. Нажать ОК.

10. В окне Сортировка диапазона нажать ОК.

11. Снять выделение с диапазона ячеек в таблице. В данном случае список отсортирован только по одному признаку сортировки, а строки упорядочены в соответствии с расположением наименований товаров по алфавиту.

Работа с именами ячеек.

Для того, чтобы дать ячейке имя надо: вставка - имя: применить, присвоить, вставить, создать или заголовки диапазонов (название строк или столбцов). Заголовки и имена в формулах. Для ссылки на ячейки в столбцах и строках можно использовать заголовки этих столбцов и строк листа. Также для представления ячеек, диапазонов ячеек, формул или констант можно создавать имена. Заголовки можно использовать в формулах, содержащих ссылки на данные на том же листе; для представления группы ячеек, находящейся на другом листе, этой группе следует присвоить имя. Использование определенных имен для представления ячеек, констант или формул - Определенное имя в формуле облегчает понимание назначения формулы. Например, формулу =СУММА (Продано_в_первом_квартале) легче опознать чем =СУММ (С20: С30). Имена можно использовать в любом листе книге. Имя можно присвоить формуле или постоянному значению (константе). Например, имя "ПроцентнаяСтавка", которому присвоено значение 6,2 процента, можно использовать в любом месте для вычисления процентов. Также можно ссылаться на определенное имя в другой книге, или определить имя, ссылающееся на ячейку в другой книге. Допустимые знаки. Первый знак в имени должен быть буквой или знаком подчеркивания. Остальные знаки имени могут быть: буквами, числами, точками и знаками подчеркивания. Ссылки на ячейки как имена. Имена не могу г иметь такой же вид, как и ссылки на ячейки, например 2$ 100 или КЛ С1. Использование нескольких слов. В имени может быть больше одного слова, но пробелы недопустимы. В качестве разделителей слов могут быть использованы знаки подчеркивания и точки - например: Налогнапродажи или Первый. Квартал. Число знаков, которое можно использовать. Имя может содержать до 255 знаков. Учет регистра в именах. Имя может состоять из строчных и прописных букв, но Мюгозой Ехсе1 их не различает. Например, если создано имя "Продажа", а затем в той же книге создано другое имя "ПРОДАЖА", то второе имя заменит первое.

12. Встроенные функции Ехсе1. Операции над рабочими листами. Консолидация данных. Подведение промежуточных итогов в таблице

Функции Excel - это стандартные формулы, позволяющие производить расчеты в финансовой, статистической, математической, логической и других областях деятельности. Они сгруппированы по категориям и имеют одинаковый синтаксис.

Функции задаются с помощью математических и других формул, в соответствии с которыми выполняются вычисления по заданным величинам, называемым аргументами, и в указанном порядке, определяемом синтаксисом. Синтаксис встроенных функций достаточно прост:

Имя функции (аргумент1; аргумент2; аргумент3 и т.д.), где:

Имя функции - показывает в программе, о каких вычислениях идет речь. Примеры имен функции - СУММ, СРЗНАЧ и др.

Аргументы - значения, которые функция использует, вычисляя результат. Аргументы перечисляются в скобках следом за именем функции. В качестве аргументов могут выступать числовые значения, текст, логические значения, массивы, значения ошибок или ссылки, дата/время, а также другие функции и формулы. В Excel различают обязательные (которые всегда нужно задавать) и необязательные аргументы. Отдельные аргументы разделяются символами точки с запятой (;).

Результат - значение, полученное при вычислении функции.

Многие математические операции в Excel производятся с использованием встроенных функций.

Функции могут быть выбраны из списка функций с помощью меню Вставка|Функция или с помощью нажатия пиктограммы f (x) на стандартной панели инструментов с соответствующим выбором необходимой функции.

После выбора требуемой функции подключается Мастер функций, позволяющий пользователю пошагово заполнять ее аргументы.

Функции в Excel подразделяются на следующие основные группы:

Математические, арифметические и тригонометрические функции.

Функции для работы с датами и временем.

Финансовые функции.

Логические функции.

Функции для работы со ссылками и массивами.

Функции для работы с базами данных.

Статистические функции.

Текстовые функции и др.

Функции для работы с датой и временем позволяют анализировать и работать со значениями даты и времени в формулах. Значения даты и времени сохраняются и обрабатываются программой как числа.

Финансовые функции решают в основном задачи расчета амортизации и определения процентов по займам и инвестициям, а также анализируют операции с ценными бумагами.

Логические функции оперируют с логическими значениями и результат их также представляет собой логическое значение - ИСТИНА или ЛОЖЬ.

Функции для работы со ссылками и массивами данных для поиска в списках или таблицах, а также для нахождения ссылки к ячейке.

Функции для работы с базами данных применяются для работы с базами данных (списками) и таблицами с соответствующей структурой данных. С помощью этих функций можно выполнять анализ данных рабочего листа.

Статистические функции позволяют решать множество различных задач как сложных профессиональных, так и простых, например, определение арифметического среднего.

Текстовые функции используются при работе с текстом, позволяют искать, заменять или объединять определенные последовательности символов, а также подсчитывать количество символов и многое другое.

Десять последних функций, применяемых пользователем, Excel автоматически группирует в категорию "10 недавно использовавшихся".

Подведение промежуточных итогов

При работе со списками команда Данные|Итоги быстро создает промежуточные итоги по выбранным категориям. Эта команда выполняет две достаточно сложные задачи:

Вставляет строку и создает функцию Промежуточные итоги для всех изменяемых данных в указанном столбце. Эта функция автоматически ссылается на корректное количество ячеек, расположенных над ней.

Создает структуру, которая с помощью щелка на кнопке отображает данные с большей или меньшей степенью детализации.

Прежде чем воспользоваться командой Данные|Итоги, следует отсортировать список по столбцу, для которого будет вычислен промежуточный итог.

Команда Итоги создает на листе структуру, где каждый уровень содержит одну из групп, для которых подсчитывается промежуточный итог. Вместо того чтобы рассматривать сотни строк данных, можно закрыть любой из уровней и опустить ненужные детали.

13. Понятие алгоритма. Свойства алгоритмов. Элементы блок-схем алгоритмов

Порядок выполнения операций над данными с целью получения искомых результатов. Для реализации одного и того же алгоритма и могут использоваться различные программы.

Свойства:

детерминированность (определен-ть, однозначн-ть), понятен любым исполнителям.

массовость: использование для решения множества задач.

результативность: он должен через конечное число шагов завершить работу

дискретность: возможность разбиение алгорит процесса на элементарные действия.

Способы описания:

словесный (на естественном языке),

формульно-словесный,

графический (изображ из графических символов),

операторный,

с помощью таблиц решений.

Блок-схема - графич представление алгоритма, где он в виде последовательности связанных между собой функциональных блоков, каждый из которых соответствует выполнению одного или нескольких действий.

В блок-схеме каждому типу действий соответствует геометрическая фигура в виде блочного символа.

Они соедин линиями переходов, определяющими очередность выполнения действий. Ex: процесс решение, модификация, ввод-вывод, пуск-останов, документ.

Базовые структуры алгоритмов - это опред набор блоков и стандартных способов их соединения для выполнения типичных последовательностей действий.

линейные - разветвляющиеся - циклические/

14. Структуры алгоритмов: алгоритмы линейной и разветвляющейся структур, алгоритмы циклической структуры

Базовые структуры алгоритмов - это определенный набор блоков и стандартных способов их соединения для выполнения типичных последовательностей действий.

К основным структурам относятся: Линейные, разветвляющиеся, циклические.

Линейными - структуры, где действия осущ последовательно друг за другом.

Разветвляющимся - алгоритм, где действие выполняется по одной из возможных ветвей решения задачи, в зависимости от выполнения условий.

Состоит из условия (от выполнения/невыпол его осущ последовательность действий) и двух последовательностей команд.

Условия - любое (истинное/ложное) утверждение, выражено как словами, так и формулой.

Циклическим - алгоритм, где часть операций (тело цикла - последовательность команд) выполняется многократно.

Cтруктура цикл сущ в вариантах: Цикл типа для. Предписывает выполнять тело цикла для всех значений некоторой переменной (параметра цикла) в заданном диапазоне. Цикл типа пока. Предписывает выполнять тело цикла до тех пор, пока выполняется условие, записанное после слова пока. Цикл типа делать - пока. Предписывает выполнять тело цикла до тех пор, пока выполняется условие, записанное после слова пока. Условие проверяется после выполнения тела цикла. Заметим, что циклы для и пока называют также циклами с предпроверкой условия а циклы делать - пока - циклами с постпроверкой условия. Иными словами, тела циклов для и пока могут не выполниться ни разу, если условие окончания цикла изначально не верно. Тело цикла делать - пока выполнится как минимум один раз, даже если условие окончания цикла изначально не верно.

15. Понятие программы, программирования, программного продукта. Системы и языки программирования

Программа - описание структуры алгоритма на языке алгоритмич. программирования.

Языки программирования - формальные искусствен. языки для описания алгоритма решения задачи на компьютере.

Языки: низкий уровень и высокий уровень.

Язык низкого уровня - язык програмиров. ориентированный на команды процесса и учитывающ. его особенностей (ансамблер). С помощью этих языков создаются компактные оптимальные программы. При этом программист получает доступ ко всем возможностям процессора. Используется для написания небольших системах приложения, драйвера и т.д.

Язык высокого уровня - язык програмиров. имитирующий естественный, обладающий укрупнен. командами, ориентир. на человека. В них не учитывается особенности конкретных компьютерн. архитектур. (легко переносимые на др. платформы). Языки высоких уровней ориентиров. на решения больших содержат. прикладных задач и требует использов. соответсв. программ переводчиков для преобраз. машиных данных в машинный код.

Компилятор - переводит весь текст программы в машин. код и затем передает на исполнения процессора.

Импретатор - выполняет команды языка переводя на машин. язык и исполняя каждую команду поочередно.

Процесс создания программы включает этапы:

1. составление исходного кода программы на языке програмиров.2. трансляции необходимый для создания объектного кода программы.3. построение загрузочного модуля готовый к исполнению исходный код трансляция>объектный код редактор связи>загрузочный модуль

Система програмир. включает:

1. текстовой редактор - для создания и редактиров. исходного кода программ.2. компилятор 3. редактор связи 4. отладчик 5. библиотека функций 6. справочная система

16. Язык программирования Visual Basic for Applications (VBA): Общая характеристика языка. Интерфейс редактора УВА. Типы данных УВА. Назначение кнопок стандартной панели инструментов. Встроенные элементы управления

Visual Basic for Applications (VBA)

Язык VBA.1. главн. меню 2. окно проектов 3. окно макетов формы 4. панели инструментов 5. окно свойств объектов 6. панель элементов управления 7. окно программного кода.

Типы данных VBA.

integer - целые числа, long - целые числа, но больше чем integer, string - текстовой тип, double - десятичн. числа с двойной точностью, curreney - денежный формат чисел, single - десятичн. числа, date - дата и время, object - для ссылки на рисунок или любой объект, boolean - логический (ложь, истина), variant - значение переменой любого из выше перечисленных типов (универсал).

Назначение кнопок стандартн. панелей инструментов. form - добавляет форму в проект, module - добавляет модуль в проект, open project - открыв. существ. проект, save project - сохраняет проект, menu editor - редактор меню, properties - свойства, object brouser - расмотр всех возможн. объектов.

пуск - запуск, пауза - преостоновление, стоп - остановление.

Встроенные элементы управления:

Pointer - указатель

Picture Box - окно рисунка

Label - надпись

Tixt Box - текстовое поле

Command Button - командн. кнопка

Cleck Boy - флажок

Option Button - переключатель

17. Язык программирования Visual Basic for Applications (VBA): Операторы, выражения и операции. Процедуры УВА

Visual Basic for Applications (VBA)

Процедура - именованный набор описаний и команд. VBA входящий в состав программного модуля. Типы:

1. подпрограмма - [Private Public] Sub имя подпрограммы ([аргументы]).

2. функции Function имя функции ([параметры]) [As тип]

Нельзя включать объявление процедурн. функции в состав процедуры в программы или др. функции.

Несомненно, с помощью Excel можно создавать сложные и мощные приложения, но существует средство, которое позволяет создавать приложения более виртуозно. Это средство - Visual Basic for Applications (VBA) - объектно-ориентированный язык программирования, разработанный в свое время для записи макросов, а вскоре дополненный возможностью создания процедур в приложениях.

С помощью VBA можно записывать последовательности повторяющихся команд, характерных для какого-либо приложения, и назначить правила, по которым эти последовательности (процедуры VBA) будут вызываться в приложении пользователя. Например, при нажатии на кнопку, рабочий лист Excel будет отформатирован в соответствии с требованиями пользователя, оформленными в виде записей на VBA и сохраненными в виде шаблона.

С помощью средств VBA можно обеспечить нестандартный диалог с пользователем, создавая свои диалоговые формы и обрабатывая реакцию пользователя на события при работе с приложением.

Единый язык программирования - VBA - для всех продуктов Microsoft Office способствует их более тесному взаимодействию. С помощью VBA можно разрабатывать приложения, одновременно использующие различные компоненты нескольких приложений.

Макрос - часто используемая именованная последовательность команд, которую можно запускать с помощью одной инструкции. Макросы, по сути, являются компьютерными программами, но они не выполняются независимо, а работают только в среде Excel. Их чаще всего используют для автоматизации трудоемких или часто повторяющихся задач.

Существует несколько способов создания макросов: можно автоматически записать последовательность необходимых действий или вручную ввести инструкции на особом листе, называемом модулем. Для ввода инструкций в модуле и используется язык VBA.

Таким образом, Excel обладает большими возможностями как "простой" работы с электронными таблицами, так и сложным экономико-математическим аппаратом для анализа данных. Все инструменты Excel спроектированы так, что, воспользоваться ими можно различными путями в зависимости от предпочтения пользователя. Весь интерфейс можно настроить оп своему вкусу, он понятен, нагляден и не требует специальных технических навыков. С ним легко и просто работать.


Подобные документы

  • Рождение и развитие Basic. Краткое описание Visual Basic for Applications. Новые возможности Visual Basic 5.0. Пример взаимодействия Excel и Visual Basic. Программирование табличных функций. Встраивание, применение функций. Формы, средства управления OLE.

    реферат [20,7 K], добавлен 11.03.2010

  • Язык программирования Visual Basic: краткая история возникновения, значение и общая характеристика. Изучение основных свойств Visual Basic, синтаксис языка. Обзор ключевых операторов Visual Basic, пользовательские процедуры и функции данного языка.

    контрольная работа [36,4 K], добавлен 23.07.2014

  • Написание тестирующей программы для проверки знаний учащихся с помощью языка программирования Visual Basic for Applications (VBA), встроенного в пакет Microsoft Office. Общие сведения о программе, условия ее выполнения, настройка, проверка, выполнение.

    контрольная работа [25,2 K], добавлен 07.06.2010

  • Сумма двух разреженных полиномов, заданных ненулевыми коэффициентами и их номерами. Разработка программ на языке программирования Visual Basic for Applications. Вывод справочной информации. Операционная система Windows. Хранение двоичных данных.

    научная работа [390,2 K], добавлен 09.03.2009

  • Функции и основная роль коммерческого банка. Особенности кредитных и депозитных операций. Описание среды программирования и сущность Visual Basic for Applications (VBA). Схема алгоритма программы, процедура сохранения файла и выхода из программы.

    курсовая работа [1,9 M], добавлен 04.04.2012

  • Разработка программного продукта с помощью языка программирования Visual Basic. Описание интерфейса пользователя и возможностей программы. Исходный код основных модулей. Программа, демонстрирующая основные возможности диаграмм и среды Visual Basic.

    контрольная работа [989,9 K], добавлен 29.03.2011

  • Теория тестирования. Тест как система заданий и его эффективности. Качество тестовых заданий. Проверка качества тестовых заданий. Матрица результатов. Современный подход к понятию "трудность". Visual Basic for Applications (VBA). Объектные модели.

    дипломная работа [198,9 K], добавлен 10.11.2008

  • Рабочая среда Visual Basic (VB) и ее основные компоненты. Ввод и вывод данных в VB. Объявление переменных и констант в программе. Создание и работа с процедурами и функциями, их виды. Организация ветвления в VB. Использование циклов в программировании.

    практическая работа [502,5 K], добавлен 26.10.2013

  • Структура и основные операции коммерческого банка. Использование языка программирования Visual Basic for Application, математическая формулировка задачи. Разработка модуля программы расчёта кредитов и депозитов. Схема алгоритма выполнения программы.

    курсовая работа [2,9 M], добавлен 09.04.2012

  • Исследование теоретических аспектов разработки программы посредством использования Visual Basic. Анализ достоинств и недостатков данного языка программирования. Изучение особенностей создания интерфейса приложения. Основные этапы реализации программы.

    практическая работа [460,6 K], добавлен 22.01.2013

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.