Создание виртуального 3D тура из серии виртуальных фотопанорам

Обзор программ для сшивания фотопанорам. Создание фотопанорам для виртуального тура. Выбор и загрузка изображений. Автоматическое склеивание снимков. Указание дополнительных контрольных точек. Объединение панорам в виртуальный тур, его реализация.

Рубрика Программирование, компьютеры и кибернетика
Вид курсовая работа
Язык русский
Дата добавления 22.01.2016
Размер файла 3,5 M

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru

Размещено на http://www.allbest.ru

Содержание

фотопанорама тур виртуальный снимок

Введение

1. Технология создания 3D панорам

1.1 Технические особенности

1.2 Обзор программ для сшивания фотопанорам

2. Создание фотопанорам для виртуального тура

2.1 Съёмка

2.2 Выбор и загрузка изображений

2.3 Автоматическое склеивание снимков

2.4 Указание дополнительных контрольных точек

2.5 Оптимизация

2.6 Создание панорамы

2.7 Исправление мелких дефектов

3. Объединение панорам в виртуальный тур

3.1 Элементы виртуального тура

3.2 Реализация виртуального тура

Заключение

Список использованных источников

Введение

Задачей курсового проекта является создание виртуального 3D тура из серии виртуальных фотопанорам. Элементами виртуального тура, как правило, являются сферические, цилиндрические или кубические панорамы, соединенные между собой интерактивными ссылками-переходами (хотспотами).

Виртуальный тур является эффективным инструментом маркетинга, позволяющим показать потенциальному потребителю товар, услугу или объект особым образом. К достоинствам 3D панорамы, в отличии от обычной фотографии, можно отнести то, что она охватывает гораздо больше пространства и пользователь может детально рассмотреть всё вокруг точки съёмки, поскольку каждая панорамная фотография охватывает 360° обзора. Просмотр 3D панорамы создает «эффект присутствия» в точке съемки. На основе панорамных фото собираются связанные между собой переходы.

Процесс создания панорам состоит из трех последовательных этапов:

съемка - производится панорамная съемка объектов, на основе которых будет сделан виртуальный тур;

обработка фотоматериала: коррекция цветов, ретушь, удаление дефектов и нежелательных элементов на фото;

создание виртуального тура - склейка 3D панорам в виртуальный тур.

В качестве объектов съёмки были выбраны аудитории, холлы и музеи университета.

Для обработки фотографий использовался графический редактор Adobe Photoshop CS6.

Для склеивания панорам существует довольно много программ, часть из них позволяет сохранять готовые изображения в виде виртуальных панорам, обеспечивает генерацию соответствующих HTML-кодов, которые дают возможность встроить виртуальные панорамы в веб-страницы с минимальными усилиями. При выполнении курсового проекта были использованы PTGui и Pano2VR, позволяющие добиться качественных результатов склейки снимков в фотопанораму.

Отчёт состоит из 3 глав. В первой главе описана технология создания 3D панорам, во второй - процесс создания фотопанорам, последняя глава содержит описание создания виртуального тура.

1.Технология создания 3D панорам

1.1 Технические особенности

Фотопанорамы обычно создаются из нескольких специально подготовленных перекрывающихся фотографий, которые затем «сшиваются» с помощью различных программ в единую панораму. В фотоаппарате должна быть предусмотрена функция фиксации экспозиции -- ручной режим установки выдержки и диафрагмы, а так же ручной режим установки баланса белого, благодаря чему фотографии не будут отличаться друг от друга яркостью и контрастностью. Для съёмки использовался цифровой фотоаппарат FUJIFILM FINEPIX AV100, который полностью отвечает вышеперечисленным требованиям.

Одним из важных моментов создания панорамы является необходимость вращения камеры вокруг нодальной точки объектива. Нодальная точка - это точка внутри объектива камеры, где пересекаются лучи света, идущие к матрице. При вращении камеры вокруг этой точки отсутствует параллакс объектов. Параллакс - смещение объектов переднего плана относительно объектов заднего плана при повороте камеры. Такое смещение может вызвать трудности при сшивании панорамы. Чтобы избежать подобных проблем был использован штатив Rekam MaxiPod с панорамной головкой.

Снимать каждый последующий кадр нужно так, чтобы он перекрывал предыдущий примерно на 30%. Больший процент перекрытия означает лучшее качество сборки готовой фотопанорамы, благодаря большему количеству схожих объектов. Необходимо следить, чтобы линия горизонта оставалась неизменной, контролировать это позволяют пузырьковые уровни на штативе. Кроме того, места швов лучше располагать на достаточно однотонных объектах.

При съемке важно, чтобы освещение не менялось, в кадр не попадали движущиеся объекты: автомобили, облака, люди, качающиеся от ветра деревья.

Использование автоматической фокусировки при съемке 3d панорамы может привести к тому, что отдельные кадры сфокусируются по-разному, или, еще хуже, некоторые кадры окажутся совсем вне фокуса, тогда собрать панораму будет невозможно.

Желательно производить съемку в формате RAW, который обеспечивает дополнительные возможности по обработке каждого кадра, например изменение экспозиции.

Существуют различные виды панорам:

Плоскостная ? это обычная широкоугольная фотография, составленная из нескольких кадров;

Цилиндрическая панорама (циклорама) ? это панорама с возможность обзора на 360° по горизонтали, но только на 180° по вертикали. При рассматривании такой фотопанорамы зритель находится на оси цилиндра и озирается вокруг (или вращает цилиндр вокруг себя).

Если угол обзора фотопанорамы по горизонтали равен 360°, то циклорама предпочтительнее плоскостной развёртки, так как не требует вертикального разрыва.

Сферическая панорама. Панорама проецируется на внутренность сферы. Если угол обзора по горизонтали равен 360°, а по вертикали равен 180°, то панорама заполняет внутреннюю поверхность сферы целиком.

При рассматривании такой фотопанорамы зритель находится в центре сферы и озирается вокруг.

Сферическая панорама позволяет поместить необходимые элементы над наблюдателем или под ним (а на это ни плоскостная развёртка, ни циклорама, естественно, не способны). Развертка сферической панорамы называется эквидистантной проекцией

Кубическая панорама. Панорама проецируется на внутренность куба.

С точки зрения зрителя кубическая панорама обладает всеми достоинствами сферической панорамы и в идеале должна создавать у зрителя почти совершенное представление того, что он смотрит именно на поверхность сферы (не считая естественного различения между сферою и кубом, создаваемого бинокулярным зрением человека).

Преимуществом кубической панорамы по сравнению со сферической является простота изготовления, хранения, транспортировки, поскольку иметь дело приходится уже не с поверхностью сложной формы, а только с шестью гранями куба -- плоскими и квадратными.

1.2 Обзор программ для сшивания фотопанорам

Сшивание снимков в виртуальные панорамы производится в специальных программах-сшивателях, как правило, умеющих сшивать в автоматическом, полуавтоматическом либо ручном режимах. Так как использовался штатив, и угол наклона камеры не изменялся, можно использовать автоматический режим ? нет необходимости указывать контрольные точки на всех парах снимков, это потребуется сделать только на некоторых кадрах для более качественной сборки панорамы.

Технология сшивания во всех программах примерно одинакова. Вначале нужно загрузить исходный набор изображений и установить порядок их размещения. В части программ можно тут же провести необходимую коррекцию изображений (разумеется, гораздо лучше, если коррекция снимков будет сделана заранее в более подходящих для этой цели программах, например в Adobe Photoshop). Потом снимки преобразуются к определенной проекции, например сферической, -- это необходимо, поскольку только в таком виде снимки можно сшивать.

Затем осуществляется состыковка полученных изображений между собой -- автоматически либо вручную путем установки контрольных точек для каждой из пар граничащих друг с другом снимков. Последнее очень трудоемко, но нередко позволяет провести сшивание далеко не идеальных снимков. Очевидно, что качество совмещения снимков, напрямую, зависит от точности выставления контрольных точек. И, наконец, на последнем этапе смежные изображения смешиваются с целью выравнивания их яркости, контрастности и цветовой тональности.

Результатом всех этих действий станет получение фотопанорамы. Для превращения ее в виртуальную потребуется конвертировать панораму в соответствующий формат, а для демонстрации виртуальной панорамы в Интернете ее нужно будет вручную встроить в файл существующей интернет-страницы либо сгенерировать шаблонную веб-страницу.

Далее приведен краткий обзор программ, которые применялись в ходе выполнения курсового проекта.

Программа PTGui является одним из лидеров среди программ, предназначенных для создания панорам. Это продукт нидерландской компании New House Internet Services BV. Изначально программа разрабатывалась как интерфейс для популярного инструмента создания панорам Panorama Tools. Начиная с версии 5.0, программа может использоваться и как интерфейс для Panorama Tools, и как отдельное приложение для сшивания картинок.

Программа подходит и новичкам, и профессионалам. В PTGui предусмотрено два режима работы - простой и продвинутый. Между режимами можно переключиться в любой момент. Простой режим позволяет создавать панорамы автоматически и требует минимум ручной работы. Продвинутый дает полный контроль над процессом создания панорамы, позволяя изменять любые параметры.

PTGui умеет автоматически расставлять контрольные точки, выравнивать горизонт, корректировать цвет и экспозицию. Есть возможность создания многорядных панорам и огромных гигапиксельных фотографий. Результаты можно сохранять в виде многослойной картинки, которую в дальнейшем удобно обрабатывать в Adobe Photoshop. Есть поддержка HDR-изображений. На рисунке 1 представлено окно программы.

Рисунок 1 - Окно программы PTGui

При работе в простом режиме панорама создается за три шага: загружаются фотографии, выполняется анализ снимков, создаётся панорама. Первый и третий - тривиальны: нажать кнопку - выбрать файлы, нажать кнопку - создать результирующий файл.

Второй шаг - анализ - также автоматизирован: программа самостоятельно находит и расставляет контрольные точки, определяет расположение фотографий друг относительно друга, выставляет тип панорамы, выбирает оптимальный режим выравнивания горизонта. Большинство параметров скрыто от глаз пользователя, однако основные параметры можно изменять, например, редактировать контрольные точки, корректировать параметры экспозиции и цвета. В продвинутом режиме для редактирования доступно гораздо больше параметров. Появляется возможность задать параметры линз фотоаппарата, обрезать края изображения, просмотреть детальную информацию о каждой картинке, явно указать, какие алгоритмы использовать для слияния, интерполяции, смешивания изображений и т. д.

Готовая панорама - это результирующая картинка, собранная из исходных снимков. PTGui позволяет сохранить панораму в нескольких разных форматах. Во-первых, в виде единой картинки в формате JPEG или TIFF. Во-вторых, в виде PSD-файла Adobe Photoshop в многослойном виде - каждая исходная картинка будет размещаться в результирующем файле на отдельном слое. В-третьих, панораму можно сохранить в виде нескольких картинок. Наконец, панораму сразу можно конвертировать в формат QuickTime VR (QTVR), специально предназначенный для панорам.

Pano2VR -- удобный инструмент для конвертирования готовых панорам в формат Quicktime VR (QTVR) или Macromedia Flash 8/9/10 с одновременным формированием связанных с ними HTML-файлов (рисунок 2). В качестве исходных панорам могут быть использованы панорамы в форматах JPEG, PNG или TIFF (поддерживаются проекции Cylindrical, Equirectangular, Cube Faces и др.) либо виртуальные QTVR-панорамы. Кроме того, в программе имеется возможность трансформации панорамных изображений в сферу, зеркальный шар, цилиндр, горизонтальный крест и т. п. Возможно добавление в виртуальную панораму активных зон для перехода на конкретные вебстраницы, например, с другими панорамами, что позволяет получать упрощенные виртуальные туры.

У виртуальной панорамы можно ограничить углы просмотра по горизонту, наклоны и допустимые углы обзора. Также регулируется задействованное число сегментов, размер окна обзора, качество визуализации и т. п., разрешается включать/отключать автоматическое воспроизведение. В случае Flash-панорамы дополнительно предусмотрена возможность выбора шаблона оформления, который при необходимости несложно отредактировать и сохранить для дальнейшего применения. Предусмотрена генерация связанного с виртуальной панорамой HTML-файла, причем при создании QTVR-панорам в настройках HTML-файла можно определить, потребуется ли использовать для просмотра плагин DevalVR.

Рисунок 2 - Окно программы Pano2VR

Для пользователей Windows на сайте разработчика также предлагается утилита Pano2QTVR 1.6, которая обеспечивает конвертирование панорам в форматы Quicktime VR (QTVR) и Macromedia Flash 8.

2.Создание фотопанорам для виртуального тура

2.1 Съёмка

Объектом съёмки выступал музей, состоящий из двух комнат. Условие - создание цилиндрической панорамы. При осуществлении съёмки фотоаппарат был переведён в полностью ручной режим, который обозначается символом P. Штатив с фотоаппаратом был установлен в середине комнаты

Исходя из освещения комнаты, значение ISO установлено на отметке 3200 и зафиксирован баланс белого (рисунок 3).

Рисунок 3 - Настройки фотоаппарата в ручном режиме

Далее последовательно снимался кадр за кадром, степень перекрытия соседних кадров составляла приблизительно 30-40%. Так как условием было создание цилиндрической панорамы - необходимо было снять лишь один ряд фотографий по горизонтали на 360° в обеих комнатах.

Итого, при съёмке первого и второго помещения, получилось 11 и 13 кадров соответственно.

2.2 Выбор и загрузка изображений

После того, как были получены изображения, можно переходить к склеиванию их в панораму. Работу начинали с загрузки фотографий предназначенных для склейки в PTGui. Сделать это можно нажатием соответствующей кнопки и указав на диске заранее подготовленные фотографии (рисунок 4) или просто перетаскиванием нужных файлов в окно программы.

Рисунок 4 - Загрузка фотографий в PTGui

Открытые в программе снимки отобразятся в виде ленты. Если щелкнуть по этой ленте, откроется дополнительное окно Source Images, в котором можно установить порядок размещения изображений (рисунок 5).

Рисунок 5 - Лента изображений в PTGui

2.3 Автоматическое склеивание снимков

Далее нажимаем кнопку Align images, программа запустит свой алгоритм анализа снимков, проанализирует все исходные кадры и в перекрывающихся областях соседних кадров сгенерирует контрольные точки. Затем PTGui совместит фотографии и проведет их оптимизацию. После автоматического выравнивания на экране появится новое окно Panorama Editor (пример представлен на рисунке 6), в котором можно изменять ориентацию, как отдельных частей панорамы, так и всей панорамы целиком. Кроме этого, передвигая боковой ползунок , можно обрезать лишние объекты, которые не будут использоваться в цилиндрической панораме.

Рисунок 6 - Окно «Panorama Editor»

Иногда программа может недостаточно точно определить места сшивания некоторых снимков, поэтому необходимо, вручную выполнить процедуру соединения отдельных изображений, путем добавления контрольных точек на эти изображения.

2.4 Указание дополнительных контрольных точек

Контрольные точки представляют собой пары отметок на соединяемых изображениях, которые обозначают совпадающие детали на снимках. Чем точнее расположены контрольные точки и чем больше будет их число, тем правильнее будет составлен шов между отдельными изображениями. Для управления контрольными точками фотографий следует перейти на вкладку Control Points. В двух окнах показаны объединяемые снимки, на которых видны пары контрольных точек (рисунок 7). Все эти точки пронумерованы и выделены цветом. Ниже, под изображениями показана таблица, в которой представлена подробная информация о координатах правых и левых контрольных точек.

Рисунок 7 - Меню контрольных точек

Алгоритм программы несовершенен, поэтому иногда контрольные точки могут определяться недостаточно верно. В этом случае нужно щелкнуть правой кнопкой мыши на проблемной точке и удалить неудачную отметку, выбрав команду Delete.

После этого можно вручную проставить контрольные точки, щелкая по изображению на объектах присутствующих на обоих кадрах. Парную контрольную точку программа создаст сама, останется лишь проследить за правильностью ее расположения и, в случае необходимости, передвинуть ее на правильную позицию. Таким образом, устанавливаем максимум контрольных точек, стараясь, по возможности, расставлять их по всей перекрывающейся области кадров, а не только в одном месте. Также очень важно размешать контрольные точки с максимальной точностью.

2.5 Оптимизация

Для совершенной склейки панорамы, то есть склейки без видимых «швов», дистанция между парами контрольных точек должна быть минимальной. В процессе оптимизации рассчитывается, каким образом должны трансформироваться и выравниваться отдельные кадры панорамы, чтобы минимизировать дистанцию между контрольными точками.

Для этого откроем вкладку Optimizer, перед этим нажав Advanced на вкладке Project Assistant для перехода в расширенный режим. Из списка коррекции дисторсии линзы выбираем опцию «Heavy + lens shift». Выбираем алгоритм оптимизации PTGui (вариант с алгоритмом Panorama Tools даёт результат лучше родного оптимизатора PTGui, но он недоступен в данной сборке, однако его можно скачать отдельно с сайта разработчиков). Запускаем процесс оптимизации, после чего появится окно с результатами, где указана средняя, минимальная и максимальная дистанция между контрольными точками. Необходимо снизить на минимум среднюю дистанцию между контрольными точками. В результатах оптимизации кроме цифр PTGui даёт еще одну оценку проведенного процесса - "very bad", "bad", "not so bad", "not so good", "good", "very good" или "too good to be true". Но ориентироваться только по этим оценкам не стоит, поскольку они не учитывают размер исходных фотографий.

Если получили среднюю дистанцию больше 5pix, то желательно её уменьшить. Для этого необходимо подтвердить результат оптимизации и снова перейти к таблице контрольных точек. Проверяем, чтобы контрольные точки были упорядочены по дистанции. Если видим несколько контрольных точек с сильным отклонением от среднего значения дистанции, то эти точки следует удалить. После этого снова выполняем оптимизацию и проверяем результат. Если значения остались высокими, то следует повторить удаление контрольных точек с наихудшим значением дистанции и оптимизацию, пока результат нас не устроит. Но при этом необходимо следить, чтобы осталось достаточное количество контрольных точек для сшива панорамы и не появлялись дефекты.

В процессе оптимизации получили среднюю дистанцию 2.52pix (рисунок 8), оптимизатор пометил этот результат как «good». Данный результат нас устраивает, поэтому можно переходить к следующему этапу.

Рисунок 8 - Результат оптимизации

2.6 Создание панорамы

После завершения оптимизации переходим на закладку Create Panorama. Здесь можем выбрать желаемый размер, формат готовой панорамы, имя файла и путь для его сохранения. Окно программы представлено на рисунке 9. PTGui Pro позволяет сохранять панораму также в виде отдельных слоев, где каждый слой соответствует каждому исходному кадру панорамы. Эта опция бывает особо полезной, если нужно отретушировать на панораме повторяющиеся движущиеся предметы.

Рисунок 9 - Меню Create Panorama программы PTGui

Наконец запускаем процесс сборки панорамы и дожидаемся её завершения. В зависимости от количества и размера исходных фотографий, размера результирующей панорамы процесс может длиться от нескольких секунд до нескольких часов. Так же, время ожидания может зависеть от вычислительной мощности компьютера.

В результате нашей работы получаем проекцию цилиндрической панорамы, которая представлена на рисунке 10.

Рисунок 10 - Проекция цилиндрической панорамы

Так как музей состоит из двух помещений, повторяем все вышеперечисленные действия и для другой комнаты.

2.7 Исправление мелких дефектов

На предыдущем этапе была получена цилиндрическая проекция. В различных областях имеются мелкие дефекты после сборки снимков в панораму. После добавления контрольных точек вручную результат улучшился, однако всё же потребовалось дополнительное редактирование в Adobe Photoshop (рисунок 11).

Рисунок 11 - Исправление дефектов в Adobe Photoshop

При редактировании были использованы Штамп, Восстанавливающая кисть, Трансформирование. В результате проделанной работы были исправлены различные мелкие дефекты изображения, оставшиеся после склеивания панорамы (рисунок 12)

Рисунок 12 - Кадры «до» и «после» редактирования

3.Объединение панорам в виртуальный тур

3.1 Элементы виртуального тура

Отличительной особенностью виртуального тура является возможность перемещения от панорамы к панораме. Она реализуется с помощью, так называемых, точек перехода, которые позволяют «путешествовать» по виртуальному туру в зависимости от желания зрителя. Чтобы сделать виртуальный тур более удобным и информативным используется множества элементов:

горячая точка (hotspot);

кнопки и панель управления;

интерактивный список панорам и миниатюры;

карта виртуального тура и радар;

всплывающие окна с текстом, видео;

звуковое сопровождение.

Горячая точка - это изображение, текст или область панорамы, которые представляет собой ссылку. При наведении курсора на горячую точку всплывает подсказка, а нажатие активирует загрузку соответствующей 3D панорамы или открывает всплывающее окно. Горячих точек на одной панораме может быть несколько, они логически соответствуют направлению движения, которое мы используем в реальности. То есть в помещении они, скорее всего, будут расположены на дверях, а на открытой местности обозначат точку проведения фото съёмки. 

Кнопка и панель управления. Кнопка это основной элемент управления виртуальным туром. В виде кнопки можно использовать текст, графическое изображение в формате jpg, bmp, gif, png или swf-файл. Кнопкам присвоить несколько значений одновременно, если они не противоречат друг другу. Чаще всего используются следующие значения:

управление движением панорамы (Включение/Отключение вращения, Увеличение/Уменьшение изображения, сброс, и т.п.);

переключение между панорамами;

включение/Отключение полноэкранного режима;

включение/Отключение звукового сопровождения;

открытие/Закрытие всплывающего окна;

открытие ссылки, отправка E-mail, отправка на печать;

панелью управления называют группу статичных кнопок размещённых по периметру окна; 

интерактивный список панорам и миниатюры.

Интерактивный список включает в себя наименования всех 3D панорам. Он позволяет быстро найти и открыть любую панораму, входящую в состав виртуальной экскурсии. Миниатюры представляют собой тот же список, только оформленный в виде фотографий. 

Карта виртуального тура позволяет облегчить ориентацию в пространстве цифровой реальности. А горячие точки, размещённые на карте, имеют дополнительную функцию - радар. Радаром называют цветную зону, вращающуюся вокруг горячей точки. Она указывает направление, которое в данный момент соответствует изображению на 3D панораме. 

Всплывающее окно является важным элементом, который позволяет сделать виртуальный тур более информативным. А размещение информации проходит без ущерба для просмотра самой панорамы, так как после загрузки всплывающие окна скрыты от пользователя и появляются только после того, как мы его активируем. Открытие и закрытие всплывающих окон может сопровождаться различными спецэффектами.

В виртуальный тур можно добавлять видео. Получается интересный эффект. Его можно разместить и внутри самой панорамы, например на изображении экрана телевизора.

В качестве звукового сопровождения могут использоваться Mp3 файлы с описанием места съемки или просто приятной мелодией. Можно закрепить свою собственную мелодию для каждой панорамы входящей в состав виртуальной экскурсии и добавить звук для кнопок или горячих точек, который будет воспроизводиться после нажатия.

3.2 Реализация виртуального тура

После того, как было завершено редактирование панорамы, перейдём к созданию виртуального тура. Для этого будем использовать программу Pano2VR. Импортируем изображение панорамы и выставляем Тип: Цилиндрическая (рисунок 13). Это ограничит возможность управления панорамой лишь по горизонтали.

Рисунок 13 - Импорт изображения панорамы

Затем, перейдем к разделу Параметры проекции (рисунок 14).

Рисунок 14 - Меню «Параметры проекции»

Здесь задаём вид по умолчанию для исходной панорамы, т.е. кадр, с которого будет начинаться просмотр виртуального тура. Для этого передвинем панораму туда, куда необходимо и нажмём кнопку Сохранить в области Установки\Ограничения. Также выставим ограничения обзора, так как обзор вверх и вниз нам не нужен. Остальные параметры менять не будем, нажмём кнопку ОК.

Далее переходим к разделу Информация о проекте, форма информационного блока представлена на рисунке 15. Этот раздел используется для пользовательских данных, добавления информации об изображении. Добавленная информация тут же появится в выводимом HTML шаблоне, если выбран параметр автоматического включения информации. Также можно добавить HTML-теги.

Рисунок 15 - Раздел «Информация о проекте»

Проделываем данную операцию с настройками для всех панорам, из которых состоит наш тур. Затем перейдём к следующему разделу - Активные зоны. В этом разделе будут настраиваться точки перехода между панорамами. Переходим во вкладку Область активных зон и ставим галочку Включить. Сообщение спросит должен ли быть создан файл активных зон (рисунок 16). Отвечаем утвердительно.

Рисунок 16 - Создание файла активных зон

Создадим новую Активную зону. ID задаётся по умолчанию - Активная зона 1. Для рисования точки перехода можно использовать инструменты Карандаш, Прямоугольник, Эллипс и др. Для удобства рисования также можно воспользоваться функцией Масштаб. Нарисуем область, которая будет интерактивной, с помощью инструмента Прямоугольник. Активная зона будет красного цвета. Активных зон может быть несколько. Для создания дополнительных зон необходимо кликнуть на кнопку рядом с ID текущей Активной зоны в виде чистого листа. Результат показан на рисунке 17.

Рисунок 17 - Активная зона: Помещение 1

Введём имя горячей точки в поле Заголовок. Это имя будет видно при наведении курсора мыши на активную область. Далее создадим связь с другой панорамой в туре. Для этого выберем нужную ссылку в области URL (рисунок 18).

Рисунок 18 - Создание связей между панорамами

Повторим эти действия для другого помещения и в результате получим готовый виртуальный тур, с возможностью перехода из одной комнаты в другую (рисунок 19).

Рисунок 19 - Активная зона: Помещение 2

Далее перейдём к добавлению кнопок и панели управления. Для этого в разделе Экспорт выберем формат экспорта Flash и нажимаем Добавить, в результате попадаем в меню настроек (рисунок 20). В разделе Оформление из выпадающего списка выберем нужный скин. В данном случае будем использовать controller_new.ggsk, также можно редактировать, предложенный вариант оформления, или загрузить свой шаблон с помощью команды Файл.

Рисунок 20 - Меню «Настройки»

Откроем редактор оформления. Здесь можно добавить свои кнопки, изменить стиль оформления, задать звук при нажатии на элементы панели управления, добавить текст, добавить всплывающие подсказки или вставить интерактивные элементы в виде анимаций. В данном случаем мы добавим две кнопки перехода в различные помещения. Окно редактора показано на рисунке 21.

Рисунок 21 - Редактор оформления

Создадим панель управления с кнопками навигации, приближения и отдаления, перехода в полноэкранный режим. Добавим два изображения, по клику на которые будет осуществляться перемещение из одного помещения в другое (рисунок 22).

Рисунок 22 - Дополнительные кнопки

Кликаем два раза на изображение и переходим к редактированию его свойств. На вкладке Actions/Modifiers создаём действие, в результате чего по клику на изображении будет осуществляться переход к другой панораме (рисунок 23).

Рисунок 23 - Создание действия

Закончим редактирование, нажав кнопку ОК. Сохраним текущей шаблон под названием controller_new_museum.ggsk для его использования в другом помещении. Вернёмся к меню Настройки экспорта. Зададим имя экспортируемого файла и нажмём ОК. Появится сообщение с вопросом подтверждения экспорта, ответим утвердительно (рисунок 24).

Рисунок 24 - Экспорт файла

По такой же аналогии зададим настройки и для панорамы другой комнаты, изменив лишь адреса ссылок на *.swf файлы панорамы. Результаты проделанной работы для первого и второго помещений представлены на рисунках 25 и 26 соответственно.

Рисунок 25 - Виртуальный тур: Музей - Помещение 1

Рисунок 26 - Виртуальный тур: Музей - Помещение 2

Так как были созданы Активные зоны, перемещение может осуществляться как с использованием панели управления, так и непосредственно по клику на арочный проём. В итоге, мы получили готовый виртуальный тур, состоящий из нескольких панорам, с панелью управления, всплывающими окнами с текстом и с возможностью перехода из одного помещения в другое.

Заключение

Сферические и цилиндрические 3D панорамы и виртуальные туры - это удобная технология, позволяющая получить наиболее точное представление о месте, будь то туристическая достопримечательность, торговые площади, недвижимость или уникальный интерьер автомобиля.

Как и сферические панорамы, цилиндрическая редко демонстрируется напечатанной на бумаге. Чаще её просматривают на экране компьютера или иного устройства в виде интерактивного Flash-приложения. Но, в отличие от сферической панорамы, зритель не может посмотреть «вверх» и «вниз», он может перемещать свой взгляд только по горизонтали.

Интерактивная панорама предоставляет зрителю возможность не просто увидеть отдельные элементы, а оценить всё пространство в объеме, чего не может предоставить обычная фотография.

Преимуществами трехмерных панорам пользуются агентства недвижимости, строительные компании, отельные комплексы, санатории и дома отдыха, кафе и рестораны, музеи и выставки, туристические компании, торговые центры и автосалоны.

Для создания качественных панорам требуется специальное оборудование: цифровая камера, с возможностью съёмки в ручном режиме; штатив; панорамная головка. Для обработки панорам и монтирования виртуального тура создано множество программ, наиболее популярными из которых, являются PTGui и Pano2VR. Эти программы имеют достаточно простой интерфейс и, в то же время, предоставляют все возможности для создания удобного и информативного виртуального тура.

В ходе разработки курсового проекта был создан виртуальный тур по аудиториям университета. Он может быть размещён на сайте учебного заведения, например, для ознакомления абитуриентов.

Список использованных источников

Роджер, Дж. Использование Microsoft Office Word 2003. Специальное издание / Дж. Роджер: Вильямс, 2006. - 56-60 с.

Лапин А. Фотография как… М.; Издательство МГУ, 2003

Айсманн К. Ретуширование и обработка изображений в Photoshop: практическое руководство / К. Айсманн. - Минск: Вильямс, 2004. - 496 с.

Создание виртуальных туров и панорам [Электронный ресурс] - В режиме доступа: http://pano.su/ Дата доступа: 04.12.2013.

Виртуальные туры и панорамы [Электронный ресурс] - В режиме доступа: http://1panorama.ru/ Дата доступа: 04.12.2013.

Создание виртуальных туров [Электронный ресурс] - В режиме доступа: http://habrahabr.ru/qa/4885/ Дата доступа: 04.12.2013.

Размещено на Allbest.ru


Подобные документы

  • Создание виртуального музея, интерактивность как требование к приложению. Проектирование объектной модели хранилища данных виртуального музея. Обзор, сравнение систем управления содержимым. Реализация основного функционала подсистемы, этапы ее разработки.

    дипломная работа [3,0 M], добавлен 13.10.2016

  • Создание образа диска с помощью программного продукта Nero для резервного копирования, распространения программного обеспечения, виртуальных дисков, тиражирования однотипных систем. Возможности Alcohol 120%, Daemon Tools для эмуляции виртуального привода.

    курсовая работа [188,9 K], добавлен 07.12.2009

  • Анализ современного рынка программных продуктов. Понятие виртуального тура и возможности его применения. Изучение программного обеспечения и технологии создания виртуальных туров. Панорамный снимок и виртуальная брошюра. Настройка параметров панорамы.

    курсовая работа [3,5 M], добавлен 22.03.2016

  • Создание виртуального бизнес-центра в виде портала "Proffis". Реализация потребности вести единые списки объектов бизнеса у множества компаний. Проектирование архитектуры подсистемы WebList. Типы пользователей системы: администратор, лидеры и операторы.

    дипломная работа [2,0 M], добавлен 23.03.2012

  • Понятие "виртуального офиса". Защищённый канал доступа сотрудников к системам фирмы, хостинг систем, документооборот, портал. Пользователи виртуального офиса. Услуги и преимущества виртуального офиса, принцип работы. Недостатки и ненадежные провайдеры.

    контрольная работа [34,9 K], добавлен 21.10.2010

  • Повышение быстродействия операционной системы. Разработка драйверов для средств хранения данных, управление работой устройства командами PnP. Создание, настройка параметров и установка классового драйвера виртуального диска, его структура и свойства.

    курсовая работа [163,2 K], добавлен 18.06.2009

  • Анализ существующих виртуальных музеев. Формирование основных требований к виртуальному 3D музею. Анализ цифровой и текстовой информации о Московском Мультимедиа Арт Музее. Разработка структуры и интерфейса мобильного приложения виртуального музея.

    дипломная работа [3,8 M], добавлен 26.08.2017

  • Понятие виртуального магазина. Преимущества и недостатки виртуальных магазинов. Классификация виртуальных магазинов. Организация деятельности виртуальных магазинов. Создание виртуальных магазинов. Способы оплаты в Интернет. Процессинговая система.

    курсовая работа [72,0 K], добавлен 30.09.2007

  • Обзор технологии OpenStack, область ее применения. Реализация библиотеки классов. Реализация базовых классов и интерфейсов архитектуры. Создание виртуального сервера. Интеграция разработанной библиотеки классов и архитектура проектного решения.

    дипломная работа [1,0 M], добавлен 09.08.2016

  • Многослойная архитектура драйверов. Организация внутреннего хранения данных диска. Выбор и обоснование языка и среды программирования. Обработка расширенных запросов. Процедуры установки драйвера виртуального диска. Блокировка выгрузки устройства.

    курсовая работа [159,1 K], добавлен 23.06.2009

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.