Моделирование и анализ электрических схем в среде Electronics Workbench

Структура окна и система меню File, Edit, Circuit, Window, Help, Analysis. Обмен данными с программой PSpice. Контрольно-измерительные приборы: мультиметр, функциональный генератор, осциллограф, ненератор слова, логический анализатор и преобразователь.

Рубрика Коммуникации, связь, цифровые приборы и радиоэлектроника
Вид отчет по практике
Язык русский
Дата добавления 28.04.2015
Размер файла 1,8 M

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru/

Оглавление

Введение

1. Структура окна и система меню

1.1 Меню File

1.2 Меню Edit

1.3 Меню Circuit

1.4 Меню Window

1.5 Меню Help

1.6 Меню Analysis программы EWB 5.0

1.7 Обмен данными с программой PSpice

2. Технология подготовки схем

3. Контрольно-измерительные приборы

3.1 Мультиметр (Multimeter)

3.2 Функциональный генератор (Function Generator)

3.3 Осциллограф (Oscilloscope)

3.4 Измеритель АЧХи ФЧХ (Bode Plotter)

3.5 Генератор слова (Word Generator)

3.6 Логический анализатор (Logic Analyzer)

3.7 Логический преобразователь (Logic Converter)

4. Практические занятия

4.1 Занятие 1. Изучение основных возможностей программы

4.2 Занятие 2. Моделирование и анализ цифровых устройств

Библиографический список

Приложение

Введение

меню программа измерительный прибор

Содержит основные сведения, инструкции, методики организации и проведения экспериментов при исследовании схем в среде схемотехнического моделирования Electronics Workbench. Приводятся краткие сведения из теории элементов и устройств, предлагаемых для самостоятельного исследования в ходе двух практических занятий. Даются формы для записи результатов экспериментов и теоретических расчетов, облегчающие последующий их анализ, а также контрольные вопросы, ориентирующие обучающихся на осознание целей экспериментов и их направленности. Разработан в соответствии с Государственным общеобразовательным стандартом высшего профессионального образования.

Предназначен для студентов дневной формы обучения специальности 210100 - управление и информатика в технических системах.

Табл. 7. Ил. 43. Библиогр.: 2 назв.

Система схемотехнического моделирования Electronics Workbench предназначена для моделирования и анализа аналоговых, цифровых и цифро-аналоговых схем большой степени сложности. Имеющиеся в программе библиотеки включают в себя большой набор широко распространенных электронных компонентов. Есть возможность подключения и создания новых библиотек компонентов.

Параметры компонентов можно изменять в широком диапазоне значений. Простые компоненты описываются набором параметров, значения которых можно изменять непосредственно с клавиатуры, активные элементы моделью, представляющей собой совокупность параметров и описывающей конкретный элемент или его идеальное представление. Модель выбирается из списка библиотек компонентов, параметры модели также могут быть изменены пользователем.

Широкий набор приборов позволяет производить измерения различных электрических величин, задавать входные воздействия, строить графики. Все приборы изображаются в виде, максимально приближенном к реальному, поэтому работать с ними просто и удобно.

Electronics Workbench может проводить анализ схем на постоянном и переменном токах. При анализе на постоянном токе определяется рабочая точка схемы в установившемся режиме работы. Результаты этого анализа не отражаются на приборах, они используются для дальнейшего анализа схемы. Анализ на переменном токе использует результаты анализа на постоянном токе для получения линеаризованных моделей нелинейных компонентов. Анализ схем может проводиться как во временной, так и в частотной областях. Программа также позволяет производить анализ цифро-аналоговых и цифровых схем.

Результаты моделирования можно вывести на принтер или импортировать в текстовый или графический редактор для их дальнейшей обработки.

Программа Electronics Workbench совместима с программой Pspice, то есть предоставляет возможность экспорта и импорта схем и результатов измерений в различные её версии.

1. Структура окна и система меню

Рабочeе окно программы EWB 5.1 (рис. 1.1) содержит поле меню, линейку инструментов, контрольно-измерительных приборов и линейку библиотек компонентов, одна из которых в развернутом виде показана в левой части окна. В рабочем поле программы располагается моделируемая схема с подключенными к ней "иконками" контрольно-измерительных приборов и краткое описание схемы (description). При необходимости каждый из приборов может быть развернут для установки режимов его работы и наблюдения результатов.

Рис. 1.1. Окно программы EWB 5.1

Рассмотрим команды меню программы EWB 5.1 в порядке их следования на рис. 1.1.

1.1 Меню File

Меню File предназначено для загрузки и записи файлов, получения твердой копии выбранных для печати составных частей схемы, а также для импорта/экспорта файлов в форматах других систем моделирования и программ разработки печатных плат.

1. Первые четыре команды этого меню: New (Ctrl+N), Open... (Ctrl+0), Save (Ctrl+S), Save As... -- типичные для Windows команды работы с файлами, и поэтому пояснений не требуют. Схемные файлы программы EWB имеют следующие расширения: .са3 и .cd3 -- аналоговые и цифровые схемы для EWB 3.0, .са4 -- аналого-цифровые схемы для EWB и .ewb -- аналого-цифровые схемы для EWB 5.0.

2. Revent to Saved... -- стирание всех изменений, внесенных в текущем сеансе редактирования, и восстановление схемы в первоначальном виде.

3. Print... (CTRL+P) -- выбор данных для вывода на принтер: Schematic -- схемы (опция включена по умолчанию); Description -- описания к схеме; Part list -- перечня выводимых на принтер документов; Label list -- списка обозначений элементов схемы; Model list -- списка имеющихся в схеме компонентов; Subcircuits -- подсхем (частей схемы, являющихся законченными функциональными узлами и обозначаемых прямоугольниками с названием внутри); Analysis options -- перечня режимов моделирования; Instruments -- списка приборов.

В этом же подменю можно выбрать опции печати (кнопка Setup) и отправить материал на принтер (кнопка Print), можно также изменить масштаб выводимых на принтер данных в пределах от 20 до 500 %.

В меню также предусмотрена возможность обмена данными с программой разработки печатных плат EWB Layout.

1.2 Меню Edit

Меню Edit позволяет выполнять команды редактирования схем и копирования экрана.

Первые пять команд этого меню: Cut (CTRL+X), Copy (CTRL+C), Paste (CTRL+V), Delete (Del), Select All (CTRL+A) -- типичные для Windows команды работы с файлами, и поэтому пояснений не требуют.

Команда Copybits (CTRL+I) превращает курсор мыши в крестик, которым по правилу прямоугольника можно выделить нужную часть экрана. После отпускания левой кнопки мыши выделенная часть копируется в буфер обмена, после чего его содержимое может быть импортировано в любое приложение Windows. Копирование всего экрана производится нажатием клавиши Print Screen: копирование активной в данный момент части экрана, например, диалогового окна -- комбинацией Alt+Print Screen. Команда очень удобна при подготовке отчетов по моделированию, например при оформлении лабораторных работ.

Команда Show Clipboard для показа содержимого буфера обмена.

1.3 Меню Circuit

Меню Circuit используется при подготовке схем, а также для задания параметров моделирования. Оно содержит команды управления расположением графического изображения компонентов: Flip Horizontal -- зеркальное отображение компонента по горизонтали и Flip Vertical -- то же, но по вертикали. Команды Rotate, Flip Horizontal и Flip Vertical могут быть выполнены также нажатием кнопок с соответствующими графическими изображениями.

Команда Component Properties (свойства компонента) содержит ряд закладок. Так, при выборе закладки Value задаются номинальное сопротивление компонента (резистора), значение линейного (ТС1) и квадратичного (ТС2) температурных коэффициентов сопротивления. С учетом этих параметров действительное значение резистора определяется выражением

R=Rn[1+TC1(T-Tn)+TC2 (T-Tn)2],

где Rn -- номинальное сопротивление резистора; Тn=27°С -- номинальная температура; Т -- текущее значение температуры резистора.

При выборе закладки Fault приводятся условия моделирования и набор выводов компонента с опцией на каждый вывод, что позволяет выборочно имитировать ту или иную неисправность. Например, если требуется имитировать нарушение контакта вывода 1 резистора, то в этом случае включаются опции 1 и Open (открыто -- обрыв). Введение таких дефектов в схему позволяет отрабатывать у учащегося навыки поиска и локализации неисправностей.

При выборе закладки Display с помощью диалогового окна задается характер вывода на экран обозначений компонента. При выборе опции Use Schematic Options global setting используются установки, принятые для всей схемы, в противном случае используется индивидуальная настройка вывода на экран позиционного обозначения и номинального значения для каждого компонента.

Диалоговое окно при выборе закладки Analysis Setup позволяет установить температуру для каждого компонента индивидуально или использовать ее номинальное значение, принятое для всей схемы (Use global temperature).

Меню команды Component Properties содержит подменю Models для активных компонентов, с помощью которого выбирается тип библиотечного компонента, редактируются его параметры, создается новая библиотека и выполняются другие команды.

Окна команды Schematic Options при выборе закладок Wiring и Printing связаны с прокладкой проводников на схеме и организацией их взаимных соединений (Routing options), удалением проводников (Rewiring options) и соединений (Auto-delete connectors -- автоматическое удаление неиспользуемых соединений, например дублирующих друг друга), с масштабированием выводимой на принтер информации.

1.4 Меню Window

Меню Window содержит следующие команды:

Arrange (CTRL+W) -- упорядочивание информации в рабочем окне EWB путем перезаписи экрана, при этом исправляются искажения изображений компонентов и соединительных проводников;

Circuit -- вывод схемы на передний план;

Description (CTRL+D) -- вывод на передний план описания схемы, если оно имеется, или окно-ярлык для его подготовки (только на английском языке).

1.5 Меню Help

Меню Help построено стандартным для Windows способом. Оно содержит краткие сведения по всем рассмотренным выше командам, библиотечным компонентам и измерительным приборам, а также сведения о самой программе. Отметим, что для получения справки по библиотечному компоненту его необходимо отметить на схеме щелчком мыши (он высветится красным цветом) и затем нажать клавишу F1.

1.6 Меню Analysis программы EWB 5.0

1. Первые три команды -- Activate (CTRL+G), Stop (CTRL+T),

Pause (F9) -- команды запуска, остановки и прерывания.

2. Analysis Options... (CTRL+Y) -- набор команд для установки параметров моделирования.

2.1. Global -- настройки общего характера, задаются с помощью диалогового окна (рис. 1.2), в котором параметры имеют следующее назначение:

Рис. 1.2. Диалоговое окно настройки параметров моделирования общего характера

Abstol -- абсолютная ошибка расчета токов;

Gmin -- минимальная проводимость ветви цепи (проводимость ветви, меньшая GMIN, считается равной нулю); Pivrel, Pivtol -- относительная и абсолютная величины элемента строки матрицы узловых проводимостей (например, при расчете по методу узловых потенциалов), необходимые для его выделения в качестве ведущего элемента;

Reltol -- допустимая относительная ошибка расчета напряжений и токов;

Temp -- температура, при которой проводится моделирование;

Vntol -- допустимая ошибка расчета напряжений в режиме Transient (анализ переходных процессов);

Chgtol -- допустимая ошибка расчета зарядов;

Ramptime -- начальная точка отсчета времени при анализе переходных процессов;

Convstep -- относительный размер шага итерации при расчете режима по постоянному току;

Convabsstep -- абсолютный размер шага итерации при расчете режима по постоянному току;

Convlimit -- включение или выключение дополнительных средств для обеспечения сходимости итерационного процесса (например, за счет использования метода вариации напряжений источников питания;

Rshunt -- допустимое сопротивление утечки для всех узлов относительно общей шины (заземления).

Temporary... -- объем дисковой памяти для хранения временных файлов (в Мбайт).

2.2. DC -- настройка для расчета режима по постоянному току (статический режим). Для настройки этого режима используется диалоговое окно (рис. 1.3), параметры которого имеют следующее назначIеtlн1ие:-- максимальное количество итераций приближенных расчетов;

Gminsteps -- размер приращения проводимости в процентах от GMIN (используется при слабой сходимости итерационного процесса);

Srcsteps -- размер приращения напряжения питания в процентах от его номинального значения при вариации напряжения питания (используется при слабой сходимости итерационного процесса).

Рис. 1.3. Диалоговое окно установки параметров режима DC

Кнопка Reset Defaults предназначена для установки по умолчанию параметров, показанных на рис. 1.2. Используется в том случае, если после редактирования необходимо вернуться к исходным данным.

2.3. Transient -- настройка параметров режима анализа переходных процессов (диалоговое окно на рис. 1.4):

Itl4 -- максимальное количество итераций за время анализа переходных процессов;

Рис. 1.4. Диалоговое окно настройки режима моделирования переходных процессов дифференциального уравнения:

Maxord -- максимальный порядок (от 2 до 6) метода интегрирования дифференциального уравнения;

Trtol -- допуск на погрешность вычисления переменной;

Method -- метод приближенного интегрирования

Trapezoidal -- метод трапеций, Gear -- метод Гира;

Асст -- разрешение на вывод статистических сообщений о процессе моделирования.

2.4. Device -- выбор параметров МОП-транзисторов (диалоговое окно показано на рис. 1.5):

Defad -- площадь диффузионной области стока, м2;

Defas -- площадь диффузионной области истока, м2;

Defl -- длина канала полевого транзистора, м;

Defw -- ширина канала, м;

Рис. 1.5. Выбор параметров МОП-транзисторов

Tnom -- номинальная температура компонента;

Bypass -- коммутация нелинейной части модели компонента;

Trytocompact -- включение или выключение линейной части модели компонента.

2.5. Instruments -- настройка параметров контрольно-измерительных приборов (рис. 1.6):

Pause after each screen -- пауза (временная остановка моделирования) после заполнения экрана осциллографа по горизонтали (Oscilloscope);

Generate time steps automatically -- автоматическая установка временного шага (интервала) вывода информации на экран;

Minimum number of time points -- минимальное количество отображаемых точек за период наблюдения (регистрации);

Рис. 1.6. Диалоговое окно настройки параметров

Тмах --промежуток времени от начала до конца моделирования;

Set to Zero -- установка в нулевое (исходное) состояние контрольноизмерительных приборов перед началом моделирования;

User-defined -- управление процессом моделирования проводится пользователем (ручной пуск и остановка);

Calculate DC operating point -- выполнение расчета режима по постоянному току;

Points per cycle -- количество отображаемых точек при выводе амплитудно-частотных и фазо-частотных характеристик (Bode plotter);

Use engineering notation -- использование инженерной системы обозначений единиц измерения (например, напряжения будут выводиться в милливольтах (мВ), микровольтах (мкВ), нановольтах (нВ) и т.д.).

3. DC Operating Point --расчет режима по постоянному току. В режиме DC из моделируемой схемы исключаются все конденсаторы и закорачиваются все индуктивности.

Рассмотрение DC-режима и последующих команд меню Analysis целесообразно вести на примере практических устройств. В качестве таковых используем фильтр верхних частот на операционном усилителе (рис. 1.7) и генератор Колпитца (рис. 1.8).

Рис. 1.7. Фильтр высоких частот на операционном усилителе

Рис. 1.8. Генератор Колпитца

Отметим, что при использовании команд меню Analysis целесообразно в меню Circuit>Schematic Options>Show/Hide включить опции Show Reference ID и Show Nodes. Отметим также, что в схеме фильтра входное напряжение во всех случаях принято равным 100 мкВ.

Результаты расчета режима генератора Колпитца по постоянному току показаны на рис. 1.9. В верхней части рисунка указано имя схемного файла. Ниже приведены потенциалы узлов схемы в контрольных точках 1, 2, 3, 4 и на выводах транзистора.

4. AC Frequency... -- расчет частотных характеристик. Выполнение команды начинается с задания в диалоговом окне (рис. 1.10) следующих параметров:

Fstart, Fstop -- границы частотного диапазона (минимальное и максимальное значение частоты соответственно);

Sweep type -- масштаба по горизонтали: декадный (Decade), линейный (Linear) и октавный (Octave);

Number of points -- числа точек;

Vertical scale -- масштаба по вертикали: линейный (Linear), логарифмический (Log) и в децибелах (Decibel);

Nodes in circuit -- списка всех узлов цепи;

Nodes for analysis -- номеров узлов, для которых рассчитываются характеристики схемы, перечень таких узлов устанавливается нажатием кнопок Add -> (добавить) и | <Remove (удалить);

Simulate -- кнопка запуска моделирования.

Рис. 1.9. Результат расчета режима по постоянному току генератора Колпитца

Рис. 1.10. Окно выбора параметров моделирования

Результаты моделирования фильтра представлены на рис. 1.11 в виде амплитудно-частотной (АЧХ -- верхняя кривая) и фазо-частотной (ФЧХ -- нижняя кривая) характеристик. Аналогичные характеристики можно получить также и с помощью измерителя АЧХ-ФЧХ, причем с более высокой точностью за счет сканирования АЧХ и ФЧХ в выбранных точках визирной линейкой.

Дополнительные манипуляции с результатами расчета выполняются с помощью командных кнопок, расположенных в верхней части окна (рис. 1.11). Первые восемь кнопок являются стандартными и пояснений не требуют. Назначение третьей группы кнопок рассмотрено ниже.

Рис. 1.11. Результаты расчета частотных характеристик фильтра

Рис. 1.12. Окно оформления результатов моделирования General

4.1. Properties -- параметры графического изображения, таково название первой кнопки. При ее нажатии открывается диалоговое окно (рис. 1.12), имеющее закладки General, Left Axis, Bottom Axis, Right Axis, Top Axis и Traces.

Окно General состоит из четырех блоков:

Title -- редактирование названия с возможностью изменения шрифта;

Grid -- нанесение на графики сетки с возможностью редактирования толщины линий и их цвета;

Trace Legend -- отображение на экране сигнала в контрольных точках схемы с указанием цвета соответствующих графиков;

Cursors -- вывод на экран характеристик АЧХ и ФЧХ в табличном виде для одного или всех выбранных узлов схемы.

При выборе заставки Left Axis диалоговое окно оформления результатов моделирования имеет вид, показанный на рис. 1.13. Оно состоит из следующих блоков:

Label -- редактирование обозначения оси Y с возможностью изменения шрифта и его атрибутов (например, можно заменить символ обозначения напряжения V на U);

Axis -- изменение толщины линии оси Y и ее цвета;

Division -- количество разбиений в одном большом делении сетки; Range -- диапазон значений по оси Y;

Scale -- установка масштаба по оси Y (линейный, логарифмический и т.д.).

Рис. 1.13. Окно оформления результатов моделирования Left Axis

Для заставок Bottom Axis, Rigt Axis и Top Axis окна настроек имеют аналогичный вид. Для заставки Traces окно настроек показано на рис. 1.14.

Окно состоит из следующих блоков:

Trace -- выбор номера контрольной точки, для которой редактируется изображение характеристики;

Label -- задание метки рассматриваемой точки (на рис. 1.14 она совпадает с номером контрольной точки, однако здесь может быть размещена и другая информация в виде комментариев);

Pen Size -- выбор ширины линии для изображения характеристики;

Color -- выбор цвета линии;

Sample -- образец линии; Х Range -- выбор оформления для оси X, аналогичного выбранному в окне Bottom Axis или Top Axis;

Рис. 1.14. Окно оформления результатов моделирования Traces

Y Range -- выбор оформления для оси Y, аналогичного выбранному в окне Left Axis (рис. 1.13) или Right Axis;

Offsets -- установка смещения координат по осям Х и Y.

4.1

-- эти кнопки имеют соответственно названия Toggle Grid (вставить сетку), Toggle Legend (вставить обозначение контрольной точки), Toggle Cursor (вывести числовые данные), Restore Graph (восстановить графическое обозначение, т.е. проигнорировать введенные изменения), Reverse Color (инвертировать цвет).

4.2 Transient... -- расчет переходных процессов. Диалоговое окно команды (рис. 1.15) содержит следующие данные: Initial conditions -- установка начальных условий моделирования; назначение составных частей этого блока рассматривались при описании окна, изображенного на рис. 1.6;

Рис. 1.15. Задание режимов моделирования переходных процессов

Tstart -- время начала анализа переходных процессов; Tstop -- время окончания анализа;

Generate time steps automatically -- расчет переходных процессов с переменным шагом, выбираемым автоматически в соответствии с допустимой относительной ошибкой RELTOL, задаваемой в окне, изображенном на рис. 1.2; если эта опция выключена, то расчет ведется с учетом двух других опций, описанных при рассмотрении окна настройки параметров (см. рис. 1.6);

Tstep -- временной шаг вывода результатов моделирования на экран монитора.

Порядок использования параметров Nodes in circuit описан при рассмотрении окна выбора параметров моделирования (см. рис. 1.10).

При указанных в рассмотренном окне параметрах результаты моделирования переходных процессов в фильтре представлены на рис. 1.16.

Здесь показан также ярлык (он может быть размещен в любом месте экрана), с помощью которого можно узнать, в какой точке схемы снята синусоида.

Рис. 1.16. Результаты моделирования переходных процессов в фильтре

Из рис. 1.16 видно запаздывание выходного сигнала относительно входного.

5. Fourier... -- проведение Фурье-анализа (спектрального анализа). При выборе этой команды необходимо задать параметры моделирования с помощью диалогового окна (рис. 1.17), в котором опции имеют следующее назначение:

Output node -- номер контрольной точки (узла), в которой анализируется спектр сигнала;

Fundamental frequency -- основная частота колебания (частота первой гармоники);

Number harmonic --число гармоник, подлежащих анализу;

Vertical scale -- масштаб по оси Y (линейный, логарифмический, в децибелах);

Рис. 1.17. Окно установки режима Фурье-анализа

Advanced -- набор опций этого блока предназначен для определения более тонко структуры анализируемого сигнала путем введения дополнительных выборок (по умолчанию выключены);

Number of points per harmonic -- количество отсчетов (выборок) на одну гармонику;

Sampling frequency -- частота следования выборок;

Display phase -- вывод на экран распределения фаз всех гармонических составляющих в виде непрерывной функции (по умолчанию выводится график только амплитуд гармоник);

Output as line graph -- вывод на экран распределения амплитуд всех гармонических составляющих в виде непрерывной функции (по умолчанию -- в виде линейчатого спектра).

Если в окне (см. рис. 1.17) установить последние две опции, то в результате анализа получают кривые распределения амплитуд в логарифмическом масштабе и распределения фаз гармонических составляющих.

Рис. 1.18. Окно установки параметров моделирования

6. Monte Carlo... -- статистический анализ по методу Монте-Карло. В диалоговом окне установки параметров моделирования для этой команды (рис. 1.18) задаются следующие параметры:

Number of runs -- количество статистических испытаний;

Global Tolerance -- отклонения параметров резисторов, конденсаторов, индуктивностей, источников переменного и постоянного тока и напряжения;

Seed -- начальное значение случайной величины (этот параметр определяет начальное значение датчика случайных чисел и может задаваться в пределах 1...32767 ;

Distribution type ? закон распределения случайных чисел: Uniform ? равновероятное распределение на отрезке (-1, +1) и Gaussian ? гауссовское распределение на отрезке (-1, +1) с нулевым средним значением и среднеквадратическим отклонением 0,25. Требуемый закон распределения выбирается после нажатия кнопки в поле рассматриваемой опции.

Global tolerance -- отклонение параметров резисторов, конденсаторов, индуктивностей, источников переменного и постоянного тока и напряжения;

Collating function -- характеристики схемы (выбираются из предлагаемого списка): максимальное и минимальное значение величины (Max. value, Min. value), максимальная и минимальная частота (Frequency at max. Frequency at min), значение частоты (Rise edge frequency. Fall edge frequency), при котором происходит пересечение заданного уровня порогового напряжения Threshold снизу-вверх и сверху-вниз;

Output node -- выбор выходной точки схемы.

В нижней части окна перечислены режимы моделирования, для которых может быть проведен многовариантный анализ. В правом нижнем углу находятся кнопки для установки параметров этих режимов, диалоговые окна которых практически не отличаются от рассмотренных выше.

Результаты статистического анализа генератора Колпитца при указанных на рис. 1.18 значениях параметров приведены на рис. 1.19, а, на котором ломаная кривая показывает изменения постоянной составляющей (напряжения покоя) на выходе схемы при случайном изменении параметров ее компонентов при числе испытаний 20.

В режиме анализа переходных процессов результаты статистических испытаний при числе испытаний 2 показаны на рис. 1.19, б (малое число испытаний выбрано из чисто оформительских соображений, поскольку каждый результат испытаний отображается другим цветом, и в черно-белом исполнении это выглядело бы не лучшим образом).

На рис. 1.19,б приведены также среднее значение контролируемой

Рис. 1.19. Результаты статистических испытаний генератора Колпитца: а изменение постоянной составляющей; б режим анализа переходных процессов величины Mean, ее среднеквадратическое отклонение Standard deviation (std), процентное содержание данных с отклонениями в ±1 std, ±2 std и т.д.

7. Display Graph -- этой командой вызываются на экран графики результатов выполнения одной из команд моделирования. Если в процессе моделирования использовано несколько команд этого меню, то результаты их выполнения накапливаются и в знакомом нам окне отображаются в виде закладок с наименованием команд, которые могут перемещаться кнопками, расположенными в правом верхнем углу окна. Это позволяет оперативно просматривать результаты моделирования без его повторного проведения. Отметим, что вызов команды происходит автоматически при выполнении первой же команды из меню Analysis. Если в схеме используется осциллограф, то после запуска моделирования и предварительно установленной команды Display Graph в ее окне появляется закладка Oscilloscope с изображением осциллограммы; если используется измеритель АЧХ-ФЧХ, то появляется закладка Bode с изображением АЧХ и ФЧХ и т.д. Одновременно графическая информация выводится также и на основные приборы.

1.7 Обмен данными с программой PSpice

Обмен данными с PSpice и другими программами (OrCAD, EWB Layout и др.) производится с помощью команд Export и Import меню File.

Перед выполнением команды Export необходимо загрузить файл схемы.

В строке "Тип файла" можно выбрать следующие типы файлов: Spice (*.cir), WAD PCB (*.net). Tango (*.net). Eagle (*.scr), Layo1 (*.cmp), Ultimate (*.plc), EWB Layout (*.plc).

При выборе типа файла Spice получаем файл с расширением .cir (в данном случае 2m-osc.cir) с текстовым описанием схемы в формате PSpice. В случае импорта файлов в формате PSpice в программе EWB выполняется построение принципиальной схемы. После выбора команды Import открывается диалоговое окно, в котором необходимо указать имя импортируемого файла (только в формате SPICE). После этого вызывается меню размещения (Part Placement). Выбор в этом меню режимов Default (по умолчанию) и Quick (быстрый) приводит к достаточно быстрому выводу схемы, однако вид ее получается крайне неудобочитаемым. Выбор режима Customized (самостоятельная настройка) приводит к цепочке последовательно вызываемых меню, в которых корректируется размещение, скорость формирования изображения схемы, плотность размещения, максимальное количество проводников.

2. Технология подготовки схем

Прежде чем создавать чертеж принципиальной схемы средствами программы EWB, необходимо на листе бумаги подготовить ее эскиз с примерным расположением компонентов и с учетом возможности оформления отдельных фрагментов в виде подсхем. Целесообразно также ознакомиться с библиотекой готовых схем программы (см. приложение) для выбора аналога (прототипа) или использования имеющихся решений в качестве подсхем.

В общем случае процесс создания схемы начинается с размещения на рабочем поле EWB компонентов из библиотек программы в соответствии с подготовленным эскизом. Разделы библиотеки программы EWB поочередно могут быть вызваны с помощью меню Window или с помощью "иконок", расположенных рядом с линейкой контрольно-измерительных приборов (см. рис. 1.1). Каталог выбранной библиотеки устанавливается в любое место стандартным способом -- перетаскиванием за шапку заголовка. Для открытия каталога нужной библиотеки необходимо подвести курсор мыши к соответствующей "иконке" и нажать один раз левую кнопку, после чего серый фон "иконки" меняется на желтый. Необходимый для создания схемы значок (символ) компонента переносится из каталога на рабочее поле программы движением мыши при нажатой левой кнопке, после чего кнопка отпускается (для фиксирования символа) и производится двойной щелчок по значку компонента. В раскрывающемся диалоговом окне устанавливаются требуемые параметры (сопротивление резистора, тип транзистора и т.д.), выбор подтверждается нажатием кнопки Accept или клавиши Enter. На этом этапе необходимо предусмотреть место для размещения контрольных точек и "иконок" контрольно-измерительных приборов.

Если в схеме используются компоненты одинакового номинала (например, резисторы с одинаковым сопротивлением), то номинал такого компонента рекомендуется задать непосредственно в каталоге библиотеки и затем переносить компоненты в нужном количестве на рабочее поле. Для изменения номинала компонента необходимо два раза щелкнуть мышью по символу его графического изображения и в раскрывающемся после этого окне внести изменения.

При размещении компонентов схемы на рабочем поле программы EWB 5.0 можно воспользоваться динамическим меню.

После размещения компонентов производится соединение их выводов проводниками. При этом необходимо учитывать, что к выводу компонента можно подключить только один проводник. Для выполнения подключения курсор мыши подводится к выводу компонента, и после появлении прямоугольной площадки синего цвета нажимается левая кнопка. Появляющийся при этом проводник протягивается к выводу другого компонента до появления на нем такой же прямоугольной площадки, после чего кнопка мыши отпускается, и соединение готово.

При необходимости подключения к этим выводам других проводников в библиотеке Passive выбирается точка (символ соединения) и переносится на ранее установленный проводник. Чтобы точка почернела (первоначально она имеет красный цвет), необходимо щелкнуть мышью по свободному месту рабочего поля. Если эта точка действительно имеет электрическое соединение с проводником, то она полностью окрашивается черным цветом. Если на ней виден след от пересекающего проводника, то электрического соединения нет, и точку необходимо установить заново. После удачной установки к точке соединения можно подключить еще два проводника.

Если соединение нужно разорвать, курсор подводится к одному из выводов компонентов или точке соединения. При появлении площадки нажимается левая кнопка, проводник отводится на свободное место рабочего поля, после чего кнопка отпускается. Если необходимо подключить вывод к имеющемуся на схеме проводнику, то проводник от вывода компонента курсором подводится к указанному проводнику, и после появления точки соединения кнопка мыши отпускается. Следует отметить, что прокладка соединительных проводников производится автоматически, причем препятствия -- компоненты и другие проводники -- огибаются по ортогональным направлениям (по горизонтали или вертикали).

Точка соединения может быть использована не только для подключения проводников, но и для введения надписей (например, указания величины тока в проводнике, его функционального назначения и т.п.). Для этого необходимо дважды щелкнуть по точке и в раскрывшемся окне ввести необходимую запись (не более 14 символов), причем запись можно смещать вправо путем введения слева нужного количества пробелов. Это свойство может быть использовано и в том случае, когда позиционное обозначение компонента (например Cl, R10) накладывается на рядом проходящий проводник или другие элементы схемы.

Если необходимо переместить отдельный сегмент проводника, к нему подводится курсор, нажимается левая кнопка, и после появления в вертикальной или горизонтальной плоскости двойного курсора производятся нужные перемещения.

Подключение к схеме контрольно-измерительных приборов производится аналогично. Причем для таких приборов, как осциллограф или логический анализатор, соединения целесообразно проводить цветными проводниками, поскольку их цвет определяет цвет соответствующей осциллограммы. Цветные проводники целесообразны не только для обозначения проводников одинакового функционального назначения, но и для проводников, находящихся в разных частях схемы (например, проводники шины данных до и после буферного элемента). Примеры такого оформления можно найти в каталогах готовых схем (см. файл ad.c-dacl.ca4).

При обозначении компонентов необходимо придерживаться рекомендации правил, предусмотренных ЕСКД (единой системой конструкторской документации). Что касается пассивных компонентов, то при выборе их обозначений особых трудностей не возникает. Трудности возникают при выборе активных элементов микросхем, транзисторов и т.п., особенно при необходимости использования компонентов отечественного производства, когда требуется установить точное соответствие функциональных обозначений выводов и параметров зарубежных и отечественных компонентов. Для облегчения этой задачи можно воспользоваться таблицами соответствия зарубежных и отечественных компонентов.

При импортировании в создаваемую схему другой схемы или ее фрагментов целесообразно действовать в следующей последовательности:

• командой File>Save As записать в файл создаваемую схему, указав его имя в диалоговом окне (расширение имени файла указывать не обязательно, программа сделает это автоматически);

• командой File>0pen загрузить на рабочее поле импортируемую схему стандартным для Windows образом;

• командой Edit>Select All выделить схему, если импортируется вся схема, и выделить ее нужную часть;

• командой Edit>Copy скопировать выделенную схему в буфер;

• командой File>0pen загрузить создаваемую схему;

• командой Edit>Paste вставить содержимое буфера обмена на рабочее поле; после вставки импортируемая схема будет выделена (и отмечена красным цветом) и может оказаться наложенной на создаваемую схему;

• клавишами управления или мышью отбуксируйте импортированную часть в нужное место, после чего можно отменить выделение;

• после подключения импортированной схемы необходимо щелчками мыши пройтись по всем ее компонентам, чтобы исключить их смещения, возникающие при буксировке и приводящие к ступенчатым искажениям проводников.

Перемещения отдельных фрагментов схемы при ее компоновке выполняются вышеописанным образом после выделения фрагмента.

После подготовки схемы рекомендуется составить ее описание (окно-ярлык вызывается из меню Window>Description), в котором указывается назначение; после проведения моделирования указываются его результаты. К сожалению, программа EWB позволяет вводить описание только на английском языке. Кроме того, в EWB не предусмотрены средства для редактирования графических изображений компонентов, а также введения новых шрифтов.

3. Контрольно-измерительные приборы

Панель контрольно-измерительных приборов находится под полем меню рабочего окна программы EWB 5.0 (см. рис. 1.1) и содержит цифровой мультиметр, функциональный генератор, двухканальный осциллограф, измеритель амплитудно-частотных и фазо-частотных характеристик, генератор слов (кодовый генератор), 16-канальный логический анализатор и логический преобразователь (рис. 3.1). Общий порядок работы с приборами такой: "иконка" прибора курсором переносится на рабочее поле и подключается проводниками к исследуемой схеме. Для приведения прибора в рабочее (развернутое) состояние необходимо дважды щелкнуть курсором по его "иконке". Рассмотрим каждый прибор подробно.

Рис. 3.1. Панель контрольноизмерительных приборов

3.1 Мультиметр (Multimeter)

На лицевой панели мультиметра (рис. 3.2) расположен дисплей для отображения результатов измерения, клеммы для подключения к схеме и кнопки управления:

-- выбор режима измерения тока, напряжения, сопротивления и ослабления (затухания);

-- выбор режима измерения переменного или постоянного тока;

-- режим установки параметров мультиметра. После нажатия на эту кнопку открывается диалоговое окно (рис. 3.3), на котором обозначены:

Рис. 3.2. Лицевая панель мультиметра

Ammeter resistance -- внутреннее сопротивление амперметра;

Voltmeter resistance -- входное сопротивление вольтметра;

Ohmmeter current -- ток через контролируемый объект;

Decibel standard -- установка эталонного напряжения VI при измерении ослабления или усиления в децибелах (по умолчанию Vl = l В). При этом для коэффициента передачи используется формула:

K[дБ]=20log(V2/Vl),

где V2 напряжение в контролируемой точке.

Рис. 3.3. Окно установки режимов мультиметра

Приведем пример использования мультиметра в режиме dB. Предположим, что необходимо измерить коэффициент передачи аудиоусилителя на частоте 20 кГц. Для этого к его входу подключим источник переменного синусоидального напряжения частотой 20 кГц и напряжением V1=1 В, а к выходу -- мультиметр. Предположим далее, что в режиме измерения напряжения получена величина выходного напряжения V2=100 В. Следовательно, коэффициент передачи усилителя K= V2/Vl =100. Переведем мультиметр в режим dB, тогда получим значение коэффициента усиления в децибелах K[дБ]=20log100=40 дБ. Предположим далее, что частота входного сигнала увеличена до 100 кГц и получено напряжение на выходе усилителя V2=0,1 В, т.е. коэффициент передачи в данном случае составляет К=0,1/1=0,1. В режиме dB мультиметр измерит К[дб]=20log0,1= -20 дБ.

Отметим, что мультиметр измеряет эффективное (действующее) значение переменного тока.

3.2 Функциональный генератор (Function Generator)

Лицевая панель генератора показана на рис. 3.4.

Управление генератором ocyществляется следующими кнопками:

-- выбор формы выходного сигнала: синусоидальной (выбрана; по умолчанию), треугольной и прямоугольной;

Frequency-- установка частоты выходного сигнала;

Duty cycle-- установка коэффицента заполнения в %: для импульсных сигналов это отношение длительности импульса к периоду повторения -- величина, обратная скважности, для треугольных сигналов -- соотношение между длительностями переднего и заднего фронта;

Amplitude -- установка амплитуды выходного сигнала;

Offset установка смещения (постоянной составляющей) выходного сигнала;

Рис. 3.4. Лицевая панель функционального генератора

-- выходные зажимы; при заземлении клеммы Сommon (общий) на клеммах "-" и "+" получаем

3.3 Осциллограф (Oscilloscope)

Лицевая панель осциллографа показана на рис. 3.5.

Рис. 3.5. Лицевая панель осциллографа

Осциллограф имеет два канала (CHANNEL) А и В с раздельной регулировкой чувствительности в диапазоне от 10 мкВ/дел (mV/Div) до 5 кВ/дел (kV/Div) и регулировкой смещения по вертикали (Y POS). Выбор режима по входу осуществляется нажатием кнопок . Режим АС предназначен для наблюдения только сигналов переменного тока (его еще называют режимом "закрытого входа", поскольку в этом режиме на входе усилителя включается разделительный конденсатор, не пропускающий постоянную составляющую). В режиме 0 входной зажим замыкается на землю. В режиме DC (включен по умолчанию) можно проводить осциллографические измерения как постоянного, так и переменного тока. Этот режим еще называют режимом "открытого входа", поскольку входной сигнал поступает на вход вертикального усилителя непосредственно. С правой стороны от кнопки DC расположен входной зажим.

Режим развертки выбирается кнопками . В режиме Y/T (обычный режим, включен по умолчанию) реализуются следующие режимы развертки: по вертикали -- напряжение сигнала, по горизонтали -- время; в режиме В/А: по вертикали -- сигнал канала В, по горизонтали -- сигнал канала А; в режиме А/В: по вертикали -- сигнал канала А, по горизонтали -- сигнал канала В. В режиме развертки Y/T длительность развертки (TIME BASE) может быть задана в диапазоне от 0,1 нс/дел (ns/div) до 1 с/дел (s/div) с возможностью установки смещения в тех же единицах по горизонтали, т.е. по оси Х (X POS). В режиме Y/T предусмотрен также ждущий режим (TRIGGER) с запуском развертки (EDGE) по переднему или заднему фронту запускающего сигнала (выбирается нажатием кнопок ) при регулируемом уровне (LEVEL) запуска, а также в режиме AUTO (от канала А или В), от канала А, от канала В или от внешнего источника (ЕХТ), подключаемого к зажиму в блоке управления TRIGGER. Названные режимы запуска развертки выбираются кнопками. Заземление осциллографа осуществляется с помощью клеммы GROUND в правом верхнем углу прибора. При нажатии на кнопку Zoom лицевая панель осциллографа существенно меняется (см. рис. 3.6): увеличивается размер экрана, появляется возможность прокрутки изображения по горизонтали и его сканирования с помощью вертикальных визирных линий (синего и красного цвета), которые за треугольные "ушки" (они обозначены также цифрами 1 и 2) могут быть установлены с помощью курсора в любое место экрана. При этом в индикаторных окошках под экраном приводятся результаты измерения напряжения, временных интервалов и их приращений (между визирными линиями).

Рис. 3.6. Лицевая панель осциллографа в режиме ZOOM

Изображение можно инвертировать нажатием кнопки Reverse и записать данные в файл нажатием кнопки Save. Возврат к исходному состоянию осциллографа -- нажатием кнопки Reduce.

3.4 Измеритель АЧХ и ФЧХ (Bode Plotter)

Измеритель (рис. 3.7) предназначен для анализа амплитудночастотных (при нажатой кнопке Magnitude, включена по умолчанию) и фазо-частотных (при нажатой кнопке Phase) характеристик при логарифмической (кнопка LOG, включена по умолчанию) или линейной (кнопка LIN) шкале по осям Y (Vertical) и Х (Horizontal).

Рис. 3.7. Лицевая панель измерителя АЧХ и ФЧХ

Настройка измерителя заключается в выборе пределов измерения коэффициента передачи и вариации частоты с помощью кнопок в окошках F -- максимальное и I -- минимальное значение. Значение частоты и соответствующее ей значение коэффициента передачи или фазы индицируются в окошках в правом нижнем углу измерителя. Значения указанных величин в отдельных точках АЧХ или ФЧХ можно получить с помощью вертикальной визирной линии, находящейся в исходном состоянии в начале координат и перемещаемой по графику мышью или кнопками < , >. Результаты измерения можно записать также в текстовый файл. Для этого необходимо нажать кнопку Save и в диалоговом окне указать имя файла (по умолчанию предлагается имя схемного файла). В полученном таким образом текстовом файле с расширением .bоd АЧХ и ФЧХ представляются в табличном виде.

Подключение прибора к исследуемой схеме осуществляется с помощью зажимов IN (вход) и OUT (выход). Левые клеммы зажимов подключаются соответственно ко входу и выходу исследуемого устройства, а правые -- к общей шине. Ко входу устройства необходимо подключить функциональный генератор или другой источник переменного напряжения, при этом каких-либо настроек в этих устройствах не требуется.

3.5 Генератор слова (Word Generator)

Внешний вид генератора слова в развернутом виде показан на рис. 3.8.

Генератор (его называют еще кодовым генератором) предназначен для генерации двадцати 16-разрядных двоичных слов, которые набираются пользователем на экране, расположенном в левой части лицевой панели.

Каждая кодовая комбинация заносится с помощью клавиатуры, номер редактируемой ячейки фиксируется в окошке Edit блока Adress (на рис. 3.8 помещена цифра 0003, поскольку курсор находится в третьей ячейке, верхняя ячейка -- нулевая). Всего таких ячеек и, следовательно, комбинаций -- 2048. В процессе работы генератора в отсеке Adress индицируется номер текущей ячейки (Current), ячейки инициализации или начала работы (Initial) и конечной ячейки (Final).

Рис. 3.8. Лицевая панель генератора слова

Выдаваемые на 16 выходов (в нижней части генератора) кодовые комбинации индицируются в текстовом (ASCII) и двоичном коде (Binary) в пошаговом (при нажатии кнопки Step), циклическом (при нажатии кнопки Cycle) режимах или с выбранного слова до конца (при нажатии клавиши Burst) при заданной частоте посылок (установка -- нажатиями кнопок в окнах Frequency).

Запуск генератора осуществляется по переднему или заднему фронту с помощью кнопок . Имеется внешний запуск (нажата кнопка External) по готовности данных (клемма Data ready). Сигнал с этого выхода сопровождает каждую выдаваемую на выход кодовую комбинацию и используется в том случае, когда исследуемое устройство обладает свойством квитирования (подтверждения). В этом случае после получения очередной кодовой комбинации и сопровождающего его сигнала Data ready исследуемое устройство должно выдать сигнал подтверждения получения данных, который подается на вход синхронизации генератора (клемма в блоке Trigger) и производит очередной запуск генератора.

К органам управления относится также кнопка Breakpoint -- прерывание работы генератора в указанной ячейке. При этом требуемая ячейка выбирается на дисплее генератора курсором, а затем нажимается кнопка Breakpoint. После нажатия кнопки Pattern появляется меню, показанное на рис. 3.9, в котором обозначено:

Рис. 3.9. Окно предустановок генератора слова

Clear buffer -- стереть содержимое всех ячеек (содержимое буфера экрана);

Open -- загрузить кодовые комбинации (из файла с расширением .dp);

Save -- записать все набранные на экране комбинации в файл;

Up counter -- заполнить буфер экрана кодовыми комбинациями, начиная с 0 в нулевой ячейке и далее с прибавлением 1 в каждой последующей ячейке;

Down counter -- заполнить буфер экрана кодовыми комбинациями, начиная с FFFF в нулевой ячейке и далее с уменьшением на 1 в каждой последующей ячейке;

Shift right ? заполнить каждые четыре ячейки комбинациями 1-2-4-8 со смещением их в следующих четырех ячейках вправо (см. на рис. 3.8 нижние ячейки);

Shift left ? то же самое, но со смещением влево.

3.6 Логический анализатор (Logic Analyzer)

Внешний вид логического анализатора показан на рис. 3.10. Анализатор предназначен для отображения на экране монитора 16-разрядных кодовых последовательностей одновременно в 16 точках схемы.

Он снабжен двумя визирными линейками (как в осциллографе в режиме Zoom), что позволяет получать точные отсчеты временных интервалов Tl, T2 и Т2-Т1, а также линейкой прокрутки по горизонтали, что позволяет анализировать процессы на большом временном интервале.

В блоке Clock имеются клеммы для подключения как обычного (Extend), так и избирательного (Qualifier) источника запускающих сигналов, параметры которых могут быть установлены с помощью меню на рис. 3.11, вызываемого кнопкой Set.

Запуск генератора можно производить по переднему (Positive) или заднему (Negative) фронту запускающего сигнала с использованием внешнего (External) или внутреннего (Internal) источника. В окне Clock qualifier можно установить значение логического сигнала (0, 1 или X), при котором производится запуск анализатора.

Рис. 3.10. Лицевая панель логического анализатора

Дополнительные условия запуска анализатора могут быть выбраны с помощью диалогового окна (рис. 3.12), которое вызывается кнопкой Set в блоке Trigger.

Рис. 3.11. Меню установки параметров запускающих сигналов

С помощью этого окна в каналах А, В и С можно задать нужные двоичные 16-разрядные комбинации сигналов и затем в строке Trigger combinations установить дополнительные условия отбора.

Перечислим некоторые из них:

A OR В запуск анализатора от канала А или В;

A THEN В запуск анализатора от канала А, если сигнал в канале В;

(А OR В) THEN С запуск анализатора от канала А или В, если сигнал в канал С равен 1.

Рис. 3.12. Окно установки дополнительных параметров запуска

В окне Trigger qualifier можно задать логические сигналы 1, 0 или X, при наличии которых производится запуск анализатора.

3.7 Логический преобразователь (Logic Converter)

Внешний вид логического преобразователя показан на рис. 3.13.

На лицевой панели преобразователя показаны клеммы-индикаторы входов А, В,..., Н и одного выхода OUT, экран для отображения таблицы истинности исследуемой схемы, экранстрока для отображения ее булева выражения (в нижней части). В правой части панели расположены кнопки

Рис. 3.13. Лицевая панель логического преобразователя

управления процессом преобразования (Conversions). Возможные варианты использования преобразователя:

1. Логический анализ n-входового устройства с одним выходом (входы исследуемого устройства подключаются к клеммам А... Н, а выход -- к клемме OUT). В этом случае, используя кнопки управления, получим:

1.1. -- таблицу истинности исследуемого устройства;

1.2. -- булево выражение, реализуемое устройством;

1.3. -- минимизированное булево выражение;

1.4. -- схему устройства на логических элементах без ограничения их типа;

1.5. -- схему устройства только на логических элементах И-НЕ.

1.6 -- таблицу истинности по булеву выражению.

2. Синтез логического устройства по таблице истинности.

2.1. Щелчком мыши по входным клеммам А, В,..., Н, начиная с клеммы А, активизируем мышью требуемое число входов анализатора (на рис. 3.10 показаны активными входы А, В, С и D), в результате чего на экране анализатора получим начальную таблицу истинности, в которой будут представлены все возможные комбинации входных сигналов и соответствующие им значения логических сигналов (0 или 1) в столбце OUT.

2.2. Отредактируем полученную таблицу в соответствии с заданием путем записи 1 или Х в столбце OUT в строках, которые по комбинациям входных сигналов соответствуют заданным. Пусть, например, в первой строке при комбинации входных сигналов 0000 (см. рис. 3.13) нужно на выходе получить не 0, а 1. Для этого ставим курсор мыши на первую строку в столбце OUT, производим щелчок и на клавиатуре вводим 1. Дальнейшие перемещения с целью редактирования остальных строк столбца OUT удобнее производить с помощью клавиш управления курсором. При этом данные в столбцах А, В, С и D редактирования не требуют, поскольку в этих столбцах уже имеются все возможные комбинации.

Далее выполняем команды из п. 1, начиная с подп. 1.2.

3. Синтез логического устройства по булеву выражению.

3.1. Булево выражение заносится в экран-строку после предварительной ее активизации. Используются символы А...Н, при инверсии ? А'...Н'.


Подобные документы

  • Обозначение приставок и множителей. Горячие клавиши и их интерпретация. Среда Multisim, ее компоненты. Виртуальные приборы: мультиметр, генератор сигналов, осцилограф, построитель частотных характеристик, анализатор спектров. Требования к топологии схем.

    курсовая работа [1,5 M], добавлен 11.09.2015

  • Моделирование измерителя интервалов времени в MathCad. Сборка схемы генератора прямоугольных импульсов в среде программирования Electronics WorkBench. Назначение и конструкция дефектоскопа ультразвукового УД2-12. Генератор синхронизации импульсов.

    курсовая работа [593,2 K], добавлен 04.04.2015

  • Анализ электрических характеристик интегральных схем и модели их элементов. Моделирование диодов на основе р-п-перехода в программе PSPICE: эмиссия, температурный потенциал, напряжение пробоя, диффузионная емкость, вольтфарадная характеристика.

    реферат [432,2 K], добавлен 13.06.2009

  • Проектирование схемы устройства управления, выбор и описание элементов схем (ввода-вывода, логические, счетчик и другие элементы), принципы и подходы к реализации различных функций. Моделирование работы схемы в Electronics Workbench, анализ результатов.

    контрольная работа [690,8 K], добавлен 04.04.2016

  • Управляющая оболочка Schematics. Графический редактор: конфигурация; установка параметров изображения; подключение библиотек. Создание принципиальных схем. AC Sweep-расчёт частотных характеристик. Конфигурирование и запуск программы моделирования PSpice.

    курсовая работа [1,9 M], добавлен 23.03.2011

  • Получение канонической формы представления логических функций. Минимизация совершенной дизъюнктивной нормальной формы функций методами Карно и Кайва. Моделирование схемы преобразователя двоичного кода в код индикатора с помощью Electronics Workbench.

    курсовая работа [1,7 M], добавлен 14.12.2012

  • Анализ схемы многокаскадного усилителя переменного сигнала; расчет параметров активных и пассивных функциональных элементов. Исследование их свойств в среде виртуальной электронной лаборатории Electronics WorkBench, сравнение с расчетными параметрами.

    курсовая работа [669,5 K], добавлен 22.11.2011

  • Назначение, параметры и органы управления мультиметра. Назначение, параметры и органы управления функционального генератора. Назначение, параметры и органы управления электронного осциллографа. Схема лабораторного стенда для наблюдения сигнала

    лабораторная работа [373,2 K], добавлен 04.10.2008

  • Расчет напряжения, параметров элементов усилителя. Коэффициент передач электрических сигналов. Выбор марки транзисторов. Моделирование устройства в системе схемотехнического моделирования Electronics Workbench. Характеристики усилительных каскадов.

    курсовая работа [260,9 K], добавлен 24.11.2014

  • Реализация устройства, выполняющего счет до 30, с помощью среды разработки Electronics Workbench. Принцип работы счетчика - подсчёт числа импульсов, поданных на вход. Составные элементы устройства: генератор, пробник, логические элементы, триггер.

    курсовая работа [121,3 K], добавлен 22.12.2010

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.