Проектирование офисных сетей в среде CiscoPacketTracer 5.3.3

Разработка городской офисной сети с полносвязной топологией. Применение протоколов маршрутизации ОSPF, Static. Выбор сетевых устройств для связи компьютеров между собой, их технические характеристики. Элементы системы безопасности. Кеширование информации.

Рубрика Коммуникации, связь, цифровые приборы и радиоэлектроника
Вид курсовая работа
Язык русский
Дата добавления 21.02.2016
Размер файла 230,5 K

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://allbest.ru

Проектирование офисных сетей в среде CiscoPacketTracer 5.3.3

Задание

Тема курсового проекта: «Проектирование офисных сетей в среде CiscoPacketTracer 5.3.3»

Исходные данные к работе: Городская сеть на 3 офиса. Офисы соединены сетью с полносвязной топологией. Немаршрутизируемый адрес 192.168.1.0/28. Технология основной сети: OSPF. Альтернативная сеть: Static. Протоколы маршрутизации: Ethernet. Альтернативная сеть: Frem Relay. В общей сети размещены: DNSсервер 25.25.25.25/8, NTP сервер 96.10.10.10/8, FTP сервер 12.12.12.12/8, WEBсервер 10.10.10.10/8 . Офис 1: IP входной 134.25.0.20/30. Количество машин 6. Офис 2: IP входной сети 208.5.5.16/29. Количество машин 8, 2 VLAN. Офис 3: IP входной сети 215.15.15.20/30. Количество машин 6 (4 по Wi-Fi, 2 проводные). Использовать LINKSYS .

Введение

В данной работе мною, для реализации полученного задания были выбраны технологии Ethernet и Serial.

На сегодняшний день Ethernet обеспечивает высокую скорость для передачи информации.

Преимущества Ethernet:

· Высокая пропускная способность;

· Большие расстояния передачи.

Serial используется для связи компьютеров между собой.

Преимущества Serial:

· Возможность передачи на значительно большие расстояния;

· Гораздо более простой соединительный кабель.

1. Выбор топологии и протокола маршрутизации

На основании полученного задания мною была использована полносвязная топология. Полносвязная топология - сеть, в которой каждый компьютер связан с каждым другим через отдельный сетевой интерфейс по отдельному каналу связи, что позволяет каждому компьютеру передавать информацию другим с очень высокой надежностью и защищенностью. Но, к сожалению, аппаратные затраты (провода, сетевые карты) слишком высоки для реализации при большом количестве компьютеров в сети.

В качестве протоколов маршрутизации мною были выбраны протоколы ОSPF и Static.

OSPF (англ. Open Shortest Path First) -- протокол динамической маршрутизации, основанный на технологии отслеживания состояния канала (link-state technology) и использующий для нахождения кратчайшего пути Алгоритм Дейкстры (Dijkstra's algorithm).

Протокол OSPF был разработан IETF в 1988 году. Последняя версия протокола представлена в RFC 2328. Протокол OSPF представляет собой протокол внутреннего шлюза (Interior Gateway Protocol -- IGP). Протокол OSPF распространяет информацию о доступных маршрутах между маршрутизаторами одной автономной системы.

OSPF имеет следующие преимущества:

· Высокая скорость сходимости по сравнению с дистанционно-векторными протоколами маршрутизации;

· Поддержка сетевых масок переменной длины (VLSM);

· Оптимальное использование пропускной способности (т. к. строится минимальный остовный граф по алгоритму Дейкстры).

Статическая маршрутизация - вид маршрутизации, при котором маршруты указываются в явном виде при конфигурации маршрутизатора. Вся маршрутизация при этом происходит без участия каких-либо протоколов маршрутизации.

При задании статического маршрута указывается:

· Адрес сети (на которую маршрутизируется трафик), маска сети

· Адрес шлюза (узла), который отвечает за дальнейшую маршрутизацию (или подключен к маршрутизируемой сети напрямую)

· Метрика (иногда именуется также "ценой") маршрута. При наличии нескольких маршрутов на одну и ту же сеть некоторые маршрутизаторы выбирают маршрут с минимальной метрикой.

Преимущества:

· Лёгкость отладки и конфигурирования в малых сетях.

· Отсутствие дополнительных накладных расходов (из-за отсутствия протоколов маршрутизации).

2. Выбор сетевых устройств

В данной работе были выбраны устройства наиболее подходящие для её выполнения, с учетом канальных стандартов и протоколов маршрутизации. Эти устройства будут описаны далее. Также, в их число вошли маршрутизаторы, коммутаторы и точки доступа, разработанные разработчиками программы PacketTracer5.3.3, в которой собственно и проводилась основная часть курсовой работы. Эти устройства обладают совместимостью с реальными девайсами и имеют большой модульный набор, позволяющий не только сделать устройство функциональным, но использовать его в более изощренных ситуациях при построении сетей. Как уже оговаривалось, сейчас будут описаны реальные устройства, прототипы которых использовались в построении сети.

Маршрутизатор Cisco 2811

Cisco 2811 - маршрутизатор с интеграцией сервисов, обеспечивающий все потребности небольших офисов и филиалов (до 36 рабочих мест) в современных коммуникациях.

Может выполнять функции:

· маршрутизатора доступа и маршрутизатора локальной сети;

· центра IP-телефонии и голосовой почты (в вариантах Voice bundle и Voice Security bundle);

· интегрированного решения для обеспечения безопасности (в вариантах Security bundle и Voice Security bundle);

· межсетевой экран;

· система предотвращения вторжений;

· шифрование и создание VPN-туннелей;

· система Cisco NAC и фильтрация по URL;

· центр беспроводного доступа -беспроводное подключение ноутбуков и WLAN-телефонов. (При установке модулей HWIC-AP-G-E, HWIC-AP-AG-E или подключении точек доступа).

Технические характеристики маршрутизатора Cisco 2811

- Память DRAM - По умолчанию: 256 MB Максимум: 768 Mb

- Память Compact Flash - По умолчанию: 64 MB Максимум: 256 MB

- Встроенные USB 1.1 ports- 2

- Встроенные порты LAN - 2-10/100

- Встроенный AIM (внутренний)слот - 2=

- Количество слотов для интерфейсных модулей - 4 слота, все слоты поддерживают HWIC, WIC, VIC, или VWIC типы интерфейсных модулей

- Слоты для сетевых модулей - 1 слот, поддерживает NM или NME модули

- Extension Voice Module Slot - 1

- PVDM (DSP) слоты на материнской плате - 2

- Встроенное аппаратное ускорение шифрования - Да

- Встроенная аппаратная поддержка VPN - DES, 3DES, AES 128, AES 192, and AES 256

- Консольный порт управления (up to 115.2 kbps) - 1

- Auxiliary порт (up to 115.2 kbps) - 1

- Минимальная версия ПО Cisco IOS - 12.3(8)T

Коммутатор Cisco Catalyst 2960-24TT

Cisco Catalyst 2960 серия - это линейка коммутаторов промышленного класса с фиксированной конфигурацией, поддерживающая стандарт IEEE 802.3af и предварительный стандарт Cisco Power over Ethernet (PoE) в конфигурациях Fast Ethernet и Gigabit Ethernet. Cisco Catalyst 2960 является идеальным коммутатором уровня доступа для малого промышленного сетевого доступа или филиалов офисов, объединяя конфигурации 10/100/1000 и PoE для максимальной производительности и защиты инвестиций, одновременно позволяя начать развертывание новых приложений, таких как IP-телефония, беспроводной доступ, видеонаблюдение, системы управления строительством, и удаленные видеостойки. Покупатели могут развернуть такие интеллектуальные службы, как улучшенное качество обслуживания (QoS), ограничение скорости, настраиваемые списки доступа (ACL), управление многоадресной передачей, и высокопроизводительная IP-маршрутизация и одновременное упрощение традиционной коммутации. Cisco Network Assistant является централизованным управляющим приложением, упрощающим задачи администрирования для коммутаторов Cisco, маршрутизаторов, и беспроводных точек доступа. Cisco Network Assistant обеспечивает мастера настройки, которые упрощают объединение нескольких сетей и интеллектуальных сетевых служб.

Технические характеристики Cisco Catalyst 2960-24TT:

Физические характеристики:

Размеры (ширина x глубина x высота), см:

44.5 x 30 x 4.41RU

Вес, кг:

5.1

Параметры питания:

* Потребляемая мощность: 485 Вт* AC: 100 - 240 В (автоопределение), 5.5 - 2.8 А, 50 - 60 Гц* DC (Cisco RPS 2300): + 12 В - 7.5 А* PoE: 370 Вт

Индикаторы статуса:

* На каждом порте: целостность соединения, отключение, активность, скорость, полный дуплекс, функционирование PoE, ошибка PoE, отключение PoE* Состояние системы: система, RPS, состояние соединения, дуплекс, скорость, PoE

Характеристики памяти:

Оперативная память:

128 МБ

Флеш-память:

16 МБ

Интерфейсные порты:

Медные интерфейсы:

24 x RJ-45 10/100 Fast Ethernet PoE

Оптические интерфейсы:

2 x SFP Gigabit Ethernet

Другие интерфейсы:

1 x консольный порт

Сетевые особенности:

Поддерживаемые стандарты:

* IEEE 802.1s* IEEE 802.1w* IEEE 802.1x* IEEE 802.3ad* IEEE 802.3af* IEEE 802.3x полный дуплекс на портах 10BASE-T, 100BASE-TX, и 1000BASE-T* IEEE 802.1D Spanning Tree Protocol* IEEE 802.1p CoS приоритизации* IEEE 802.1Q VLAN * Спецификация IEEE 802.3 10BASE-T* Спецификация IEEE 802.3u 100BASE-TX* Стандарты RMON I и II* SNMPv1, SNMPv2c, и SNMPv3

Производительность:

* Матрица коммутации: 32 Гбит/с* Неблокируемая коммутация на скорости 6.5 миллионов пакетов/с (размер пакетов 64 байта)* Возможность настройки до 12000 MAC-адресов* Возможность настройки до 11000 однонаправленных маршрутов* Возможность настройки до 1000 IGMP-групп* Возможность установки MTU до 9000 байт, с максимальным кадром Ethernet 9018 байт (Jumbo frames) на портах Gigabit Ethernet, до 1546 байт для маркированных кадров Multiprotocol Label Switching (MPLS) на портах 10/100

Простота использования и легкость развертки:

* Express Setup* Поддержка IEEE 802.3af и предварительного стандарта Cisco PoE* Автоматическая настройка DHCP* Автоматическая настройка QoS (Auto QoS)* Автоматическое определение скорости на каждом порте 10/100* Автоматический выбор режима дуплекса* Dynamic Trunking Protocol (DTP)* Port Aggregation Protocol (PAgP)* Link Aggregation Control Protocol (LACP)* DHCP-сервер* DHCP Relay* Настройка по умолчанию* Автоматическое определение кроссовер (Auto-MDIX)* Time-domain reflectometer (TDR)

Работоспособность и масштабируемость:

Избыточное резервирование:* Технологии Cisco UplinkFast и BackboneFast* IEEE 802.1w Rapid Spanning Tree Protocol* Per-VLAN Rapid Spanning Tree Plus (PVRST+)* Cisco Hot Standby Router Protocol (HSRP)* Unidirectional Link Detection Protocol (UDLD) и Aggressive UDLD* Автоматическое восстановление портов* Cisco Redundant Power System 2300 (RPS 2300)* Equal cost routing (ECR)* Агрегация полосы пропускания до 8 Гбит/с с использованием технологии Cisco Gigabit EtherChannel и до 800 Мбит/с с использованием технологии Fast EtherChannelВысокопроизводительная IP-маршрутизация:* Аппаратная архитектура Cisco Express Forwarding* Стандартные однонаправленные протоколы IP-маршрутизации (статическая, RIPv1, RIPv2 и RIPng)* Усовершенствованные однонаправленные протоколы IP-маршрутизации (OSPF, Interior Gateway Routing Protocol [IGRP], EIGRP, Border Gateway Protocol Version 4 [BGPv4] и IS-ISv4)* Возможность IPv6-маршрутизации (OSPFv3, EIGRPv6)* Policy-Based Routing (PBR)* Внутрисетевая маршрутизация* Protocol Independent Multicast (PIM) для многоадресной передачи IPмаршрутизации, включая PIM в разреженном режиме (PIM-SM), PIM в плотном режиме (PIM-DM), и PIM в разреженно-плотном режиме* Возможность передачи не IP-трафика между двумя VLANОптимизация полосы пропускания:* Возможность штормового контроля на каждом порте при широковещании и одноадресной передачи* IEEE 802.1d Spanning Tree Protocol* IEEE 802.1s Multiple Spanning Tree Protocol* VPN routing/forwarding (VRF)-Lite* Local Proxy Address Resolution Protocol (ARP) и частная граница VLAN* Минимизация VLAN1* VLAN Trunking Protocol (VTP)* Internet Group Management Protocol v3 (IGMP) Snooping для IPv4 и IPv6 MLD v1 и v2 Snooping * Фильтрация IGMP* Multicast VLAN registration (MVR)

QoS:

* Стандарт 802.1p CoS и классификация DSCP* QoS ACL* Четыре выходные очереди на каждом порте* Возможность настройки расписания SRR* Weighted tail drop (WTD)* Строгий приоритет очереди* Функция Cisco CIR* Возможность ограничения трафика по признакам: MAC-адресу, IP-адресу, номера портов TCP/UDP с использованием списков доступа* Асинхронные прием и передача данных* Возможность настройки до 64 политик на каждом порте Fast Ethernet или Gigabit Ethernet

Сетевая безопасность:

* IEEE 802.1x* IEEE 802.1x с назначением VLAN* IEEE 802.1x с голосовой VLAN* IEEE 802.1x и безопасность портов* IEEE 802.1x с гостевой VLAN* Веб-аутентификация для не клиентов 802.1x* Многодоменная аутентификация* MAC Auth Bypass (MAB)* Безопасность VLAN ACLs (VACL)* Стандартная и расширенная безопасность маршрутизации (RACL)* Списки доступа, зависящие от портов (PACL), для интерфейсов 2 уровня* Однонаправленная фильтрация MAC-адресов* SSHv2, Kerberos, и SNMPv3* Частная граница VLAN, ограничение трафика* Поддержка двунаправленной передачи данных на порте Switched Port Analyzer (SPAN)* Аутентификация TACACS+ и RADIUS* Оповещение о MAC-адресах* Dynamic ARP Inspection (DAI)* DHCP snooping* Безопасность источников IP* DHCP Interface Tracker (Option 82)* Безопасность портов* Доверенная граница* Многоуровневая безопасность* BPDU Guard* Spanning-Tree Root Guard (STRG)* Динамические VLAN* Cisco Network Assistant* Поддержка до 2000 настаиваемых пунктов (ACE)

Управление:

Особенности управления:* Командная строка Cisco IOS Software CLI* Cisco Discovery Protocol version 2 (CDPv2)* The PoE MIB* Шаблоны для управления базой коммутации* Generic On-Line Diagnostic (GOLD)* Каналы VLAN* Поддержка до 1024 VLAN и до 128 ступеней spanning-tree* Поддержка до 4000 идентификаторов VLAN* Remote SPAN (RSPAN)* Embedded Remote Monitoring (RMON)* Маршрутизация 2 уровня* Поддержка 9 групп RMON* Domain Name System (DNS)* Trivial File Transfer Protocol (TFTP)Cisco Network Assistant Software:* Поддержка администрирования до 250 пользователей * Удобный графический интерфейс* Cisco AVVID (архитектура для голоса, видео и встроенных данных)* Мастер настройки безопасности* Поддержка многоуровневой настройки * Возможность настройки нескольких устройств и портов * Система оповещенийПоддержка CiscoWorks:* Поддержка SNMP v1, v2c, и v3 и Telnet* Cisco Discovery Protocol версий 1 и 2* LAN Management Solution

Linksys WRT300N

Linksys WRT300N поддерживает стандарт 802.11n, в котором применяются четыре новейшие технологии. Именно они позволяют увеличить скорость передачи в 12 раз по сравнению со стандартом Wireless-G (802.11g). Технология Wireless-N обеспечивает расширенный спектр услуг. С Linksys WRT300N вы можете выполнять несколько дел одновременно: работу в Интернете, прослушивание потоковой музыки или просмотр видео высокого разрешения. Кроме этого, владелец Linksys WRT300N получает возможность организации совместного доступа к файлам, участия в сетевых играх, а также совершения телефонных вызовов через Интернет. И это еще не все достоинства беспроводного маршрутизатора Linksys WRT300N. В Linksys WRT300N применяется новая технология передачи сигнала. Поэтому зона охвата в сети Wireless-N превышает в 4 раза зоны охвата сетей, которые строились по предыдущим технологиям. Именно это увеличивает силу сигнала, практически устраняет мертвые зоны и обеспечивает непрерывную связь в любой точке дома или офиса, даже там, где раньше она была недоступна. И еще один плюс - оборудование Linksys для сетей Wireless-N, и Linksys WRT300N в частности, совместимо со всеми видами оборудования стандартов Wireless-B и Wireless-G, которые существуют на сегодняшний день.

Основные характеристики Linksys WRT300N

Производитель

Linksys

Модель

WRT300N

Тип устройства

точка доступа / маршрутизатор

Корпус

настольный/настенный * черного/синего цвета индикаторы:- электропитание

WAN

Тип линии связи: Ethernet, Fast Ethernet Скорость передачи данных (макс.): 100 Мбит/сек. Кол-во каналов: 1 Кол-во портов: 1 Протоколы передачи данных:- IP Встроенные службы:- брандмауэр

LAN

Тип сети: Ethernet, Fast Ethernet, беспроводная сеть Кол-во базовых портов: 4 (макс. 4) Скорость передачи по базовым портам:- 10 Мбит/сек.- 100 Мбит/сек.- 11 Мбит/сек.- 36 Мбит/сек.- 54 Мбит/сек.- 540 Мбит/с Скорость передачи по UPLINK: 100 Мбит/сек. MDI: 4 автоматически переключающихся порта Специальные функции:- 128-бит. WEP шифрование- 256-бит. WEP шифрование- 64-бит. WEP шифрование- Wi-Fi Protected Access (WPA) Встроенные службы:- брандмауэр Поддерживаемые стандарты:- IEEE 802.11b- IEEE 802.11g- IEEE 802.11n- IEEE 802.3 (Ethernet)- IEEE 802.3u (Fast Ethernet)

Беспроводное соединение

2.4 ГГц

Дополнительные характеристики

Интерфейсы

Ethernet 10/100BaseT * RJ-45 * (ГВС (WAN)) 4 x Ethernet 10/100BaseT * RJ-45 * (базовый порт)

Опции безопасности

- фильтрация MAC-адресов- RADIUS per-command authentication

Технические характеристики

Электропитание

внешний адаптер питания - 220 В (перемен. ток)

Размеры, вес

18.8 x 4 x 17.6 см, 527 г

Сертификаты

CE Mark, FCC

DNS (англ. Domain Name System -- система доменных имён) -- компьютерная распределённая система для получения информации о доменах. Чаще всего используется для получения IP-адреса по имени хоста (компьютера или устройства), получения информации о маршрутизации почты, обслуживающих узлах для протоколов в домене (SRV-запись).

Распределённая база данных DNS поддерживается с помощью иерархии DNS-серверов, взаимодействующих по определённому протоколу.

Основой DNS является представление об иерархической структуре доменного имени и зонах. Каждый сервер, отвечающий за имя, может делегировать ответственность за дальнейшую часть домена другому серверу (с административной точки зрения -- другой организации или человеку), что позволяет возложить ответственность за актуальность информации на серверы различных организаций (людей), отвечающих только за «свою» часть доменного имени.

Начиная с 2010 года, в систему DNS внедряются средства проверки целостности передаваемых данных, называемые DNS Security Extensions (DNSSEC). Передаваемые данные не шифруются, но их достоверность проверяется криптографическими способами.

DNS обладает следующими характеристиками:

· Распределённость администрирования. Ответственность за разные части иерархической структуры несут разные люди или организации.

· Распределённость хранения информации. Каждый узел сети в обязательном порядке должен хранить только те данные, которые входят в его зону ответственности и (возможно) адреса корневых DNS-серверов.

· Кеширование информации. Узел может хранить некоторое количество данных не из своей зоны ответственности для уменьшения нагрузки на сеть.

· Иерархическая структура, в которой все узлы объединены в дерево, и каждый узел может или самостоятельно определять работу нижестоящих узлов, или делегировать (передавать) их другим узлам.

· Резервирование. За хранение и обслуживание своих узлов (зон) отвечают (обычно) несколько серверов, разделённые как физически, так и логически, что обеспечивает сохранность данных и продолжение работы даже в случае сбоя одного из узлов.

FTP (англ. File Transfer Protocol -- протокол передачи файлов) -- протокол, предназначенный для передачи файлов в компьютерных сетях. FTP позволяет подключаться к серверам FTP, просматривать содержимое каталогов и загружать файлы с сервера или на сервер; кроме того, возможен режим передачи файлов между серверами (см. FXP).

FTP является одним из старейших прикладных протоколов, появившимся задолго до HTTP, в 1971 году. Он и сегодня широко используется для распространения ПО и доступа к удалённым хостам.

Протокол FTP относится к протоколам прикладного уровня и для передачи данных использует транспортный протокол TCP. Команды и данные, в отличие от большинства других протоколов, передаются по разным портам. Исходящий Порт 20, открываемый на стороне сервера, используется для передачи данных, порт 21 для передачи команд. Порт для приема данных клиентом определяется в диалоге согласования. В случае, если передача файла была прервана по каким-либо причинам, протокол предусматривает средства для докачки файла, что бывает очень удобно при передаче больших файлов.

HTTP (сокр. от англ. HyperText Transfer Protocol -- «протокол передачи гипертекста») -- протокол прикладного уровня передачи данных (изначально -- в виде гипертекстовых документов). Основой HTTP является технология «клиент-сервер», то есть предполагается существование потребителей (клиентов), которые инициируют соединение и посылают запрос, и поставщиков (серверов), которые ожидают соединения для получения запроса, производят необходимые действия и возвращают обратно сообщение с результатом. HTTP в настоящее время повсеместно используется во Всемирной паутине для получения информации с веб-сайтов. В 2006 году в Северной Америке доля HTTP-трафика превысила долю P2P-сетей и составила 46 %, почти половина из которого -- это передача потокового видео и звука.

HTTP используется также в качестве «транспорта» для других протоколов прикладного уровня, таких как SOAP, XML-RPC, WebDAV.

Основным объектом манипуляции в HTTP является ресурс, на который указывает URI (англ. Uniform Resource Identifier) в запросе клиента. Обычно такими ресурсами являются хранящиеся на сервере файлы, но ими могут быть логические объекты или что-то абстрактное. Особенностью протокола HTTP является возможность указать в запросе и ответе способ представления одного и того же ресурса по различным параметрам: формату, кодировке, языку и т. д. Именно благодаря возможности указания способа кодирования сообщения клиент и сервер могут обмениваться двоичными данными, хотя данный протокол является текстовым.

HTTP -- протокол прикладного уровня, аналогичными ему являются FTP и SMTP. Обмен сообщениями идёт по обыкновенной схеме «запрос-ответ». Для идентификации ресурсов HTTP использует глобальные URI. В отличие от многих других протоколов, HTTP не сохраняет своего состояния. Это означает отсутствие сохранения промежуточного состояния между парами «запрос-ответ». Компоненты, использующие HTTP, могут самостоятельно осуществлять сохранение информации о состоянии, связанной с последними запросами и ответами. Браузер, посылающий запросы, может отслеживать задержки ответов. Сервер может хранить IP-адреса и заголовки запросов последних клиентов. Однако сам протокол не осведомлён о предыдущих запросах и ответах, в нём не предусмотрена внутренняя поддержка состояния, к нему не предъявляются такие требования.

Network Time Protocol (NTP) -- сетевой протокол для синхронизации внутренних часов компьютера с использованием сетей с переменной латентностью.

NTP использует для своей работы протокол UDP. Система NTP чрезвычайно устойчива к изменениям латентности среды передачи.

NTP использует алгоритм Марзулло (предложен Кейтом Марзулло (Keith Marzullo) из Университета Калифорнии, Сан-Диего), включая такую особенность, как учёт времени передачи. В версии 4 способен достигать точности 10 мс (1/100 с) при работе через Интернет, и до 0,2 мс (1/5000 с) и лучше при работе внутри локальных сетей.

NTP -- один из старейших используемых протоколов. NTP разработан Дэвидом Л. Миллсом (David L. Mills) из университета Дэлавера в 1985 году и в настоящее время продолжает совершенствоваться. Текущая версия -- NTP 4.

NTP использует иерархическую систему «часовых уровней». Уровень 1 синхронизован с высокоточными часами, например, с системой GPS, ГЛОНАСС (Единая Государственная шкала времени РФ) или атомным эталоном времени. Уровень 2 синхронизируется с одной из машин уровня 1, и так далее.

Время представляется в системе NTP 64-битным числом (8 байт), состоящим из 32-битного счётчика секунд и 32-битного счётчика долей секунды, позволяя передавать время в диапазоне 232 секунд, с теоретической точностью 2?32 секунды. Поскольку шкала времени в NTP повторяется каждые 232 секунды (136 лет), получатель должен хотя бы примерно знать текущее время (с точностью 50 лет).

Наиболее широкое применение протокол NTP находит для реализации серверов точного времени. Для достижения максимальной точности предпочтительна постоянная работа программного обеспечения NTP в режиме системной службы. В семействе операционных систем Microsoft Windows, -- это служба W32Time (модуль w32time.dll, выполняющийся в svchost.exe).

Более простая реализация этого алгоритма известна как SNTP -- простой синхронизирующий сетевой протокол. Используется во встраиваемых системах и устройствах, не требующих высокой точности, а также в пользовательских программах точного времени.

VLAN (аббр. от англ. Virtual Local Area Network) -- виртуальная локальная компьютерная сеть, представляет собой группу хостов с общим набором требований, которые взаимодействуют так, как если бы они были подключены к широковещательному домену, независимо от их физического местонахождения. VLAN имеет те же свойства, что и физическая локальная сеть, но позволяет конечным станциям группироваться вместе, даже если они не находятся в одной физической сети. Такая реорганизация может быть сделана на основе программного обеспечения вместо физического перемещения устройств.

В устройствах Cisco, протокол VTP (VLAN Trunking Protocol) предусматривает VLAN-домены для упрощения администрирования. VTP также выполняет «чистку» трафика, направляя VLAN трафик только на те коммутаторы, которые имеют целевые VLAN-порты (функция VTP pruning). Коммутаторы Cisco в основном используют протокол 802.1Q Trunk вместо устаревшего проприетарного ISL (Inter-Switch Link) для обеспечения совместимости информации.

По умолчанию на каждом порту коммутатора имеется сеть VLAN1 или VLAN управления. Сеть управления не может быть удалена, однако могут быть созданы дополнительные сети VLAN и этим альтернативным VLAN могут быть дополнительно назначены порты.

Native VLAN -- это параметр каждого порта, который определяет номер VLAN, который получают все непомеченные (untagged) пакеты.

DHCP (англ. Dynamic Host Configuration Protocol -- протокол динамической конфигурации узла) -- это сетевой протокол, позволяющий компьютерам автоматически получать IP-адрес и другие параметры, необходимые для работы в сети TCP/IP. Данный протокол работает по модели «клиент-сервер». Для автоматической конфигурации компьютер-клиент на этапе конфигурации сетевого устройства обращается к так называемому серверу DHCP, и получает от него нужные параметры. Сетевой администратор может задать диапазон адресов, распределяемых сервером среди компьютеров. Это позволяет избежать ручной настройки компьютеров сети и уменьшает количество ошибок. Протокол DHCP используется в большинстве сетей TCP/IP.

3. Элементы безопасности

сеть топология информация офисный

SSH (англ. Secure SHell -- «безопасная оболочка») -- сетевой протокол сеансового уровня, позволяющий производить удалённое управление операционной системой и туннелирование TCP-соединений (например, для передачи файлов). Схож по функциональности с протоколами Telnet и rlogin, но, в отличие от них, шифрует весь трафик, включая и передаваемые пароли. SSH допускает выбор различных алгоритмов шифрования. SSH-клиенты и SSH-серверы доступны для большинства сетевых операционных систем.

SSH позволяет безопасно передавать в незащищенной среде практически любой другой сетевой протокол. Таким образом, можно не только удаленно работать на компьютере через командную оболочку, но и передавать по шифрованному каналу звуковой поток или видео (например, с веб-камеры). Также SSH может использовать сжатие передаваемых данных для последующего их шифрования, что удобно, например, для удаленного запуска клиентов X Window System.

Большинство хостинг-провайдеров за определенную плату предоставляют клиентам доступ к их домашнему каталогу по SSH. Это может быть удобно как для работы в командной строке, так и для удаленного запуска программ (в том числе графических приложений).

SSH -- это протокол прикладного уровня (или уровня приложений). SSH-сервер обычно прослушивает соединения на TCP-порту 22. Спецификация протокола SSH-2 содержится в RFC 4251. Для аутентификации сервера в SSH используется протокол аутентификации сторон на основе алгоритмов электронно-цифровой подписи RSA или DSA. Для аутентификации клиента также может использоваться ЭЦП RSA или DSA, но допускается также аутентификация при помощи пароля (режим обратной совместимости с Telnet) и даже ip-адреса хоста (режим обратной совместимости с rlogin). Аутентификация по паролю наиболее распространена; она безопасна, так как пароль передается по зашифрованному виртуальному каналу. Аутентификация по ip-адресу небезопасна, эту возможность чаще всего отключают. Для создания общего секрета (сеансового ключа) используется алгоритм Диффи -- Хеллмана (DH). Для шифрования передаваемых данных используется симметричное шифрование, алгоритмы AES, Blowfish или 3DES. Целостность переданных данных проверяется с помощью CRC32 в SSH1 или HMAC-SHA1/HMAC-MD5 в SSH2.

Для сжатия шифруемых данных может использоваться алгоритм LempelZiv (LZ77), который обеспечивает такой же уровень сжатия, что и архиватор ZIP. Сжатие SSH включается лишь по запросу клиента, и на практике используется редко.

TELNET (англ. TErminaL NETwork) -- сетевой протокол для реализации текстового интерфейса по сети (в современной форме -- при помощи транспорта TCP). Название «telnet» имеют также некоторые утилиты, реализующие клиентскую часть протокола. Современный стандарт протокола описан в RFC 854.

Исторически Telnet служил для удалённого доступа к интерфейсу командной строки операционных систем. Впоследствии его стали использовать для прочих текстовых интерфейсов, вплоть до игр MUD и анимированного ASCII-art. Теоретически, даже обе стороны протокола могут являться программами, а не человеком.

Протокол telnet используется в управляющем соединении FTP, то есть заходить на сервер командой telnet ftp.example.net ftp для выполнения отладки и экспериментов не только возможно, но и правильно (в отличие от применения клиентов telnet для доступа к HTTP, IRC и большинству других протоколов).

В протоколе не предусмотрено использование ни шифрования, ни проверки подлинности данных. Поэтому он уязвим для любого вида атак, к которым уязвим его транспорт, то есть протокол TCP. Для функциональности удалённого доступа к системе в настоящее время применяется сетевой протокол SSH (особенно его версия 2), при создании которого упор делался именно на вопросы безопасности. Так что следует иметь в виду, что сессия Telnet весьма беззащитна, если только не осуществляется в полностью контролируемой сети или с применением защиты на сетевом уровне (различные реализации виртуальных частных сетей). По причине ненадёжности от Telnet как средства управления операционными системами давно отказались.

Заключение

Проведя данную работу, я узнал много нового о сетевых устройствах и то, как они устроены. Научился более широко понимать принципы работы многих устройств. Packet Tracer является очень хорошим средством моделирования в процессе обучения, а также отличным симулятором сети. В нем производится работа в двух средах: физической и логической схемы, которые практически полностью отображают суть настоящей сети. В этой работе можно производить свои исследования, ставить эксперименты, изучая новую ситуацию построения общей большой зависимой схемы.

Список использованной литературы

1. Бешенков С.А., Кузьмина Н.В., Ракитина Е.А. Информатика. -- М., 2012.

2. Бешенков С.А., Ракитина Е.А. Информатика. Учебник 10 кл. -- М., 2014.

3. Кузнецов А.А. и др. Информатика, тестовые задания. -- М., 2006.

4. Михеева Е.В. Практикум по информации: учеб. пособие. -- М., 2010.

5. Семакин И.Г. и др. Информатика. Структурированный конспект базового курса. -- М., 2007.

6. Семакин И.Г., Хеннер Е.К. Информатика.. -- М., 2009.

7. Угринович Н.Д. Преподавание курса «Информатика и ИКТ». -- М., 2012.

8. Андреева Е.В. и др. Математические основы информатики, Элективный курс. -- М., 2009.

Приложение

Конфигурация устройств

Router1(Rt1)

Current configuration : 1399 bytes

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption

hostname rt1

enable secret 5 $1$mERr$4dpRATIgxQacPVK0CfNV4/

clock timezone nsk -7

ip domain-name net

interface Serial0/0

no ip address

encapsulation frame-relay

clock rate 64000

interface Serial0/0.1 multipoint

ip address 197.150.150.1 255.255.255.248

frame-relay interface-dlci 101

frame-relay interface-dlci 102

frame-relay interface-dlci 103

clock rate 2000000

interface FastEthernet1/0

ip address 201.201.201.1 255.255.255.252

interface FastEthernet2/0

ip address 134.25.0.21 255.255.255.252

interface FastEthernet4/0

ip address 201.201.201.14 255.255.255.252

router ospf 1

log-adjacency-changes

passive-interface Serial0/0

network 134.25.0.20 0.0.0.3 area 0

network 201.201.201.0 0.0.0.3 area 0

network 201.201.201.12 0.0.0.3 area 0

ip classless

ip route 208.5.5.16 255.255.255.248 197.150.150.2 150

ip route 215.15.15.20 255.255.255.252 197.150.150.3 150

ip route 12.0.0.0 255.0.0.0 197.150.150.4 150

ip route 25.0.0.0 255.0.0.0 197.150.150.4 150

ip route 96.0.0.0 255.0.0.0 197.150.150.4 150

ip route 10.0.0.0 255.0.0.0 197.150.150.4 150

!

line con 0

password 7 08701E1D5D

login

line vty 0 4

password 7 08701E1D5D

login

transport input ssh

ntp server 96.10.10.10 key 0

!

End

Router2(Rt2)

Current configuration : 1396 bytes

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption

hostname rt2

enable secret 5 $1$mERr$4dpRATIgxQacPVK0CfNV4/

!

clock timezone nsk -7

!

ip domain-name net

!

interface Serial0/0

no ip address

encapsulation frame-relay

clock rate 64000

!

interface Serial0/0.1 multipoint

ip address 197.150.150.2 255.255.255.248

frame-relay interface-dlci 201

frame-relay interface-dlci 202

frame-relay interface-dlci 203

clock rate 2000000

!

interface FastEthernet1/0

ip address 201.201.201.2 255.255.255.252

!

interface FastEthernet2/0

ip address 201.201.201.5 255.255.255.252

!

interface FastEthernet3/0

ip address 208.5.5.17 255.255.255.248

!

router ospf 1

log-adjacency-changes

passive-interface Serial0/0

network 208.5.5.16 0.0.0.7 area 0

network 201.201.201.0 0.0.0.3 area 0

network 201.201.201.4 0.0.0.3 area 0

!

ip classless

ip route 134.25.0.20 255.255.255.252 197.150.150.1 150

ip route 215.15.15.20 255.255.255.252 197.150.150.3 150

ip route 12.0.0.0 255.0.0.0 197.150.150.4 150

ip route 25.0.0.0 255.0.0.0 197.150.150.4 150

ip route 96.0.0.0 255.0.0.0 197.150.150.4 150

ip route 10.0.0.0 255.0.0.0 197.150.150.4 150

!

line con 0

password 7 08701E1D5D

login

line vty 0 4

password 7 08701E1D5D

login

transport input ssh

!

ntp server 96.10.10.10 key 0

!

End

Router3(Rt3)

Current configuration : 1458 bytes

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption

hostname rt3

!

enable secret 5 $1$mERr$4dpRATIgxQacPVK0CfNV4/

!

!

!

clock timezone nsk -7

!

ip domain-name net

!

interface Serial0/0

no ip address

encapsulation frame-relay

clock rate 64000

!

interface Serial0/0.1 multipoint

ip address 197.150.150.3 255.255.255.248

frame-relay interface-dlci 301

frame-relay interface-dlci 302

frame-relay interface-dlci 303

clock rate 2000000

!

interface FastEthernet1/0

ip address 215.15.15.21 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet2/0

ip address 201.201.201.6 255.255.255.252

!

interface FastEthernet3/0

ip address 201.201.201.9 255.255.255.252

!

router ospf 1

log-adjacency-changes

passive-interface Serial0/0

passive-interface FastEthernet1/0

network 215.15.15.16 0.0.0.7 area 0

network 201.201.201.0 0.0.0.7 area 0

network 201.201.201.8 0.0.0.7 area 0

!

ip classless

ip route 134.25.0.20 255.255.255.252 197.150.150.1 150

ip route 208.5.5.16 255.255.255.248 197.150.150.2 150

ip route 12.0.0.0 255.0.0.0 197.150.150.4 150

ip route 25.0.0.0 255.0.0.0 197.150.150.4 150

ip route 96.0.0.0 255.0.0.0 197.150.150.4 150

ip route 10.0.0.0 255.0.0.0 197.150.150.4 150

!

line con 0

password 7 08701E1D5D

login

line vty 0 4

password 7 08701E1D5D

login

transport input ssh

!

ntp server 96.10.10.10 key 0

!

end

Router4(Rt4)

Current configuration : 1799 bytes

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption

hostname rt4

!

enable secret 5 $1$mERr$4dpRATIgxQacPVK0CfNV4/

!

clock timezone nsk -7

!

ip domain-name net

!

interface Serial0/0

no ip address

encapsulation frame-relay

clock rate 64000

!

interface Serial0/0.1 multipoint

ip address 197.150.150.4 255.255.255.248

frame-relay interface-dlci 401

frame-relay interface-dlci 402

frame-relay interface-dlci 403

clock rate 2000000

!

interface FastEthernet3/0

ip address 201.201.201.10 255.255.255.252

!

interface FastEthernet4/0

ip address 201.201.201.13 255.255.255.252

!

interface FastEthernet5/0

ip address 12.0.0.1 255.0.0.0

duplex auto

speed auto

!

interface FastEthernet6/0

ip address 25.0.0.1 255.0.0.0

duplex auto

speed auto

!

interface FastEthernet7/0

ip address 96.0.0.1 255.0.0.0

duplex auto

speed auto

!

interface FastEthernet8/0

ip address 10.0.0.1 255.0.0.0

duplex auto

speed auto

!

router ospf 1

log-adjacency-changes

passive-interface Serial0/0

passive-interface FastEthernet5/0

passive-interface FastEthernet6/0

passive-interface FastEthernet7/0

passive-interface FastEthernet8/0

network 12.0.0.0 0.255.255.255 area 0

network 25.0.0.0 0.255.255.255 area 0

network 96.0.0.0 0.255.255.255 area 0

network 10.0.0.0 0.255.255.255 area 0

network 201.201.201.12 0.0.0.3 area 0

network 201.201.201.8 0.0.0.3 area 0

!

ip classless

ip route 134.25.0.20 255.255.255.252 197.150.150.1 150

ip route 208.5.5.16 255.255.255.248 197.150.150.2 150

ip route 215.15.15.20 255.255.255.252 197.150.150.3 150

!

line con 0

password 7 08701E1D5D

login

line vty 0 4

password 7 08701E1D5D

login

transport input ssh

!

ntp server 96.10.10.10 key 0

!

End

Router(Office1)

Current configuration : 1094 bytes

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption

hostname office1

!

enable secret 5 $1$mERr$4dpRATIgxQacPVK0CfNV4/

!

clock timezone nsk -7

!

ip ssh version 1

ip domain-name net

!

spanning-tree mode pvst

!

interface FastEthernet0/0

ip address 192.168.10.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet1/0

ip address 134.25.0.22 255.255.255.252

ip nat outside

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

passive-interface FastEthernet0/0

network 192.168.10.0 0.0.0.255 area 0

network 134.25.0.20 0.0.0.3 area 0

!

ip nat inside source list 1 interface FastEthernet1/0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 134.25.0.21 150

!

access-list 1 permit 192.168.10.0 0.0.0.255

!

line con 0

password 7 08701E1D5D

login

line vty 0 4

password 7 08701E1D5D

login

transport input ssh

!

!

ntp server 96.10.10.10 key 0

!

End

Router(Office2)

Current configuration : 1696 bytes

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption

hostname office2

!

enable secret 5 $1$mERr$4dpRATIgxQacPVK0CfNV4/

!

ip dhcp excluded-address 192.168.20.1 192.168.20.2

ip dhcp excluded-address 192.168.20.129 192.168.20.130

!

ip dhcp pool vlan1

network 192.168.20.0 255.255.255.128

default-router 192.168.20.1

dns-server 25.25.25.25

ip dhcp pool vlan2

network 192.168.20.128 255.255.255.128

default-router 192.168.20.129

dns-server 25.25.25.25

clock timezone nsk -7

!

ip ssh version 1

ip domain-name net

!

spanning-tree mode pvst

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.20.1 255.255.255.128

ip nat inside

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 192.168.20.129 255.255.255.128

ip nat inside

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet1/0

ip address 208.5.5.18 255.255.255.248

ip nat outside

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

passive-interface FastEthernet0/0

network 192.168.20.0 0.0.0.127 area 0

network 192.168.20.128 0.0.0.127 area 0

network 208.5.5.16 0.0.0.7 area 0

!

ip nat inside source list 1 interface FastEthernet1/0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 208.5.5.17 150

!

access-list 1 permit 192.168.20.0 0.0.0.127

access-list 1 permit 192.168.20.128 0.0.0.127

!

line con 0

password 7 08701E1D5D

login

line vty 0 4

password 7 08701E1D5D

login

transport input ssh

!

ntp server 96.10.10.10 key 0

!

End

Switch (Switch0)

Current configuration : 1170 bytes

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption

hostname Switch0

enable secret 5 $1$mERr$4dpRATIgxQacPVK0CfNV4/

spanning-tree mode pvst

interface FastEthernet0/1

interface FastEthernet0/2

interface FastEthernet0/3

interface FastEthernet0/4

interface FastEthernet0/5

interface FastEthernet0/6

interface FastEthernet0/7

interface FastEthernet0/8

interface FastEthernet0/9

interface FastEthernet0/10

interface FastEthernet0/11

interface FastEthernet0/12

interface FastEthernet0/13

interface FastEthernet0/14

interface FastEthernet0/15

interface FastEthernet0/16

interface FastEthernet0/17

interface FastEthernet0/18

interface FastEthernet0/19

interface FastEthernet0/20

interface FastEthernet0/21

interface FastEthernet0/22

interface FastEthernet0/23

interface FastEthernet0/24

interface GigabitEthernet1/1

interface GigabitEthernet1/2

!

interface Vlan1

ip address 192.168.10.2 255.255.255.0

!

line con 0

password 7 08701E1D5D

login

!

line vty 0 4

password 7 08701E1D5D

login

line vty 5 15

password 7 08701E1D5D

login

!

End

Switch (Switch1)

Current configuration : 1360 bytes

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption

hostname Switch1

enable secret 5 $1$mERr$4dpRATIgxQacPVK0CfNV4/

spanning-tree mode pvst

interface FastEthernet0/1

switchport mode trunk

interface FastEthernet0/2

interface FastEthernet0/3

interface FastEthernet0/4

interface FastEthernet0/5

interface FastEthernet0/6

switchport access vlan 2

interface FastEthernet0/7

switchport access vlan 2

interface FastEthernet0/8

switchport access vlan 2

interface FastEthernet0/9

switchport access vlan 2

interface FastEthernet0/10

interface FastEthernet0/11

interface FastEthernet0/12

interface FastEthernet0/13

interface FastEthernet0/14

interface FastEthernet0/15

interface FastEthernet0/16

interface FastEthernet0/17

interface FastEthernet0/18

interface FastEthernet0/19

interface FastEthernet0/20

interface FastEthernet0/21

interface FastEthernet0/22

interface FastEthernet0/23

interface FastEthernet0/24

interface GigabitEthernet1/1

interface GigabitEthernet1/2

interface Vlan1

ip address 192.168.20.2 255.255.255.128

!

interface Vlan2

ip address 192.168.20.130 255.255.255.128

!

line con 0

password 7 08701E1D5D

login

!

line vty 0 4

password 7 08701E1D5D

login

line vty 5 15

password 7 08701E1D5D

login

!

!

End

DNS

LINKSYS

Логическая схема

Office 1

Office 2

Office 3

Физическая схема

Размещено на Allbest.ru


Подобные документы

  • Общие сведения о сетевых анализаторах, особенности их применения. Виды и анализ конвергентных (мультисервисных) сетей. Обратная сторона использования и сущность анализаторов сетевых протоколов. Принцип действия и работа системы мониторинга безопасности.

    курсовая работа [3,5 M], добавлен 01.03.2013

  • Основные типовые топологии вычислительных сетей, их изучение, анализ, оценка. Вывод о работе сетей с различной топологией (цепочечной, полносвязной, ячеистой, комбинированной). Преимущества и недостатки топологий, влияющих на производительность сети.

    дипломная работа [65,9 K], добавлен 02.03.2009

  • Разработка проекта пассивной оптической сети доступа с топологией "звезда". Организация широкополосного доступа при помощи технологии кабельной модемной связи согласно стандарту Euro-DOCSIS. Перечень оборудования, необходимого для построения сети.

    курсовая работа [2,7 M], добавлен 27.11.2014

  • Проектирование локальной сети для фирмы ОАО Росэнерго. Исследование информационных потоков компании. Выбор топологии сети, технологий и сетевых протоколов. Распределение адресного пространства. Разработка архитектуры сети. Экономическая оценка проекта.

    дипломная работа [1,5 M], добавлен 28.08.2016

  • Создание топологии соединения офисов в разных частях города. Настройки IP адресов, маршрутизации, безопасности. Конфигурация Web сервера и E-mail с сопоставлением символьных имен IP адресов. Оборудование, необходимое для создания корпоративной сети.

    курсовая работа [3,5 M], добавлен 25.02.2015

  • Конструкция волоконно-оптической кабелей связи. Использование системы передачи ИКМ-30. Технические характеристики ОКЗ-С-8(3,0)Сп-48(2). Расчет длины регенерационного участка. Проектирование первичной сети связи на железной дороге с использованием ВОЛС.

    курсовая работа [189,4 K], добавлен 22.10.2014

  • Расчет допустимой конфигурации домена коллизий для локальной сети. Проектирование горизонтальных и вертикальных линий, магистральная проводка. Разработка плана кабельной системы для связи в сеть всех компьютеров. Выбор местоположения аппаратных комнат.

    контрольная работа [650,8 K], добавлен 26.01.2011

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.