Комплексный пакет ChemOffice для построения, корректирования и двухмерной и трехмерной визуализации химических формул

Интерфейс программы ChemDraw 6.0, особенности ее использования для написания схем химических реакций. Визуализация молекулярных структур с использованием программы Chem3D пакета ChemOffice. Редактирование и анализ геометрии трехмерных моделей молекул.

Рубрика Химия
Вид курсовая работа
Язык русский
Дата добавления 18.05.2014
Размер файла 1,4 M

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru/

Размещено на http://www.allbest.ru/

Введение

Создание и совершенствование компьютерной техники, появление новых технологий передачи, обработки, накопления и представления информации облегчило и ускорило вычислительную работу во многих областях науки и, в частности, химии. Квантовая химия, молекулярная механика, планирование химического синтеза, получение и обработка экспериментальных данных с помощью новых информационных технологий и компьютерной техники - это лишь некоторые типичные примеры. Увеличение вклада информационных в развитие химии связано в первую очередь с появлением персональных компьютеров с высокими эксплуатационными характеристиками и новых технологий передачи информации. Благодаря их относительно низкой цене и доступности для широкого круга пользователей такое оборудование стало обычным в большинстве химических лабораторий и учебных заведениях мира.

Сферами использования компьютеров среди химиков является подготовка текстов, содержащих химические структуры, визуализация пространственной структуры молекул, прогнозирование физико-химических свойств органических соединений на основании их химического строения и т.д. Популярные текстовые редакторы, такие как Microsoft Word, Word Perfect или WordPro и др., несмотря на свои широкие возможности, не имеют удобных инструментов для создания химических структур высокого качества. Для решения задач создания химических структур, схем реакций в полиграфических целях, использования их при создании баз данных, поиска в информационных системах, программах квантовой химии и других областях создано много различных программных средств. Одной из них является - ChemOffice.

Интегрированный программный комплекс ChemOffice включает следующие четыре специализированных приложения:

1) «химический редактор» CS Сhem Draw, являющийся традиционным средством редактирования химических формул;

2) специальный редактор баз данных СS СhemFinder, предназначенный для создания, редактирования и управления базами данных химических соединений;

3) программа CS Chem3D, предназначенная для визуализации химических соединений, компьютерного моделирования и расчётов;

4) редактор таблиц CS Table Editor, предназначенный для просмотра и редактирования табличных данных, используемых в пакете CS Chem3D.

Одним из важнейших элементов химического исследования является анализ геометрической структуры соединений. Эта область науки получила название структурная химия. Важнейшими экспериментальными методами, позволяющими исследовать геометрическую структуру молекул, является адсорбционная и эмиссионная спектроскопия. А также дифракционные методы. Структурные формулы отражают связанность различных атомов и молекул друг с другом. Классическим примером двухмерной структурной модели является структурная формула бензола: Брутто-формула С6Н6 не позволяет передать взаимосвязь между атомами углерода кольца, в связи с чем возникает необходимость отображения структуры в виде геометрического образца - задача визуализации структуры. Ещё более актуальной эта задача становиться при изучении стереоизомеров. Конформационный анализ соединений требует использование трёхмерной модели молекул. До появления компьютеров в качестве таких моделей широко применялись механические модели молекул (модели Стьюарта-Бриглеба). За последние десятилетие создано большое количество различных программных пакетов, позволяющих решать задачи визуализации как плоских, так и пространственных моделей молекул. Первые версии программ позволяли решать в основном задачи пространственных структур. В дальнейшим круг задач, решаемых с использованием специализированных «химических» программных пакетов, был расширен, и в настоящее время наиболее мощные из них реализуют практически все основные задачи компьютерной химии, включая управление базами данных химических соединений, методы квантовой химии и численного моделирования.

Целью данной работы было изучить возможности программного комплекса СhemOffice для построения, корректирования и двухмерной и трёхмерной визуализации химических формул.

В связи с поставленной целью нами решались следующие задачи:

1) Описать программное приложение ChemDraw 8.0 и выявить его возможности для двумерного построения и редактирования структурных химических формул;

2) Описать программное приложение Сhem3D Ultra 8.0 и определить его возможности для трёхмерной визуализации химических формул;

3) Определить различные способы редактирования и анализа геометрии трехмерных моделей молекул.

1. Редактирование структурных химических формул в программе ChemDraw

1.1 Пользовательский интерфейс программы ChemDraw 6.0

программа химический молекулярный трехмерный

Программа ChemDraw, являющаяся одним из компонентов интегрированного пакета программных средств ChemOffice, предназначена для двумерного изображения молекулярных структур и относится к так называемым двумерным химическим редакторам. Она позволяет отображать на плоскости молекулярные структуры любой сложности, записывать уравнения реакции, именовать молекулы и преобразовывать их в дальнейшее трёхмерные модели Chem3D.

Все представленные на экране элементы пользовательского интерфейса можно разделить на:

· главное меню;

· главная панель;

· контрольная панель.

Обзор важнейших элементов главной панели

Изменение масштаба окна отображения молекулярных структур осуществляется с помощью кнопок (Zoom: magnify, reduce)

Для того чтобы переместить выделенные объекты на передний / задний план (Bring to front/Sent to back).

Кнопка (Atom properties) вызывает одноименное окно со свойствами атомов. Аналогичную функцию, только для связей, выполняет кнопка (Bond Properties).

Кнопка (Analyze) вызывает окно Analyze Structure (Анализ структуры), отображающее различные характеристики молекулы.

Кнопка (Сheck Structure) проверяет выделенную молекулярную структуру на наличие ошибок, а кнопка (Clean structure) проверяет соответствие молекулы обычным длинам связей и углам. Если соответствие отсутствует (особенно, когда молекула рисовалась вручную), то делаются необходимые исправления в её структуре.

Остальные кнопки главной панели предназначены для настройки шрифта, размеры шрифта, стиля букв и нижней и верхней индексации.

Есть одна важная функция, о которой следует упомянуть, - это возможность именовать молекулярные структуры по внешнему виду. Вы выбираете молекулу и вызываете пункт главного меню Structure (Структура) / Convert Structure to Name (Преобразовать структуру в название). После небольшой паузы программа выдаёт название молекулы (рисунок 1.1).

Рисунок 1.1

Обратную операцию - преобразование имени в структуру (Convert Name to Structure) - можно вызвать из того же пункта главного меню Structure. Например, (3-бром-фенил) - фенил-метанон, верно записанный по-английски (рисунок 1.2).

Рисунок 1.2

Обзор важнейших элементов контрольной панели

С помощью контрольной панели осуществляется процесс рисования большинства молекулярных структур.

· Кнопки (Selection) осуществляют выделение нарисованных молекул или их фрагментов с помощью лассо и прямоугольника.

· Кнопка (Eraser) удаляет атомы / связи.

· Кнопки (Bonds) предназначены для добавления связей (название приведены не по химическому типу, а по виду отображения): одинарной / пунктирной / пунктирной широкой / пунктирной широкой суженной / толстой / толстой суженной / пустой суженной / направленной / волнистой.

· Кнопка (Text) предназначена для ввода текста. Параметры шрифта и индексации настраиваются с помощью главной панели.

· Кнопка (Pen) включает режим рисования векторной графики: сглаженной ломанной линии.

· Добавление всевозможных стрелок производиться кнопкой (Arrow).

· Кнопка (Orbital) позволяет нарисовать различные электронные орбитали.

· Кнопка (Drawing Elements) добавляет различные элементв рисования: скобки, плоские фигуры, линии и др.

· Кнопка (Chemical Symbols) позволяет нарисовать особые химические символы (заряды ионов, значки радикалов и прочие).

· Кнопка (Arc) рисует дуги разных углов: сплошные и пунктирные.

· Кнопка (Atom-to-Atom mapping) отображает реакционные центры молекул. Поддерживаются только одностадийные реакции.

· Кнопка (Templates) вызывает контекстное меню заготовок: аминокислот, ароматических циклов, бициклов, конформеров и т.д.

· Кнопка (Acyclic Chain) создаёт цепь с указанным числом звеньев.

· Серия кнопок (Rings) позволяют быстро добавить в вашу работу различные кольца циклоалканов и ароматические кольца.

1.2 Использование программы ChemDraw для написания схем химических реакций

Запись схемы химической реакции

В качестве примера выберем упрощенный вариант механизма реакции Гриньяра (с магнийорганическими веществами).

1. Прежде всего нарисуем молекулу карбонильного соединения. Для этого нажмите кнопку (Solid Bond) и с помощью нее добавьте на лист простую связь. Далее подведем курсор к концу связи добавим еще одну связь - она будет присоединять второй радикал. Третья связь будет соединять углерод и кислород. Проведём её из центрального углеродного атома, чтобы сделать её двойной, необходимо повторить операцию добавления связи повторно или вызвать контекстное меню связи (правым щелчком мыши) и выбрать пункт Double-Plane. Теперь проставим названия атомов. Двойным щелчком на каждом атоме задайте его тип. Выделить рисунок кнопкой Marquee и нажмите Clean для очистки структуры. Результат представлен на рисунке 1.3.

Рисунок 1.3

2. Теперь добавим второй реагент: магнийорганическое производное (рисунок 1.4).

Рисунок 1.4

3. Рисуем продукты реакции: спирт и хлорид магния (рисунок 1.5).

Рисунок 1.5

4. Теперь добавляем стрелку и знак плюс. Это осуществляется с помощью кнопок Arrow и Тext. В итоге можно получить требуемое уравнение реакции.

Синтез Гриньяна (рисунок 1.6)

Рисунок 1.6

Запись схемы реакций с указанием реакционных центров

Указание реакционных центров позволяет прояснить в необходимых случаях механизм химической реакции. Кроме того, при хранении схем химических реакций в базе данных с использованием программы ChemFinder в ней может быть произведён поиск реакции по типу реакционного центра. Наиболее важная часть реакции - это часть, в которой происходят изменения от реагентов к продуктам реакции. Эта часть, которая может включать в себя ряд атомов и связей, называется реакционным центом. Например, в молекуле циклогексанона при восстановлении карбонильной группы только двойная связь и два образующих её атома являются частью реакционного центра. Остальная часть при переходе к продукту остаётся без изменений. В программе ChemDraw cуществуют специальные средства для указания реакционных центров в структурной формуле молекулы.

Рассмотрим реакцию гидрохлорирования 2-метил-бутена-2, которая может протекать по двум направления: по правилу Марковникова (А) и против (В) (рисунок 1.7). Для того чтобы указать на каждой из схем атомы углерода, по которым идёт реакция, удобно создать карту реакции. В карте реакции можно указать реакционные центры: номера атомов, которые принимают участие в химическом превращении.

А)

В)

Рисунок 1.7 Реакция гидрохлорирования 2-метил-бутена-2: А) по правилу Марковникова; В) против правила Марковникова

Создадим карты первой и второй реакции. Нарисуем схемы обеих реакций. Для указания реакционных центров в первой реакционных центров в первой реакции нажмите кнопку Reaction Atom-to-Atom-map и проведите стрелку от атома хлора ко второму атому углерода, при этом автоматически около атомов и связей будут созданы символы реакционных центров (рисунок 1.8). Затем проведите стрелку от атома водорода к третьему атому углерода.

Рисунок 1.8

Во второй реакции стрелку необходимо провести от атома хлора к третьему атому углерода и от атома водорода - ко второму атому углерода (рисунок 1.9).

Рисунок 1.9

Символ Rxn обозначает реакционный центр. Лишние реакционные центры следует удалить. Для этого выберем соответствующую связь, вызовем правой кнопкой мыши ее контекстное меню и в пункте Reaction Center выберите пункт Unspecified. Оставим символы Rxn только у двойной связи и у связи Н-С1 (рисунок 1.10).

Рисунок 1.10

Таким образом, создаётся картина реакции. Теперь, если при включённой кнопке Reaction Atom-to-Atom-map указать мышью на один из атомов реакционного центра первой молекулы, на второй молекуле автомaтически выделиться другой атом, участвующий в реакции. В дальнейшем помеченная таким образом реакция может быть сохранена в базе данных программы ChemFinder, и по ней может быть осуществлён поиск по типу реакционного центра.

2. Визуализация молекулярных структур с использованием программы Chem3D пакета ChemOffice

В отличие от двумерных редакторов химических формул программы Chem3D и HyperChem позволяют осуществлять полное трехмерное моделирование и визуализацию химических соединений.

Основным приложением пакета ChemOffice является программа CS Chem3D. Рассмотрим только создание и редактирование трехмерных моделей химических соединений в пакете CS Chem3D Ultra версии 8.0.

2.1 Пользовательский интерфейс программы Chem3D Ultra 8.0

Основные элементы пользовательского интерфейса можно разделить следующим образом:

· Главное меню;

· Главная панель;

· Контрольная панель.

Главное меню

Как и в любом стандартном приложении Windows, Chem3D Ultra 6.0. имеет главное меню, расположенное вверху экрана. Посредством его осуществляется доступ к основным функциям пакета.

Пункт меню File (Файл) содержит стандартный набор возможностей для открытия, сохранения и печати файлов.

· Пункт New Model (Новая модель) открывает новое окно пользователя. С, что Chem3D Ultra 8.0 работает в многооконном режиме.

· Пункт Templates (Заготовки) предлагает открыть новое окно с уже заданными настройками (например, цвет фона или способ отображения молекул) или с заготовками моделей молекул. Например, динамицин А и кристалл NaCl (рисунок 2.1).

Рисунок 2.1

· Пункты Open/Close Window/Save/Save As. (Открыть / Закрыть окно / Сохранить / Сохранить как…) представляют собой стандартные функции открытия, закрытия и сохранения файлов.

· Пункт Revert to Saved (Вернуться к сохраненному) убирает все изменения после последнего сохранения.

· Пункт Set Default Settings (По умолчанию) использует установки данной модели для новой модели.

· Пункты Print/Print Setup (Печать / Настройка) открывает стандартное диалоговое окно для настройки и последующей распечатки файла.

Пункт меню Edit (Правка) также предоставляет обычный набор функций копирования, вставки, отмены последнего действия и выбора.

Пункт Undo/Redo (Отменить / Вернуть) отменяет или, наоборот, возвращает изменения последнего действия.

Пункт Cut (Вырезать) вырезает выбранный элемент молекулы / текст и копирует его в буфер обмена.

Пункт Copy (Копировать) копирует выбранный элемент молекулы / текст в буфер обмена.

Пункт Paste (Вставить) выбранный элемент молекулы / текст из буфера обмена.

Пункт Clear (Очистить) удаляет выбранный элемент / текст.

Пункт Copy As (Копировать как…) позволяет копировать выделенное как ChemDraw - структуру или растр (Bitmap)

Пункт Select All (Выбрать все) выбирает все элементы.

Пункт Select Atoms (Выбрать атомы) позволяет выбирать атомы по определенному признаку: Revers (Выбрать невыбранные, т.е. обратить выделение), Select C (Выбрать все атомы одного элемента), Select Adjiacent (Выбрать все атомы, смежные к данному), Select Fragment (Выбрать все атомы данного фрагмента).

Пункты Clear Frames/ Molecular Surfaces/Calculations (Очистить) позволяет очистить кадры / молекулярные поверхности / расчеты.

Пункт меню View (Вид) предоставляет широкий ассортимент настроек вида молекул / связей / панелей и т.д. Он состоит из трех разделов.

Первый раздел включает три пункта: галочку Toolbar (Главная панель), включающую отображение главной панели; галочку Tools Palette (Контрольная панель), отображающую видимость контрольной панели, и пункт Settings (Настройки), выводящий диалоговое окно настройки вида молекул. Его назначение мы рассмотрим позднее.

Второй раздел объединяет пункты, с помощью которых можно визуализировать различные расчетные характеристики молекулярной модели. Подробно Соответствующие расчетные методы компьютерной химии будут рассмотрены в последующих главах. Здесь же мы лишь опишем назначение отдельных пунктов.

• Пункт Solvent Accessible Surface (Поверхность, доступная растворителю) отображает модель молекулы в виде поверхности, доступной молекулам растворителя. Поверхность изображается на основании расчета методом Конолли площади, заметаемой центром пробной сферы (моделирующей растворитерль) при ее мысленном прокатывании по поверхности исследуемой молекулы. При этом атомы в модели молекулы представляются в виде сфер с радиусами, равными ван-дер-ваальсовским радиусам соответствующих атомов.

Это окно включает следующий набор настроек:

• Solvent Radius (Радиус растворителя) может быть установлен значениями от 0,1 до 10 А движением бегунка. По умолчанию радиус растворителя установлен равным 1.4 А, соответствующим воде.

• Map Properti (Свойства поверхности) предлагает настройки цвета отображения поверхности.

• Resolution (Разрешение) устанавливает качество отображаемой поверхности от грубого до тонкого. Как видно, при низком разрешении поверхность, доступная растворителю, становиться почти эллипсоидальной, тогда как при высоком разрешении она почти повторяет исходную модель молекулы.

Рисунок 2.2 Модель молекулы бутана (а) и поверхность доступная растворителю с разрешением 40 (б)

· Пункт Connolly Molecular Surface (Молекулярная поверхность Конолли) предлагает аналогичные настройки. В данном случае для построения поверхности используется другой алгоритм Конолли, в котором поверхность определяется контактом с молекулой растворителя ? сферой с заданной величиной ван-дер-ваальсовского радиуса.

· Пункт Total Charge Density (Общая плотность заряда) позволяет визуализировать пространственную плотность распределения заряда ? электронную плотность в пространстве, окружающем ядро молекулы, или вероятность нахождения электронов в окружении молекулы.

Окно настроек позволяет задать метод расчета (Calculation), тип поверхности (Surface Туре), ее цвет и т.д.

· Пункт Total Spin Density (Спиновая плотность) описывает пространственное распределение разницы в плотностях между ^-спиновыми и v-спиновыми электронами в данной точке.

· Пункт Molecular Electrostatic Potential (Молекулярный электростатический потенциал) позволяет оценить распределение молекулярного электростатического потенциала. Последний характеризует притяжение или отталкивание между молекулой и протоном в данной точке. Притяжение определяется отрицательными значениями потенциала, а отталкивание - положительными.

· Пункт Molecular Orbitalis (Молекулярные орбитали) позволяет показать поверхности, визуально отображающие различные стабильные электронные распределения в молекуле. Расчет их может быть проведен квантово-химическими методами.

· Пункт Partial Charges (Частичные заряды) используется для отображения частичных зарядов на атомах, вычисленных на основании квантово-химического расчета.

В последнем разделе пункта меню View приведены ссылки па таблицы с параметрами, используемыми в расчетах. Например, таблица ММ2 Atom Type Parameters содержит поля с параметрами атомов, используемыми при расчете энергии молекулы методом молекулярной механики.

Пункт меню Tools (Инструменты) предлагает инструменты отображения различных панелей, меню, функции масштабирования и отражения молекулы.

В первом разделе сосредоточены пункты настройки рабочего окна программы.

Галочка Show Status Bar включает отображение строки состояния.

Галочка Show Rotation Bars включает отображение средств вращения молекулы в окне визуализации.

Галочка Show Movie Controller включает отображение контроллера анимации.

Галочка Show Messages включает отображения поля с сообщениями.

Галочки Show Model Table включает отображения полей с различными данными (измерения, группы, координаты)

Галочка Show H's and Lp's включает отображение атомов водорода и неподеленных электронных пар в модели молекулы.

Рисунок 2.3 Модель молекулы этилового спирта: а) отображение атомов водорода и неподелённых электронных пар; б) выключено

В следующих разделах сосредоточены пункты, позволяющие управлять отображением модели молекулы в окне редактора модели.

• Функции Magnify (Увеличить) и Reduce (Уменьшить) соответственно изменяют масштаб молекулы в окне визуализации. Их действие дублируют кнопки в нижней левой части окна модели, а также горячие клавиши F7 и F8 соответственно.

• Функция Rectify (Исправить) проверяет наличие в молекуле связей, согласно химическим правилам. Например, если четырехвалентный углерод содержит только две связи, будут добавлены два атома водорода. По умолчанию это делается автоматически.

• Функция Clean Up Structure (Очистить) проверяет соответствие в модели молекулы длин связей и валентных углов принятым в химии стандартным значениям. Если соответствие отсутствует (например, когда молекула рисовалась вручную), то делаются необходимые исправления в ее структуре.

• Функция Dock (Стыковать) ориентирует один фрагмент относительно другого.

• Функция Overlay (Покрыть) покрывает один фрагмент другим с помощью атомных пар.

• Пункт Reflect (Отразить) позволяет отразить молекулу относительно заданных плоскостей или инвертировать ее относительно начала координат.

• Пункт Fit Model to Window (Вписать модели в окно) изменяет масштаб молекулы таким образом, чтобы она была полностью видна в окне визуализации.

• Пункт Fit Selection to Window (Вписать выделение в окно) изменяет масштаб выделенной части модели (Selection) таким образом, чтобы она была полностью видна в окне визуализации.

• Пункт Fit All Frames to Window (Вписать все кадры в окно) изменяет масштаб всех кадров анимации таким образом, чтобы они были полностью видны в окне визуализации.

Пункт меню Object (Объект) предлагает инструменты настройки отображения различных параметров молекулы, а также измерения длин связей, межатомных расстояний и углов.

• Функция Move to Center (Двигать в центр) перемещает молекулу или выделение в центр окна визуализации.

• Функция Move То (Двигать в…) перемещает молекулу или выделение на соответствующую ось X, Y или Z.

• Пункт Colorize (Изменить цвет) дает возможность изменить цвет атомов по желанию с помощью палитры.

• Пункт Show Elements Symbols (Показать символы элементов) позволяет отображать символы элементов (например, С, Н и т.д.).

• Пункт Show Serial Numbers (Показать порядковые номера) отображает порядковые номера атомов в модели молекулы, установленные программой.

• Пункт Show Solid Spheres (Показать твердые сферы) включает отображение атомов в виде сплошных сфер.

• Пункт Show Dot Surfaces (Показать точечные поверхности) включает отображение атомов в виде сфер с ван-дер-ваальсовскими радиусами посредством точек.

• Функции Set Distance (Определить расстояние), Set Bond Length (Определить длину связи), Set Bond Angle (Определить угол) и Set Dihedral Angle (Определить двугранный угол) позволяют измерить и при необходимости изменить соответствующие расстояния и углы в модели молекулы. Для того чтобы пользоваться ими, необходимо выделить с помощью мыши атомы, образующие нужную связь или формирующие нужный угол, и выбрать соответствующую функцию. Результат измерения будет отображен в окне Measurements (Измерения) в поле Actual (Фактическое). Кроме того, в поле Optimal будет отображено значение данной величины, принятое в качестве стандартного для выбранной связи или угла. При необходимости можно измерить выделенное расстояние между атомами или угол, следует набрать с клавиатуры требуемое значение в поле Actual и нажать клавишу ввода или щёлкнуть мышью в окне редактора.

• Функция Break Bond (Разорвать связь) разрывает выделенную связь.

• Пункт Set Bond Order (Установить порядок связи) изменяет порядок связи на одинарный / двойной / тройной.

• Функция Bond Proximate (Ближайшая связь) создает химическую связь между двумя ближайшими атомами. Ближайшими в программе считаются два атома, расстояние между которыми меньше, чем принятое стандартное значение для длины связи плюс некоторое значение, величину которого (в процентах от длины связи) можно изменить в настройках пункта меню View\Settings\Building.

• Пункт Add Centroid (Добавить центровой) создает атом-пустышку в центре выделенной молекулы. Эта функция удобна при моделировании координационных соединений.

• Функция Invert (Инвертировать) выполняет операцию пространственной симметрии в выбранной группе хиральных атомов.

• Пункт Set Z Matrix (Установить Z-матрицу) позиционирует выбранный атом в Z-матрице молекулы. Относительное положение каждого атома в молекуле определяется набором переменных, образующих так называемую Z-матрицу молекулы. С помощью данного пункта можно выбрать атом, который в системе отсчета Z-матрицы будет установлен в качестве начального.

• Функции Hide/Show (Скрыть / Отобразить) позволяет скрыть (видимость) выбранных атомов или отобразить их в окне визуализации.

• Пункт Define Group (Определить группу) позволяет сгруппировать выбранные атомы под определенным именем.

Пункт меню Analyze (Анализировать) предлагает инструменты анализа молекул и расчета их свойств.

• Пункты Spin About X/Y/Z/Selected Axis (Вращать) включают режим вращения молекулы относительно оси X/Y/Z или выбранной оси. С помощью кнопок меню анимации возможно записать анимацию, а затем воспроизвести ее.

• Пункт Spin Torsional Angles (Вращать двугранные углы) вызывает операцию вращения определенных групп атомов относительно двугранного угла.

• Пункт Show Measurements (Показать измерения) открывает окно Measurements, в котором отображаются и валентных и двугранных углов для всех атомов молекулы.

• Пункт Extended Huckel Surfaces (Поверхности расширенного метода Хюккеля) позволяет расчитать молекулярную поверхность расширенным методом Хюккеля. Метод Хюккеля ? это один из простейших полуэмпирических квантово-химических методов расчёта. Вычисления с его помощью осуществляются наиболее быстро. Следует заметить, однако, что при его использовании не следует забывать о поговорке: «Вам как сосчитать ? быстро или точно?» После проведения расчета выберите какую-нибудь молекулярную поверхность (молекулярную орбиталь) в меню View (Вид) и отобразите её кнопкой Show Surface (Показать поверхность). Аналогичным образом можно отобразить распределение частичных зарядов в молекуле.

• Пункт Deviation from Plane (Отклонение от плоскости) показывает отклонения выбранных атомов от нормальной плоскости.

• Пункт Compute Properties (Расчет свойств) вызывает одноименное окно, позволяющее выводить результаты расчета выбранного свойства или группы свойств молекулы или соответствующего вещества. Данный пункт объединяет различные расчетные методы, представленные в пакете Chem3D

Пункты меню ММ2 (Молекулярная механика), Gamess, Gaussian и МОРАС предлагают методы расчета потенциальной энергии молекул и прочих характеристик эмпирическими, полуэмпирическимии и неэмпирическими квантово-механическими методами.

• Пункт Run ММ2 Job… (Запустить ММ2 задачу) открывает диалоговое окно для выбора файла описания задания ММ2 с расширением *.jdf и *.fdt.

• Пункт Minimize Energy… (Минимизировать энергию) запускает процесс минимизациипотенциальной энергии молекулы.

• Пункт Molecular Dynamics… (Молекулярная динамика) активизирует молекулярно-динамический эксперимент с возможностью задания температуры, числа итераций и других параметров.

• Пункт Compute Properties… (Расчет свойств) открывает окно для выбора типа расчета.

• Пункт Show Used Parameters (Показать использовавшиеся параметры) отображает параметры ММ2 в окне Messages (Сообщения).

Контрольная панель

Контрольная панель располагается в левой части экрана и имеет небольшой набор необходимых средств.

• Кнопка (Select Tool) позволяет выбрать индивидуальные атомы или связи. С помощью нажатой кнопки <Shift> можно выбрать группы атомов или связей.

• Кнопка (Trackball Tool) вращает целую модель вокруг осей X и Y.

• Кнопки (Bond) создают одинарную / двойную / тройную химическую связь.

• Кнопка (Uncoordinated bond) создает некоординированную связь (с неспаренным электроном).

• Кнопка (Text) позволяет ввести новый элемент, тип атома, формальный заряд или порядковый номер для выбранного атома молекулы, кроме того, дает возможность заменить тип выбранных атомов. Если щелкнуть по пустому месту в окне визуализации, то будет дана возможность создать новый фрагмент, просто записав формулу, например С2Н50Н.

• Кнопка (Eraser Tool) - средство, позволяющее «стирать» атомы и связи.

Окно визуализации располагается в центре экрана и служит средством создания, редактирования и отображения молекулярных структур.

По краям окна располагаются кнопки вращения молекулы.

• Кнопка (Revolve) вращает всю молекулу целиком или на определённый выбранный угол.

• Кнопки (Scale) позволяют уменьшить / увеличить масштаб изображения в окне визуализации.

• Кнопки (Animation) используются при создании и воспроизведении анимации (рисунок 2.4).

Рисунок 2.4 Фрагмент анимационной компьютерной модели «Диссоциация хлорида»

• Окно Messages (Сообщения), открываемое кнопкой-треугольником, отображает в текстовом виде результаты измерений и вычислений.

3. Редактирование и анализ геометрии трёхмерных моделей молекул

Существует несколько способов создания трехмерной модели химического соединения.

3.1 Использование двумерной модели, созданной в одном из простых химических редакторов

Двумерная модель в виде структурной формулы соответствующего соединения может быть создана в приложении CS ChemDraw или в другом «химическом редакторе», например ISIS/Draw, а затем перенесена в окно Chem3D через буфер обмена Windows при Помощи операций «копировать» и «вставить». При вставке в окно Chem3D структурная формула автоматически преобразуется в трехмерную модель, при этом соответствующим длинам валентных связей и углов между атомами присваиваются стандартные для данных элементов значения. Для тех редакторов, с которыми Chem3D не поддерживает интерфейса через буфер обмена Windows, импорт модели может быть осуществлён через файл одного из стандартных химических форматов (файлы с расширением.alс.mol.msm.mop и многие другие).

3.2 Написание брутто-формулы соединения в рабочем поле окна

После нажатия кнопки с буквой «А» на панели инструментов курсор приобретает вид перекрестья с буквой «А» в центре. Если щелкнуть мышью в любом месте рабочего окна, появляется поле ввода текста, в котором можно заглавными латинскими буквами набрать брутто-формулу соответствующего соединения, например СНЗ(СН2) 2С6Н5. После нажатия клавиши ввода в рабочем окне будет создана трехмерная модель соответствующего соединения. Следует иметь в виду, что одной и той же брутто-формуле могут отвечать различные структурные изомеры, поэтому возможно, что созданная модель потребует затем дальнейшего редактирования.

3.3 Непосредственное редактирование с использованием кнопок на панели инструментов

Этот способ является основным, поскольку позволяет создать трехмерную модель любой сложной конфигурации. При нажатии одной из кнопок на панели инструментов, соответствующей одинарной (наклонная черта), двойной (две наклонных черты) или тройной (три наклонных черты) связи, курсор в рабочем поле окна принимает вид перекрестья. Для того чтобы получить трехмерную модель молекулы из двух углеродных атомов, достаточно провести черту при помощи левой клавиши мыши в рабочем поле окна. Нужное количество атомов водорода, соответствующее выбранному типу связи, будет добавлено автоматически. Дальнейшее редактирование может проводиться добавлением новых связей взамен выбранных атомов водорода, изменением геометрии модели, путем перетаскивания мышью выбранных атомов, созданием циклов, путем переноса и последующего наложения нужных атомов углерода, образующих цикл, изменением типа связи. Для того чтобы изменить тип связи, нужно щелкнуть по кнопке на панели инструментов, соответствующей нужному типу связи, и с нажатой клавишей мыши соединить чертой два выбранных атома углерода. Для создания модели с гетероатомами, например кислорода или азота, нужно выбрать на панели инструментов кнопку текстового ввода (кнопка с буквой «А»), выделить щелчком мыши нужный атом (водорода или углерода) и набрать в текстовом поле символ необходимого атома или брутто-формулу заместителя. В процессе редактирования возможно вращение созданной модели или отдельных ее частей в пространстве, изменение размеров отображаемой области, отражение и перемещение. Вращение модели в двух перпендикулярных плоскостях производится при помощи полос прокрутки в нижней и правой частях рабочей области окна. При помещении курсора в область полос прокрутки он приобретает вид ладони. Перемещая в таком состоянии курсор с нажатой левой клавишей мыши вдоль полосы прокрутки, можно вращать модель вокруг горизонтальной и вертикальной оси (правая вертикальная и нижняя полосы прокрутки соответственно). Если необходимо вращать отдельные элементы модели вокруг выбранной связи, нужно выделить нужную связь, выбрав щелчком мыши один или более нужных атомов. Выбор атомов производится при нажатой кнопке на панели инструментов. При необходимости выделить, несколько атомов нужно щелкать на них, удерживая нажатой клавишу Shift, или обвести атомы рамкой с нажатой клавишей мыши. Вращение группы атомов вокруг выделенной связи производится перемещением левой вертикальной полосы прокрутки. Выбор клавиши на панели инструментов позволяет одновременно вращать модель в двух плоскостях произвольном направлении. Изменение размеров отображаемой области может осуществляться нажатием кнопок в нижней части рабочего окна (левая кнопка соответствует уменьшению размеров модели, правая ? увеличению) или выбором пунктов меню Tools/Reduce (уменьшить, функциональная клавиша F8) и Tools/Magnify (увеличить, клавиша F7). Чтобы переместить в плоскости экрана атомов, нужно выделить их и, установив указатель курсора на один из выделенных атомов, перемещать по экрану с нажатой левой клавишей мыши.

Программа допускает различные способы визуализации трёхмерной модели. По умолчанию используется представление Cylindrical bonds (рисунок 3.1). Существует много других представлений, каждое из которых пользователь может настроить по своему усмотрению. Выбор конкретного представления модели и настройка изображения производятся в окне Settings пункта меню View.

После того как создана пространственная модель исследуемого соединения, могут быть изучены, а при необходимости изменены геометрические параметры модели ? длины связей валентные углы между атомами.

Рисунок 3.1 Визуализация изомеров координационного иона [Pt(NH3)4ClBr]2+

Анализ геометрии модели производится выбором вкладки меню Analyze/Show Measurements, в котором можно выбрать соответственно пункты Show Bond Lengths (Показать длины связей), Show Bond Angels (Показать валентные углы), Show Dihedral Angels (Показать двугранные углы), Show Close Contacts (Показать ближайшие контакты).

Если необходимо отключить отображение порядковых номеров для каких-либо атомов модели, следует выделить их при помощи мыши и на вкладке Show Serial Numbers пункта меню Object установить значение Hide (Спрятать). При отображении геометрических параметров модели в окне Measurements справа от поля с обозначением атомов, к которым относится соответствую щий параметр (например, длина связи), выводятся два числовых поля: Actual и Optimal. В поле Actual содержатся действительны значения параметра модели (например, длина соответствующей связи в ангстремах), в поле Optimal выводятся значения данного параметра, устанавливаемые для данной группы атомов по умолчанию в базе данных Chem3D. Для того чтобы изменить какой либо из геометрических параметров модели, достаточно щёлкнуть мышью в поле Actual для соответствующей группы атомов и набрать на клавиатуре нужное значение. После нажатия клавиши Enter в окне модели будет изменен соответствующий размер. Для чтобы присвоить всем длинам связей и валентным углам cстандартные для соответствующих элементов значения, необходимо выделить мышью нужную часть модели или все соединение и выбрать пункт меню Tools\Clean Up Structure.

Заключение

Последние десятилетия двадцатого века ознаменовались глобальными переменами, затронувшими практически все сферы жизни человечества. Мир вступил в эпоху информационного общества, для которого характерно, прежде всего, перепроизводство научной информации. Наращивание информации в обществе продолжается на беспрецедентном уровне. Многие считают, что в течение ближайших десяти лет 100% того, что мы сегодня знаем, составит лишь 10% имеющийся базы знаний. Постоянно обновляющиеся научные знания требуют от человека, прежде всего, умения ориентироваться в информационном пространстве, критически подходить к отбору информации, создавать новые знания и способы деятельности на основе полученной информации. Кроме того, применение информационных технологий даёт возможность сделать процессы обучения и управления процессами обучения более эффективными и интенсивными.

Подводя черту, под всем выше сказанным хочется заметить, что компьютерные программы, в том числе и ChemOffice, могут успешно применяться как для научной деятельности, так и при изучении курса химии в школе и ВУЗах.

Библиографический список

1. Белохвостов, А.А. К вопросу об использовании информационных технологий в обучении / А.А. Белохвостов // Материалы XVII Международной электронной научной конференции «Новые технологии в образовании». - Воронеж, 2006. - С. 11-12

2. Белохвостов, А.А. Визуализация пространственной структуры химических соединений / А.А. Белохвостов // Материалы региональной научной конференции студентов, магистрантов, аспирантов и молодых учёных. II Машеровские чтения. - Витебск: изд-во «ВГУ им. П.М. Машерова», 2007. - С. 48-49

3. Соловьёв, М.Е. Компьютерная химия/ Соловьёв М.Е., Соловьёв М.М. - М.: СОЛОН-Пресс, 2005. - 5 с.

Размещено на Allbest.ru


Подобные документы

  • Методы построения кинетических моделей гомогенных химических реакций. Исследование влияния температуры на выход продуктов и степень превращения. Рекомендации по условиям проведения реакций с целью получения максимального выхода целевых продуктов.

    лабораторная работа [357,5 K], добавлен 19.12.2016

  • Методы построения кинетических моделей гомогенных химических реакций. Расчет изменения концентраций в ходе химической реакции. Сравнительный анализ численных методов Эйлера и Рунге-Кутта. Влияние температуры на выход продуктов и степень превращения.

    контрольная работа [242,5 K], добавлен 12.05.2015

  • Понятие и расчет скорости химических реакций, ее научное и практическое значение и применение. Формулировка закона действующих масс. Факторы, влияющие на скорость химических реакций. Примеры реакций, протекающих в гомогенных и гетерогенных системах.

    презентация [1,6 M], добавлен 30.04.2012

  • Методы 3D QSAR/QSPR. Концепция непрерывных молекулярных полей. Визуализация молекулярных полей, полей регрессионных коэффициентов. Построение моделей 3D QSAR/QSPR на основе функций принадлежности точки атомным типам. Оценка качества 3D-QSAR/QSPR моделей.

    дипломная работа [653,1 K], добавлен 16.06.2013

  • Тепловые эффекты химических реакций, а также основные факторы, влияющие на их динамику. Закон Гесса: понятие и содержание, сферы практического применения. Энтропия системы и анализ уравнения Больцмана. Направления химических реакций и энергия Гиббса.

    лекция [34,1 K], добавлен 13.02.2015

  • Рассмотрение превращения энергии (выделение, поглощение), тепловых эффектов, скорости протекания химических гомогенных и гетерогенных реакций. Определение зависимости скорости взаимодействия веществ (молекул, ионов) от их концентрации и температуры.

    реферат [26,7 K], добавлен 27.02.2010

  • Общее понятие о химической реакции, ее сущность, признаки и условия проведения. Структура химических уравнений, их особенности и отличия от математических уравнений. Классификация и виды химических реакций: соединения, разложения, обмена, замещения.

    реферат [773,3 K], добавлен 25.07.2010

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.