Создание базы данных в Microsoft Access

Создание моделей данных, основных таблиц с помощью конструктора таблиц, связей между таблицами, форм для заполнения таблиц, запросов на выборку данных, отчетов для вывода на печать и начальной кнопочной формы. Основные объекты Microsoft Access.

Рубрика Программирование, компьютеры и кибернетика
Вид контрольная работа
Язык русский
Дата добавления 18.03.2012
Размер файла 4,5 M

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru/

Размещено на http://www.allbest.ru/

Содержание

Создание базы данных и основных таблиц

Создание связей между таблицами

Создание форм для заполнения таблиц

Создание запросов на выборку данных

Создание отчетов для вывода на печать

Создание начальной (главной) кнопочной формы

Список использованных источников

Приложение

Создание базы данных и основных таблиц

Для того чтобы создать базу данных, мы, во-первых, запускаем систему управления базами данных. Сделаем это с помощью команды «ПУСК-ПРОГРАММЫ-MICROSOFT OFFICE-MICROSOFT ACCESS».

На моем компьютере установлен пакет Microsoft Office 2007. Запустится Access.

MS Access поддерживает реляционную модель данных, т.е. база данных состоит из множества взаимосвязанных отношений, каждому отношению соответствует отдельная таблица.

Таблицы состоят из строк и столбцов. Столбцы таблицы отражают общие свойства или характеристики объектов реального мира, которые моделируются с использованием данной таблицы. Для каждого свойства пользователь выделяет один столбец. Строки таблицы соответствуют различным экземплярам реальных объектов и называются записям.

Таблица - это объект, предназначенный для хранения данных в виде записей (строк) и полей (столбцов). Обычно, каждая таблица используется для хранения сведений по одному конкретному вопросу.

Форма - объект, Microsoft Access, предназначенный, в основном .для ввода данных. В форме можно разместить элементы управления ,применяемые для ввода , изображения и изменения данных в полях таблиц.

Запрос - объект, позволяющий получить нужные данные из одной или нескольких таблиц.

Отчёт - объект базы данных Microsoft Access ,предназначенный для печати данных.

В таблице сохраняют записи, содержащие сведения определённого типа, например, список клиентов или опись товаров. Составной частью таблицы являются поля.

Поле - это элемент таблицы, который содержит данные определённого рода , например, фамилию сотрудника. В режиме таблицы для представления поля используется столбец или ячейка, в этом случае имя поля является заголовком столбца таблицы.

Запись - полный набор данных об определённом объекте. В режиме таблицы запись изображается как строка.

Вот первоначальное окно для создания базы данных:

Нажатием кнопки «« в правой панели появится окно для выбора пути и имени создаваемой базы данных: . Набираем имя, выбираем путь для сохранения базы данных и нажимаем кнопку ««. Наша база данных готова для создания в ней таблиц, форм, запросов и отчетов.

Создадим нашу первую таблицу с помощью конструктора таблиц.

На вкладке «Создание» выбираем «Конструктор таблиц».

Наша первая таблица будет называться «Поставщики». Зададим ей необходимые поля, для которых определим имя, тип данных и свойства (размер поля).

Таблица «Поставщики» будет иметь следующую структуру:

Зададим (уникальное поле, однозначно определяющее записи). Сохраним нашу таблицу.

После закрытия конструктора наша таблица появится в левой панели:

Аналогично создадим вторую таблицу «Бензин». Её структура будет следующей:

Посмотрим остальные таблицы в режиме конструктора:

Создание связей между таблицами

Схема данных является графическим образом БД. Она используется различными объектами Access для определения связей между несколькими таблицами. Например, при создании формы, содержащей данные из нескольких взаимосвязанных таблиц, схема данных обеспечивает автоматический согласованный доступ к полям этих таблиц. Она же обеспечивает целостность взаимосвязанных данных при корректировке таблиц.

После того, как созданы таблицы БД, можно установить связи между ними, обратившись к схеме данных. Запуск схемы данных выполняется через значок « » на вкладке «Работа с базой данных».

Связь между таблицами устанавливает отношения между совпадающими значениями в ключевых полях, обычно между полями, имеющими одинаковые имена в обеих таблицах. В большинстве случаев с ключевым полем одной таблицы, являющимся уникальным идентификатором каждой записи, связывается внешний ключ другой таблицы.

Обязательным условием при установлении связи является совпадение связываемых полей по типу и формату.

Тип отношения в создаваемой Microsoft Access связи зависит от способа определения связываемых полей.

Отношение «один-ко-многим» является наиболее часто используемым типом связи между таблицами. В отношении «один-ко-многим» каждой записи в таблице A могут соответствовать несколько записей в таблице B, но запись в таблице B не может иметь более одной соответствующей ей записи в таблице A.

При отношении «один-к-одному» запись в таблице A может иметь не более одной связанной записи в таблице B и наоборот. Отношения этого типа используются не очень часто, поскольку большая часть сведений, связанных таким образом, может быть помещена в одну таблицу. Отношение «один-к-одному» может использоваться для разделения очень широких таблиц, для отделения части таблицы по соображениям защиты, а также для сохранения сведений, относящихся к подмножеству записей в главной таблице.

При отношении «многие-ко-многим» одной записи в таблице A могут соответствовать несколько записей в таблице B, а одной записи в таблице B несколько записей в таблице A. Этот тип связи возможен только с помощью третьей (связующей) таблицы, первичный ключ которой состоит из двух полей, которые являются внешними ключами таблиц A и B. Отношение «многие-ко-многим» по сути дела представляет собой два отношения «один-ко-многим» с третьей таблицей.

Связь между таблицами определяется путем добавления связываемых таблиц в окно «Схема данных» с последующим перетаскиванием ключевого поля из одной таблицы в другую.

Если схема данных создается заново, то при нажатии на кнопку «Схема данных» открывается окна схемы данных, в которой мы, выполнив команду «» можем добавить нужные нам таблицы для их связывания.

В этом окне следует выделить требуемые таблицы и нажать «Добавить».

В результате в окно схемы данных будут добавлены графические образы таблиц.

Access автоматически определил тип связи как «один-ко-многим».

Можно также установить флажки "каскадное обновление связей" и "каскадное удаление связей". В этом случае Access автоматически скорректирует (удалит) записи в подчиненных таблицах, если будут изменены записи в базовой таблице.

После нажатия на кнопку "Создать", образы таблиц будут соединены связями как показано на рисунке. Ключевые в базовых таблицах выделяются жирным шрифтом.

Получившаяся схема данных:

Создание форм для заполнения таблиц

Access предоставляет возможность вводить данные как непосредственно в таблицу, так и с помощью форм. Форма в БД - это структурированное окно, которое можно представить так, чтобы оно повторяло форму бланка. Формы создаются из набора отдельных элементов управления.

Внешний вид формы выбирается в зависимости от того, с какой целью она создается. Формы Access позволяют выполнять задания, которые нельзя выполнить в режиме таблицы. Формы позволяют вычислять значения и выводить на экран результат. Источником данных для формы являются записи таблицы или запроса.

Форма предоставляет возможности для:

? ввода и просмотра информации базы данных

? изменения данных

? печати

? создания сообщений

Способы создания форм:

? Конструктор форм (предназначен для создания формы любой сложности)

? Мастер форм (позволяет создавать формы различные как по стилю, так и по содержанию)

? Автоформа: в столбец (многостраничная - поля для записи выводятся в один столбец, в форме одновременно отображаются данные для одной записи)

? Автоформа: ленточная (все поля записи выводятся в одну строку, в форме отображаются все записи)

? Автоформа: табличная (отображение записей осуществляется в режиме таблица)

? Автоформа: сводная таблица

? Автоформа: сводная диаграмма

? Диаграмма (создается форма с диаграммой, построенной Microsoft Graph)

? Сводная таблица (создается форма Access, отображаемая в режиме сводной таблицы Excel)

Алгоритм создания наших форм следующий:

Выбираем в левой панели таблицу, для которой будет строиться форма. Затем на вкладке «Создание» выбираем «Конструктор форм» или другой способ создания формы.

Первую форму создадим, нажатием на кнопку «». Нам будет выдана готовая структура формы, нам остается только принять предложение Microsoft Access.

Туда мы добавим кнопки для добавления и удаления записей, а также для закрытия формы. Эту нужно только для удобства заполнения формы.

В режиме конструктора наша форма будет выглядеть так:

Форму «Сотрудники» создадим с помощью мастера форм, который предложит нам выбрать таблицу, из которой будут выбираться поля для формы и непосредственно сами поля.

Выбираем поле, нажимаем > - поле переходит в столбец выбранных полей. Когда закончим выбор всех нужных нам полей, нажимаем «Далее».

Внешний вид формы - «В один столбец», стиль формы - «Техническая».

Если мы хотим добавить в нашу форму ещё элементы помимо тех, что нам предложил «Мастер форм», мы в следующем окне

выберем команду «Изменить макет формы» и нажмем «Готово». Форма откроется для редактирования в режиме конструктора.

После добавления кнопок наша форма в режиме конструктора примет следующий вид:

Остальные формы создадим аналогично, только заменим простые поля на поля со списком там, где это необходимо.

Посмотрим оставшиеся формы в режиме конструктора:

После создания структуры таблиц и форм мы можем внести в наши таблицы начальные сведения.

Вот что у нас получилось:

Создание запросов на выборку данных

В СУБД MS Access можно применять пять типов запросов.

Запрос на выборку обеспечивает отбор данных по определенному условию.

Запрос с параметром позволяет менять условие отбора в одном запросе.

Запрос на изменение меняет содержимое исходных таблиц.

Перекрестные запросы позволяют анализировать данные и создавать таблицу аналогичную таблице Excel со строками и столбцами.

Запросы на языке SQL позволяют пользователю сформулировать сложные по структуре критериев и вычислений запросы.

Конструктор предназначен для самостоятельного создания нового запроса.

Простой запрос - для создания запроса на выборку из определенных полей.

Перекрестный запрос - создание запроса, выводящего данные в компактном формате, подобном формату электронной таблицы.

Повторяющиеся записи - создание запроса на поиск повторяющихся записей в простой таблице или запросе.

Записи без подчиненных - создание запроса на поиск записей, которым не соответствует ни одна запись в подчиненной таблице.

Запрос выбора является стандартным типом запроса.

С помощью запросов выбора пользователь может увидеть часть данных таблицы, проанализировать и даже изменить их. Данные доступные пользователю в одном запросе, могут храниться в одной или нескольких таблицах одной базы.

После выполнения запроса выбора Access отобразит результат запроса в специальной таблице - динамическом наборе данных.

Мастер простого запроса

В первом диалоговом окне мастера простого запроса из списка «Таблицы/Запросы», необходимо выбрать таблицу, поля которой будут участвовать в запросе. Из списка представленных полей «Доступные поля» выбрать и перенести в список «Выбранные поля» поля для создания запроса.

Пункт 1 выполнить для всех таблиц, участвующих в запросе.

Нажать кнопку «Далее».

В следующем диалоговом окне мастера можно задать для запроса только выборку записей или суммирование полей.

Указать имя запроса.

Проверить выполнение запроса.

Окно запроса разделено на две части.

В верхней части находятся таблицы, представленные в форме списков полей.

Каждый список полей снабжен заголовком, содержащим имя таблицы.

В нижней части окна содержится спецификация запроса. Эта область называется областью проектирования (запрос по образцу). В ней запросы описываются наглядными элементами. Поля перетаскиваются из верхней области запроса в область проектирования.

Каждая колонка области содержит информацию о поле в запросе.

Поле:

Имя таблицы:

Сортировка:

Вывод на экран:

Условие отбора:

Если пользователь составляет запрос на основе нескольких таблиц, между таблицами необходимо объявить отношение, связывая их поля друг с другом.

Связь отображается на экране соединенной линией между связанными полями обеих таблиц.

Для объявления связи между двумя таблицами прямо в окне проектирования запроса необходимо перетащить поле одной таблицы в поле такого же типа другой таблицы.

Условия отбора (критерии) - это инструкции, определяющие какие записи должны отбираться по запросу.

Условия могут задаваться для одного или нескольких полей запроса.

Access проверяет корректность выражения для отбора.

Записи в запросе могут быть рассортированы в алфавитном порядке или числовым способом в возрастающей или убывающей последовательности. Сортировку можно производить по содержимому нескольких полей. Для сортировки необходимо щелкнуть мышью на ячейке того поля, по которому необходимо произвести сортировку и указать способ сортировки: Ascending (По возрастанию) или Descending (По убыванию), который выбирают из списка.

Итоговый запрос - это запрос на выборку, который предназначен для выполнения итоговых вычислений по данным.

Итоговый запрос можно создать с помощью Мастера простого запроса или Конструктора.

Создание Итогового запроса с помощью Конструктора:

1) В режиме конструктора Запроса щелкнуть по кнопке «Групповые операции» на панели инструментов. В бланке Запроса появится строка Групповые операции.

2) Во всех полях автоматически устанавливается значение группировка.

Access предоставляет такие групповые операции:

Sum - вычисляет сумму всех значений заданного поля в каждой группе (для числовых и денежных полей);

Avq - вычисляет среднее арифметическое значений данного поля в каждой группе (для числовых и денежных полей);

Count - возвращает число записей, в которых данное поле имеет значение, отличное от Null. Для того чтобы подсчитать число записей каждой группы с учетом значения Null, надо ввести выражение Count(*) в строку поле, т.е. определить вычислимое поле (для числовых, текстовых, денежных полей, полей типа дата/время).

И другие групповые операции.

Чтобы иметь возможность многократно выполнять запрос, при выполнении изменяя условия отбора, необходимо добавить параметр. Для установления параметра в строку Условие отбора вместо обычного условия вводится в квадратных скобках текст-подсказка. Access размещенную в квадратные скобки информацию рассматривает как имя запроса.

В одном запросе можно задать несколько параметров, главное, чтобы тексты-подсказки были информативными и уникальными. При выполнении такого запроса Access поочередно с помощью окон предлагает ввод значений каждого параметра.

Для проектирования параметрического запроса необходимо:

1) Разработать запрос выбора, включающий интересующие поля, установить критерии отбора.

2) Заполнить его параметризуемые поля не конкретным критерием выбора, а обращением к пользователю для ввода критерия. Это обращение во время выполнения запроса выдается пользователю, он введет критерий отбора, на основе которых ведется отбор данных. Обращение в ячейке критериев записывается в квадратных скобках.

Представим наши запросы сначала в виде конструктора.

Последнее поле «Сумма» в этом запросе вычисляемое. В нём мы производим перемножение полей «Цена» (из таблицы «Бензин») и «Количество литров» (из таблицы «Поступление товара»), чтобы определить стоимость партии поставки.

access таблица данное запрос

В следующем запросе мы просим пользователя ввести номер интересующей заправки. Само поле «Номер автозаправки» не будем отображать (а зачем, если пользователь сам запросил номер заправки?).

Остальные запросы:

Следующий запрос - итоговый. Он выдает общую сумму по количеству литров и общую сумму продаж по дням.

Ну и ещё один запрос с параметром:

Создание отчетов для вывода на печать

После создания всех основных объектов базы данных мы можем создать отчеты. Отчеты - это такая печатная форма для наглядного вывода полученных данных (чаще из запросов, реже - из таблиц).

При печати таблиц и запросов информация выдается практически в том виде, в котором хранится. Подробный отчет включает всю информацию из таблицы или запроса, но содержит заголовки и разбит на страницы с указанием верхних и нижних колонтитулов.

В Microsoft Access можно создавать отчеты различными способами:

? Конструктор

? Мастер отчетов

? Автоотчет: в столбец

? Автоотчет: ленточный

? Мастер диаграмм

? Почтовые наклейки

Мастер позволяет создавать отчеты с группировкой записей и представляет собой простейший способ создания отчетов. Он помещает выбранные поля в отчет и предлагает шесть стилей его оформления. После завершения работы Мастера полученный отчет можно доработать в режиме Конструктора. Воспользовавшись функцией Автоотчет, можно быстро создавать отчеты, а затем вносить в них некоторые изменения.

Для печати отчета необходимо выполнить следующее:

? В меню Файл щелкнуть на команде Печать.

? В области Печатать щелкнуть на варианте Страницы.

? Чтобы напечатать только первую страницу отчета, введите 1 в поле "с" и 1 в поле "по".

? Щелкнуть на кнопке ОК.

Прежде чем печатать отчет, целесообразно просмотреть его в режиме Предварительного просмотра, для перехода к которому в меню Вид нужно выбрать Предварительный просмотр.

Если при печати в конце отчета появляется пустая страница, убедитесь, что параметр Высота для примечаний отчета имеет значение 0. Если при печати пусты промежуточные страницы отчета, убедитесь, что сумма значений ширины формы или отчета и ширины левого и правого полей не превышает ширину листа бумаги, указанную в диалоговом окне Параметры страницы (меню Файл).

Создадим наши отчеты.

При создании отчета поступления товара (бензина на автозаправки) с помощью мастера укажем несколько свойств:

Это будет означать, что наши данные будут отсортированы в списке по возрастанию номеров автозаправки и по алфавиту типов бензина. Помимо этого будет посчитана итоговая сумма количества литров и суммы продаж по полям.

Наш отчет в режиме конструктора:

Отчет по продажам сделаем с помощью автоотчета.

Готовые отчеты - в приложении.

Создание начальной (главной) кнопочной формы

Теперь, когда мы уже создали все необходимые объекты в нашей базе данных, мы создадим главную форму, с которой будет начинаться вход в нашу базу данных, и в которой мы сможем получить компактный доступ ко всем объектам нашей базы данных сразу.

На эту форму мы поместим кнопки, нажатие на которые будет запускать другие формы, выполнять запросы или выдавать на просмотр или печать отчеты.

Наша главная форма в режиме конструктора будет выглядеть так:

А при запуске её в Access при открытии так:

Наша база данных готова.

Список использованных источников

1. А. Федоров, Н. Елманова, «Базы данных для всех». - М.: КомпьютерПресс, 2001 - 256с.: ил.

2. Берлинер Э.М., Глазырина И.Б., Глазырин Б.Э. Office 2000. - М.: ЗАО "Издательство БИНОМ", 2000. - 528с.

3. Гайдамакин Н.А. «Автоматизированные информационные системы, базы и банки данных» - М. Гелиос АРВ, 2002. - 368с.

4. Кузнецов С.Д., «СУБД и файловые системы». - М.: Майор, 2001. - 176с.

5. Макарава Н.В. и др. «Информатика»: Учебник. - М: Финансы и статистика, 2009. - 349с.: ил.

6. Симонович С.В. и др. «Информатика»: Базовый курс. - СПб.: Питер, 2010. - 350с.

7. Фигурнов В.Э. IBM PC для пользователя. Изд. 7-е, исправл. и доп.-С.Петербург, "Коруна", НПО "Информатика и компьютеры", 2004. - 352с.

8. Хомоненко А.Д. и др. «Основы информационных технологий»: Учебное пособие. - СПб: КОРОНА print, 2008.

9. Хомоненко А.Д., Цыганков В.М., Мальцев М.Г. «Базы данных»: Учебник/под редакцией А.Д. Хомоненко. - СПб: КОРОНА print, 2010, - 416с.

Размещено на Allbest.ru


Подобные документы

  • Компоненты реляционной базы данных Microsoft Access. Создание структуры таблиц и определение связей между ними. Проектирование форм для сводных таблиц и запросов с помощью конструктора окон. Разработка и создание автоотчетов и запросов на выборку данных.

    реферат [3,3 M], добавлен 29.01.2011

  • Создание базы данных в Microsoft Access с помощью мастера шаблонов. Создание таблиц путём ввода данных, с помощью мастера таблиц или таблицы в режиме конструктора таблиц. Создание запросов в Microsoft Access, с помощью мастера или конструктора запросов.

    реферат [27,3 K], добавлен 08.09.2010

  • Характеристика Microsoft Access. Создание структуры базы данных. Определение основных тем таблиц базы данных и информации, которую будут содержать поля таблиц. Создание таблиц, запросов, форм и отчетов. Страницы доступа к данным. Макросы и модули.

    курсовая работа [1,1 M], добавлен 09.12.2012

  • Сущность и виды СУБД Microsoft Access. Алгоритм создания базы данных сессионной успеваемости студентов ВУЗа. Проектирование форм для сводных таблиц с помощью конструктора окон. Разработка отчетов и запросов на выборку данных. Создание кнопочной формы.

    курсовая работа [5,4 M], добавлен 09.05.2011

  • Структура многотабличных баз данных, создание и редактирование таблиц в MS Access, установка связей между таблицами, фильтрация и сортировка данных, создание БД "Месторождения нефти". Составление форм, запроса на выборку по разным полям и отчетов.

    лабораторная работа [531,5 K], добавлен 13.02.2012

  • Понятие и основные функции СУБД "Access". Алгоритм создания базы данных сотрудников: создание таблиц с помощью конструктора, ключевые поля, установление связей между таблицами. Создание форм для поиска и ввода данных. Работа с запросами и отчетами.

    контрольная работа [827,5 K], добавлен 01.06.2010

  • Принципы работы с реляционными базами данных в среде Microsoft Access. Основные положения базы данных Access. Составление таблиц, запросов, отчетов, страниц и модулей. Основные структуры представления базы данных. Определение связей между таблицами.

    контрольная работа [2,6 M], добавлен 03.04.2014

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.