Система сбора, хранения и обработки данных

Создание нового проекта. Окно "Task Information", команда "Indent". Проектирование базы данных в Enterprise Arhitect. Установка названия таблицы, параметров полей. Процесс генерации файла "Schema1.sql". Моделирование сигналов в Matlab, обмен данными.

Рубрика Программирование, компьютеры и кибернетика
Вид курсовая работа
Язык русский
Дата добавления 17.02.2013
Размер файла 5,0 M

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru/

ВВЕДЕНИЕ

Проектирование информационных систем всегда начинается с определения цели проекта. Основная задача любого успешного проекта заключается в том, чтобы на момент запуска системы и в течение всего времени ее эксплуатации можно было обеспечить:

требуемую функциональность системы и степень адаптации к изменяющимся условиям ее функционирования;

требуемую пропускную способность системы;

требуемое время реакции системы на запрос;

безотказную работу системы в требуемом режиме, иными словами - готовность и доступность системы для обработки запросов пользователей;

простоту эксплуатации и поддержки системы;

необходимую безопасность.

Производительность является главным фактором, определяющим эффективность системы. Хорошее проектное решение служит основой высокопроизводительной системы.

Целью данного курсового проекта является разработать структуры БД.

Разработать процедуры переноса структуры БД в выбранную СУБД.

Моделирование и обмен данными сигналов MATLAB-СУБД.

1. СОЗДАНИЕ ПЛАНА ПРОЕКТА ДЛЯ ВЫБРАННОЙ ТЕМАТИКИ

Запускаем программу Microsoft Project. Далее создаем новый проект используя команду меня «Файл - Создать», результат представлен на рисунке 1.1.

Рисунок 1.1 - Команда «Файл - Создать»

В левой части окна выбираем «Пустой проект», результат представлен на рисунке 1.2.

Рисунок 1.2 - Создание нового проекта

Таким образом, создается новый проект, для соответствующей выбранной тематики разработки.

Далее выполняем заполнение задач нашего проекта. Для того чтобы создать задачу, необходимо щелкнуть в пустом месте поля «Task Name». В появившемся окне пишем название нашей задачи и устанавливаем необходимые параметры. В поле «Duration» продолжительность в размере 44 дня, результат представлен на рисунке 1.3.

Рисунок 1.3 - Окно «Task Information»

Просматриваем получившуюся задачу в рабочей области Project, результат представлен на рисунке 1.4.

Рисунок 1.4 - Созданная задача

Далее выполняем добавление новых задач, результат представлен на рисунке 1.5.

Рисунок 1.5 - Добавленные задачи

Для того, чтобы создать вложенную задачу щелкаем правой клавишей на необходимой задаче и выбираем команду «Indent», результат представлен на рисунке 1.6.

Рисунок 1.6 - Команда «Indent»

В итоге получаем вложенную задачу, результат представлен на рисунке 7.

Рисунок 1.7 - Вложенная задача

Выполняем заполнение нашего плана в соответствие с заданием, результат представлен на рисунке 1.8.

Рисунок 1.8 - Заполнение проекта

Производим дальнейшее заполнение нашего проекта, результаты представлены на рисунке 1.9 и рисунке 1.10.

Рисунок 1.9 - Заполнение проекта

Рисунок 1.10 - Заполнение проекта

В итоге получаем следующий проект, результаты представлены на рисунке 1.11 и рисунке 1.12.

Рисунок 1.11 - Готовый проект

Рисунок 1.12 - Готовый проект

Далее выполняем сохранение проекта, используя команду меню «File - Save as», результат представлен на рисунке 1.13.

Рисунок 1.13 - Сохранение проекта

2. ПРОЕКТИРОВАНИЕ БД В ENTERPRISE ARHITECT

Разработаем структуру БД, представленная в таблице 1:

Таблица 1 - Структура БД

Таблица

Ячейки

Server

ID

Name

Param

ID

Temp

Volt

ID_MetaData

MetaData

ID

HostName

Note

ID_Server

Разработка структуры БД будет производится в программе Enterprise Arhitect. Запускаем данную программу, используя команду основного меню «File - New project» выполняем создание проекта. После выполнения команды появляется окно в которым предлагается сохранить будущую структуру БД, зададим имя «projbd.eap» и нажмем кнопку «Сохранить», результат представлен на рисунке 2.1.

Рисунок 2.1 - Сохранение проекта

В Model Wizard выбираем в разделе «Technology» параметр «Core Extensions» в «Name» выбираем «Database» и нажимаем ОК, результат представлен на рисунке 2.2.

Рисунок 2.2 - Model Wizard

При нажатии кнопки ОК на схеме создаются автоматически две таблицы связанные друг с другом. Удаляем связь и переименовываем наши таблицы в соответствии с заданием.

Для первой таблицы указываем следующие параметры, а также указываем тип полей таблицы, результаты представлены на рисунке 2.3 и рисунке 2.4.

Рисунок 2.3 - Установка названия таблицы

Рисунок 2.4 - Установка параметров полей таблицы

Далее удаляем связи таблиц, для этого правой клавишей мыши щелкаем на связи и выбираем «Delete Connector». В появившемся окне устанавливаем переключатель на «Delete the connector from model» и нажимаем ОК, результат представлен на рисунок 2.5.

Рисунок 2.5 - Удаление связи таблиц

Далее выполняем редактирование второй таблицы под наши параметры, результаты представлены на рисунке 2.6 и рисунке 2.7.

Рисунок 2.6 - Установка названия таблицы

Рисунок 2.7 - Установка параметров полей таблицы

Добавляем остальные поля таблицы, результат представлен на рисунке 2.8.

Рисунок 2.8 - Добавление полей таблицы

Далее с панели «ToolBox» перетягиваем компонент «Table», т.е. третью таблицу и редактируем её параметры, результат представлен на рисунке 2.9.

Рисунок 2.9 - Редактирование параметров таблицы

Далее выполняем настройки связей таблицы. Выставим параметры для связей таблицы, результаты представлены на рисунке 2.10, рисунке 2.11 и рисунке 2.12.

Рисунок 2.10 - Установки параметров связи таблиц

Рисунок 2.11 - Установка параметров связи таблиц

Рисунок 2.12 - Установка параметров связи таблиц

Далее указываем имя связи между таблицами, результат представлен на рисунок 2.13.

Рисунок 2.13 - Установка связей между таблицами

Далее аналогично создаем связь между двумя другими таблицами, результаты представлены на рисунке 2.14, рисунке 2.15 и рисунке 2.16.

Рисунок 2.14 - Установка связей между таблицами

Рисунок 2.15 - Установка связей между таблицами

Рисунок 2.16 - Установка связей между таблицами

В правой части окна отображаются все три таблицы и их структура, результат представлен на рисунке 2.17.

Рисунок 2.17 - Структура таблиц

Полученная схема, результат представлен на рисунке 2.18.

Рисунок 2.18 - Полученная схема

3. СОЗДАНИЕ СХЕМЫ ЦЕЛЕВОЙ СУБД

Открываем в Enterprise Arhitect ранее созданный проект с именем «projectbd.eap».

Далее выполняем команду основного меню «Tools - Database Engineering - Generate Package DDL» в появившемся окне устанавливаем необходимые параметры, а также указываем путь к сохраняемому файлу «Schema1.sql», результат представлен на рисунке 3.1.

Рисунок 3.1 - Сохранение Schema1.sql

Рисунок 3.2 - Установка параметров генерации

Для генерации файла «Schema1.sql» нажимаем кнопку «Generate», результат представлен на рисунке 3.2.

Далее запускаем Microsoft SQL Server 2008. В появившемся окне нажимаем «Connect», результат представлен на рисунке 3.3.

Рисунок 3.3 - Подключение к SQL-серверу

Далее откроем ранее созданный sql-файл, результат представлен на рисунке 3.4.

Рисунок 3.4 - Открытие ранее созданного sql-файла

Выбираем файл и нажимаем кнопку «Open».

Создадим новую базу данных и укажем её имя, результат представлен на рисунке 3.5.

Рисунок 3.5 - Установка имени новой базы данных

Далее создаем запрос, который создаст структуру нашей базы данных, результат представлен на рисунке 3.6.

Для того, чтобы создать вопрос щелкаем правой клавишей мыши по имени базы данных и выбираем «Scripts Database As - CREATE to - New Query Editor Window». Далее заменяем содержимое нового окна на содержимое нашего запроса. Для создания структуры БД нажимаем кнопку «Execute».

Рисунок 3.6 - Запрос на создание базы данных

После выполнения запроса в структуре базы данных видим необходимые таблицы, результат представлен на рисунке 3.7.

Рисунок 3.7 - Таблицы базы данных

4. МОДЕЛИРОВАНИЕ СИГНАЛОВ В MATLAB. ОБМЕН ДАННЫМИ С SQL-SERVER

Запускаем Matlab. В Matlab выполняем заполнение массивов X и Y двумя способами. Для создания массива Х выполним следующую функцию в командной строке Matlab:

X=1:1:101;

Полученный массив значений мы можем видеть в верхней части рабочей области, результат представлен на рисунке 4.1.

Рисунок 4.1 - Полученный массив значений

база данные мatlab аrhitect

Далее выполним заполнение элементами массива Y1, используя следующую функцию:

Y1=round(rand(size(X)));

Просмотрим полученный массив Y1, результат представлен на рисунке 4.2.

Рисунок 4.2 - Полученный массив Y1

Построим модель Simulink для создания модели Y2.

Для блока «To Workspace» установим следующие параметры, результат представлен на рисунке 4.3.

Рисунок 4.3 - Параметры блока To Workspace

Для блока «Rounding Function», результат представлен на рисунке 4.4.

Рисунок 4.4 - Параметры блока Rounding Function

Для блока «Unifrom Random Number», результат представлен на рисунке 4.5.

Рисунок 4.5 - Параметры блока Unifrom Random Number

В итоге получим следующую схему, результат представлен на рисунке 4.6.

Рисунок 4.6 - Полученная схема

После выполнения моделирования получим массив Y2 заполненный значениями, которые мы можем просмотреть в рабочей области Matlab, результат представлен на рисунке 4.7.

Рисунок 4.7 - Массив Y2

Для каждой из наших таблиц укажем поле ID как Identify Column, результат представлен на рисунке 4.8.

Рисунок 4.8 - Изменение поля Identify Column

Заполним таблицы MetaData и Server несколькими значениями, результаты представлены на рисунке 4.9 и рисунке 4.10.

Рисунок 4.9 - Заполнение значениями таблицы Server

Рисунок 4.10 - Заполнение значениями таблицы MetaData

ЗАКЛЮЧЕНИЕ

В ходе выполнения курсовой работы были получены следующие результаты:

Создал файл проект;

Выделены основные этапы разработки информационной системы;

Заполнен план в соответствие с заданием;

Создана таблица;

Создана схема БД;

В Enterprise Arhitect связаны таблицы и подготовлены для генерации схемы БД для целевой СУБД;

Создана структура БД;

Создана схема для целевой СУБД;

Смоделирован сигнал в MatLab;

Установлена связь MatLab с SQL-сервером;

Цель данной курсовой работы выполнена.

СПИСОК ИСПОЛЬЗУЕМОЙ ЛИТЕРАТУРЫ

Семенов А.С. Информационные технологии: объективно-ориентированное моделирование: Учеб. пособие для вузов. - М.: СТАНКИН, 2009. - 82 с.

Марков А.А. Моделирование информационно-вычислительных процессов: Учеб. пособие для вузов. - М.: Изд-во МГТУ им. Н.Э. Баумана, 2007. - 360 с.

Шафрин Ю. А. Информационные технологии: В 2ч.-М.: Лаборатория Базовых Знаний. Ч.1: Основы информатики и информационных технологий.-2010. -320 с.

Шафрин Ю. А. Информационные технологии: В 2ч.-М.: Лаборатория Базовых Знаний. Ч.2: Офисная технология и информационные системы.-2009. - 336 с.

Database Toolbox - Работа с данными - Matlab.Exponenta.Ru [Электронный ресурс] // matlab.exponenta.ru/database/index.php (дата обращения: 10.01.13).

Тестирование информационных систем [Электронный ресурс] // www.neoflex.ru/products_solutions/testirovanie_informacionnyh_sistem (дата обращения: 10.01.13).

MATLAB - Википедия [Электронный ресурс] // http://ru.wikipedia.org/wiki/MATLAB#COM-.D0.BF.D0.BE.D1.80.D1.82 (дата обращения: 13.01.13).

Сбор данных - Решения MathWorks [Электронный ресурс] // sl-matlab.ru/solutions/facility/fgetdata.php (дата обращения: 13.01.13).

ПРИЛОЖЕНИЕ А

Результаты работы программы

Рисунок А.1 - Готовый проект

Рисунок А.2- Результат проекта

ПРИЛОЖЕНИЕ Б

Исходный код программы

Код записи в базу данных из Matlab:

clear

clc

conn = database ('BD_project1','sa','itc-dmin', 'com.microsoft.sqlserver.jdbc.SQLServerDriver','jdbc:sqlserver://127.0.0.1:1433;database=BD_project1')

setdbprefs('DataReturnFormat','numeric')

curs = exec(conn, 'select * from Param');

curs = fetch(curs);

curs.Data

get(conn, 'AutoCommit')

for i=1:1:100

colnames{1,1} = 'Temp';

colnames{1,2} = 'Volt';

colnames{1,3} = 'ID_MetaData';

mydata{i,1} = X(i);

mydata{i,2} = Y(i);

mydata{i,3} = 1;

end

fastinsert(conn, 'Param', colnames, mydata)

close(curs)

close(conn)

В итоге получаем записанные значения, результат представлен на рисунке Б.1

Рисунок Б.1 - Записанные в БД значения

Код чтения из базы данных:

clear

clc

conn=database('BD_project1','sa','itc-admin','com.microsoft.sqlserver.jdbc.SQLServerDriver','jdbc:sqlserver://127.0.0.1:1433;database=BD_project1')

curs1 = exec(conn, 'select Param.ID, Param.Temp, Param.Volt from Param, MetaData, Signal where (Server.ID = MetaData.ID_Server) and (Param.ID_MetaData=Param.ID')

setdbprefs('DataReturnFormat','numeric');

ReadCoord=fetch(curs1)

close(curs1)

curs2 = exec(conn, 'select MetaData.HostName, MetaData.Note, Server.Name from MetaData, Server where (Server.ID=MetaData.ID_Signal')

setdbprefs('DataReturnFormats','structure');

ReadTitle=fetch(curs2)

close(curs2)

close(conn)

stem(ReadCoord.Data(:,2),ReadCoord.Data(:,3))

axis([-1 101 -1 2])

HostName=ReadTitle.Data.HostName{1};

Name=ReadTitle.Data.Name{1};

Note=ReadTitle.Data.Note{1};

ReadCoord.Data

myTitle=['ViewHost= ' HostName ' SignalName - ' Name ' Note: 'Note]

title(myTitle);

Полученный результат представлен на рисунке Б.2.

Рисунок Б.2 - Записанные в БД значения

Размещено на Allbest.ru


Подобные документы

  • Разработка структуры базы данных. Этапы разработки информационной системы. Моделирование сигналов в MatLab. Обмен данными в SQL-сервером. Генерация схемы базы данных для целевой СУБД. Редактирование параметров таблицы. Установка параметров генерации.

    курсовая работа [5,3 M], добавлен 01.02.2013

  • Создание базы данных. Поиск, изменение и удаление записей. Обработка и обмен данными. Проектирование базы данных. Определение формул для вычисляемой части базы. Редактирование полей и записей. Формы представления информации, содержащейся в базе данных.

    курсовая работа [67,0 K], добавлен 23.02.2009

  • Создание базы данных, выполнение поиска, изменение и удаление записей, обработка, проектирование и обмен данными. Определение формул для вычисляемой части базы данных. Заполнение таблицы с помощью Мастера форм. Формы представления и анализ информации.

    учебное пособие [5,0 M], добавлен 12.08.2009

  • Изучение процесса обмена данными между приложениями в среде MS Office, используя при этом разные форматы хранения и представления информации. Создание файла исходных данных формата CSV по шаблону. Выполнение тестов, расчетов с исходным набором данных.

    курсовая работа [3,4 M], добавлен 27.01.2015

  • Создание набора классов, реализующих функции генерации метаданых для заданного файла данных спутника MTSAT-1R. Существующие методы решения. Реализация алгоритма получения необходимых полей с нужными данными. Разработка структуры базы данных инвентаря.

    курсовая работа [38,6 K], добавлен 17.07.2009

  • Проектирование базы данных "Общежитие" в СУБД Microsoft Access. Создание запросов, состоящих из комбинаций разных типов данных. Создание форм и полей таблицы в режиме конструктора. Ввод и просмотр данных в режиме таблицы, создание связей между ними.

    курсовая работа [4,3 M], добавлен 24.06.2019

  • Анализ предметной области. Перечень хранимой информации: таблицы, поля, типы. Выделение сущностей, атрибутов, ключей, связей. Начальное заполнение данными БД. Создание и запуск базовых запросов. Проектирование базы данных в среде Enterprise Architect.

    курсовая работа [1,6 M], добавлен 16.02.2016

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.