Создание базы данных больных в Visual Foxpro 9.0

Теоретические основы создания баз данных в Visual Foxpro 9.0. Описание программы, использование ее команд. Создание табличной базы данных, отношений между таблицами в многотабличной базе данных больных в больнице. Редактирование табличного отчета.

Рубрика Программирование, компьютеры и кибернетика
Вид курсовая работа
Язык русский
Дата добавления 19.12.2013
Размер файла 681,2 K

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru/

Содержание

  • Введение
  • Глава 1. Теоретические основы создания баз данных в Visual Foxpro 9.0
  • 1.1 Описание программы Visual FoxPro
  • 1.2 Теоретические аспекты программы Visual FoxPro
  • 1.3 Основные команды, используемые при создании курсового проекта
  • Глава 2. Создание базы данных больных в Visual FoxPro 9.0
  • 2.1 Создание табличной базы данных в Visual FoxPro 9.0
  • 2.2 Создание отношений между таблицами в многотабличной БД больных в больнице
  • 2.3 Создание простейшей формы однотабличной формы в среде Visual FoxPro 9.0
  • 2.4 Создание и редактирование табличного отчета в среде Visual FoxPro 9.0
  • Заключение
  • Список литературы
  • Приложения

Введение

В современном обществе значимость информации как ресурса неоспорима. Современный экономист должен уметь обрабатывать информацию, представлять ее в форме, удобной для обработки, хранения, передачи, а значит, должен владеть средствами проектирования информационных систем, ядом которых является база данных. Для облегчения деятельности пользователя с большими объемами информации были созданы базы данных. Поэтому в настоящее время наблюдается бурный рост информационных технологий и стремительное развитие систем управления базами данных СУБД.

В настоящее время в жизнедеятельности человека играет все большую роль автоматизация. Это касается и автоматизации информации. Учет межсессионной успеваемости студентов, продажа билетов, ведение библиотек, учет иностранных студентов, учет больных в больнице и многие другие - это лишь малая часть отраслей, в которых применяются базы данных.

Наиболее популярной СУБД является Microsoft Visual FoxPro. в ней реализованы все атрибуты реляционных СУБД. В БД поддерживается целостность данных с помощью первичных ключей и связей между таблицами.

База данных - совокупность специальным образом организованных данных, хранимых в памяти вычислительной системы и отображающих состояние объектов и их взаимосвязь. Информацию, хранящуюся в БД можно широко использовать в различных приложениях, причем способы использования данных можно легко и быстро изменять. Также обеспечивается возможность запрашивать, находить и изменять информацию в БД.

Предметная область курсового проекта - обработка информации о больных в больнице, предоставление информаций о месте их жительства, личной карточки больного, диагноза, назначения и т.д. Разработанная база данных может хранить обширные объемы информации о каждом больном, его заболевании, лечащего врача, длительности заболевания и прочее.

Базы являются очень востребованными при учете больных в больницах. Грамотно составленная система учета больных в больнице очень сильно экономит время при обращении к необходимой информации. При правильном составлении и внесении информации в базу скорость поиска необходимой информации сводится до минимума. Создание такой базы данных поможет с легкостью работать с информацией, хранящейся в ней. Позволит получить полную информацию, как о каждом отдельном больном, так и обо всех больных выбранного врача.

Разрабатываемую базу данных можно с легкостью использовать в больнице. Она является удобной и понятной для любого типа пользователей. База позволяет добавлять новых больных, а также вести учет их заболеваемости и типе лечения. Больные, заболевания которых окончились более пяти лет назад, отправляются в архив.

Глава 1. Теоретические основы создания баз данных в Visual Foxpro 9.0

1.1 Описание программы Visual FoxPro

Visual FoxPro (VFP) - визуальная среда разработки систем управления реляционными базами данных, выпускаемая в настоящее время корпорацией Майкрософт. Последней версией является 9.0. Использует язык программирования FoxPro. Среда разработки версии 7.0 может работать в операционных системах Windows 9x и ядра NT, версии 8.0 и 9.0 - только в Windows XP, 2000, 2003. Среда исполнения (runtime) версий 8.0 и 9.0 работает под любой версией Windows, начиная с 98г.

Первоначально FoxPro (первоначальное название - FoxBASE) разрабатывалась Fox Software, начиная с 1984 года. В 1992 году Fox Technologies объединилась с Microsoft, новые версии продукта обрели ряд новых функций и приставку "Visual". Последняя версия оригинального FoxPro - версия 2.6 - работала под Mac OS, DOS, Windows и Unix; уже в версии Visual FoxPro 3.0 список поддерживаемых платформ сократился до Mac OS и Windows, а в более поздних версиях - уже только до Windows. Текущая версия Visual FoxPro основана на COM, и Microsoft утверждает, что.net-версии продукта не будет. Существует проект Sedna, который должен обеспечить возможность взаимодействия Visual FoxPro с.net.

Благодаря встроенному механизму обработки курсора БД, тесной связи между языком и данными и другим мощным функциям, пакет Visual FoxPro 9.0 служит великолепным инструментом для создания решений любого масштаба на основе баз данных. Сосредоточенный на работе с данными, объектно-ориентированный язык, используемый в этом пакете, предлагает разработчикам гибкий инструментарий для создания приложений на основе БД для индивидуального использования, для работы в клиент-серверных средах, а также в Интернете. Разработчики получают в свое распоряжение все необходимое для управления информацией - от средств упорядочения таблиц, обработки запросов и создания интегрированных систем управления реляционными базами данных (СУБД) до полноценной разработки "с нуля" приложения для конечного пользователя.

Создаваемые с помощью пакета Visual FoxPro 9.0 web-службы XML, могут использоваться в качестве источников данных любыми клиентскими платформами, поддерживаемыми средой разработки Visual Studio.net 2003 и предназначенными для работы с web-службами XML, включая платформу ASP.net, а созданные с использованием среды разработки Visual Studio.net 2003 web-службы XML или любые стандартные web-службы XML могут использоваться приложениями пакета Visual FoxPro 9.0.

1.2 Теоретические аспекты программы Visual FoxPro

Имена таблиц

Таблицы, как и любые другие объекты в Visual FoxPro, имеют имена. таблицы бывают свободные и входящие в базу данных. Для таблиц, входящих в базу данных, вы можете задать два имени. Одно вводится в диалоговом окне Create (Создать), а второе - на вкладке Table (Таблица) окна конструктора таблицы. Имя, вводимое в диалоговом окне Create (Создать) при создании таблицы, является именем файла, в котором таблица сохраняется на диске. При задании этого имени необходимо придерживаться ограничений, накладываемых операционной системой на количество символов в имени файла. Второе имя таблицы является внутренним и хранится в базе данных. Внутреннее имя таблицы может содержать до 128 символов. Оно вводится в поле Name (Имя) вкладки Table (Таблица) окна конструктора таблицы.

Наименование таблицы может содержать буквы, цифры и знак подчеркивания. Создавая новую таблицу, необходимо помнить, что в базе данных не может быть двух таблиц, имеющих одинаковые имена. Если в базе данных уже имеется таблица с таким именем, на экране появляется запрос, заменить ли существующую таблицу новой.

При работе в окне конструктора базы данных внутреннее имя таблицы отображается в заголовке окна таблицы. В том случае, если таблица не имеет внутреннего имени, вместо него отображается имя файла, в котором данная таблица сохранена.

В наименовании таблицы недопустимо использование пробелов и специальных символов.

Определение полей таблицы

При определении полей таблицы используется вкладка Fields (Поля), позволяющая ввести наименование поля, тип данных, размещаемых в поле, и ширину. При определении числовых полей необходимо также задать количество десятичных знаков.

Помимо основных параметров, в нижней части вкладки Fields (Поля) для каждого поля можно определить дополнительные параметры, которые будут определять условия ввода в него данных, а также краткое описание, которое поможет разработчику при модификации таблицы в процессе создания приложения или его сопровождения.

Ввод наименований полей

Наименования полей таблицы вводятся на вкладке Fields (Поля) в строке ввода столбца Name (Имя). При задании наименований полей вы можете использовать буквы, цифры и знак подчеркивания. Ваши попытки ввести специальные символы Visual FoxPro проигнорирует.

Длина наименования поля ограничивается 128-ю символами. Вряд ли вы воспользуетесь возможностью задавать такие длинные имена. Обычно для имен полей используют краткие названия, которые более наглядны и легко читаемы.

Visual FoxPro не позволяет иметь в таблице поля с одинаковыми именами. При вводе имени, уже имеющегося в таблице, программа выдает предупреждение, указывающее, что поле с таким именем в таблице уже существует.

Типы полей

Поля таблицы предназначены для хранения в них данных. Это могут быть числа, текстовая информация, даты, графические файлы и т.д. Для определения типа данных, размещаемых в поле, используются тип поля, его ширина и количество знаков после запятой. Для их ввода предназначены столбцы Туре (Тип), Width (Ширина) и Decimal (Десятичные) вкладки Fields (Поля) конструктора таблицы.

В Visual FoxPro допустимыми являются типы полей, перечисленные в табл.1.1

Таблица 1.1, Типы полей Visual FoxPro

Тип

Наименование

Отображаемые данные

Текстовый

Character, Character (binary)

Текстовые поля могут содержать буквы, цифры и специальные символы. Максимальная ширина поля составляет 254 символа. тип Character (binary) используется в том случае, если не требуется учитывать кодовую страницу отображаемых данных

Числовой

Integer, Numeric, Float, Double

Integer отображает целые числа от-2 147 483 647 до +2 147 483 646. Числовые поля типа Numeric и Float отображают данные с фиксированной точкой в диапазоне от-0.9999999999x1 (Г19 до +0.9999999999х10+2°. Тип данных Double используется для хранения данных с высокой точностью в диапазоне от±4.9406564854 1247x1 (Г324 до±1.797693 13486232x1 (Г308

Денежный

Currency

В поле денежного типа могут содержаться числа от - 922 337 203 685 477.5807 до922 337 203 685 477.5807

Дата

Date

В поле типа Date может содержаться любая дата от 01.01.0001 до 31.12.9999

Дата и время

DateTime

В поле типа DateTime может содержаться любая дата от 01.01.0001 до 31.12.9999 и время от 00: 00: 00 а. m. до 11: 59: 59 р. m.

Логический

Logical

Содержит логическое значение True (Т.) (Истина) или False (. F.) (Ложь)

Текстовое поле произвольной длины

Memo, Memo (binary)

Memo-поле содержит символьные данные большого объема

Двоичное поле произвольной длины

General

Поле данного типа предназначено для хранения в таблицах изображений и других двоичных данных

Задание свойств полей

В нижней части вкладки Fields (Поля) конструктора расположены поля, позволяющие задать для каждого поля таблицы свойства, которые будут использоваться при вводе в них данных.

Область Display (Отображение) содержит поля, позволяющие задать форматы ввода и отображения данных (табл.1.2).

Таблица 1.2 Назначение полей области Display вкладки Fields

Поле

Назначение

Format (Формат)

Задает формат отображения данных в формах, отчетах и окне Browse

Input mask (Маска ввода)

Задает формат ввода данных

Caption (Надпись)

Определяет заголовок поля

Область Map field type to classes (Используемые типы полей для классов) предназначена для указания библиотеки и имени класса, который будет использоваться для создания объектов при размещении данного поля таблицы в форме (табл.1.3).

Таблица 1.3 Назначение полей области Map field type to classes вкладки Fields

Поле

Назначение

Display library (Показывать библиотеку)

Задает местоположение и имя файла библиотеки классов

Display class (Показывать класс)

Задает имя класса из выбранной библиотеки

Область Field validation (Проверка правильности ввода) позволяет задать параметры, описанные в табл.1.4.

база visual foxpro табличный

Таблица1.4 Назначение полей области Field validation вкладки Fields

Поле

Назначение

Rule (Условие)

Условие правильности ввода данных

Message (Сообщение)

Сообщение, выводимое при неправильном вводе данных в поле

Default Value (Значение по умолчанию)

Значение, вводимое в поле по умолчанию

В текстовом поле Field comment (Комментарий) можно ввести краткое описание поля, которое может потребоваться при последующих модификациях структуры таблицы и сопровождении проекта.

Свойство NULL

Для каждого поля вы можете определить признак, разрешающий при вводе данных оставлять это поле пустым. Для этого используется свойство NULL в описании поля таблицы.

Назначение кнопок окна конструктора таблицы

Ввод полей в окне конструктора таблицы осуществляется последовательно. После определения всех необходимых параметров первого поля вы переходите на новую строку и вводите информацию для следующего поля таблицы. На вкладке Fields (Поля) справа расположены четыре кнопки. Кнопка ОК предназначена для закрытия окна конструктора таблицы и сохранения всех изменений, внесенных в структуру таблицы.

Если вы изменили структуру таблицы, но хотите от этого отказаться, вам необходимо воспользоваться кнопкой Cancel (Отмена).

Для добавления в таблицу нового поля установите курсор на поле, выше которого вы предполагаете разместить новое, и нажмите кнопку Insert (Вставить). Будет добавлена пустая строка, в которую вы можете ввести информацию о новом поле.

Для удаления поля таблицы перейдите на строку с описанием данного поля и нажмите кнопку Delete (Удалить).

Кнопки Insert (Вставить) и Delete (Удалить) на вкладке Indexes (Индексы) позволяют добавлять в таблицу новые индексы и удалять существующие.

Модификация таблицы

Структуру таблицы, созданную с помощью мастера или конструктора таблицы, можно модифицировать, т.е. изменить наименование любого поля и его тип, вставить новое поле или удалить существующее, изменить порядок следования полей в таблице.

Чтобы модифицировать таблицу, откройте ее в конструкторе таблицы. Для этого выполните одно из следующих действий.

· В окне проекта установите курсор на модифицируемую таблицу и нажмите кнопку Modify (Модифицировать).

· В окне проекта установите курсор на модифицируемую таблицу, нажмите правую кнопку мыши и в появившемся на экране контекстном меню выберите команду Modify (Модифицировать).

· При открытии конструктора таблицы из окна конструктора базы данных выделите модифицируемую таблицу и нажмите кнопку Modify Table (Модифицировать таблицу) на панели инструментов Database Designer (Конструктор базы данных) или выберите команду Modify (Модифицировать) в меню Database (База данных).

В результате на экране открывается диалоговое окно Table Designer (Конструктор таблицы), содержащее структуру модифицируемой таблицы.

Изменение наименований полей и их типов

Ошибки, допущенные при задании имени поля или его типа, легко устраняются. Установите курсор на имя поля, которое хотите изменить, и, используя клавишу <Backspace> или <Del>, удалите ошибочные символы. После этого введите правильное имя поля.

Для изменения типа поля установите курсор в столбец Туре (Тип) и выберите из списка требуемое значение.

Добавление и удаление полей

Для добавления нового поля в таблицу выполните следующие действия:

1. С помощью клавиш-стрелок или мыши установите курсор на строку, перед которой вы хотите вставить пропущенное поле. При этом курсор может находиться в любом столбце Name (Имя), Туре (Тип) или Width (Размер).

2. Нажмите кнопку Insert (Вставить).

3. Visual FoxPro вставляет пустую строку с именем NewF l d. Введите требуемое имя поля.

4. Используя значения списка Туре (Тип), задайте тип поля.

5. В столбце Width (Размер) введите размер нового поля.

Для удаления поля из структуры таблицы установите курсор на поле, которое требуется удалить, и нажмите кнопку Delete (Удалить) окна конструктора.

Изменение порядка расположения полей

Порядок расположения полей, заданный при создании структуры таблицы, можно изменить. Для этого выполните следующие действия:

1. Установите курсор на поле, расположение которого хотите изменить. На кнопке появляется значок перемещения поля в виде двунаправленной стрелки.

2. Установите курсор на значок перемещения.

3. Нажмите кнопку мыши и, удерживая ее нажатой, переместите значок вверх или вниз на требуемое место в структуре.

4. Отпустите кнопку мыши. Поле изменило свое местоположение.

Отношения между таблицами

Между таблицами существует четыре типа отношений. Это "один-к-одному", "один-ко-многим", "много-к-одному", "много-ко - многим". Все эти типы отношений поддерживаются в Visual FoxPro.

Отношение "один-к-одному" означает, что каждая запись в одной таблице соответствует только одной записи в другой таблице. В качестве примера можно рассмотреть отношения между списком служащих предприятия и таблицей, содержащей их служебные характеристики.

Наиболее часто встречающимся является тип отношения "один-ко-многим". В качестве примеров могут быть рассмотрены отношения между покупателем и купленными им товарами, между предприятием и работающими на нем сотрудниками.

Отношение "много-к-одному" можно сравнить с отношением "один-ко-многим", рассматриваемое с другой точки зрения. Например, между клиентами и сделанными им заказами существует отношение "один-ко-многим". С другой стороны, если в качестве исходной точки рассматривать заказы, то между сделанными заказами и клиентами получается отношение "много-к-одному".

1.3 Основные команды, используемые при создании курсового проекта

При работе с Visual FoxPro вы можете использовать как кнопки панели инструментов, так и строку меню, все команды которого являются иерархическими. При выборе определенной команды открывается ее подменю.

При отсутствии в главном окне Visual FoxPro других открытых окон, строка меню содержит пункты File (Файл), Edit (Правка), View (Вид), Tools (Сервис), Program (Программа), Windows (Окна) и Help (Справка). При открытии окон в меню добавляются команды, применимые только к объектам данного окна. Например, при работе с таблицами в главное меню добавляется пункт меню Table (Таблица), при открытии на экране формы в меню появляется пункт Form (Форма).

Команды меню File

Меню File (Файл) содержит команды, связанные с доступом к файлам. Эти команды позволяют создавать новые файлы разных типов, открывать существующие файлы, закрывать, сохранять и печатать их.

Команда Save As HTML (Сохранить файл в формате HTML) открывает соответствующее диалоговое окно, позволяющее сохранить текущую форму, меню, отчет или таблицу в формате HTML (HyperText Markup Language).

Очень удобна команда Revert (Возвратить), позволяющая отменить все изменения файла, сделанные в текущем сеансе редактирования.

В нижней части меню располагаются имена последних четырех открывавшихся проектов, которые предоставляют возможность быстрого открытия любого из них. Последней командой этого меню является команда Exit (Выход). Она аналогична действию команды QUIT (Выход) в командном окне и предназначена для выхода из Visual FoxPro.

Команды меню Edit

Меню Edit (Правка) имеется во многих приложениях Windows. В Visual FoxPro команды этого меню используются при создании форм и отчетов, редактировании программ.

Команды Paste Special (Специальная вставка), Insert Object (Вставить объект), Object (Объект) и Links (Связи) применимы только к полям типа General и OLE-объектам. Остальные команды применяются при редактировании как программ, так и полей таблиц.

Незнакомой для вас по другим приложениям Windows может оказаться команда Go to Line (Переход на строку), предназначенная в Visual FoxPro для работы с программами. С помощью данной команды можно переходить к строке с указанным номером в тексте программы.

При вводе имени объекта, свойства, команды или функции после ввода активизирующего символа (как правило, точка, пробел или открывающая скобка) команда List Members Visual FoxPro активизирует список допустимых значений (свойств, методов, событий и объектов) для указанного в редакторе объекта.

Последняя в меню - команда Properties (Свойства), при выборе которой открывается диалоговое окно Edit Properties (Редактирование свойств), позволяющее задавать параметры сохранения программных файлов, просматривать их свойства, дату последнего редактирования и занимаемый объем на диске.

Команды меню View

Пункт меню View (Вид) содержит команды, управляющие просмотром текущего открытого файла. Если вы не просматриваете файл, то меню содержит всего одну команду Toolbars (Панели инструментов). Эта команда открывает диалоговое окно, в котором перечислены панели инструментов, используемые при работе в Visual FoxPro.

При работе в конструкторах в меню View (Вид) содержатся команды, управляющие отображением используемых в данном режиме работы панелей инструментов. Так, например, при работе в конструкторе форм в меню появляются команды для выбора следующих панелей: Color Palette (Цветовая палитра), Layout (Расположение), Form Designer (Конструктор форм) и Form Controls (Элементы управления формы).

При просмотре таблиц или редактировании форм, меню или отчетов в меню появляются дополнительные команды. Например, если вы работаете с таблицами, в меню появляется несколько новых команд. Команды Edit (Редактирование) и Browse (Обзор) переводят таблицу в режим просмотра и редактирования содержащихся в ней записей. Отличие между этими двумя командами состоит в стиле отображения содержимого таблицы.

Команды меню Format

Меню Format (Формат) содержит команды, управляющие характеристиками шрифта, выравниванием текста и объектов, определением интервалов между объектами. Однако при работе с различными конструкторами становятся доступными и дополнительные команды.

Команды меню Tools

Это меню содержит мастера и средства отладки программ.

Первой в меню Tools (Сервис) располагается команда Wizards (Мастера), открывающая список мастеров Visual FoxPro. Мастер - это программа, которая помогает пользователю в решении таких задач, как создание форм, отчетов, таблиц. Процесс создания при этом заключается в ответах на вопросы мастера относительно создаваемого объекта.

Далее в меню расположена команда Macros (Макрос), предназначенная для создания макросов.

Команда Debugger (Отладчик) предназначена для отладки. Она открывает диалоговое окно Visual FoxPro Debugger, в котором вы можете просмотреть значения переменных, элементов массива, полей, возвращаемые значения функциями Visual FoxPro и т. д,

Команда Component Gallery (Галерея компонентов) открывает окно Catalogs - Component Gallery (Каталоги - галерея компонентов) для работы в Галерее компонентов Visual FoxPro. Команда Coverage Profiler (Анализ выполнения) позволяет просмотреть информацию о выполненной программе. Команда Run Active Document (Запуск активного документа) открывает одноименное диалоговое окно для выбора активного документа и его запуска.

в меню Tools (Сервис) команды: ObjectBrowser (Обзор объектов), IntelHSense Manager (Менеджер IntelliSense), TaskList (Список заданий), Document View (Просмотр документа).

Команда Object Browser (Браузер объектов) открывает одноименное окно, позволяющее просматривать классы, свойства, методы, события и константы выбранных библиотек.

Команда IntelliSense Manager (Менеджер IntelliSense) открывает окно настройки параметров, управляющих анализом синтаксиса вводимых в окнередактора программных конструкций.

Команда Task List (Список заданий) позволяет запомнить место, в которое вы можете вернуться впоследствии нажатием оперативной клавиши. Кроме того, данная команда позволяет вводить список необходимых задач, аналогично Microsoft Outlook.

Команда Document View (Просмотр документа) открывает диалоговое окно, в котором отображается список процедур, функций и операторов для открытой в окне редактора программы. При выборе элемента списка осуществляется переход на этот элемент в окне редактора.

Последняя команда в меню Tools (Сервис) - Options (Параметры). С ее помощью можно настраивать конфигурацию Visual FoxPro

Команды меню Program

Меню Program (Программа) содержит команды, связанные с выполнением и компиляцией программ.

Команды меню Windows

В меню Windows (Окна) имеются команды, которые управляют открытыми на экране окнами. С помощью этих команд можно упорядочивать, скрывать, очищать окна и переходить из одного окна в другое. Кроме того, команды данного меню позволяют активизировать любое открытое окно.

Команда Command Window (Командное окно) из меню Windows (Окно) активизирует командное окно Command (Команда), позволяющее использовать команды при работе с Visual FoxPro.

Команда Properties Window (Окно свойств) открывает диалоговое окно Properties (Свойства), позволяющее просмотреть и изменить свойства объектов, расположенных в форме курсоров и отношений.

Для открытия окна Data Session (Окно данных), которое содержит список всех открытых в данном сеансе таблиц и отношений между ними

Команды меню Help

Help (Справка) - последнее меню главного окна. Табл.1.2 содержит список команд, доступных в этом меню. Этот список претерпел некоторые изменения в Visual FoxPro 9.0 по сравнению с предыдущей версией программы.

Таблица 1.2 Назначение команд меню Help

Команда меню

Назначение

Microsoft Visual FoxProHelp (Справочная системаVisual FoxPro)

Открывает окно справочной системы Visual FoxPro 7.0

MSDN Search (Поиск в MSDN)

Ищет справочную информацию в MSDN

Technical support (Техническая поддержка)

Отображает информацию о технической поддержке, оказываемой Microsoft

Visual FoxPro on the Web (Visual FoxPro на Web-страницах)

Открывает Web-страницу Microsoft Visual FoxPro. Для использования этой команды необходим доступ в Интернет

About Microsoft VisualFoxPro (0 программеMicrosoft Visual FoxPro)

Открывает диалоговое окно About Microsoft Visual FoxPro, в котором содержится информация об авторских правах на программу, номер версии программы и ее идентисрикатор, имя файла ресурсов и используемый по умолчанию каталог. В этом окне можно также посмотреть разнообразную информацию о компьютере, ресурсах системы

Рассмотрим назначение некоторых наиболее часто используемых команд:

• CREAT - создание базы данных;

• USE - активация базы данных для работы с нею;

• LIST - вывод на экран всей базы данных для ее просмотра;

• BROWS - корректировка записей;

• APPEND - добавление записей;

• CLEAR - очистка экрана;

• SORT - сортировка записей;

• DISPLAY - вывод на дисплей одной записи для ее просмотра;

• SUM - вычисление суммы;

• AVERAGE - вычисление среднего арифметического;

• QUIT - выход из СУБД.

LIST fio_b for pol = "м" (см. рис.1.1)

на экран фамилии мужского пола

LIST FIELDS FOR fio_b="А" (см. рис.1.2)

LIST DATABASE (см. рис.1.3)

BROWSE FIELDS fio_b for otdel="неврология" (см. рис.1.4)

Глава 2. Создание базы данных больных в Visual FoxPro 9.0

2.1 Создание табличной базы данных в Visual FoxPro 9.0

Для начала нашего курсового проекта, а именно создания базы данных "больных в больнице" мы составим инфологическую модель (см. рис.2.1).

Цель инфологического моделирования - обеспечение наиболее естественных для человека способов сбора и представления той информации, которую предполагается хранить в создаваемой базе данных. Поэтому инфологическую модель данных пытаются строить по аналогии с естественным языком (последний не может быть использован в чистом виде из-за сложности компьютерной обработки текстов и неоднозначности любого естественного языка). Основными конструктивными элементами инфологических моделей являются сущности, связи между ними и их свойства (атрибуты).

Инфологическая модель отображает реальный мир в некоторые понятные человеку концепции, полностью независимые от параметров среды хранения данных. Существует множество подходов к построению таких моделей: графовые модели, семантические сети, модель "сущность-связь" и т.д. Наиболее популярной из них оказалась модель "сущность-связь" или называемая ещё ER-моделью (от англ. Entity-Relationship, т.е. сущность-связь).

Инфологическая модель применяется после словесного описания предметной области.

Итак, в нашей модели присутствуют две взаимосвязанные таблицы, в которых описываются следующие данные об учете больных в больнице:

1. ФИО - фамилия, имя, отчество больного

2. Дата рождения больного

3. Дата поступления в больницу

4. Пол

5. Диагноз, с которым больной поступил в больницу

6. История болезни - карта, заводимая на больного в момент поступления в больницу в приемном покое, в которой описывается состояние больного на момент поступления;

7. Лечащий врач, который ведет больного на протяжении его реабилитационного периода;

8. Отделение, в которое помещается больной;

9. Номер палаты, в которой будет лежать пациент;

10. Назначение, которое врач прописывает пациенту на время его реабилитации;

11. Срок реабилитации - это время, которое пациент будет находиться на стационарном лечении;

12. Дата выписки больного.

В следующей нашей таблице описывается необходимая информация пациенту о враче, который будет его вести во время стационарного лечения:

1. ФИО врача;

2. Его должность;

3. Его степень;

4. Стаж работы;

5. Отделение, в котором работает;

6. И его специализация.

Составив инфологическую модель, перейдем непосредственно к созданию базы данных в программе Visual FoxPro 9.0. для этого мы запускаем программу Visual FoxPro 9.0: Пуск/программы/ Visual FoxPro 9.0.

Для создания базы данных мы для начала ознакомимся с элементами рабочего окна программы. Ознакомившись, перейдем к созданию базы данных. Для начала создаем новый проект: file/new/project/new file, указать ранее созданную нами папку и присвоить имя проекту "БД больных в больнице" и сохранить (см. рис.2.2, 2.3).

Все создаваемые в дальнейшем элементы будут храниться в проекте "БД больных в больнице".

БД создается следующим образом, в окне project manager (менеджер проекта) нужно выполнить действия: data/database/new/new database, присвоить имя "больные в больнице" и сохранить. Структура проекта и его элементы отражаются в окне программы project manager.

Для создания таблицы в БД "больные в больнице" нам необходимо: в окне project manager щелкнуть клавишей мыши на вкладке Data/Database/больные в больнице/Tables/New/New table, присвоить имя "таблица больные" и сохранить. (см. рис.2.4)

В появившемся окне Table Designer (конструктор таблиц) на вкладке Fields (поля) создать структуру таблицы пользуясь инфологической моделью. Окно конструктора таблицы Table Designer (Конструктор таблицы) содержит три вкладки, предназначенные для определения следующих параметров:

· Fields (Поля) - полей таблицы;

· Indexes (Индексы) - индексов;

· Table (Таблица) - условий достоверности вводимых данных, а также триггеров добавления, удаления и модификации.

Создавая структуру, мы каждому полю даем имя, тип, и то количество символов, которое нам необходимо для записи. При необходимости мы можем редактировать таблицу: изменять название полей, тип, количество символов для записи, добавлять поля, удалять ненужные поля (см. рис.2.5).

Name - это название поля

Type - это тип поля

Width - это количество символов необходимых для записи в таблице.

Далее перейдем на вкладку Indexes (индексы) окна Table Designer (конструктор таблиц) и присвоить созданной таблице индекс L_V c типом индекса Primary, в дальнейшем индексы нам потребуются для связывания двух таблиц, в которых первая таблица с типом индекса Primary будет материнской, а вторая дочерней. (см. рис.2.6).

Далее для ввода и редактирования содержимого данных в таблице "таблица больные" нам необходимо в командном окне программы ввести команду в командном окне "APPEND" и нажать клавишу Enter. (см. рис.2.7).

Далее в открывшемся окне мы вводим данные, в нашем случае данные о 10 больных у которых различные отделения, лечащие врачи, назначения, истории болезней и т.д.

Аналогичным образом мы создаем вторую таблицу "таблица лечащий врач", которая будет дочерней и будет иметь тип индекса regular. (см. рис.2.8, 2.9).

Далее аналогичным образом используя команду APPEND, мы заполняем вторую таблицу.

Существуют два режима просмотра таблиц в Visual FoxPro 9.0. с помощью ввода в командном окне команды "EDIT" (см. рис.2.10), и с помощью команды "Brows" (см. рис.2.11)

2.2 Создание отношений между таблицами в многотабличной БД больных в больнице

Применение индексов позволяет решить одну из главных задач, предъявляемых к СУБД, - возможность быстрого поиска необходимой информации.

Для создания индексов таблицы используется вкладка Indexes (индексы) окна конструктора Table Designer. Все индексы в Visual FoxPro имеют имена, задаваемые в поле Name (имя). Для задания типа создаваемого индекса используется список Type (тип).

Табл.2.1 Типы индексов и их описание

Тип индекса

Описание

Regular

(обычный)

Создается индекс, в котором для каждой записи таблицы храниться значение индексного выражения. Если несколько записей имеют одинаковое значение индексного выражения, то каждое значение хранится отдельно и содержит ссылку на связанную с ней запись.

Unique

(уникальный)

Создается индекс, в котором хранятся только неповторяющиеся значении индексного выражения. Если две или более записей содержат одинаковое значение индексного выражения, то будет храниться только одно значение и ссылка на первую из записей с одинаковым значением индексного выражения. Таблица может иметь несколько уникальных индексов.

Candidate

(кандидат)

Создается уникальный индекс, который не содержит полей с пустыми значениями. Этот индекс обладает всеми качествами первичного ключа и не является им только по той причине, что таблица не может содержать более одного первичного ключа.

Primary

(первичный)

Создается уникальный индекс, который используется для связывания таблиц и определения условий целостности данных. Поля, входящие в первичный ключ, не должны допускать ввода пустых значений. В отличие от уникального индекса, таблица может иметь только один первичный ключ.

Как правило, в Visual FoxPro при создании форм, отчетов и запросов используется несколько таблиц, между которыми установлены постоянные отношения. Такие таблицы называются связанными. Из двух связанных таблиц одна является главной, а другая - подчиненной. Главную таблицу называют родительской, а подчиненную - дочерней. При создании индексов для родительской таблицы должен быть определен ключ типа Primary

(Первичный) или типа Candidate (Кандидат), а для дочерней таблицы - индекс для связи с родительской таблицей типа Regular (Обычный). Одним из основных требований, предъявляемых к базам данных, является целостность данных, которую определяют установленные между таблицами отношения. Для определения целостности данных в данной программе используется окно построителя условий целостности данных Referential integrity Builder (построитель целостности данных), которое содержит перечень всех установленных отношений между таблицами.

Итак, перейдем непосредственно к связыванию таблиц. Для этого нам необходимо модифицировать таблицы и задать индексные поля. Так как мы уже в предыдущем разделе задали индексные поля (см. рис.2.6, 2.9) нам остается лишь связать таблицы. Для этого нам необходимо навести курсор мыши на материнскую таблицу в область где показан индекс (маленький ключик) нажимаем на него (см. рис.2.12). Далее не отпуская кнопки мы протягиваем стрелку мыши до второй, связываемой с материнской, дочерней таблице. В результате у нас появляются две взаимосвязанные таблицы (см. рис.2.13).

Для редактирования отношений между таблицами нам необходимо два раза щелкнуть на линии соединения, после чего появится диалоговое окно Edit Relationship (редактирование отношения) (см. рис.2.14). В этом окне слева приведено наименование материнской таблицы и расположен раскрывающийся список индексов таблицы, справа размещена аналогичная информация о дочерней таблице.

Так же в этом окне указан тип соединения между таблицами. Далее в окне Edit Relationship (редактирование отношения) нажмем на кнопку Referential integrity (целостность данных), в появившемся диалоговом окне Referential integrity Builder (построитель целостности данных) (см. рис.2.15) выбрать отношение "таблица больные, таблица лечащий врач".

В полях Update (изменить) Delete (удалить) Insert (заменить) установить тип действий Restrict (запрет изменений) (см. рис.2.16).

2.3 Создание простейшей формы однотабличной формы в среде Visual FoxPro 9.0

В Visual FoxPro 9.0 для просмотра, ввода и редактирования данных хранящихся в таблицах, используются формы, являющиеся наглядным средством представления информации. Важным преимуществом форм является то что они позволяют работать не с одной а с несколькими связанными таблицами, что в свою очередь, так же увеличивает наглядность.

Для создания форм можно использовать несколько следующих способов:

· Form Wizard (мастер форм)

· Form Builder (построитель форм)

· Builder (построитель объектов формы)

· Auto Format Builder (построитель автоформата)

· Form Designer (конструктор форм).

Что бы создать форму для одной или связанных таблиц с возможностью задания отображаемых в форме полей, стиля их отображения и указания типа кнопок управления, можно использовать Form Wizard (мастер форм).

Для самостоятельной разработки форм с заданными свойствами или изменения формы, созданной с помощью мастера, нам необходимо использовать Form Designer (конструктор форм).

Для облегчения размещения в конструкторе форм полей и надписей, оформленных в соответствии с выбранным стилем, можно использовать Form Builder (построитель форм).

Приступим к созданию формы по нашим таблицам. Для этого мы в окне Project Manager, щелкнув клавишей мыши на вкладке Documents/ forms/Forms Wizard/Form Wizard нажмем клавишу Ok (см. рис.2.17)

В появившемся окне Form Wizard в области Database and tables (базы данных и таблицы) выбрать Б.Д. "больные в больнице" и указать таблицу "таблица больные" для которой будет создаваться форма. Далее в из области Available fields (имеющиеся поля) выбрать поля которые нам нужны будут при заполнении форм, используя кнопки расположенные между списками (см. рис.2.18).

Далее для перехода к следующему шагу необходимо нажать кнопку Next (далее).

В появившемся диалоговом окне в области Style установить стиль отображения объектов и в области Button type выбрать тип кнопок управления Text button (см. рис.2.19).

Для перехода к следующему шагу нажмем кнопку Next. В появившемся следующем диалоговом окне нам необходимо задать критерии сортировки данных, указав поля по которым будет осуществляться упорядочивание (см рис.2.20).

И на последнем шаге создания формы в области Type a title for your form (тип заголовка формы) указать имя формы "таблица больные" (см. рис.2.21). С помощью кнопки Preview (просмотр) мы можем просмотреть как будет выглядеть наша форма. Что бы вернуться в рабочую область нужно будет нажать кнопку Return to Wizard, в случаи нахождения ошибок мы можем вернуться к предыдущим шагам воспользовавшись кнопкой Back (см. рис.2.22).

Теперь нам нужно нажать кнопку Finish (готово) и в появившемся диалоговом окне выбрать кнопку Save As (сохранить как) и указать папку в которой будет сохранена наша форма.

Далее в окне Project Manager запустить форму "таблица больные форма" (см. рис.2.23).

С помощью кнопок на нижней панели можно водить или редактировать записи в данной таблице. Top - первая запись, Prev - предыдущая запись, Next - следующая запись, Bottom - последняя запись, Find - найти, Save - сохранить, Print - вывести на печать, Add - добавить запись, Edit - редактировать запись, Delete - удалить запись, Exit - выход.

2.4 Создание и редактирование табличного отчета в среде Visual FoxPro 9.0

Отчет это форматированное представление данных, выводимое на экран, принтер или файл. Отчет, создаваемый в данной программе, может быть представлен в табличном виде или в свободной форме. Табличные отчеты используются для печати данных, представленных в виде списка. При создании отчета в данной программе можно использовать следующие способы:

· Report Wizard - мастер отчета. Позволяет быстро создать отчет, применяя сортировку, группировку данных и заданный стиль оформления;

· Report Designer - конструктор отчета. Позволяет разрабатывать собственные отчеты или модифицировать отчеты, созданные с помощью мастера;

· Quick Report - быстрый отчет, предназначен для размещения в конструкторе отчета полей и заданий среды окружения.

Для создания отчета в окне Project Manager прейдем на вкладку Documents/ Reports/New/New Report/Report Wizard. В появившемся окне Wizard Selection указать тип создаваемого отчета Report Wizard (мастер отчетов) и нажать кнопку Ok (см. рис.2.25).

В появившемся диалоговом окне мастера отчета выбрать из верхнего списка области Database and tables (базы данных и таблицы) базу данных "больные в больнице", а из нижнего "таблица больные" (см. рис.2.26).

Перенести из списка Available fields (имеющиеся поля) в список Selected fields (выбранные поля) поля, которые нам необходимо разместить в создаваемом отчете. Далее с помощью кнопки Next перейдем к следующему шагу.

В следующем окне мастера создания отчета укажем поля по которым мы хотим осуществить группировку данных отчета (см. рис.2.27).

В следующем диалоговом окне мы выберем стиль отображения отчета (см. рис.2.28).

Далее нам нужно указать порядок размещения объектов в отчете и ориентацию страниц. В области Number of Columns (количество колонок) указать 1, в области Orientation (ориентация) указать Portrait (книжная), в области Field Layout (расположение полей) указать Rows (строка) (см. рис.2.29).

После установки всех требований перейти на следующий шаг.

Далее нам нужно задать поле, по которому требуется упорядочение данных в отчете. Из списка Available fields or index tag (выбранные поля и индексы) перенести в список Selected fields (выбранные поля) необходимое нам поле. Сформировав список полей перейти на следующий этап.

На последнем этапе аналогичным образом как и при создании отчета необходимо указать имя отчета, и можно просмотреть наш отчет (см. рис.2.31, 2.32). Далее выберем папку где будет хранится наш отчет.

Заключение

Современный уровень информатизации общества предопределяет использование новейших технических, технологических, программных средств в различных информационных системах экономических объектов, методов и моделей, технических, программных, технологических средств и специалистов, предназначенную для обработки информации

Итак, подведем итоги нашего курсового проекта. При создании нашего курсового проекта мы научились создавать базу данных, а именно:

1. Создавать и редактировать табличные базы в программе Visual FoxPro 9.0;

2. Присваивать индексы, создавать отношения между таблицами;

3. Создавать формы;

4. Создавать и редактировать отчеты.

Данная база данных может быть внедрена в практику учета ведения больных в больнице. Она позволяет легко вносить необходимые данные о больном и о его состоянии. Данная база данных при внедрении ее в практику ведения больных в больницах может упростить работу регистратуры, так как позволит легко и без проблем найти необходимую информацию о данном больном. Так же благодаря базе данных время, которое тратиться на заполнение данных о больном будет сокращенно.

Список литературы

1. Ребекка М. Райордан Основы баз данных 2001г.

2. Трифонова Н.А., Прозорова С.С. Office для студента. 2004г.

3. Ролланд Ф.Д. Основные концепции баз данных. 2002г.

4. Карпова Т. Базы данных: модели, разработка, реализация, 2001.

Приложения

Ход программы

MODIFY DATABASE

USE "таблица больные" AGAIN IN 0 ALIAS Таблица_больные

SELECT Таблица_больные

BROWSE LAST

USE "таблица лечащий врач" AGAIN IN 0 ALIAS Таблица_лечащий_врач

SELECT Таблица_лечащий_врач

BROWSE LAST

MODIFY DATABASE

MODIFY FORM "c: \users\муту\documents\б. д. больные в больнице\таблица больные форма. scx"

MODIFY REPORT "c: \users\муту\documents\б. д. больные в больнице\таблица больные. frx"

DO FORM "c: \users\муту\documents\б. д. больные в больнице\таблица больные форма. scx"

MODIFY FORM "c: \users\муту\documents\б. д. больные в больнице\таблица больные форма. scx"

REPORT FORM "c: \users\муту\documents\б. д. больные в больнице\таблица больные. frx" PREVIEW

MODIFY REPORT "c: \users\муту\documents\б. д. больные в больнице\таблица больные. frx"

REPORT FORM "c: \users\муту\documents\б. д. больные в больнице\таблица больные. frx" NOEJECT NOCONSOLE TO PRINTER

MODIFY FORM "c: \users\муту\documents\б. д. больные в больнице\таблица больные форма. scx"

DO FORM "c: \users\муту\documents\б. д. больные в больнице\таблица больные форма. scx"

MODIFY FORM "c: \users\муту\documents\б. д. больные в больнице\таблица больные форма. scx"

DO FORM "c: \users\муту\documents\б. д. больные в больнице\таблица больные форма. scx"

USE "лечащий врвч" EXCLUSIVE IN 0 ALIAS Лечащий_врвч

SELECT Лечащий_врвч

MODIFY STRUCTURE

SELECT Лечащий_врвч

MODIFY STRUCTURE

USE маришка EXCLUSIVE IN 0

SELECT Маришка

MODIFY STRUCTURE

MODIFY DATABASE

DO FORM "c: \users\муту\documents\visual foxpro projects\лечащий врвч. scx"

MODIFY DATABASE

Размещено на Allbest.ru


Подобные документы

  • Создание базы данных в Visual FoxPro. Упорядочивание данных в таблицах. Определение отношений между таблицами и проверка условий целостности данных. Расширенные SQL-запросы и безусловная выборка значений. Использование квантора существования в запросах.

    методичка [926,3 K], добавлен 30.09.2013

  • Базы данных и системы управления базами данных. Структура простейшей базы данных, свойства полей. Понятие языка SQL. Проектирование баз данных, режимы работы, объекты. СУБД Microsoft Access. Создание базы данных "Электротовары" средствами Visual FoxPro.

    курсовая работа [5,7 M], добавлен 29.04.2014

  • Разработка базы данных FoxPro (БД), листинг программы. Работа с несколькими таблицами и установление взаимосвязей между ними. Система меню, формирование отчетов. Использование расширенных средств ввода и вывода данных. Организация справочной системы.

    дипломная работа [1,7 M], добавлен 20.08.2009

  • Создание таблиц базы данных с помощью MS Access "Страны Азии". Форма базы данных и запросы к выборкам данных. Модификация структуры таблиц, создания связей между главными таблицами, редактирование данных и проектирование форм для реальной базы данных.

    контрольная работа [723,9 K], добавлен 25.11.2012

  • Описание модели предметной области, построение функциональной модели. Проектирование структуры базы данных, реализация спроектированной базы данных при помощи СУБД Visual FoxPro. Создание форм при помощи мастера форм, построение исполняемого файла.

    лекция [4,0 M], добавлен 04.11.2009

  • Структура многотабличных баз данных, создание и редактирование таблиц в MS Access, установка связей между таблицами, фильтрация и сортировка данных, создание БД "Месторождения нефти". Составление форм, запроса на выборку по разным полям и отчетов.

    лабораторная работа [531,5 K], добавлен 13.02.2012

  • Описание предметной области. Организация диалога пользователя с компьютером. Определение важных для предметной области объектов, их свойств и отношений друг с другом. Среда разработки базы данных - Microsoft Visual FoxPro 6.0. Требования к приложению.

    курсовая работа [880,1 K], добавлен 11.01.2012

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.