Создание базы данных "Спортивный клуб"

Характеристика программных продуктов ERwin, Microsoft Excel и Access. Создание сущностей и связей, преобразование логической модели в физическую в среде ERWin. Создание таблиц в MS Access, работа с запросами и отчетами. Построение диаграмм в MS Excel.

Рубрика Программирование, компьютеры и кибернетика
Вид курсовая работа
Язык русский
Дата добавления 09.12.2013
Размер файла 2,5 M

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru/

  • Содержание

Введение

1. Описание предметной области

2. Описание программного обеспечения

2.1 Erwin

2.2 MS Excel

2.3 MS Access

3. Работа в среде ERWin

4. Работа в СУБД MS Access

4.1 Создание таблиц

4.2 Создание связей

4.3 Создание запросов

4.4 Создание отчета

4.5 Создание форм

5. Работа в табличном процессоре MS Excel

5.1 Оформление таблиц

5.2 Построение диаграмм

6. Руководство пользователя

Заключение

Список литературы

Введение

Существует много веских причин перевода существующей информации на компьютерную основу. Сейчас стоимость хранения информации в файлах ЭВМ дешевле, чем на бумаге.

В деловой или личной сфере часто приходится работать с данными из разных источников, каждый из которых связан с определенным видом деятельности. Для координации всех этих данных необходимы определенные знания и организационные навыки. Базы данных позволяют хранить, структурировать информацию и извлекать оптимальным для пользователя образом.

Microsoft Access объединяет сведения из разных источников в одной реляционной базе данных. Создаваемые формы, запросы и отчеты позволяют быстро и эффективно обновлять данные, получать ответы на вопросы, осуществлять поиск нужных данных, анализировать данные, печатать отчеты, диаграммы и почтовые наклейки.

Базы данных (БД) составляют в настоящее время основу компьютерного обеспечения информационных процессов, входящих практически во все сферы человеческой деятельности.

Базы данных являются эффективным средством представления структур данных и манипулирования ими. Концепция баз данных предполагает использование интегрированных средств хранения информации, позволяющих обеспечить централизованное управление данными и обслуживание ими многих пользователей. При этом БД должна поддерживаться в среде ЭВМ единым программным обеспечением, называемым системой управления базами данных (СУБД). СУБД вместе с прикладными программами называют банком данных.

В курсовой работе будет рассмотрен процесс создания базы данных «Спортивный клуб».

1. Описание предметной области

В спортивном клубе проводятся различные виды занятий (силовые тренировки, йога, танцы). В базе данных должна храниться информациях о тренерах спортивного клуба, которая характеризуется следующими параметрами:

- код тренера;

- фамилия;

- имя;

- отчество;

- адрес;

- телефон;

- стаж работы, лет.

Тренеры проводят несколько различных видов занятий, которые характеризуется следующими параметрами:

- код вида занятия;

- вид занятия.

Один вид занятия может проводиться несколькими разными тренерами. Еженедельно обновляется расписание занятий, которое характеризуется следующими параметрами:

- код занятия;

- дата;

- время;

- продолжительность, мин;

- цена;

- скидка членам клуба, %;

- код вида занятия;

- код тренера.

Таким образом, в базе данных предусмотрено три таблицы: «Тренеры», «Виды занятий» и «Занятия».

Рассмотрим связи между таблицами.

Таблицы «Виды занятия» и «Занятия» связаны отношением «один-ко-многим», поскольку в расписании может находиться много занятий одного и того же вида.

Таблицы «Тренеры» и «Занятия» связаны отношением «один-ко-многим», поскольку один и тот же тренер может проводить много разных занятий.

2. Описание программного обеспечения

2.1 Erwin

На современном рынке средств разработки ИС достаточно много систем, в той или иной степени удовлетворяющих перечисленным требованиям. CASE-средства ERwin и BPwin, разработанные фирмой PLATINUM, входят в число лучших на сегодняшний день.

ERwin - средство разработки структуры базы данных (БД). ERwin сочетает графический интерфейс Windows, инструменты для построения ER-диаграмм, редакторы для создания логического и физического описания модели данных и прозрачную поддержку ведущих реляционных СУБД и настольных баз данных. С помощью ERwin можно создавать или проводить обратное проектирование (реинжиниринг) баз данных.

Возможны две точки зрения на информационную модель и, соответственно, два уровня модели. Первый - логический (точка зрения пользователя) - описывает данные, задействованные в бизнесе предприятия. Второй - физический - определяет представление информации в БД. ERwin объединяет их в единую диаграмму, имеющую несколько уровней представления.

2.2 MS Excel

С появлением персональных компьютеров широкое распространение получили обработка числовых табличных данных, позволяющих решать широкий круг научно-технических, планово-экономических, учетно-статистических и других задач, для которых исходные данные и результаты обработки могут быть представлены в табличной форме или в самой сути которых лежит табличное представление информации.

Электронная таблица -- компьютерный эквивалент обычной таблицы, в клетках (ячейках) которой записаны данные различных типов: тексты, даты, формулы, числа.

Главное достоинство электронной таблицы -- это возможность мгновенного пересчета всех данных, связанных формульными зависимостями при изменении значения любого операнда.

Лидирующую позицию среди пакетов обработки электронных таблиц по праву занимает широко известный пакет MS Excel фирмы Microsoft. Пакет поставляется как в виде самостоятельного средства, так и в составе интегрированного средства MS Office.

Документ Excel называется рабочей книгой. Рабочая книга может состоять из нескольких рабочих листов. Имена и порядок расположения листов можно изменять. Выбор другого листа рабочей книги осуществляется щелчком мыши по ярлычку этого листа. На рабочем листе можно создать одну или несколько рабочих таблиц, хотя создавать более одной таблицы на рабочем листе не принято. Рабочая таблица состоит из ячеек, которые образуются в местах пересечения строк и столбцов. Ячейка является элементарной областью для хранения данных.

В ячейке могут храниться данные трех типов: числовые, текстовые и формулы. Формула в Excel - это математическое выражение, начинающееся со знака «=» и определяющее порядок вычисления значения в производной ячейке на основе значений из основных или других производных ячеек. При вводе формулы в ячейке отображается не сама формула, а результат вычислений по этой формуле. При изменении исходных значений, входящих в формулу, результат пересчитывается немедленно.

2.3 MS Access

Приложение Microsoft Access (далее Access) является мощной и высокопроизводительной 32-разрядной системой управления реляционной базой данных (далее СУБД).

Практически все СУБД позволяют добавлять новые данные в таблицы. С этой точки зрения СУБД не отличаются от программ электронных таблиц (Excel), которые могут эмулировать некоторые функции баз данных. Существует три принципиальных отличия между СУБД и программами электронных таблиц:

СУБД разрабатываются с целью обеспечения эффективной обработки больших объёмов информации, намного больших, чем те, с которыми справляются электронные таблицы.

СУБД может легко связывать две таблицы так, что для пользователя они будут представляться одной таблицей. Реализовать такую возможность в электронных таблицах практически невозможно.

СУБД минимизируют общий объём базы данных. Для этого таблицы, содержащие повторяющиеся данные, разбиваются на несколько связанных таблиц.

Access - мощное приложение Windows. При этом производительность СУБД органично сочетаются со всеми удобствами и преимуществами Windows.

Как реляционная СУБД Access обеспечивает доступ ко всем типам данных и позволяет одновременно использовать несколько таблиц базы данных. Можно использовать таблицы, созданные в среде Paradox или dBase.

Access специально спроектирован для создания многопользовательских приложений, где файлы базы данных являются разделяемыми ресурсами в сети. В Access реализована надёжная система защиты от несанкционированного доступа к файлам.

Несмотря на то, что Access является мощной и сложной системой, его использование не сложно для непрофессиональных пользователей.

Microsoft Access объединяет сведения из разных источников в одной реляционной базе данных.

Создаваемые формы, запросы и отчеты позволяют быстро и эффективно обновлять данные, получать ответы на вопросы, осуществлять поиск нужных данных, анализировать данные, печатать отчеты, диаграммы.

3. Работа в среде ERWin

В среде ERWin создадим сущности, соответствующие исходным данным. Для создания сущности выбираем на панели инструментов кнопку Entity (рис. 1).

Рис. 1. Создание сущности

В результате будет создана пустая сущность, которую необходимо заполнить атрибутами, дважды щелкнув по ней мышью (рис. 2). Для каждого атрибута укажем его тип на вкладке Datatype.

Рис. 2. Создание атрибутов сущности

Чтобы обеспечить связь сущностей, нужно указать ключевое поле с помощью флажка Primary Key.

Таким образом создадим три сущности и свяжем их с помощью кнопки, показанной на рис. 3.

Рис. 3. Создание связей

В результате получим связанные сущности (рис. 4.).

Рис. 4. Логическая модель

Преобразуем логическую модель в физическую (рис. 5).

Рис. 5. Физическая модель

Далее импортируем сущности в СУБД Access (рис. 6).

Рис. 6. Импорт базы данных в Access

4. Работа в СУБД MS Access

4.1 Создание таблиц

Cтруктуры таблиц, экспортированных из среды ERWin, представлены на рисунках 7-9.

Рис. 7. Таблица «Занятия»

Рис. 8. Таблица «Тренеры»

Рис. 9. Таблица «Виды занятий»

Заполненные таблицы представлены на рис. 10-12.

Рис. 10. Таблица «Занятия»

Рис. 11. Таблица «Тренеры»»

Рис. 12. Таблица «Виды занятий»

4.2 Создание связей

После распределения данных по таблицам и определения ключевых полей необходимо выбрать схему для связи данных в разных таблицах. Для этого нужно определить связи между таблицами.

Свяжем таблицы «Тренеры» и «Занятия» по полю «Код тренера» (рис. 13).

Рис. 13. Окно «Изменение связей»

После этого нажимаем кнопку ОК и у нас появится связь между таблицами.

Аналогично свяжем остальные таблицы согласно схеме на рис. 14.

Рис. 14. Схема данных

4.3 Создание запросов

Запросы являются основным средством извлечения информации из базы данных. С помощью запроса можно выбрать определенную информацию и рассортировать ее по значениям полей и даже добавлять описания в презентации.

Запрос на выборку «Аэробика или занятия с ценой 250-300 рублей».

В отдельный столбец записана формула: Цена со скидкой: [Цена]*(1-[Скидка членам клуба, %]/100)

Структура запроса в режиме конструктора показана на рис. 15. Результат запроса показан на рис. 16.

Рис. 15. Структура запроса «Аэробика или занятия с ценой 250-300 рублей»

Рис. 16. Результат запроса «Аэробика или занятия с ценой 250-300 рублей»

Итоговый запрос «Количество занятий каждого вида в расписании».

Структура запроса в режиме конструктора показана на рис. 17. Результат запроса показан на рис. 18.

Рис. 17. Структура запроса «Количество занятий каждого вида в расписании»

Рис. 18. Результат запроса «Количество занятий каждого вида в расписании»

Запрос-действие «Удаление занятия из расписания». Структура запроса в режиме конструктора показана на рис. 19. Результат запроса показан на рис. 20.

Рис. 19. Структура запроса «Удаление занятия из расписания»

Рис. 20. Результат запроса «Удаление занятия из расписания»

4.4 Создание отчета

По своим свойствам и структуре отчеты во многом похожи на формы, но предназначены только для вывода данных, причем для вывода не на экран, а на принтер. В связи с этим отчеты отличаются тем, что в них приняты специальные меры для группирования выводимых данных и для вывода специальных элементов оформления, характерных для печатных документов.

Пользователь имеет возможность разработать отчет самостоятельно или создать отчет с помощью мастера. Мастер по разработке отчетов Microsoft Access выполняет всю рутинную работу и позволяет быстро разработать отчет.

Мастер отчетов запускается из диалогового окна База данных. На первом этапе выбирают поля базовых таблиц и запросов, на которых отчет основывается.

На втором этапе добавляют уровни группировки, если они необходимы.

На третьем этапе задают метод сортировки записей и тип итогов.

На четвертом этапе посредством переключателей выбирают вид макета и способ ориентации страницы отчета.

На пятом этапе задают стиль оформления отчета. Название интересующего стиля щелкают в правой части окна, а образец отчета показывается в левой. При выборе стиля оформления необходимо учитывать возможности принтера.

Последний диалог мастера предлагает сохранить отчет под заданным именем. Кроме того, предусмотрена возможность вернуться на несколько шагов назад или изменить макет отчета, переключившись в режим конструктора.

После этого можно переключиться в режим конструктора и внести изменения в стандартный макет.

Отчет по запросу «Аэробика или занятия с ценой 250-300 рублей» представлен на рис. 21-22.

Рис. 21. Отчет «Аэробика или занятия с ценой 250-300 рублей» в режиме конструктора

Рис. 22. Отчет «Аэробика или занятия с ценой 250-300 рублей»

4.5 Создание форм

Формы обеспечивают доступ к информации, хранящейся в базовых таблицах, без непосредственного открытия последних. Это существенно упрощает ввод, редактирование, удаление и просмотр данных. Во-первых, на экран выводятся только необходимые поля и записи. Во-вторых, формы могут иметь красивое графическое оформление и удобные элементы управления, что заметно облегчает восприятие. Мы рассмотрим создание формы с помощью мастера. Для создания формы необходимо открыть окно База данных и перейти на вкладку Формы.

Рассмотрим создание формы с помощью мастера.

Мастер форм запускается из диалогового окна Новая форма. Работа с ним выполняется в четыре основных этапа.

Первый диалог мастера предназначен для указания таблиц и полей, которые войдут в форму.

На втором этапе задают внешний вид формы.

Третий шаг -- определение стиля оформления формы.

Наконец, на четвертом этапе осуществляется сохранение формы под каким-либо именем.

Мастер позволяет разрабатывать формы на основе как одного, так и нескольких объектов.

Форма ввода и редактирования данных показана на рис. 23.

Рис. 23. Форма «Тренеры»

Рис. 24. Форма «Виды занятий»

Такие формы могут применяться как для вывода, так и для ввода данных.

Создадим диаграмму по запросу «Количество занятий каждого вида в расписании».

Создаем новую форму с помощью конструктора форм.

Отображаем Панель элементов, если ее нет на экране. Включаем кнопку Мастер, далее кнопку Добавить диаграмму на Панели элементов и помещаем элемент на форму, захватив область для будущей диаграммы.

Будет запущен Мастер, который запросит имя таблицы или запроса. Выберем запрос «Количество занятий каждого вида в расписании».

Выберем все поля с данными. Выберем тип диаграммы Круговая.

В следующем окне Мастера появится образец графика. Закроем конструктор и откроем созданную форму в обычном режиме.

При необходимости снова откроем форму в режиме конструктора, кликнем правой кнопкой на осях, заголовке, легенде, выберем в появляющемся меню Формат и корректируем шрифты.

В результате получим диаграмму, показанную на рис. 25.

Рис. 25. Диаграмма «Количество занятий каждого вида в расписании»

Представление форм и отчетов, а также выполнение макросов и запросов, легко реализовать посредством удобной кнопочной формы, связывающей различные элементы базы данных с помощью ссылок.

Создадим меню с помощью диспетчера кнопочных форм (рис. 26).

Рис. 26. Создание меню

Для автозапуска используем меню «Сервис / Параметры запуска» (рис. 27).

Рис. 27. Параметры запуска

Таким образом, создано меню для ввода и корректировки информации в базу данных (рис. 28).

Рис. 29. Меню

5. Работа в табличном процессоре MS Excel

5.1 Оформление таблиц

erwin access запрос отчет

Загрузим MS Excel. Импортируем таблицы из СУБД Access с помощью команды «Сервис / Связи с Office / Анализ в Microsoft Excel».

Загрузим MS Excel. Импортируем таблицы из MS Access. Откроем таблицу «Тренеры».

Для оформления заголовка таблицы установим курсор в ячейку А2 и введем название таблицы. Для размещения названия таблицы по ширине таблицы объединим ячейки А2:G2, выбрав в строке меню команду Формат / Ячейки / Выравнивание / Объединение ячеек.

Для длинных названий, используемых в заголовках таблицы, применим форматирование ячеек. Выделим диапазон ячеек А4:G4 и выберем в меню команду Формат / Ячейки / Выравнивание / Переносить по словам.

Для сортировки данных в строке меню выберем команду Данные / Сортировка, в появившемся окне диалога укажем: Сортировать по - «Стаж работы, лет» и тип сортировки - «по возрастанию». В итоге получим отсортированную таблицу.

Вычислим итоговую функцию (среднее). Для этого введем в ячейку G15 формулу =СРЗНАЧ(G5:G14). Таким образом найдем средний стаж работы тренеров.

В результате таблица примет вид, показанный на рис. 30.

Аналогичным образом создадим и отсортируем таблицы «Занятия» и «Виды занятий»

Для связи таблиц «Тренеры» и «Занятия» скопируем коды тренеров из таблицы «Тренеры» и вставим их в соответствующие поля таблицы «Занятия» с помощью команды Правка / Специальная вставка.

Рис. 30. Таблица «Тренеры»

Для автоматической подстановки данных из таблиц «Тренеры» и «Виды занятий» в таблицу «Занятия» в ячейку С8 запишем формулу =ВПР($B$8:$B$37;'Виды занятий'!$A$5:$B$8;2;0). Затем скопируем формулу до конца столбца с помощью автозаполнения.

Для фильтрации данных таблицы «Занятия» выберем в меню команду Данные / Фильтр / Расширенный фильтр и зададим следующие условия (рис. 31).

Рис. 31. Условия фильтра

В результате выполненных действий по заданным критериям получим таблицу (рис. 32).

Рис. 32. Вид таблицы «Занятия»

5.2 Построение диаграмм

По данным столбцов «Фамилия» и «Стаж работы, лет» таблицы «Тренеры» построим стандартную диаграмму.

Диаграммы связаны с теми данными на рабочем листе, по которым они были созданы, поэтому диаграммы будут автоматически обновляться при обновлении данных.

Для построения диаграммы выделим в таблице интервалы ячеек: В4:В14 и G4:G14. Диаграмму создадим с помощью мастера диаграмм, который вызывается с помощью команды в строке главного меню Вставка / Диаграмма. При построении диаграммы выполним четыре шага.

На первом шаге мастера диаграмм выберем тип и вид диаграммы (круговая). Переход к следующему шагу осуществим нажатием кнопки «Далее».

На втором шаге выберем диапазон данных для построения диаграммы (т.к. вначале определили диапазон, в окне мастера диаграмм он уже установлен).

На третьем шаге установим параметры диаграммы.

После всех произведенных действий с построением диаграммы, на четвертом шаге построения поместим ее на отдельном листе «Диаграмма» (рис. 33).

Рис. 33. Диаграмма по результатам таблицы «Тренеры»

Аналогичным образом построим диаграмму по данным таблицы «Занятия», изменив лишь тип и расположение диаграммы (рис. 34).

Рис. 34. Диаграмма по результатам таблицы «Занятия»

6. Руководство пользователя

Работу с созданным программным продуктом начинаем с открытия CD-диска. Устанавливаем его на компьютер, открываем Мой Компьютер, в появившемся перечне выбираем название диска, открываем его. Открываем файл с названием «Спортивный клуб».

Работа в программе начинается с кнопочной формы «Спортивный клуб», в которой представлены кнопки, которые ссылаются на основные элементы БД (запросы, отчеты, формы).

При нажатии кнопок из категории «Запросы» (рис. 35), мы получаем возможность выполнить запросы, разработанные для базы данных.

Рис. 35. Страница «Запросы» кнопочной формы

Также с помощью главной кнопочной формы можно просмотреть созданный отчет. Для этого необходимо выбрать пункт меню «Отчет».

Также с помощью главной кнопочной формы можно осуществить просмотр и добавление новых данных в таблицы базы данных. Для этого необходимо выбрать пункт меню «Формы» (рис. 36) и в открывшемся списке выбрать нужную форму.

Рис. 36. Страница «Формы» кнопочной формы

Кнопка «Выход» позволяет закрыть данную форму и перейти в окно базы данных.

Заключение

В ходе выполнения данной работы удалось ознакомиться с основными принципами построения реляционных баз данных при помощи пакета Erwin, СУБД Microsoft Access, а также с помощью табличного процессора MS Excel. Изучены структура базы данных, принципы построения основных элементов базы данных, таких как таблицы, запросы, формы и отчеты. На основе полученных знаний создана база данных в соответствии с поставленной задачей. А именно, разработана база данных «Спортивный клуб».

База данных состоит из трех таблиц. Разработанная база данных существенно облегчит работу со сведениями о занятиях в спортивном клубе. В базе данных разработаны и реализованы запросы, которые позволят быстро вывести все необходимые сведения, начиная от простой сортировки и заканчивая расчетами. Отчет, созданный на основе запроса позволит представить всю информацию в удобном и наглядном виде. Формы обеспечат легкий и удобный ввод данных. Кнопочная форма обеспечит удобную и быструю навигацию по базе данных.

В ходе выполнения курсовой работы были закреплены знания и практические навыки работы на персональном компьютере с использованием современных компьютерных технологий, ориентированных на работу с базами данных и системами управления БД.

Выполненная работа позволила углубить знания в области информатики и использования современных информационных систем.

Список литературы

1. Вейскас Д. Эффективная работа с Microsoft Access. СПб: «Питер Пресс», 2006. - 856 стр.

2. Горев А., Макашарипов С., Ахаян Р. Эффективная работа с СУБД, СПб: «Питер», 2007. - 704с.

3. Access - для самостоятельного освоения/ А.И.Бородина, Л.И. Крошинская, Е.Н. Лядинская. - Мн.: НО ООО «БИП-С», 2008. - 236 с.

4. Гончаров А. Access в примерах. СПБ.: Питер, 2008. - 366 с.

5. Ботт Эд. Microsoft Office 4 (Серия "Без проблем!") / Пер. с англ. М.: БИНОМ, 2006. - 561 с.

6. Алексеева Т.И., Башин Ю.Б. Проектирование баз данных в примерах и задачах. - М: Экспресс, 2007. - 532 с.

7. Бемер С, Фратер Г. MS Access 2000 для пользователя. - Киев: BHV, 2001. - 624 с.

8. Биллинг В.А., Дехтярь М.И. VBA и Office 2000. Офисное программирование. - М.: Русская редакция, 2002. - 431 с.

9. Киммел П. Программирование для Microsoft Access 2000 за 24 часа. - Минск: Высшая школа, 2002. - 318 с.

10. Пакеты программ офисного назначения: Учебное пособие / Под ред. С.В. Назарова. - М.: Информ-пресс, 2008. - 385 с.

11. Стоцкий Ю. Самоучитель по Office XP. - СПб.: Питер, 2008. - 427 с.

12. Харитонова И.И. Самоучитель по Microsoft Access 2000. - СПб: Питер, 2001. - 472 с.

Размещено на Allbest.ru


Подобные документы

  • Многотабличные базы данных. Виды связей между таблицами. Создание запросов, форм и отчетов. Работа с текстовым процессором MS Excel, создание таблиц и заполнение их соответствующими расчетами. Создание в MS Access базы данных заданной структуры.

    контрольная работа [3,0 M], добавлен 25.03.2014

  • Понятие и основные функции СУБД "Access". Алгоритм создания базы данных сотрудников: создание таблиц с помощью конструктора, ключевые поля, установление связей между таблицами. Создание форм для поиска и ввода данных. Работа с запросами и отчетами.

    контрольная работа [827,5 K], добавлен 01.06.2010

  • Техника создания списков, свободных таблиц и диаграмм в среде табличного процессора Microsoft Excel. Технология создания базы данных в среде СУБД Microsoft Access. Приобретение навыков подготовки и демонстрации презентаций в среде Microsoft Power Point.

    лабораторная работа [4,8 M], добавлен 05.02.2011

  • Создание базы данных "Спортивный клуб" средствами Microsoft Access: нормализация информационно-логической модели данных, построение связей между таблицами, разработка форм, запросов, отчетов, макросов, главной кнопочной формы в интерфейсе пользователя.

    курсовая работа [2,8 M], добавлен 10.06.2011

  • Анализ баз данных и систем управления ими. Проектирование и создание реляционной базы данных в среде MS Access для ресторана "Дельфин": построение информационно логической модели, разработка структур таблиц базы данных и схемы данных, создание Web-узла.

    курсовая работа [3,7 M], добавлен 15.11.2010

  • Создание логической модели данных. Назначение кнопок Erwin Toolbox. Создание БД в СУБД InterBase. Использование утилиты WISQL. Создание Script-файла. Перенос структуры данных с одного сервера на другой. Синхронизация каталога БД и текущей модели.

    курсовая работа [4,6 M], добавлен 26.11.2011

  • Процесс проектирования базы данных, разработка её логической структуры в соответствии с инфологической моделью предметной области. Работа с программой СУБД Access, свойства таблиц и их полей, создание межтабличных связей; инфологическое проектирование.

    курсовая работа [1,7 M], добавлен 17.12.2009

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.