Разработка базы данных для создания учетных записей на файловом сервере

Особенности создания учетных записей на файловом сервере. Разработка функциональной модели базы данных. Отчет по дугам модели. Сущность, атрибуты и связи информационной модели. Разработка базы данных в системе управления базами данных MS Access.

Рубрика Программирование, компьютеры и кибернетика
Вид контрольная работа
Язык русский
Дата добавления 23.01.2014
Размер файла 2,3 M

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru/

МИНИСТЕРСТВО ОБРАЗОВАНИЯ И НАУКИ РОССИЙСКОЙ ФЕДЕРАЦИИ

Государственное Образовательное Учреждение

Высшего Профессионального Образования

РЯЗАНСКИЙ ГОСУДАРСТВЕННЫЙ РАДИОТЕХНИЧЕСКИЙ УНИВЕРСИТЕТ

КАФЕДРА АВТОМАТИЗИРОВАННЫХ СИСТЕМ УПРАВЛЕНИЯ

Кафедра АСУ

Контрольная работа

По дисциплине

"УПРАВЛЕНИЕ ДАННЫМИ"

Рязань 2012

Содержание

  • 1. Описание предметной области
  • 2. Функциональная модель
  • 3. Отчет по дугам модели
  • 4. Сущность, атрибуты и связи информационной модели
  • 5. Разработка базы данных в системе управления базами данных MS ACCESS
  • 6. Список используемой литературы

1. Описание предметной области

Учетные записи на файловом сервере бывают различными. Они создаются по запросу пользователя, согласно его принадлежности к отделу в фирме, уровня доступа в отделе и на основе правил и стандартов корпоративной безопасности в фирме.

2. Функциональная модель

Общая модель представлена на Рис. 1.

Рис. 1

Модель может использоваться любым информационным отделом на предприятии для создания учетных записей пользователей.

Отдел ИТ фирмы получает запрос от пользователя любого отдела фирмы и основываясь на принятых правилах и стандартах безопасности создает учтенную запись на файловом сервере предприятия. Затем передает данные учетной записи пользователю для его работы.

Входной дугой является запрос пользователя, выходной - данные учтенной записи (логин и пароль). Механизмы - отдел ИТ занимающийся созданием учетных записей и база данных пользователей фирмы (с их должностями и уровнями доступа). Правила и стандарты безопасности являются управляющими данными.

Весь процесс разбивается на несколько этапов: получение запроса, уточнения должности и уровня доступа, создания учтенной записи и пароля, внесения учетной записи в группу пользователей, выдача данных учтенной записи пользователю. Этапы показаны на Рис. 2.

база учетная запись управление

Рис. 2

Создание учетной записи и отнесение её к группе можно тоже рассмотреть отдельно: создание имени пользователя (логина) исходя из уже используемых и принадлежности пользователя к отделу, генерация пароля на основе правил и стандартов безопасности, занесение учетной записи в определенную группу на основе данных о его должности и уровня доступа к данным - Рис. 3

Рис. 3

Логин создается так, что бы в имени содержать имя отдела и номерной индекс. Генерируемый пароль должен быть абсолютно бессмысленным, содержать не менее требуемых по стандарту символов, иметь определенный срок действия после которого он должен быть изменен. Пользователь не определяет логин и пароль, его создает системный администратор и заносит пользователя в группу на основе данных об отделе, уровне доступа пользователя и общего доступа к ресурсам между отделами.

Рассмотрим детально внесение пользователя в группу или группы (Рис. 4).

Рис. 4

Входная дуга - созданная учетная запись, выходная - полностью настроенная учетная запись (логин и пароль).

Операции выполняются согласно правилам, определенными работами занимаются необходимые специалисты.

Для примера покажем описание добавления необходимых групп в глоссарий:

Рис. 5

Так же для примера покажем содержимое глоссария свойства метки:

Рис. 6

Представим иерархию нашей модели в виде дерева:

А0 - Создание учетных записей;

А1 - Получение запроса;

А2 - Создание учетной записи и группы;

А21 - Создание логина;

А22 - Генерация пароля;

А23 - Внесение пользователя в группу или несколько групп;

А231 - Открытие окна настроек учетной записи;

А232 - Переход на вкладку настроек групп;

А233 - Добавление необходимых групп;

А234 - Закрытие окна настроек;

А3 - Выдача пары (логин-пароль) пользователю.

3. Отчет по дугам модели

· Запрос от пользователей - содержит данный пользователя создавшего запрос (имя, фамилия, название отдела);

· Правила и стандарты безопасности - содержит набор корпоративных правил и приказов согласно которым пользователям фирмы разрешается/запрещается определенные действия, правила создания учетных записей и паролей;

· Отдел ИТ - содержит данные сотрудников отвечающих за создание учетных записей;

· База данных работников - содержит данные о работниках (ФИО, отдел, права доступа);

· Созданная учетная запись - содержит данные созданной и настроенной учетной записи выдаваемой пользователю в итоге (логин-пароль);

· Правила создания запросов - содержит данные о том как и в какой форме пользователь должен запрашивать создание учетной записи;

· Правила создания логина, сложность пароля и принадлежность к группе - содержит данные о том как создается логин, пароль и как с помощью групп регламентируется использование общих ресурсов;

· Правила приватной выдачи учетной записи конкретному пользователю - содержит данные о том, как передавать бланк с учетной записью пользователю без утечки этих данных к окружающим;

· Заполненная форма запроса - содержит данные с ФИО, названием отдела и должностью пользователя;

· Системный администратор - содержит данные сотрудника, который работает с учетными записями;

· Уровни доступа пользователя - содержит данные о том, какими папками и файлами пользователю можно пользоваться и режимы - чтение, запись, изменение;

· Бланк с парой логин-пароль - содержит данные с логином и паролем;

· Создание логина содержащего имя отдела - содержит данные о том, как создается имя пользователя (язык, что должно содержаться в имени);

· Минимальная, максимальная длина пароля, срок действия - содержит данные о длине генерируемого пароля и дату истечения срока его действия;

· Запрет пользователю видеть (изменять) данные не его отдела - содержит данные о том, что пользователь должен быть ограничен в работе с чужими папками и файлами;

· Созданная пара логин-пароль - содержит данные о паре логин-пароль;

· Связь между отделами и общими ресурсами - содержит перекрестные связи между файлами и папками различных отделов;

· Окно настроек учетной записью - содержит свойства окна учетной записи;

· Окно настроек групп с добавленными группами - содержит данные учетной записи со всеми входящими в неё группами;

· Списки папок с которыми разрешено работать пользователю - содержит данные о списке папок и файлов разрешенных для работы пользователя;

4. Сущность, атрибуты и связи информационной модели

Перечислим сущности порожденные в нашей модели:

1. ЗАПРОС - атрибуты: Номер_запроса, Сотрудник ИТ. Идентификатор_сотрудника, Пользователь. Идентификатор_сотрудника.

2. СОТРУДНИК - атрибуты: Идентификатор_сотрудника, ФИО_сотрудника, Идентификатор_должности, Идентификатор_отдела.

3. СТРОКА ЗАПРОСА - атрибуты: Номер_запроса, Номер_строки_запроса, ФИО_сотрудника, Идеентификатор_учетной_записи.

4. ДОЛЖНОСТЬ - атрибуты: Идентификатор_должности, Название_должности

5. ОТДЕЛ - атрибуты: Идентификатор_отдела, Название_отдела.

6. УЧЕТНАЯ ЗАПИСЬ - атрибуты: Идентификатор_учетной_записи, Логин, Пароль, Идентификатор_группы.

7. ГРУППЫ - атрибуты: Идентификатор_группы, Название_группы.

8. Системный администратор - экземпляр сущности СОТРУДНИК.

9. Отдел ИТ - экземпляр сущности ОТДЕЛ.

5. Разработка базы данных в системе управления базами данных MS ACCESS

Создание базы данных.

Открываем MS Access и создаем новую базу данных из меню "Файл/Создать", меню "Создание" - "Новая база данных"

Рис. 7

В окне "Файл базы данных" даем название своей базы - "Создание учетных записей. mdb" и нажимаем "Сохранить".

Рис. 8

Теперь когда мы создали пустую базу данных нам необходимо создать таблицы. Воспользуемся для создания режимом "Создание таблицы в режиме конструктор".

Рис. 9

Войдя в режим конструктора создадим таблицу ЗАПРОС:

В поле "Имя поля" вводим названия атрибута "Номер_запроса", указываем тип данных - "Счетчик" и делаем его ключевым с помощью команды "Ключевое поле" в меню правой клавиши мыши. Затем заполняем поля "Сотрудник ИТ Идентификатор сотрудника (тип данных - текстовый) и "Пользователь Идентификатор сотрудника (тип данных - текстовый).

С помощью меню "Файл/Сохранить как." сохраняем созданную таблицу с именем "Запрос".

Получаем таблицу "Запрос"

Аналогично создаем остальные таблицы:

Таблицу "Строка запроса"

Таблицу "Сотрудник"

Таблицу "Должность"

Таблицу "Отдел"

Таблицу "Учетная запись"

Таблицу "Группы"

Индексы

Одним из основных требований предъявляемых к СУБД, является возможность быстрого поиска требуемых записей среди большого объема информации. Индексы представляют собой наиболее эффективное средство, которое позволяет значительно ускорить поиск данных в таблицах по сравнению с таблицами, не содержащими индексов.

Создание индекса для одного поля. Для создания простого индекса используется свойство Индексированное поле, позволяющее ускорить выполнение поиска и сортировки записей по одному полю таблицы. Индексированное поле может содержать как уникальные, так и повторяющиеся значения.

Создание простого индекса предполагает выполнение следующих действий:

В окне конструктора таблицы выберите в верхней половине окна поле, для которого создается индекс.

В нижней половине окна для свойства Индексированное поле выберите одно из следующих значений: Да (Допускаются совпадения) или Да (Совпадения не допускаются).

Создание составного индекса. Индексы, содержащие несколько полей, следует определять в окне индексов.

В окне конструктора откройте таблицу, для которой создается составной индекс. Для этого в окне базы данных установите указатель на данную таблицу и нажмите кнопку Конструктор.

Нажмите кнопку Индексы на панели инструментов. На экране откроется окно диалога "Индексы" (Рис. 18).

Рис. 18

В открывшемся окне диалога введите имя индекса в первом пустом поле столбца Индекс. В качестве имени индекса можно использовать имя одного из полей, включенных в индекс, или любое допустимое имя.

В столбце Имя поля той же строки нажмите кнопку раскрытие списка и выберите первое поле индекса.

В столбце Имя поля следующей строки выберите имя следующего поля индекса. (В этой строке поле столбца Индекс следует оставить пустым.) Определите таким же образом остальные поля индекса. Индекс может включать до 10 полей.

Закончив выбор полей для индекса, нажмите кнопку закрытия окна диалога.

По умолчанию задается порядок сортировки По возрастанию. Для сортировки конкретного поля по убыванию выберите в столбце Порядок сортировки строки с выбранным полем значение По убыванию.

Определение связей между таблицами.

MS Access поддерживает три типа отношений между таблицами: "один-к-одному", "один-ко-многим", "много-ко-многим".

Отношение "один-к-одному" означает, что каждая запись в одной таблице соответствует только одной записи в другой таблице.

Отношение "много-ко-многим". Отношение "много-ко-многим" возникает между таблицами в тех случаях, когда:

одна запись из первой таблицы может быть связана более чем с одной записью из второй таблицы;

одна запись из второй таблицы может быть связана более чем с одной записью из первой таблицы.

Например, врач может обследовать несколько больных, а больной обследуется у нескольких врачей.

Отношение "много-ко-многим" фактически изображается в виде двух связей с отношениями "один-ко-многим" через третью таблицу, ключ которой состоит, по крайней мере, из двух полей, которые являются полями внешнего ключа, мигрирующими из двух других таблиц.

Создание связей между таблицами осуществляется в окне "Схема данных" открываемое из меню "Сервис".

Рис. 19

Выбираем "Схема данных" и в окне "Добавление таблицы" добавляем в схему все необходимые таблицы.

Рис. 20

Рис. 21

Для связывания таблиц выбираем поле в таблице, перетаскиваем его с помощью мыши на поле связи таблицы. Как только отпускаем кнопку мыши, открывается диалоговое окно "Изменение связей".

Рис. 22

Щелкнем на кнопке "Создать", чтобы установить связь. В окне "Схема данных" появится линия новой связи.

В результате установления всех связей имеем схему данных.

Рис. 23

Если необходимо изменить существующую связь, необходимо установите указатель на линию связи, которую требуется изменить, и дважды нажмите кнопку мыши.

Определение условий целостности данных

Рис. 24

В диалоговом окне "Изменение связей" есть флажок "Обеспечение целостности данных".

В диалоговом окне "Изменение связей" можно включать или отключать режим обеспечения целостности данных, а также устанавливать дополнительные параметры обеспечения целостности данных.

Щелкаем правой кнопкой мыши на линии связи между двумя таблицами и выбираем в контекстном меню команду "Изменить связь".

В появившемся диалоговом окне устанавливаем флажок "Обеспечение целостности данных".

Для того чтобы преодолеть ограничения на удаление или изменение связанных записей, сохраняя при этом целостность данных, устанавливаем дополнительные правила целостности данных:

Установка флажка "Каскадное обновление связанных полей" позволяет автоматически изменять соответствующее значение в связанных записях при изменении значения в ключевом поле главной таблицы;

Установка флажка "Каскадное удаление связанных полей" позволяет автоматически удалять и все связанные с ней записи в подчиненной таблице при удалении записи в главной таблице.

Щелкаем на кнопке ОК, чтобы закрыть диалоговое окно "Изменение связей".

Модификация структуры таблицы

Изменение порядка следования полей. Слева от имен полей находится область выбора поля. Нажимаем на эту область. При этом вся строка будет выделена. Теперь нажимаем еще раз на область выбора поля и не отпускаем кнопку мыши. Под курсором мыши появился маленький пунктирный прямоугольник. Переносим всю строку так, чтобы она оказалась прямо над тем полем, перед которым хотим её расположить. После того как отпускаем кнопку мыши, поле будет находиться на новом месте

Удаление поля из таблицы. В конструкторе таблиц нажимаем мышью на область выбора поля, которое хотим удалить, и нажимаем клавишу Delete.

Добавление нового поля. В конструкторе таблиц нажимаем мышью на область выбора поля, над которым хотим добавить новую строку, нажимаем правую кнопку мыши и выбираем "Вставить строки. Новая строка будет вставлена над текущей строкой.

Ввод и редактирование данных.

Открываем созданную базу данных "Создание учетных записей". Затем открываем таблицу "Группа" в режиме таблицы и вводим данные.

Рис. 25

Мастер подстановок.

Он позволяет создать поле, в котором выводится список значений, облегчающий ввод данных. Можно использовать список подстановок, в котором выводятся значения из существующей таблицы или отчета. Для создания столбца подстановок выполняем следующие действия:

Откроем таблицу (например, "Запрос") в режиме конструктора, в которую нужно добавить поле с подстановкой значений в режиме конструктора.

Выберите строку поля, которое будет использоваться как внешний ключ, например поле "Пользователь Идентификатор сотрудника". Это поле требуется превратить в поле подстановок, выбирающее некоторые сведения из таблицы "Сотрудник".

В столбце "Тип данных" нажмем кнопку со стрелкой и выберите "Мастер подстановок" (Рис. 26), после чего появится диалоговое окно "Создание подстановки".

Рис. 26

Выбираем переключатель для создания столбца подстановки, использующего значения из таблицы или запроса. Нажимаем кнопку "Далее".

Рис. 27

В следующем окне выбираем таблицу со значениями, которые будет содержать столбец подстановок (например, таблицу "Сотрудник"). Нажимаем кнопку "Далее".

Рис. 28

Затем выбираем поля, содержащие значения, которые будут включены в столбец подстановок. Выбираем поле "ФИО_сотрудника". Нажимаем кнопку "Далее".

Рис. 29

Выберем сортировку по ключевому полю, а в следующем окне уберем выбор опции "Скрыть ключевой столбец"

В последнем окне мастера подстановок задайте подпись столбца подстановок, например.

Нажимаем кнопку готово. Мастер нам предложит сохранить таблицу - жмем кнопку "Да".

После Microsoft Access создаст поле подстановок и установит некоторые свойства этого поля на основании значений, выбранных в мастере.

Рис. 30

Вставка в поле значения по умолчанию.

При создании таблицы в режиме конструктора используются свойства полей таблицы. Свойства "Значение по умолчанию" незаменимо в том случае, когда значения, содержащиеся в каком-либо из полей, часто повторяются. Часто повторяемое значение можно ввести в свойство поля. При каждом добавлении новой записи в это поле автоматически будет введено значение по умолчанию.

Поиск, замена, сортировка и фильтрация данных.

Окно диалога "Поиск и замена".

Для поиска данных в MS Access предназначено окно "Поиск и замена", которое открывается нажатием клавиш Ctrl+F.

Рис. 31

В поле ввода "Образец" вводится то, что необходимо найти. Справа находится кнопка "Найти далее". При первом нажатии кнопки осуществляется поиск первого вхождения. Если найденная запись, содержащая указанное значение, не является необходимой записью, то необходимо нажать кнопку ещё раз.

Раскрывающийся список "Совпадение" содержит три установки, которые определяют тип сравнения данных с образцом, введенным для поиска:

С любой частью поля - осуществляется поиск по всему полю. Если значение, которое ищите, окажется где угодно в поле поиска, то поиск завершается успешно.

Поля целиком - образец поиска должен совпадать с полным значением поля, что позволяет существенно сузить поле поиска.

С начала поля - поиск завершается успешно только в том случае, если образец поиска находится в начале данного поля.

По умолчанию MS Access ограничивает область поиска текущим полем (то есть тем полем, в котором находится курсор). Об этом свидетельствует наименование поля, отображаемое в списке "Поиск в". Это обусловлено тем, что при работе с большими таблицами поиск только в одном поле может потребовать сотни и даже тысячи сравнений, а поиск во всех полях займет много времени. Однако можно выполнять поиск во всех полях таблицы. Для этого нужно выбрать из списка "Поиск в" наименование таблицы.

Раскрывающийся список "Просмотр" содержит опции, с помощью которых определяется направление поиска: Вверх, Вниз и Все.

В средней части окна диалога есть два флажка, которые определяют, как будет осуществляться сравнение значения поля с образцом поиска:

С учетом регистра - этот флажок указывает на то, что сравнение осуществляется с учетом регистра букв, то есть прописные и строчные буквы будут восприниматься по-разному.

С учетом формата полей - формат отображения значений, отображаемых на экране, может отличаться от формата, в котором значения хранятся в таблице.

Замена найденного значения.

Вторая вкладка окна диалога "Поиск и замена" предоставляет средства для замены найденных значений. На вкладке "Замена" дополнительно присутствуют поле "Заменить на" и кнопки "Заменить" и "Заменить все".

Рис. 32

Если выбрать "Заменить все", MS Access заменит все вхождения, соответствующие образцу поиска, заданному в поле ввода "Образец". Опция "Заменить" позволяет изменять образец поиска после каждого вхождения образца в таблице.

Сортировка данных

Можно сортировать записи в любом поле - это значит, что порядок записей устанавливается в соответствии со значениями величин, хранящихся в данном поле. После того как поле для сортировки выбрано, необходимо выделить столбец и, нажав на правую кнопку мыши, выбрать опцию "Сортировка по возрастанию" или "Сортировка по убыванию".

Другой возможный способ запустить команду Сортировка - это нажатие соответствующей кнопки на панели инструментов: и .

Иногда может возникнуть необходимость упорядочить таблицу более чем по одному значению. В этом случае расположите в таблице сортируемые поля рядом. Затем одновременно выделите оба поля и нажмите кнопку сортировки.

Использование фильтров

При работе с таблицами в базе данных фильтр используется для того, чтобы видеть только значения, определяемые заданным критерием. Создать фильтр можно в любом режиме работы с таблицей, используя кнопки панели инструментов и команды меню. Вкладка "Главная", "Фильтр" содержит 4 вида фильтров: Изменить фильтр, Фильтр по выделенному, Исключить фильтр и Расширенный фильтр.

Фильтр по выделенному

Допустим, нужны все ФИО сотрудников с Идентификатором должности = 3. Выбираем "3" в поле "Идентификатор должности", а затем нажимаем мышью кнопку "Фильтр" на панели инструментов.

6. Список используемой литературы

1. Создание IDEF0 И IDEF1X - моделей: методические указания к практическим занятиям.

2. Управление данными в MS Access: методические указания к лабораторным работам.

3. Управление данными: методические указания / Рязан. гос. радиотехн. акад.; Сост.В.Е. Борзых. Рязань, 2004.24 с.

Размещено на Allbest.ru


Подобные документы

  • Системный анализ предметной области. Построение концептуальной и даталогичной модели базы данных. Физическое проектирование базы данных. Описание функциональной модели системы управления базами данных. Разработка экранных форм ввода-вывода и отчета.

    курсовая работа [1,1 M], добавлен 09.12.2014

  • Особенности разработки инфологической модели и создание структуры реляционной базы данных. Основы проектирования базы данных. Разработка таблиц, форм, запросов для вывода информации о соответствующей модели. Работа с базами данных и их объектами.

    курсовая работа [981,4 K], добавлен 05.11.2011

  • Методика и основные этапы проектирования логической и физической модели базы данных. Реализация спроектированной модели в системе управления базами данных, принципы создания и апробация специального клиентского приложения для работы данной программы.

    курсовая работа [1,3 M], добавлен 27.06.2013

  • Понятие базы данных, модели данных. Классификация баз данных. Системы управления базами данных. Этапы, подходы к проектированию базы данных. Разработка базы данных, которая позволит автоматизировать ведение документации, необходимой для деятельности ДЮСШ.

    курсовая работа [1,7 M], добавлен 04.06.2015

  • Освоение сервисной системы управления базами данных Microsoft SQL. Разработка базы данных "Служба АТС" в среде Microsoft SQL Server Management Studio и создание запросов на языке SQL. Апробация инфологической модели "сущность - связь" базы данных.

    курсовая работа [2,9 M], добавлен 29.06.2015

  • Разработка баз данных для предприятий. Процесс создания базы данных "Видеопрокат" в MS Access, содержащей сведения о выдаче кредита. Основные таблицы базы данных: "Выдача и возврат", "Фильм", "Кассета", "Жанр", "Клиент". Схема данных, отчет по запросу.

    курсовая работа [2,7 M], добавлен 07.06.2012

  • Разработка базы данных с информацией о сотрудниках, товарах, со справочником типов товаров средствами системы управления базами данных MySQL с помощью SQL-запросов. Разработка инфологической модели предметной области. Структура таблиц, полей базы данных.

    контрольная работа [648,7 K], добавлен 13.04.2012

  • История создания предприятия и анализ его деятельности. Основные понятия торговли. Этапы разработки модели данных, построение информационно-логической модели. Разработка базы данных для учета товародвижения и документооборота на предприятии в ACCESS.

    дипломная работа [1006,2 K], добавлен 14.01.2012

  • Системы управления базами данных: сущность и характеристика. Типы данных и свойства полей СУБД Access. Объекты базы данных: таблицы, схемы данных, формы, запросы, отчеты. Разработка и проектирование базы данных "Продажи книг" в среде Microsoft Access.

    курсовая работа [1,8 M], добавлен 04.02.2013

  • Основные понятия базы данных. Разработка сложной формы для обработки данных. Модели организации данных. Архитектура Microsoft Access. Реляционные связи между таблицами баз данных. Проектирование базы данных. Модификация данных с помощью запросов действий.

    лабораторная работа [345,5 K], добавлен 20.12.2011

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.