Пакет прикладных программ при обучении информатике

Текстовый редактор, графический редактор, электронные таблицы, компьютерные математические системы. Реализация текстового редактора Micfrosoft Word в процессе обучения математики. Графический редактор CorelDRAW в создании рисунков и графических объектов.

Рубрика Программирование, компьютеры и кибернетика
Вид курсовая работа
Язык русский
Дата добавления 27.03.2013
Размер файла 450,5 K

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru/

Размещено на http://www.allbest.ru/

ОГЛАВЛЕНИЕ

Введение

ГЛАВА 1. Пакет прикладных программ в процессе обучения.

1.1 Текстовый редактор

1.2 Графический редактор

1.3 Электронные таблицы

1.4 Компьютерные математические системы

ГЛАВА 2. Практическая реализация пакета прикладных программ при обучении математики.

2.1 Реализация текстового редактора Micfrosoft Word в процессе обучения математики

2.2 Графический редактор CorelDRAW в создании рисунков и графических объектов

2.3 Возможности электронной таблицы MS EXCEL в обучении математики

2.4 Использование компьютерной математической системы Mathcad в построении графиков математических функций

Заключение

Литература

ВВЕДЕНИЕ

Одной из ведущих тенденций развития современного образования выступает приоритетность подготовки педагогических кадров, способных реализовать инновационные процессы с использованием эффективных методов обучения, развития, воспитания.

Компьютерные технологии несомненно вписываются в систему образования и даже в значительной степени определяют её будущее развитие. Современный учитель должен владеть новыми педагогическими технологиями, гибко реагировать на их изменения, и социальные условия.

Сегодня нужны такие методы обучения, которые бы облегчали и ускоряли передачу знаний учащимся, активизировали процесс усвоения ими знаний, обучали их приёмам самостоятельной работы с учебным материалом, повышали производительность учебного труда.

Данная работа посвящена с одной стороны проблемам интеллектуального, компьютерного просвещения, а с другой стороны - использованию искусственного интеллекта (компьютера), пакетов прикладных программ в обучении.

В настоящее время, когда все окружающее требует высоких интеллектуальных способностей от каждого, жизнь заставляет человека с самого раннего возраста начать свое обучение компьютерной грамотности.

Под компьютерной грамотностью мы понимаем способность индивида решать учебные, бытовые, профессиональные задачи с использованием информационных и коммуникационных технологий. Начав один раз это обучение, нельзя стоять на месте. Компьютерный мир постоянно обновляется и вместе с ним обновляются и всякого рода пакеты прикладных программ с тем ни иным назначением.

В нашей работе будут раскрыты некоторые аспекты методики информационной и вычислительной грамотности в сфере использования разного рода пакетов прикладных программ и редакторов.

По программе непрерывного образования курса информатики большое внимание уделяется изучению пакетов прикладных программ. Под пакетом прикладных программ мы понимаем набор подпрограмм, с помощью которых удобно решать задачи определённого типа.

Традиционная система обучения не в полной мере обеспечивает подготовку высококвалифицированного специалиста, умеющего работать в условиях компьютеризации общества с быстро меняющейся техникой и технологией. Поэтому становится актуальной проблема поиска методов, форм и средств подготовки учащихся, отвечающих современным требованиям.

Актуальность нашей работы обусловлена расширяющимися возможностями повышения эффективности учебного процесса с помощью использования различных видов прикладных программ.

Целью данной дипломной работы является описание возможностей пакета прикладных программ в обучении математики в средней школе.

Задачи исследования:

1. Обзор имеющейся литературы по данной теме.

2. Изучение возможностей пакета прикладных программ в обучении математики.

3. Разработка рекомендаций по организации практической работы использования прикладных программ.

Объектом исследования являются возможности пакета прикладных программ в обучении математике.

Предметом исследования являются способы, методы использования прикладных программ в учебном процессе.

Методы исследования: формально-педагогический, сравнительный, логический, теоретические (анализ, обобщение и интерпретация учебных программ и пособий, педагогической, философской и методической литературы).

Работа состоит из введения, 2-х глав и литературы.

В введении выделены проблемы и актуальность данной работы.

Первая глава посвящена изучению основных видов прикладных программ текстового редактора, графического редактора, электронных таблиц и компьютерным математическим системам. Здесь рассмотрены принципы работы таких программ как: текстовые редакторы - ЛЕКСИКОН, Micfrosoft Word, графические редакторы - WinWord, 3D Studio, AutoCAD, Photoshop, CorelDraw, электронные таблицы - MS Excel, компьютерные математические системы - MatLAB, Derive, Mathematica, Maple, Mathcad.

Во второй главе раскрывается практическая реализация этих программ в обучении математики. В данной главе рассмотренны возможности текстового редактора Micfrosoft Word в составлении качественных математических документов, создание рисунков и графических объектов редакторе CorelDRAW, использование встроенных функций, мастера диаграмм, проведение различных математических вычислений в табличном редакторе MS EXCEL, построение различных графиков математических функций и использование анимации в компьютерной математической системе Mathcad.

В заключении отражены результаты исследований.

В конце работы даётся список использованной литературы.

ГЛАВА 1. Пакет прикладных программ в процессе обучения

1.1 Текстовый редактор

Практически каждый пользователь персонального компьютера сталкивается с необходимостью подготовки тех или иных документов, статей, служебных записок, отчётов и т.д. Разумеется, эти документы можно подготовить и без компьютера, например, на пишущей машинке. Однако, с появлением персональных компьютеров стало значительно проще и удобнее, а, следовательно, и выгоднее подготавливать и редактировать различные документы.

При использовании компьютера для подготовки документов текст редактируемого документа выводится на экран и пользователь может в диалоговом режиме вносить в него свои изменения. Все внесенные изменения сразу же отображаются на экране монитора, а потом при распечатке выводится красиво и правильно оформленный текст, в котором учтены все сделанные пользователем замечания и исправления.

Удобство и эффективность применения компьютеров для подготовки текстов привели к созданию множества программ для обработки документов. Пакет программ таких типов называют редактором текстов или же WORD PROCESSORS.

Возможности таких программ различны - от программ, предназначенных для подготовки небольших документов простой структуры, до программ для набора, оформления и полной подготовки к типографскому изданию книг и журналов. А в настоящее время разработаны еще и глобальные сетевые редакторы типа текстовых, которые называются издательскими системами.

Редакторы, рассчитанные на тексты программ, как правило, выполняют следующие функции:

-диалоговый просмотр текста;

-редактирование строк программ;

-копирование и перенос блоков текста из одного участка документа в другой;

-копирование одной программы или ее части в указанное место другой программы;

-контекстный поиск и замена подстрок текста;

-автоматический поиск строки;

-распечатка программы или ее части.

Кроме всего вышеперечисленного, редакторы текстов позволяют автоматически проверять синтаксическую правильность вводимой информации. Это достигается благодаря объединению отладчика программ и редактора текста.

В нашей стране широко известны такие редакторы текстов, как Multi-Edit и Borland. По своей сути они являются компиляторами для текстов.

Так же пользуется популярностью текстовый редактор «ЛЕКСИКОН», который отличается своей доступностью, простотой, компактностью, удобством для пользователя. Редактор текстов «ЛЕКСИКОН» предназначен в основном для обработки, корректировки, просмотра, разбиения на страницы, манипуляций шрифта в тексте. При работе в текстовом редакторе «ЛЕКСИКОН» компьютер выполняет роль исполнителя команд, запросов, а так же манипуляций пользователя.

Широкую известность в нашей стране получил текстовый редактор Micfrosoft Word и различные его версии, такие как Word Perfect, WordStar, WordStar 2000 и другие. Всего существует несколько сот такого рода редакторов.

Текстовый редактор Micfrosoft Word обладает универсальными средствами, которые пригодны для самых разнообразных областей применения: для подготовки финансовых документов, рекламных материалов, юридических документов, научно-технических отчетов и т.п. Для оформления документов можно использовать различные стили, шрифты, обрамление и заполнение цветом, способы выравнивания текста, перед печатью документа можно воспользоваться режимом предварительного просмотра. Процессор Word содержит средства для создания Web-страниц, позволяет вставлять в документы гиперссылки, проверять правильность написания русских и иностранных слов, правильность пунктуации, а также стиль изложения [1].

Рассмотрим основные возможности Micfrosoft Word в работе с текстовыми документами.

Под заголовком документа Micfrosoft Word расположена строка меню. В ней перечислены пункты, объединяющие сходные по своему строению опции. Следует помнить, что любые действия могут быть выполнены с помощью той или иной опции определенного пункта меню.

Строка меню.

В меню Файл находятся следующие опции : <Создать>, <Открыть>, <Закрыть>, <Сохранить>, <Сохранить как>, <Сохранить все>, <Поиск файла>, <Сводка>, <Шаблоны>, <Параметры страницы>, <Просмотр>, <Печать>, <Выход>. Эти надписи означают соответственно: создание нового документа или шаблона; открытие уже существующего; закрытие всех окон существующего документа или шаблона; сохранение существующего документа или шаблона; сохранение копии документа в другом файле; сохранение всех открытых файлов, макрокоманд элементов автотекста, с запросом на каждом; поиск существующего файла на других дисках; отображение сводки активного документа; изменение активного шаблона или его опций; изменение параметров страниц выделенных разделов; отображение страниц так, как они будут напечатаны; печать активного документа; выход из Word с запросом о сохранении документа.

Меню правка.

В меню <Правка> находятся соответствующие опции:

<Отменить ввод>, <Повторить ввод>, <Вырезать>, <Копировать>, <Вставить>, <Специальная вставка>, <Очистить>, <Выделить все>, <Найти>, <Заменить>, <Перейти>, <Автотекст>, <Закладка>, <Связи>, <Объект>. Эти надписи означают соответственно: отменяет последнюю операцию; повторяет последнюю операцию; вырезает выделение и помещает его в буфер обмена; копирует выделение в буфер обмена; вставляет содержимое содержимое буфера обмена как связанный или внедренный объект либо объект иного формата; удаляет выделение без помещения его в буфер обмена; выделяет весь документ; ищет указанный текст или оформление; ищет и заменяет указанный текст или оформление; переходит к указанному тексту в активном документе; вставляет или определяет элементы автотекста; назначает имя текущему выделению; показывает или модифицирует связи в документе; открывает приложение в котором выбранный, внедренный или связанный документ был создан.

Меню вид.

В меню <Вид> находятся соответствующие опции: <Обычный>, <Структура документа>, <Разметка страницы>, <Главный документ>, <Полный экран>, <Панели инструментов>, <Линейка>, <Колонтитулы>, <Сноски>, <Примечания>, <Масштаб>. Эти надписи означают соответственно: устанавливает режим нормального просмотра; устанавливает режим просмотра структуры документа; устанавливает режим просмотра разметки страницы; устанавливает режим просмотра главного документа; переключает режим полного экрана; управляет отображением панелей инструментов; управляет отображением линейки; отображает верхний колонтитул в режиме просмотра режима страницы; устанавливает сноски; открывает окно просмотра примечаний; устанавливает масштаб отображения.

Меню вставка.

В меню <Вставка> находятся соответствующие опции: <Разрыв>, <Номера страниц>, <Примечание>, <Дата и время>, <Поле>, <Символ>, <Поле формы>, <Сноска>, <Название>, <Ссылка>, <Оглавление и указатели>, <Файл>, <Кадр>, <Рисунок>, <Объект>, <База данных>. Эти надписи означают соответственно: завершает страницу, колонку или раздел в точке ввода; добавляет номера страниц вверху или внизу страницы; вставляет примечание или открывает окно примечаний; вставляет текущую дату и время в текущий документ; вставляет поле в активный документ; вставляет специальный символ; вставляет новое поле формы; вставляет ссылку на обычную или концевую сноску в очку ввода; вставляет название под или над выделенным объектом; вставляет перекрестные ссылки; вставляет оглавление и указатели в документ; вставляет текст из другого файла в активный документ; вставляет пустой кадр или помещает текущее выделение в кадр; вставляет рисунок из графического файла; вставляет формулу, график, рисунок или другой объект, вставляет информацию из внешнего источника данных в активный документ.

Меню формат.

В меню <Формат> находятся соответствующие опции: <Шрифт>, <Абзац>, <Табуляция>, <Обрамление и заполнение>, <Колонки>, <Регистр>, <Буквица>, <Список>, <Нумерация заголовков>, <Автоформат>, <Таблица стилей>, <Стиль>, <Кадр>, <Рисунок>, <Рисованный объект>. Эти надписи означают соответственно: изменяет вид выделенных символов; изменяет вид и нумерацию в выделенных символах и абзацах; изменяет или удаляет позиции табуляций в выделенных абзацах; изменяет обрамление и заполнение в выделенных абзацах, ячеек таблицы и рисунков; изменяет формат колонки в выделенных разделах; изменяет регистр символов в выделении; форматирует первый символ выделенного абзаца в буквицу; создает нумерованный список или список-бюллетень; изменяет опции нумерации для стилей уровней заголовков; автоматически форматирует документ; просмотр или применение стилей из шаблона; применяет, создает или изменяет стили; изменяет размер, масштаб и кодировку кадра; изменяет размер, масштаб и кодировку рисунка; изменяет заполнение, линию, размер и положение атрибутов выделенных объектов.

Меню сервис.

В меню <Сервис> находятся соответствующие опции: <Орфография>, <Синонимы>, <Перенос слов>, <Язык>, <Статистика>, <Автокоррекция>, <Слияние>, <Конверты и наклейки>, <Установить защиту>, <Исправления>, <Макрокоманда>, <Настройка>, <Опции>. Эти надписи означают соответственно: проверяет орфографию активного документа; ищет синонимы для выделенных слов; изменяет установки переноса слов для активного документа; изменяет атрибут язык для выделенных символов; отображает статистику активного документа; добавляет или удаляет элементы автокоррекции; подготавливает основной документ для слияния; печатает или создает конверт, наклейку или лист наклеек; устанавливает защиту активного документа; устанавливает режим пометки исправлений для активного документа; выполняет, создает, удаляет или редактирует макрокоманду; настраивает интерфейс пользователя Word (меню, клавиатура и панели инструментов); изменяет настройки Word для Windows.

Меню таблица.

В меню <Таблица> находятся соответствующие опции: <Вставить таблицу>, <Удалить ячейки>, <Объединить ячейки>, <Разбить ячейки>, <Выделить строку>, <Выделить столбец>, <Выделить таблицу>, <Автоформат таблицы>, <Высота и ширина ячейки>, <Заголовки>, <Преобразовать текст>, <Сортировка текста>, <Формула>, <Разбить таблицу>, <Линии сетки>. Эти надписи означают соответственно: вставляет таблицу; удаляет выделенные ячейки таблицы; объединяет выделенные ячейки таблицы; разъединяет ранее объединенные ячейки таблицы; выделяет текущую строку таблицы; выделяет текущий столбец таблицы; выделяет всю таблицу; применяет настройки форматирования к таблице; изменяет высоту и ширину строк и столбцов таблицы; переключает атрибут заголовка таблицы; преобразует текст в таблицу; располагает выделение в указанном порядке; вставляет вычисляемое поле в ячейку таблицы; вставляет маркер конца абзаца перед текущей строкой таблицы; переключает отображение линий сетки таблицы.Меню окно.

В меню <Окно> находятся соответствующие опции:<Новое окно>, <Упорядочить все>, <Разбить>. Эти надписи означают соответственно: открывает другое окно для активного документа; упорядочивает окна в виде не перекрывающейся мозаики; разбивает активное окно по горизонтали и выравнивает получившиеся части.

Меню справка.

В меню <?> находятся соответствующие опции:<Содержание>, <Найти справку по...>, <Указатель>, <Примеры>, <Совет дня>, <Техническая поддержка>, <О программе...>. Эти надписи означают соответственно: отображает содержание справки; ищет тему справки по

Рис. 9 выделенным или набранным ключевым словам; отображает указатель справки; перечисляет уроки по изучению Word; отображает различные советы и рекомендации; отображает информацию о доступной технической поддержке Microsoft Word; отображает информацию о программе и номер версии.

1.2 Графический редактор

В настоящее время существуют различные графические редакторы, с различными возможностями и функциями. Пользователю на уровне начальной стадии обучения, а в нашем случае в курсе изучения информатики, необязательно знать все типы таковых программ, их способности, характеристики и цель их назначения. Но развитие техники и научный прогресс неумолимо быстро двигается вперед. А это означает, что ознакомление с данными пакетами нужно проводить уже на начальной стадии обучения типовым пакетам прикладных программ и редакторов.

Что же такое графический редактор? Графический редактор позволяет создавать и редактировать картинки на экране компьютера. Здесь понятие "картинки" не означает, что данные редакторы "умеют" работать только с рисунками. Понятие "картинки" выступает в более широком смысле. Как правило, пользователю предоставляется возможности рисования линий, кривых, раскраска областей экрана, создания надписей различными шрифтами и т.д. Большинство редакторов позволяют обрабатывать изображения, полученные с помощью сканера, а также выводить полученные картинки в таком виде, чтобы они могли быть включены в документ, подготовленный с помощью текстового редактора или издательской системы. Некоторые из редакторов дают возможности получения трехмерного изображения объектов, преобразования растровых изображений в векторный формат, профессиональные средства цветообработки и т.д.

Одними из самых простейших графических редакторов являются ZSoft Paintbrush, Adobe Illustrator, News.

Известность получили более мощные графические редакторы типа Corel Draw, пакеты программ с графическим редактором фирмы Microsoft, к которым относятся такие программы, как Microsoft Craft и наиболее популярная графическая оболочка Windows разных версий и типов. Имеются также редакторы, которые позволяют в научной и инженерной графике строить разного рода диаграммы и графики. Такие системы рисуют графики функций заданных в табличном и аналитическом виде, что очень удобно не только для опытных пользователей, но и для учащихся школ и других учебных заведений. Из таких программ наиболее популярны программы Harvard Grafics, SB Grafics и пакеты программ общего назначения типа Mathematica.

Редакторы типа системы деловой и научной графики позволяют наглядно представлять на экране различные данные и зависимости. Такие редакторы позволяют выводить на печать и экран различного рода гистограммы, круговые и секторные диаграммы и т.д.

Большую популярность получили также системы автоматизированного проектирования, которые позволяют осуществлять черчение и конструирование различных механизмов. Одним из лидеров графических редакторов является WinWord, поддерживаемый графической оболочкой Windows разных версий. Данный редактор предоставляет пользователю широкое меню услуг. Одним из удобств является то, что все возможности редактора появляются на экране монитора в виде маленьких картинок с меткой-подсказкой внизу. Войдя в каждый из этих так называемых меню т.е. раскрывая любую из этих картинок можем попасть в подменю, которое устроено так же. После очередного распахивания меню экрана, "входим" в экран редактора. То есть, выбирая нужный пункт меню, работаем в режиме графического редактора.

В ходе работы с графическим редактором WinWord можно набирать текст различных шрифтов, вставлять в нужное место готовые рисунки, графики, диаграммы, строить их самому, рисовать и редактировать готовые образцы.

Графический редактор Micfrosoft WinWord дает возможность пользователю осуществлять удобную работу с файлами, куда входит создание графических документов, их загрузка, сохранение и автосохранение, создание резервных копий, защита данных, дополнительные сведения о файлах. Пользователь может работать со структурой "документов", что включает в себя управление рабочими листами, добавление рабочих листов в документ, переименование рабочих листов, коррекция высоты строк и ширины столбцов.

Графический редактор дает возможность:

-построения таблиц;

-производить табличные вычисления;

-построение и оформление диаграмм ;

-работа с функциями (конструирование, редактирование, вычисление суммы, комбинирование, текстовый режим индикации формул);

-обмен данными типа импортирования рисунков, включение таблиц в текст и т.д.;

-обработка списков и анализ данных;

-создание баз данных;

-конфигурирование системы(редактора);

-получение справки и помощи.

Одной из приоритетных областей применения графических редакторов является выполнение построений графиков различных функций (с предварительным созданием таблицы значений аргументов и функции). Существует множество пакетов, которые можно использовать при изучении этой темы. Одним из них является CorelDraw. Пакет обладает большими возможностями и работает под управлением Microsoft Windows. Он может использоваться при решении самых разнообразных графических задач (создание анимации, графиков, презентаций, рисования иллюстраций). В CorelDraw для создания и преобразования изображений применяется богатый набор инструментов и команд. Используя различные системы цветов, можно создавать свой собственный цвет или пользоваться встроенными палитрами, содержащими тысячи оттенков. CorelDraw имеет различные возможности редактирования кривых, с помощью которых созданный рисунок можно довести до совершенства. Популярность CorelDraw можно объяснить возможностью применения спецэффектов.

Еще одним пакетом трехмерной графики для IBM-совместимых компьютеров является пакет 3D Studio фирмы AutoDesk Inc. Он обладает различными возможностями для создания высококачественных фотореалистических изображений и анимации. 3D Studio дает возможность легко создавать на персональном компьютере такие геометрические интерпретации, которые раньше требовали привлечения мощных рабочих станций. Последняя версия пакета 3D Studio отличается от предыдущих заметным ускорением процесса построения изображения (рендеринга), ускоренным предварительным просмотром процесса анимации (preview), обратной кинематикой (inverse cinematics), дающей возможность более наглядно оперировать с иерархическими объектами, языком управления анимацией (KeyFramer Script language), онлайновыми поверхностями, вписыванием изображения в уже готовую фотографию и т. д.

Необходимо иметь в виду, что применение графических пакетов и пакетов анимационной графики не должно ограничиваться демонстрациями и иллюстрациями в учебном процессе, нужно использовать возможности, которые они предоставляют, для выполнения различного рода учебных заданий и проектов, для осуществления исследовательской деятельности.

Пакет AutoCAD фирмы Autodesk также можно использовать при изучении математики в средней школе. С момента создания этого пакета прошло уже несколько лет, регулярно появляются новые версии. AutoCAD, представляющий собой международный стандарт, представляет разработчикам широкие возможности проектирования разнообразных технических систем. Чертежи, рисунки и схемы создаются в интерактивном режиме. В любой чертеж может быть вставлен поясняющий текст. В набор функций меню входят панорамирование, увеличение, масштабирование, поворот, секционирование, штриховка и другие операции преобразования изображений, имеется режим подсказки на каждом этапе работы.

Работа с этим пакетом дает возможность избежать таких трудоемких второстепенных операций при подготовке чертежей, как вычерчивание и заполнение форматки, проставление размеров и специальных знаков, нанесение различных видов штриховок, осевых линий, воспроизведение повторяющихся или стандартных элементов чертежа. Одним из важных достоинств AutoCAD является возможность работы с трехмерной графикой, позволяющей обучаемому строить реальные объекты, создавать проволочную модель, окрашивать лицевую и внутреннюю поверхности, отображать объект в различных проекциях. Пакет имеет несколько видовых экранов, на каждом из которых возможно отображение объекта при взгляде на него из определенной точки трехмерного пространства, что формирует пространственное изображение объекта. Причем любые изменения в одном окне автоматически вносятся во все остальные. Динамические возможности пакета позволяют вращать, перемещать трехмерные объекты в реальном времени, изменять их цвет. Таким образом, все перечисленные достоинства пакета AutoCAD позволяют говорить о целесообразности использования его при обучении математике. Причем пакет AutoCAD можно использовать не только для демонстрации геометрических объектов, способов их построения, но и также как графическую среду для выполнения учебного проекта.

И наконец, пакет Photoshop, который является законодателем стандартов в области обработки растровых изображений. Он существует в версиях для всех наиболее популярных операционных систем и способен работать с изображениями, созданными в любой из них. Развитый интерфейс программирования стимулировал интерес многочисленных разработчиков к созданию подключаемых модулей, которые делают Photoshop наилучшим инструментом для решения именно ваших профессиональных задач.

Photoshop, наряду с Illustrator, Acrobat и In Design, образует основу пакета издательских программ Adobe. Разработчики с большим вниманием относятся к обеспечению совместимости и интеграции всех программ пакета. Комплексное использование этих программ обеспечит удобство в работе и позволит избежать проблем переноса документов и неожиданностей при печати. Развитие Интернета стимулировало рост числа документов, предназначенных исключительно для электронного распространения. Большинство профессиональных разработчиков и множество любителей приняло Photoshop как основное средство подготовки графики для таких публикаций. Последними версиями своей программы специалисты Adobe откликнулись на проявление нового круга пользователей. Image Ready, новый компонент Photoshop, дает в руки Web-дизайнера все необходимые средства для создания современного и привлекательного графического решения любого Web-сайта. Новые фильтры импорта и экспорта PDF пригодятся тем, кто готовит документы в формате Adobe Acrobat.

Программа Adobe Photoshop один из самых популярных пакетов для обработки, изменения, сохранения графических объектов. Photoshop позволяет работать с палитрой, калибровать, сканировать, импортировать и экспортировать,выделять области, контуры, рисовать/редактировать, выбирать цвета, слои, каналы и маски, фильтры, размер изображения и его разрешение,цветокоррекция, преобразовать изображения, цветоделение, печать изображения.

1.3 Электронные таблицы

Электронные таблицы -- это специальные пакеты программ, разработанные для решения задач, которые можно представить в виде таблиц. На первых порах электронные таблицы применялись для обработки числовых данных. Современные электронные таблицы позволяют проводить численные эксперименты с математическими моделями, их можно использовать как простую базу данных, а также для изготовления форматированных документов с произвольной информацией. Электронные таблицы можно использовать для построения диаграмм, описывающих динамику изучаемых процессов. Эта программа является средством для экспериментирования и формирует у ученика умение находить оптимальное решение, возможность выражать решение уравнения в числовой и графической форме, умение отыскивать целочисленные решения. Работая с электронными таблицами, ученик приобретает навыки построения диаграмм по заданным значениям х и у, исследования схемы построения числовых последовательностей, анализа статистических данных.

Электронные таблицы представляют собой экран с пронумерованными ячейками. В каждую ячейку загружается некоторая информация, которая в ней и хранится. Электронные таблицы стандартного вида, которыми пользуются практически все пользователи в настоящее время разработаны фирмой Microsoft.

Электронные таблицы позволяют пользователю пакетов прикладных программ загрузить документ на экран, сохранить его, создавать копии и новые документы, а также большое количество других возможностей. Пользователь может подготавливать бухгалтерские документы, причем создаваемым документам можно присваивать разные имена. Каждый документ располагается на отдельном листе. В электронных таблицах вся информация, как уже отмечалось выше, записывается в так называемые ячейки памяти. Ячейки памяти находятся на пересечении строк и столбцов таблицы.

Возможность использования различных шрифтов, формул и функций является одним из важнейших свойств программ обработки электронных таблиц. Это, в частности, позволяет проводить статистический анализ числовых значений в таблице. Пользователю дается возможность доступа к табличным вычислениям и информационным связям, которые устанавливаются между ячейками таблицы.

Пакеты прикладных программ по обработке электронных таблиц имеют следующие возможности:

-вмонтированный менеджер файлов;

-диалоговые окна-регистры;

-отдельную пиктограмму для форматирования;

-механизмы типа Drag&Plot для быстрой активизации диаграмм.

Наибольшей популярностью в среде графических редакторов пользуются пакеты MS Excel в среде Windows и другие пакеты программ обработки электронных таблиц в среде Windows разных версий.

Рабочие листы электронной таблицы MS Excel, в которых хранятся различные документы, используются для составления таблиц, вычисления статистических оценок, управления базой данных и составления диаграмм. Для каждого из этих приложения программа создает отдельный документ и сохраняет на диске в виде файла. Файл может содержать несколько взаимосвязанные рабочих листов, образующих единый документ.

Рабочие листы - это непосредственно таблицы и диаграммы EXEL. Переход от одного листа к другому выполняется с помощью ярлычков, расположенных внизу листа ( рис. 10).

Рис. 10. Вид экрана при запуске EXCEL.

Ячейки таблицы в EXСEL расположены на пересечении столбцов и строк, которые обозначаются А, В, С, … и 1, 2, … соответственно. Таким образом, адрес ячейки формируется из названия столбца и номера строки, например А1, В12. Всего рабочий лист может содержать 256 столбцов и 16384 строк.

Активная ячейка - это ячейка, в которой установлен курсор. Она выделяется темной рамкой. Переход между ячейками производится с помощью мыши или клавиш управления курсором.

Интервал (или блок) ячеек задается адресами левой верхней и правой нижней ячеек, разделенных двоеточием, например А1:C4; B1:B10. Для выделения блока ячеек можно использовать мышь (перемещать при нажатой левой кнопке) или клавиши управления курсором при нажатой клавише Shift.

Ввести данные можно непосредственно в активную ячейку, либо набрав их в строке формул и нажав клавишу Enter. Если текст не помещается в активной ячейке, он автоматически распространяется на соседнюю ячейку. Если не помещается число - ячейка заполняется символами “#”.

Для удобства представления данных в EXСEL применяются различные форматы ячеек (числовой, денежный, научный, процент, дата и др.). Формат

влияет только на внешнее представление данных в ячейке (в отличие от функций округления). Примеры форматов (Таб. 1):

Таблица 1.

Содержимое ячейки

Формат

Результат

1234,567

1234,567

1234,5

1234,567

1234,5

1234,567

1234,567

0,23

1.4.96

1.4.96

Числовой

0

0,00

# ##0,00

Денежный

# ##0 р.

# ##0,00 р.

Научный

0,00E+00

##0,0E+0

Процент

0,00%

Дата

Д.ММ.ГГ

Д.МММ.ГГ

1235

1234,57

1 234,50

1 235 р.

1 234,50 р.

1,23E+03

1,2E+3

23%

1.04.96

1.апр.96

Присвоить формат ячейке или блоку ячеек, предварительно выделив их, можно с помощью команды Ячейки меню Формат или нажав правую кнопку мыши и набрав команду Формат ячеек.

В понятие формат ячейки входят также формат используемого шрифта, выравнивание, обрамление и заполнение, защита, которые задаются в диалоговом окне Формат ячеек или с помощью кнопок на панели инструментов (Рис. 11).

Рис. 11. Панель инструментов MS EXCEL .

Рис. 12. Панель форматирования.

Помимо различных типов данных ячейки таблицы EXCEL могут содержать формулы. В формулах допустимо использование следующих операторов: сложение (+), вычитание (-), деление (/), умножение (*), возведение в степень (^), =, <, >, <>, <=, >= и так называемых операторов связи диапазона (:), объединение(;) и объединение текстов(&).

Для ввода формулы необходимо:

1) выделить ячейку и нажать клавишу = (равно);

2) Набрать формулу и нажать Enter.

Например:

=2*6-9;

=A1*5-B3/2+C4^2

Первая формула содержит только константы и знаки арифметических операций. Вторая формула использует ссылки на ячейки А1, В3 и С4. Содержимое этих ячеек представляется в формулу и после нажатия клавиши Enter вычисляется результат. Таким образом, в ячейке показывается результат вычисления формулы, а саму формулу можно увидеть и/или отредактировать только в строке формул, предварительно выделив нужную ячейку. Следует заметить, что ссылки на ячейки во второй формуле можно набрать не только с клавиатуры, а также с помощью мыши. Для этого после нажатия клавиши = (равно) щелкните мышью в ячейке A1 (в строке формул автоматически появится A1), затем наберите *5-, щелкните мышью в ячейке В3 и т.д.

Электронная таблица MS Exsel предоставляет широкие возможности для построения различных диаграмм - графического представление числовых данных.

Для создания диаграммы необходимо выделить блок ячеек с данными, а также названиями рядов и категорий. После этого можно воспользоваться командой Диаграмма из меню Вставка или кнопкой Мастер диаграмм. В первом случае выбирается место расположения диаграммы, во втором случае курсор мыши принимает форму пиктограммы и необходимо щелкнуть мышью в том месте, где будет располагаться верхний левый угол диаграммы. Электронная таблица MS Exsel предоставляет широкие возможности выбора диаграмм различных типов (Рис. 13).

Рис. 13. Окно Мастера диаграмм в MS Exsel

В диаграмме с областями отдельные ряды данных представлены в виде закрашенных разными цветами областей.

При использовании линейчатой диаграммы отдельные значения будут представлены полосами различной длинны, расположенными горизонтально вдоль оси X.. Длина полосы соответствует величине числового значения.

Линейчатая диаграмма, в которой отдельные значения представлены вертикальными столбиками различной длинны, называется гистограммой.

Для всех трех указанных выше типов диаграмм при выборе соответствующего формата каждый ряд значений можно представить как долю от общей суммы.

На графике все отдельные значения будут соединены между собой линиями, полученными путем интерполяции. График не стоит использовать, если отдельные абсолютные значения не взаимосвязаны.

При использовании круговой диаграммы сумма всех значений принимается за 100%, а процентное соотношение величин изображается в виде круга, разбитого на несколько секторов разного цвета. В круговой диаграмме допускается только один ряд данных.

Кольцевая диаграмма - это особый вид круговой диаграммы. В этом случае сумма всех значений также принимается за 100%, а ряды данных представляют собой вложенные кольца, разделенные на сегменты в процентном отношении. Преимущество кольцевой диаграммы перед круговой состоит в возможности одновременного изображения нескольких рядов данных.

Радар - это диаграмма, в которой категории представляются лучами, расходящимися из одной точки. Каждое значение ряда данных будет выделено на оси и соединено с другими замкнутой линией.

На XY (точечной) диаграмме отдельные значения таблицы представляются точками в декартовой системе координат, которые не соединены линиями. Этот вид диаграммы больше всего подходит для представления независимых отдельных значений.

При создании объемных диаграмм с областями используется система координат с тремя осями.

Объемная гистограмма, объемная линейчатая и объемная круговая диаграммы позволяют достичь эффекта пространственного представления данных.

Объемный (трехмерный) график приобретает форму лент. Принцип построения объемных поверхностей диаграмм напоминает применяемый в картографии способ представления на физических картах высоты участка местности над уровнем моря.

Для редактирования внедренной диаграммы необходимо сначала активизировать ее двойным щелчком мыши, после чего вокруг нее появится жирная рамка, а в меню добавятся команды для редактирования диаграмм. Затем с помощью мыши или клавиш управления курсором Вверх и Вниз можно выделить для редактирования любой элемент диаграммы, а именно: область диаграммы, область построения, основание и стенки объемных диаграмм, легенду, оси, текст, стрелки, линии сетки, любой из рядов данных и др.

1.4 Компьютерные математические системы

Широкими возможностями для использования в процессе обучения обладают математические пакеты (MatLAB, Derive, Mathematica, Maple, Mathcad и др.).

Пакет Mathematica является сегодня наиболее популярным в научных кругах, особенно среди теоретиков. Пакет предоставляет широкие возможности в проведении символических (аналитических) преобразований, однако требует значительных ресурсов компьютера. Система команд пакета во многом напоминает какой-то язык программирования.

Пакет Maple также весьма популярен в научных кругах. Пользователи характеризуют Maple как очень надежный и устойчиво работающий пакет. Кроме аналитических преобразований пакет в состоянии решать задачи численно. Характерной особенностью пакета является то, что он позволяет конвертировать документы в формат LMgX -- стандартный формат подавляющего большинства научных издательств мирового класса. Кроме того, ряд других программных продуктов используют интегрированный символический процессор Maple. Например, пакет подготовки научных публикаций Scientific Workplace (фирма TCI Software Research) позволяет обращаться к символическому процессору Maple, производить аналитические преобразования и встраивать полученные результаты в документ.

Подобно упомянутым выше пакетам, пакет Matlab фактически представляет из себя своеобразный язык программирования высокого уровня, ориентированный на решение научных задач.

Особое место занимают пакеты класса MathCAD, относящиеся к так называемым CAD-системам (Computer Aided Design - дизайн или проектирование с помощью компьютера). Характерной особенностью пакета является использование привычных стандартных математических обозначений, то есть документ на экране выглядит точно так же обычный математический расчет. Для использования пакета не требуется изучать какую-либо систему команд, как, например, в случае пакетов Mathematica или Maple. Они имеют доступный и понятный интерфейс и потому пользуются успехом у пользователей. MathCAD ориентирован на решение математических задач с широким привлечением двумерной и трехмерной графики. Важными для обучения являются анимационные возможности пакета MathCAD, благодаря которым можно визуально наблюдать поведение различных объектов в динамике (колебания маятника, движение груза на пружине, полеты ракет по космическим траекториям и т. д.) и адекватно этому представлять геометрические интерпретации. Пакет так же даёт широкие возможности для проведения численных расчетов и имеет встроенный символический процессор Maple, что позволяет выполнять аналитические преобразования. В отличие от упомянутых выше пакетов, Mathcad является средой визуального программирования, то есть не требует знания специфического набора команд. Простота освоения пакета, дружественный интерфейс, относительная непритязательность к возможностям компьютера явились главными причинами того, что именно этот пакет был выбран для обучения студентов численным методам.

В последнее время просматривается тенденция к сближению и интеграции различных пакетов. Например, последние выпуски пакетов Mathematica и Maple имеют хорошие возможности для визуального программирования; в Matlab включена библиотека аналитических преобразований Maple; Mathcad позволяет работать совместно с Matlab.

Еще одной системой, которую можно использовать в образовании, является математический пакет символьной математики Derive, который удачно сочетает возможности проведения численных и символьных вычислений с простотой в обращении и невысокими требованиями к используемой компьютерной технике. Пакет имеет многооконный интерфейс пользователя и удобную систему меню. Языком реализации является один из самых известных функциональных языков -- Лисп. Он ориентирован на решение задач искусственного интеллекта и построение экспертных систем. Ввод математических символов в этой среде выполняется с клавиатуры набором слов (sqrt, abs и т. д.), которые порождают на дисплее изображения соответствующих математических символов, при необходимости в двумерном виде (например, дроби). Графический редактор позволяет получать двумерные графики в декартовой и полярной системах, координат и трехмерные графики, которые автоматически масштабируются. Современные версии Derive являются расширяемыми системами, способными адаптироваться для решения специальных задач пользователя.

Для автоматизации вычислительной и информационно-поисковой деятельности можно использовать калькулятор в компьютере. Калькулятор применяется при построении матриц функциональных зависимостей, для создания и изучения таблиц и графиков функций, анализа статистики, в приближенных вычислениях и в прогнозировании результатов числового анализа.

При изучении геометрического материала можно использовать такие пакеты, как “Живая геометрия”, Cabri Geometry, Logo, Geometry Inventor, Geometer's Sketch Pad, Конструктор геометрических фигур. Главной идеей всех этих продуктов является “открытие” геометрических закономерностей, возможность проведения компьютерного геометрического эксперимента. Программа “Живая геометрия” (русифицированная версия американской программы Geometer's SketchPAD) -- это обучающая и развивающая среда, используемая для различных геометрических построений и экспериментов. Она предоставляет возможность работы с учащимися различных уровней подготовки. Программа позволяет создавать красочные, легко варьируемые и редактируемые чертежи, осуществлять операции над ними, а также производить все необходимые измерения. В ней содержится систематизированный набор компьютерных чертежей (около 1000), иллюстрирующих практически все теоретические материалы и задачи учебника. Главной особенностью чертежей, выполняемых с помощью этой программы, является их динамичность. Чертеж как файл существует вместе со своими возможными деформациями. Свойство варьируемое позволяет свободно перемещать по экрану с помощью мыши исходные элементы, причем все отношения сохраняются, и эстетическая привлекательность чертежей, их управляемость и редактируемость создают предпосылки для осуществления геометрического эксперимента. При необходимости чертежи можно компоновать в сценарии, возможность рекурсии в построении сценариев выводит пользователя на качественно новый уровень создания и визуализации геометрических объектов. При определенных методических подходах программа позволяет учащемуся выявить закономерности в наблюдаемых геометрических явлениях, самостоятельно формулировать теоремы, подтверждать уже доказанные теоремы, применять их на практике.

Новое качество приобретает самопроверка учащимися своих работ. Чертежи предназначены, прежде всего, для самостоятельной работы детей. В процессе этой работы учащийся находится в прямом контакте с элементами чертежей; он может их деформировать, перемещать, раскрашивать, регулировать, например, толщину линий и насыщенность областей. Кроме того, он может вызывать имена объектов, производить измерения и располагать записи результатов измерений по своему вкусу. Функции учителя в процессе такой работы являются в основном консультирующими и контролирующими.

Используя пакеты динамической геометрии, ученики познают строгость, красоту и мощь мира геометрии, создают фигуры и при помощи различных манипуляций исследуют их. Наглядность и четкость образов делают процесс изучения математики более увлекательным и позволяют привить ученику интерес к изучению предмета. Предлагается использовать на уроках математики такой программный продукт, как программа рисования. Ученики могут создавать свои собственные картины, используя геометрические объекты. Можно нарисовать квадрат. Это задание даст ученикам возможность почувствовать природу данной конструкции. Следующее задание, которое можно предложить ученикам, -- деление прямоугольника на части. Нужно нарисовать прямоугольник, выбрать точку на одной из его сторон и соединить эту точку и противоположный угол. Затем необходимо измерить и сравнить площади полученных трапеции и треугольника. Перетаскивая мышью выбранную точку вдоль стороны прямоугольника, ученик может наблюдать, как меняются площади этих фигур. Выполнение всех действий должно сопровождаться объяснением полученных результатов.

По нашему мнению использование КМС преобразует деятельность как учащихся, так и учителя, изменяя её содержание и структуру. По мнению В.Я. Ляудиса, автоматизация педагогического труда не приведёт к утрате его главной психологической ценности - непосредственного межличностного общения и взаимодействия между учителем и учеником. Межличностное общение не будет деформировано, оно получит новые возможности для своего значительного творческого обогащения.

Выводы по главе 1

На основании проведенного анализа материалов научно-методических изданий и собственного практического опыта применения информационных технологий нами были рассмотрены следующие прикладные программы: текстовые редакторы - ЛЕКСИКОН, Micfrosoft Word, графические редакторы - WinWord, 3D Studio, AutoCAD, Photoshop, CorelDraw, электронные таблицы - MS Excel, компьютерные математические системы - MatLAB, Derive, Mathematica, Maple, Mathcad. В главе подробно рассмотрено назначение и основные принципы работы данных прикладных программ.

ГЛАВА 2. Практическая реализация пакета прикладных программ в обучении математики

2.1 Реализация текстового редактора Micfrosoft Word в процессе обучения математики

В данном параграфе рассмотрим возможности текстового редактора Micfrosoft Word в составлении качественных математических документов.

Набор и редактирование формул в Micfrosoft Word

Вставить в текст формулы можно разными способами. Простые формулы можно набрать как обычный текст. Например, F = ma (2-й закон Ньютона).

Для создания простых формул полезно знать, как делается верхний и нижний индекс и как вставить нестандартные символы (т, в, л). Это понадобится для ввода таких выражений, например: s=s0+v0t+at2/2 и ?f=-sin(xa-1)?x.

Для вставки символов, отсутствующих на клавиатуре можно воспользоваться диалоговым окном Символ.

1. Щелкните место вставки символа.

2. В меню Вставка выберите команду Символ, а затем откройте вкладку Символы.

3. В списке Шрифт выберите нужный шрифт.

4. Дважды щелкните символ, который следует вставить.

5. Нажмите кнопку Закрыть.

Например, используя данные опции, мы набираем формулу Закона сохранения энергии:

Использование поля Eq

Существенно обогатить вид формул можно с помощью вставки поля Eq (Вставка/Поле…, в списке Поля выберите Eq, отобразите Коды поля и нажмите Параметры…). В таблице 2. приведено несколько примеров.

Таблица 2.

Ключ

Описание

Пример использования

Результат

\f(;)

Дробь

\f (sin ?;cos ?)

\b()

Скобки автоматического размера

\b (1 ??\f(1; x2))

\i(;;)

Знак интеграла, суммы (с подключом \su) или произведения (с подключом \pr)

\i \su (i = 1;N; xi)

\s()

Управляет надстрочными и подстрочными знаками (верхними и нижними индексами)

D\s(2;0)

\o()

Наложение символов

\o(z;?), \o\ar(x;^), \o(y;.)

\l()

Формирует список из любого числа элементов, разделенных запятыми или точками с запятой, который затем можно использовать как один элемент

\l(A,B,C,D,E)

\r()

Отображает знак радикала над одним или двумя элементами

\r(3,x)

Чтобы изменить созданное поле, щёлкните правой кнопкой мыши и в контекстом меню выберите Изменить поле… для запуска мастера или Коды/значения полей для ручного редактирования.

Использование редактора формул Microsoft Equation.

Приведённая ниже формула

создана при помощи Microsoft Equation - встроенного редактора формул Microsoft Office. Чтобы запустить Реактор формул необходимо выполнить следующие действия:

в меню Вставка/Объект выбрать Microsoft Equation или на панели инструментов щелкнуть на кнопке

На экране появится панель инструментов Формула (Рис. 15):

В открытом редакторе формул, мы видим различные символы, которые предлагает нам панель инструментов Формула для набора и редактирования математических выражений (Рис. 16). Заметьте также, что меню изменилось: Вид, Формат, Стиль, Размер содержат пункты настройки Microsoft Equation.

Несколько слов о шрифтах

В шрифте Symbol также можно найти много дополнительной математической символики (например, и др.), позволяющей не прибегать к редактору формул.

Для удобства работы с формулами целесообразно добавить несколько кнопок на панель инструментов. Для этого кликните правой кнопкой мыши по любому месту панели инструментов и выберете Настройка… (самый нижний пункт), в закладке «Команды» выберите категорию «Вставка», найдите команду «» и перетащите её (drag&drop) на панель инструментов, из категории «Формат» перетащите «», «» и «».

Теперь, для того чтобы, например, вставить объект Microsoft Equation, не нужно лезть в меню - достаточно нажать кнопку ?б «Редактор формул».

Работа с автофигурами

Автофигуры, как и большинство других объектов, могут быть вставлены в любое место документа Microsoft Word и расположены поверх текста и других объектов, на заднем плане или, что более предпочтительно для удобной верстки, в качестве составного элемента текста (опция «В тексте» вкладки Формат автофигуры/Положение).


Подобные документы

  • Развитие творческого мышления в процессе решения задач и расширение области познания детей. Проектная деятельность. Продуктивное мышление. Графический редактор. Текстовый редактор. Электронные таблицы. Создание баз данных (БД), Web-страниц, презентации.

    реферат [20,1 K], добавлен 01.02.2009

  • Текстовый редактор как средство создания, обработки и хранения документов равной степени сложности. Интерфейс текстового редактора MS Word, редактирование и форматирование текста. Работа с таблицами, рисунками и диаграммами. Распечатывание документа.

    дипломная работа [283,4 K], добавлен 03.05.2009

  • Corel Draw - профессиональный пакет для создания векторных иллюстраций с возможностями редактирования текста, макетирования и подготовки Интернет-публикаций. Технологические возможности графического редактора. Ознакомление с инструментами этой программы.

    курсовая работа [1,9 M], добавлен 31.05.2009

  • Функционально-структурная организация персонального компьютера. Операционная система Windows. Функции стандартизации программы графического редактора Paint. Рисование геометрических объектов и оформление рисунков с помощью графического редактора Paint.

    курсовая работа [680,1 K], добавлен 03.12.2008

  • Если в документе Word есть вставленный объект, то Word называют приложением-клиентом. В приложения Microsoft Office можно вставлять растровые и векторные рисунки, а встроенный в Word графический редактор позволяет создавать графические объекты.

    реферат [190,9 K], добавлен 08.01.2009

  • Назначение и классификация текстовых редакторов. Характеристики и новые возможности MSOffice Word 2007. Оценка графических преимуществ и возможностей текстового редактора. Сравнительные характеристики возможностей OpenOffice.org Writer и Word 2007.

    дипломная работа [7,9 M], добавлен 05.01.2011

  • Описание текстового редактора MS WORD, его возможности. Основные элементы интерфейса редактора: кнопка Office, главные команды панели быстрого доступа, лента, контекстное меню и полоса прокрутки. Рабочая область приложения, настройка строки состояния.

    реферат [24,0 K], добавлен 23.10.2014

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.