Проектирование печатной платы РЭС в программной среде Altium Designer v.10

Краткое описание РЭС. Создание файла принципиальной электрической схемы. Проектирование библиотеки элементов. Формирование 3D-модели ПП и Gerber-файлов. Создание печатной платы. Проверка правильности электрических соединений. Компиляция проекта.

Рубрика Коммуникации, связь, цифровые приборы и радиоэлектроника
Вид курсовая работа
Язык русский
Дата добавления 17.05.2014
Размер файла 5,2 M

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru

Размещено на http://www.allbest.ru

Министерство образования и науки

Государственное образовательное учреждение

высшего профессионального образования

«Московский государственный технический университет

им. Н. Э. Баумана»

Факультет РЛ

Кафедра РЛ6 «Технологии приборостроения»

Группа РЛ6-89

Домашнее задание №1

Проектирование печатной платы РЭС

в программной среде Altium Designer v.10

Вариант 14

Выполнил: Боярцев А.В.

Проверил: Чижов А.С.

Москва 2013

Оглавление

Учебное задание

Краткое описание РЭС

Создание нового проекта

Создание файла принципиальной электрической схемы

Создание библиотеки элементов

Компиляция проекта

Создание печатной платы

Формирование 3D-модели ПП

Проверка правильности электрических соединений

Формирование Gerber-файлов

Составление УП для сверления отверстий в ПП на станке с ЦУ

Список использованных источников информации

Учебное задание

печатная плата схема компиляция

Спроектировать для своего варианта в программной среде Altium Designer v.10 печатную плату, после чего составить отчёт в формате .doc с описанием последовательности проделанной работы:

- содержание учебного задания с принципиальной схемой РЭС и кратким её описанием и назначением;

- размещение ЭРЭ на ПП; печатная плата схема аltium

- трассировка ПП ручным способом и автотрассировкой (по каким-либо двум из предлагаемых критериев) c их сравнительной оценкой;

- 3D изображение ПП со всеми электрорадиоэлементами (ЭРЭ) в натуральном виде («не кубиками») в двух проекциях - со стороны печатного монтажа и со стороны ЭРЭ;

- проверка правильности электронной модели РЭС на DRC с помощью модуля Signal Integrity;

- разработать gerber-файл(ы);

- исходные данные (размещение монтажных отверстий) и УП сверления монтажных отверстий в ПП на станке с ЦУ, используя модуль CAMtastic.

Текст, написанный шрифтом Times New Roman 12 кеглей с интервалом 1,15, должен быть проиллюстрирован «скриншотами» этапов выполнения задания. К тексту приложить все файлы с соответствующими расширениями для подтверждения выполнения этапов своего варианта задания в среде Altium Designer.

Краткое описание РЭС

Передача “Поле чудес” пользуется неизменной популярностью у телезрителей. Подобную игру можно провести и самим, например, в школе на вечере отдыха. Для нее необходим игровой барабан с секторами. Мы предлагаем вашему вниманию электронный вариант такого “барабана”.

Рис.1. Принципиальная электрическая схема звукового преобразователя «голос робота».

Как и в “Поле чудес”, электронный "барабан" имеет несколько секторов с указанием результата "хода'', сделанного участником. Но в отличие от телевизионной игры, "барабан” неподвижен, а в секторах вспыхивают поочередно светодиоды, имитируя вращение "барабана", и раздается звуковой сигнал.

Схема “барабана" приведена на рис. I. На логических элементах DD1.I и DD1.2 собран генератор прямоугольных (тактовых) импульсов, а на элементах DD1.3, DD1.4 -- генератор 34. После подачи выключателем SA1 напряжения питания загорается один из светодиодов НИ--HL10. Но генераторы 8 это время не работают, поскольку на входных выводах 13 и 1 их логических элементов низкий уровень напряжения. При нажатии на кнопку SB 1 “Пуск" напряжение поступает на входной вывод 13 элемента DD1 1, в результате чего заряжается конденсатор С1 начинает работать тактовый генератор. Его импульсы высокого уровня поступают с вывода 10 логического элемента DD1.2 на вход CN счетчика-дешифратора DD2, а также на вывод 1 элемента DD1.3, разрешая работу генератора 34. Импульсы 34 с генератора поступают через резистор R7 на усилитель звуковой частоты, выполненный на транзисторе VT1, и воспроизводятся капсюлем BF1 (ДЭМШ-1). Тактовые импульсы, поступая на вход счетчика-дешифратора, вызывают последовательное появление на его выходах сигналов высокого уровня, поочередное открывание электронных ключей на транзисторах VT2--VT11 и зажигание (также поочередное) светодиодов HL1 -- HL10. Поскольку светодиоды расположены по окружности, создается эффект “вращения барабана". Скорость “вращения" можно изменять переменным резистором R4.

После отпускания кнопки генератор тактовых импульсов продолжает некоторое время работать -- пока не разрядится конденсатор С1. Затем генерация прекращается, импульсы на счетчик не поступают, остается горящим лишь один из десяти светодиодов. Прекращается, естественно, и звуковой сигнал, поскольку на выводе 1 элемента DD1.3 появляется сигнал низкого уровня.

При следующем нажатии на кнопку SB1 процесс повюряе1Ся.

Цепочка R5C3 ослабляет влияние генератора 34 на работу счетчика, резисторы R7 и R8 -- токоограничительные, конденсатор С5 ослабляет помехи, проникающие в цепи питания

Конструктивно “барабан” выполнен в пластмассовом корпусе (рис 2) размерами 143x84x45 мм. На верхней панели корпуса расположен лист ватмана, на котором начерчена окружность, разделенная на секторы с буквенно-цифровой разметкой, а также надписями "ВКЛ” и “ПУСК". Сверху лист закрыт прямоугольной пластиной из органического стекла с отверстиями под светодиоды Надписи в секторах могут быть самыми разнообразными, заимствованными из популярной игры или придуманными ее организаторами. Переменный резистор расположен в центре секторов

Внутри корпуса размещены батарея питания (например, 3336) и печатная плата (рис 3) из одностороннего фольгированного стеклотекстолита, на которой смонтированы все элементы устройства, кроме кнопки и выключателя.

Если при проверке устройства наблюдаются сбои в работе счетчика-дешифратора, надо подобрать резистор R5.

Создание нового проекта

Базовой концепцией формирования данных, вырабатываемых в Altium Designer 10 и относящихся к одному объекту того или иного вида, является проект. Проект представляет собой текстовый файл-оболочку, объединяющую иерархически организованный набор документов, предполагающих воплощение их в единственном объекте.

Комплект документов, которые создают проект, формируется совместно с файлом проекта. Файл проекта содержит все установки, включая связи с каждым документом в проекте и все проектно-зависимые опции. Каждый документ в проекте записывается как отдельный файл, который связан с проектом через относительные ссылки к файлам на одном и том же логическом устройстве или абсолютные ссылки на файлы на различных логических устройствах. Выходные данные, генерируемые из проекта, также ссылаются на проектный файл.

Проект платы -- РСВ Project (*.PrjPcb) - строится в модуле PCB программы. Набор документов, необходимых для изготовления печатной платы. Электронная схема вводится в редакторе схем, создаваемая из библиотечных символов, которые размещаются на листе и соединяются проводниками. Проект передается в редактор плат, где каждый компонент представляется как посадочное место (корпус) и проводники на схеме преобразуются в соединительные линии от вывода к выводу. Определяется окончательный вид платы, совместно с физическими слоями платы. Описываются правила проектирования для изготовления фотошаблона, такие как ширины проводников и зазоры. Компоненты размешаются в пределах контура платы и соединяются линиями связей, которые затем заменяются трассами, вручную или автоматически. Когда проект закончен, генерируются выходные файлы в стандартных форматах, которые можно использовать для изготовления платы, установки компонентов на сборочной машине и т. д.

Создание проекта печатной платы (ПП) осуществляется с помощью опции File > New > Projects > PCB Project, как показано на рисунке 2.

Рис.2. Создание проекта печатной платы

Проектный файл в данный момент существует только в оперативной памяти компьютера, поэтому для его сохранения на жестком диске необходимо использовать команду File > Save Project As… (рис.3).

Рис.3. Сохранение проекта

При работе с документами проекта удобно использовать панель Projects. Ее можно активировать с помощью команды View > Workspace Panels > System > Projects (рис.4).

Рис.4. Активация панели Projects

Создание файла принципиальной электрической схемы

Добавление в проект файла принципиальной электрической схемы осуществляется нажатием правой кнопки мыши по названию проекта на панели Projects и выбору команды Add New to Project > Schematic (рис.5).

Рис.5. Добавление файла принципиальной электрической схемы в проект.

При первом создании нового документа схемы стоит обратить внимание, что схема открывается в дюймовой системе измерения. Поэтому, прежде чем приступать к реализации схемы, стоит настроить параметры рабочей области и текущего листа схемы. Начнем с настроек текущего документа, которые устанавливаются на вкладке Design > Document Options. Начать настройки следует с вкладки Units, на которой следует указать использование метрической системы единиц и выбрать миллиметры в качестве основной единицы измерения (рис. 6).

Рис.6. Настройка единиц измерения.

Далее на вкладке Sheet Options следует установить параметры сеток: Snap, Visible, Electrical:

Snap Grid - определяет дискретность перемещения по схеме - установим 1 мм.

Visible Grid - видимая сетка - установим 5 мм.

Electrical Grid - определяет область вокруг вывода компонента, за которую «цепляется» цепь при соединении компонентов. Значение данного параметра должно быть в 2 раза меньше, чем минимальный шаг расположения выводов УГО, чтобы области двух соседних выводов не пересекались между собой. Установим значение 1 мм. Жмём ОК для подтверждения выбранных настроек.

Для работы с библиотеками компонентов необходимо активировать панель Libraries с помощью команды View => Workspace Panels => System => Libraries (рис.7а).

а) б)

Рис.7. Последовательность пользования библиотекой: а) активация панели Libraries, б) выбор резистора из библиотек.

Для размещения УГО необходимого ЭРЭ на схеме нужно подключить необходимую библиотеку (или выбрать из списка уже подключенных библиотек), найти элемент в списке (можно использовать строку поиска) и, выделив название элемента в списке, нажать кнопку Place <Название_компонента>. Далее необходимо поместить символ на рабочем поле схемы щелчком левой кнопки мыши. На рис.7б приведен пример выбора резистора из стандартной библиотеки элементов Miscellaneous Devices.IntLib.

Создание библиотеки элементов

Полное описание электронных компонентов в Altium Designer 10 складывается из трех самостоятельных описаний:

1) элемента библиотеки схемных символов *.SchLib (в отечественной лексике - УГО);

2) элемента библиотеки топологических посадочных мест *.PCBLib;

3) файлов описания модели - SPICE-модели аналогового компонента, XSPICE-модели цифрового компонента и/или IBIS-модели для анализа паразитных эффектов в печатном монтаже (целостности сигнала).

Элемент схемной библиотеки, кроме непосредственно УГО и описания электрических контактов, содержит ссылку на “модель”. Модель представляет собой иерархическую структуру, объединяющую ссылки на две последние составные части полного описания компонента.

Библиотечные описания символа и посадочного места могут использоваться в проектировании самостоятельно, либо могут быть скомпилированы в интегральную библиотеку. Преимуществом интегральной библиотеки является ее компактность, возможность автоматически извлекать в проект составные части интегрированного образа в зависимости от того, ведется проектирование электрической схемы или печатной платы, либо моделирование, а также невозможность редактирования компонентов интегральной библиотеки. Компонент может быть открыт для редактирования из интегральной библиотеки командой Extract Sources.

Создание новой интегральной библиотеки элементов

1) Для создания интегральной библиотеки активизируем команду главного меню File > New > Project > Integrated Library (рис.8а). По этой команде образуется библиотечный пакет с именем Integrated_Libraryl.LibPkg. Этот пакет имеет статус проекта, его имя отображается в плавающей панели Projects.

2) Переименуем и сохраним образованный пакет в дисковой памяти. Для этого щелчком правой клавиши мыши на его имени в панели Projects активизировать в плавающем контекстном меню команду Save Projects As, ввести с клавиатуры новое имя, например, Transistor (рис.8б).

3) Добавим в созданный библиотечный пакет новую (пустую) библиотеку схемных символов. Для этого щелчком правой клавиши мыши на имени проекта Transistor.LibPkg активизируем плавающее контекстное меню и укажем в нем команду Add New to Project > Schematic Library. В дереве проекта открывается новый узел - библиотека с именем SchLibl.SchLib; в главном окне программы открывается пустой лист редактирования схемного компонента Component_l (рис.9а).

4) Активизируем в главном меню File команду Save As, переименуем и сохраним файл схемной библиотеки с именем Transistor.SchLib (разрешение писать не нужно) (рис.9б).

5) Активизируем в строке статуса панель-закладку SCH > Library. Открывается пустая плавающая панель редактирования SCH Library (рис.9в).

а) б)

Рис.8. Формирование интегральной библиотеки: а) создание библиотеки, б) ее сохранение.

а) б) в)

Рис.9. Формирование библиотеки символов: а) создание библиотеки, б) ее сохранение

в) активация панели SCH Library.

Формирование нового компонента может начинаться по команде главного меню Tools > Library, но в нашем случае, т.к. уже открылась панель SCH Library с пустым шаблоном Component l, можно просто переименовать его и начать процедуру формирования логического символа NPN-транзистора.

1) Укажем курсором на имя Component_l и активизируем команду главного меню Tools > Rename Component. Введем имя КТ315 в поле имени окна Rename Component и завершим переименование щелчком ОК.

2) Установим точку привязки графики УГО в центр окна редактирования командой главного меню Edit > Jump > Origin (горячие клавиши J, О). На графическом экране окна редактирования эта точка помечается перекрестием. Вокруг этой точки обычно строится вся графика УГО. В дальнейшем, при вызове логических символов из библиотеки и размещении их на поле электрической схемы, программа ведет символ за электрическую “горячую точку” - окончание линии электрического контакта, ближайшего к точке привязки графики.

3) Активизируем команду главного меню Tools > Document Options и настроим в диалоговом окне Library Editor Workspace основные элементы рабочего пространства редактора библиотек:

* Units - систему единиц измерения - установим метрическую систему единиц;

* Grids > Snap - сетку захвата при построении графики;

* Grids > Visible - сетку, видимую на экране.

В нашем частном случае целесообразно установить шаг сетки захвата 0,5 мм, а шаг видимой сетки 5 мм (рис.10).

а) б)

Рис.10. Настройка элементов рабочего пространства: а) настройка сетки, б) настройка единиц измерения.

Вычертить в окне графического редактирования УГО NPN- транзистора в соответствии с ГОСТ 2.743-91 и ГОСТ 2.759-82.

1. Активизируем команду главного меню Place > Line. Курсор меняет вид на перекрестие. Графический примитив Line представляет собой полилинию - все отрезки ломаной линии образуют единый объект.

2. Клавишей Tab активизируем функцию настройки ширины линии. Открывается диалоговое окно настройки PolyLine (рис. 11).

Рис.11. Диалоговое окно настройки PolyLine.

В окно вынесены следующие настройки линии:

* Line Width - ширина линии: курсором указывается один из вариантов ширины

* Smallest - тонкая, шириной около 0,1 мм;

* Small - тонкая, шириной 0,254 мм;

* Medium - средняя, шириной около 0,5 мм;

* Large - большая, шириной около 1 мм.

* Line Style - стиль, сплошная (Solid), точечная (Dotted) или пунктирная (Dashed);

* Color - цвет - выбирается из цветовой палитры, открывающейся по щелчку левой на цветном прямоугольнике;

* Фигуры, которыми начинается и кончается линия - Start Line Shape и End Line Shape - стрелки, точки, квадраты и т.п., или отсутствие фигур (None), а также размер этих фигур-наконечников (Line Shape Size).

Щелчком на OK завершить настройку.

3. Проложим необходимое число отрезков, образующих элементы УГО, фиксируя начало и конец каждого щелчком левой клавиши. Черчение очередного отрезка завершается щелчком правой клавиши мыши или клавишей Esc. Перед вычерчиванием линии эмиттера клавишей Tab снова активизировать настойку параметров и указать стрелку на конце отрезка (рис. 12).

Рис.12. УГО NPN-транзистора.

Далее необходимо присоединить выводы:

1) Активизируем команду главного меню Place > Pin (горячие клавиши Р, Р). На графическом экране появляется изображение электрического контакта, перемещающееся за курсором по экрану. Точка присоединения электрической связи к контакту помечена косым перекрестием. В лексике Altium Designer эта точка называется “горячим концом” (hot end). При совмещении вывода с УГО линия вывода должна примыкать к УГО противоположным концом.

2) Перед размещением вывода вызовем клавишей Tab диалог редактирования его свойств. Открывается диалоговое окно настройки свойств вывода Pin Properties (рис. 13)

Установить следующие свойства вывода:

* Display Name - логическое имя или функциональное назначение контакта. В соответствии с требованиями SPICE-технологии схемотехнического моделирования последовательность ввода и обозначений выводов транзистора должна быть: коллектор-база-эмиттер. По умолчанию первому вводимому контакту дается обозначение 0 (нуль). Изменим это обозначение на 1. Обозначения следующих выводов автоматически инкрементируются.

* Designator - имя или цоколевочное обозначение вывода, используемое при автотрассировке. По умолчанию это обозначение совпадает с обозначением Display Name и также инкрементируется. Присвоим ему обозначение B ( вывод будем устанавливать на базу, для коллектора - С, для эммитера - Е). Целесообразно также отключить видимость обозначений выводов, т.к. их функциональное назначение в случае транзистора ясно из графики УГО (видимые обозначения будут у выводов микросхем).

* Electrical Туре - электрический тип вывода. Для выводов транзистора установить тип Passive.

* Description - текстовое описание функции вывода компонента.

* В поле Graphical установить:

1. Length - длину линии вывода: установить длину 5 мм.

Orientation - ориентация линии: установить угол разворота линии вывода (против часовой стрелки, относительно положительного направления оси X). Ориентация может также меняться при установке вывода на графическом экране последовательными нажатиями клавиши ПРОБЕЛ (SPACE).

3. В иоле Symbols оставить без изменения признак No Symbol - отсутствие указателей полярности, направления передачи сигнала и т.п.

3) Щелчком ОК завершить редактирование свойств вывода и установить его на УГО в окне графического редактирования компонента.

а) б)

Рис.13. Формирование выводов: а) вызов команды, б) редактирование свойств вывода.

4) Повторить действия пп. 2, 3 для следующих выводов компонента.

5) Командой главного меню File > Save сохранить построенный компонент в библиотеке. Результат формирования схемного символа отображается в полях плавающей панели SCH Library (рис. 14).

Рис.14. Сформированное УГО NPN-транзистора.

Далее необходимо редактировать свойства компонента.

1) Аналогично п. 1 предыдущего раздела, активизировать диалоговое Library Component Properties (рис. 15).

2) В поле Default Designator внести буквенный префикс позиционного обозначения по ГОСТ 2.710-81. В случае транзистора это VT. Добавить в строку с префиксом вопросительный знак. При составлении электрической схемы на его место в позиционное обозначение вносится порядковый номер компонента, в пределах группы функционально однородных.

3) В поле Comment вписать строку комментария, в нашем случае, КТ315.

4) В поле Description вписать описание компонента, по которому он будет отыскиваться при активизации поисковой системы. В нашем случае описание может быть, например, Transistor NPN.

Остальные поля в правой половине окна, остаются пока свободными. Они будут заполняться при присоединении к компоненту моделей.

Рис.15. Свойства КТ315.

Элемент DD1 на базе микросхемы К176ЛА7 относится к многосекционным компонентам. Схемный символ многосекционного компонента может быть построен целиком, со всеми секциями в едином УГО. В этом случае создание такого символа ничем не отличается от рассмотренного. Однако, для формирования принципиальной электрической схемы, которая бы легко читалась и наглядно демонстрировала принцип действия функционального узла, такое изображение не всегда удобно. Из соображений удобочитаемости схемы и понимания ее функционирования часто бывает удобно изображать схему разнесенным способом. При едином УГО на весь компонент это невозможно, и приходится тянуть к нему линии электрической связи издалека, что затрудняет чтение схемы.

Поэтому целесообразно рассмотреть особенности формирования схемного символа многосекционного компонента разнесенным способом.

1) Выполним действия аналогично пп. 1...5 предыдущего раздела. Присвоим при этом новому библиотечному проекту имя KR176.LibPkg, а присоединенной к нему библиотеке схемных компонентов - имя KR176.SchLib.

2) Переименуем пустой компонент Component_l в плавающей панели SCH Library, присвоив ему имя KR176LA7 и установим точку привязки графики в центре главного окна графического редактора.

3) Активизируем команду главного меню Place > Line и вычертим квадрат УГО, со стороной 15 мм.

4) Активизируем команду главного меню Place > Pin и вызвать клавишей Tab диалог настройки свойств электрического вывода. Назначить первому выводу:

* обозначение Designator - 1, в соответствии с цоколевкой микросхемы, имя Display Name также также назначить 1;

* электрический тип назначить Passive, чтобы избежать размещения меток, противоречащих требованиям ЕСКД;

Закроем диалог настройки и зафиксировать первый вывод в главном окне графического редактора.

5) Продолжим установку следующих выводов. Перед установкой третьего, выходного вывода снова активизируем диалог настройки вывода, развернем вывод на 180° и установим значок инверсии выходного сигнала Outside Edge - Dot (рис. 16).

а) б)

Рис.16. Секция УГО КР176ЛА7: а) изображение, б) свойства вывода.

Для создания последующих 3-х секций (все 4 ячейки внутри одного компонента) используем Tools > New Part. Так как у нас ячейки одинаковы то графику можно копировать с последующим редактированием выводов.

При разработке библиотек, в которых у компонентов будут установлены скрытые выводы, удобно включить отображение скрытых выводов. В нашем случае выводы 7 и 14 относятся к питанию и земле, и должны быть не показаны на символе. Для установки скрытых выводов нужно при установке вывода (командой Place > Pin) зайти в свойства компонента нажатием клавиши Tab. После установки названий и обозначений выводов их стоит разместить на первой ячейке компонента (рис. 17.) при этом электрические точки привязки (hot end) этих выводов должны располагаться на корпусе.

После установки, выводов в соответствии с описанием, следует поочередно зайти в свойство каждого вывода и установить дополнительные настройки. В свойствах вывода нужно включить опцию Hide и в поле Connect То задать имя цепи, к которой по умолчанию будет подключаться данный вывод. Кроме этого, обычно, для таких выводов ставят значение 0 в поле Part Number, что говорит о непринадлежности данного вывода к какой-то конкретной ячейке микросхемы. Результат создания символа показан на рисунке 17. Если оставить принадлежность скрытого вывода к первой ячейке микросхемы, и если при этом на схеме будут задействованы только 2,3 и 4 ячейки, у микросхемы не будет подключения к соответствующей цепи! Если выводы питания и земли были созданы правильно, то при переключении между ячейками компонента они будут отображаться у всех ячеек.

а) б)

Рис.17. Установка скрытых выводов питания и земли: а) вывод питания, б) вывод земли.

Остальные УГО создаются аналогично рассмотренным выше.

Создание новой библиотеки посадочных мест

Процедура формирования новой библиотеки топологических посадочных мест (ТПМ) компонентов не отличается от процедуры формирования библиотеки схемных символов.

1) Активизируем команду главного меню File > New > Library > PCB Library. В главном окне Altium Designer открывается пустое рабочее пространство редактора РСВ-библиотек с именем новой библиотеки PcbLibl.PcbLib. Одновременно имя библиотеки появляется в ноле проектов плавающей панели Projects как свободный документ (рис. 18а.).

2) Переименуем новую библиотеку: активизируем команду главного меню File > Save As и укажем имя библиотеки, например, TPM.PcbLib.

3) Щелчком мыши на закладке РСВ в строке статуса и выбором в выпадающем меню команды РСВ Library активизируем плавающую панель редактирования ТПМ (рис. 18б.).

В поле Components, представлено имя нового, пустого, компонента PCBCOMPONENT1.

а) б)

Рис.18. Формирование библиотеки ТПМ: а) вызов команды, б) свойства.

4) Выведем курсор в свободное поле главного окна, со щелчком левой клавишей, после чего несколько раз нажимаем клавишу Page Up (“горячая” клавиша масштабирования изображения), пока на экране не станет видна сетка.

Формирование посадочного места компонента заключается в определении его конструкции и размещении в рабочем пространстве редактора РСВ Component Editor контактных площадок для электрического подсоединения, а также черчении линий контура компонента. Линии контура располагаются обычно в слое шелкографии Top Overlay. Контактные площадки для монтажа компонентов со штыревыми выводами формируются в слое Multi-Layer. Контактные площадки для поверхностно-монтируемых компонентов формируются в верхнем сигнальном слое Top Layer.

1) Перед началом формирования ТПМ следует задать систему единиц измерения и выполнить настройку сеток проектирования. Для этого активизировать команду главного меню Tools > Library Options. Открывается диалоговое окно Board Options (рис. 18.). Применительно к задаче формирования ТПМ отечественных компонентов, следует установить метрическую систему единиц измерения и настроить три сетки:

* Component Grid - сетка размещения компонентов. Значение шага сетки по горизонтали и по вертикали выбирается из выпадающего списка или вводится с клавиатуры.

* Snap Grid - сетка захвата. Назначается для размещения графических объектов - линий, вырезов и т.п. Шаг данной сетки также назначается из выпадающего списка или с клавиатуры и должен находиться в дробном соотношении с шагом сетки компонентов.

* Visible Grids - две, лучше всего, кратные, так называемые видимые сетки. Эти сетки используются только для визуального контроля действий при размещении объектов, их выравнивании и выполнении других операций графического редактирования.

2) Переименуем открытое в панели РСВ Library пустое посадочное место PCBCOMPONENT1. Назовем имя этого посадочного места по имени корпуса этого транзистора КТ-13.

3) Установим точку привязки графики в центр графического листа редактора ТПМ. Для этого воспользуемся “горячими” клавишами - последовательно нажать J, R.

Рис.19. Настройка редактора посадочных мест.

1) Активизируем команду главного меню Place > Pad (горячие клавиши Р, Р). Перед тем, как фиксировать плавающую за курсором контактную площадку (КП) на поле графического редактора, вызовем клавишей Tab диалог редактирования ее параметров. Открывается диалоговое окно свойств контактной площадки, Pad (рис. 20.).

2) В поле Location укажем координаты КП на поле графического редактора. Указываем координаты 0, 0.

3) В поле Hole Information установим вид и размер отверстия КП. Возможны следующие варианты формы отверстия:

* Round - круглое;

* Square - квадратное;

* Slot - щель.

Выбираем круглое отверстие диаметром (Hole Size) 1,4 мм. Такой диаметр превышает на 0,4 мм ширину ленточного вывода транзисторов в корпусе КТ-13 (требование ГОСТ 10317-79, обусловленное необходимостью свободной установки выводов компонентов в монтажные отверстия КП).

4) В ноле Size and Shape выбираем форму и размеры площадки металлизации КП. Возможны следующие варианты формы;

* Round - круглая, а при указании разных размеров по осям X Y - овальная форма;

* Rectangular - прямоугольная форма;

* Octagonal - восьмиугольник.

Для нашего ТПМ КТ-13 устанавливаем круглую форму с размерами X-Size 2,8 мм и Y-Size 2,8 мм.

1) В поле Properties назначим цоколевочное обозначение КП (Designator) - сохраним принятый для схемного символа порядок обозначений выводов и обозначим вывод коллектора цифрой 1. Кроме цифровых, возможны буквенные (Alphabetic) и смешанные буквенно-цифровые обозначения выводов (Alphanumeric).

2) Зафиксируем сформированную КП на поле графического редактора щелчком мыши или клавишей Enter.

После фиксации на экране первой сформированной КП за курсором начинает перемещаться вторая. Зафиксируем вторую и третью КП (выводы базы и эмиттера) по разные стороны от вывода коллектора. Обозначения Designator при этом автоматически инкрементируются.

а) б)

Рис.18. Формирование ТПМ: а) свойства КП, б) результат.

При создание посадочного места под корпус DIP целесообразно воспользоваться Мастером создания посадочного места - Component Wizard. Для этого в списке посадочных мест на панели PCB Library необходимо щелкнуть правой кнопкой мыши и выбрать Component Wizard… (рис.19).

Рис.19. Активация Component Wizard.

Появится окно приветствия Мастера. Щелкните Next.

В следующем окне необходимо выбрать тип компонента выберите Dual Inline Packages (DIP). Тип единиц - Metric (mm) (рис.20). Щелкните Next.

Рис.20. Выбор типа ЭРЭ и системы единиц.

В следующем окне необходимо настроить параметры металлизированного отверстия и контактных площадок с учетом размера сечения выводов компонента и класса точности ПП. В связи с этим выберем:

Внешний диаметр металлизированного отверстия - 0.9 мм.

Внутренний диаметр металлизированного отверстия - 0.9 мм.

Диаметр контактной площадки - 2 мм (рис.21).

Нажмите Next.

Рис.21. Настройка параметров металлизированного отверстия.

В следующих окнах необходимо настроить параметры:

Расстояния между контактами - расстояние между соседними выводами - 2.5 мм, расстояние между рядами выводов - 15 мм.

Ширина линии, обозначающей границы элемента - 0.2 мм.

Число выводов - 14.

Имя посадочного места - DIP 14.

Нажмите Finish. Результат - на рис.22. Сохраните библиотеку на жестком диске командой File > Save As…

Рис.22. Созданное посадочное место DIP 14.

Теперь необходимо привязать посадочное место к УГО. Для этого вернёмся к редактированию библиотеки ЭРЭ, во вкладку SCH Library. Выделим компонент К561ИЕ8 и нажмём кнопку Edit. Откроется окно редактирования ЭРЭ (рис.23).

Рис.23. Окно редактирования ЭРЭ.

В появившемся окне необходимо указать префикс позиционного обозначения ЭРЭ - «DD?». Знак «?» позволит в дальнейшем произвести автоматическую нумерацию ЭРЭ. Рекомендуется оставить галочку Visible в позиции Default Designator и убрать ее с позиции Default Comment.

Для добавления посадочного места к ЭРЭ используйте команду в разделе Models: Add… > Footprint и выберите нужное посадочное место из списка (рис.24).

Рис.24. Выбор посадочного места.

Altium Designer автоматически сделает привязку контактов на УГО к контактным площадкам на посадочном месте элемента.

Вернитесь в окно редактирования принципиальной схемы. Разместите на рабочем поле схемы все необходимые компоненты, в соответствии с электрической принципиальной схемой устройства и списком ЭРЭ (рис.25).

Рис.25. Размещенные ЭРЭ на ПП.

Следующий шаг заключается в рисовании линий связи между ЭРЭ. Для этого используется инструмент Place Wire. При его применении следует внимательно следить за тем, чтобы цепи были привязаны к контактам УГО. Для размещения на схеме символов земли и питания используются соответствующие инструменты - GND Power Port и VCC Power Port. Указать номиналы сопротивлений, емкостей и других параметров ЭРЭ можно через окно Edit каждого ЭРЭ. Схема после проведения линий связи и редактирования параметров приведена на рис.26.

Рис.26. Схема с соединенными ЭРЭ.

Последним этапом перед компиляцией проекта является автоматическая нумерация ЭРЭ схемы, которая выполняется командой Tools > Annotate Schematic. Далее следует нажать кнопку Update Change List, в результате чего в таблице Proposed Change List будет показана новая нумерация. Предложенный вариант устраивает пользователя, поэтому следует нажать кнопку Accept Changes. Наконец, в окне Engineering Change Order нужно последовательно нажать кнопки Validate Changes, Execute Changes и Close, после чего во всей схеме будет установлена автоматическая нумерация ЭРЭ. Таким образом, получаем схему с пронумерованными ЭРЭ (рис.27).

Рис.27. Схема с пронумерованными ЭРЭ.

Компиляция проекта

Перед передачей информации от принципиальной электрической схемы в файл платы необходимо выполнить компиляцию проекта. В рамках компиляции проводится проверка ранее заданных правил и создается отчет о корректности выполнения проекта. Кроме того, все найденные в ходе проверки ошибки помечаются на схеме и сопровождаются комментарием об их природе. Результатом компиляции является отлаженный файл проекта, готовый к формированию проекта.

Компиляция проекта осуществляется с помощью команды меню Project > Compile PCB Project. Возможные ошибки появятся на панели Messages (View > Workspace Panels > System > Massages). На рис.28 видно, компиляция прошла успешно, ошибок не найдено.

Рис.28. Окно Messages.

Формирование 3D-модели ПП

Просмотреть 3D-изображение ПП можно с помощью команды View > Switch to 3D. Изначально можно увидеть только ПП, т.к. 3D-модели не всех ЭРЭтов имеются. Недостающие 3D изображения создаём в любом CADе и сохраняем в формате STEP. На рис.29 показан пример создания модели конденсатора в системе Autodesk Inventor 2010 и ее сохранение в формате .stp.

а) б)

Рис.29.Пример создания модели в CADe: а) 3D-модель ЭРЭ; б) сохранение в формате STEP.

Создав модели для всех ЭРЭ, необходимо разместить их на ПП. Для этого в режиме 3D просмотра ПП нужно выполнить Place > 3D Body. Появится окно 3D Body (рис.30).

Рис.32. Окно 3D Body.

Для размещения ЭРЭ на вкладке 3D Model Type нужно выбрать Generic STEP Model, затем нажать кнопку Embed STEP Model и выбрать необходимую модель.

Создание печатной платы

Теперь создадим файл платы. Создадим плату для данного проекта с помощью мастера печатных плат, для чего выберем команду РСВ Board Wizard в панели Files (рис.29).

Рис.33. Панель Files.

Появившийся мастер РСВ Board Wizard по этапам запрашивает информацию о печатной плате, которая потом выразится в виде конструктивных параметров и правил проектирования. Для продолжения в появившемся окне нажмем кнопку Next. В следующем окне будет предложено выбрать систему единиц измерения, в нашем случае это метрическая система мер. Нажмем кнопку Next. Далее будет предложен список существующих шаблонов стандартных промышленных печатных плат, но так как у нас нет шаблона, выбираем Custom (пустой бланк). При этом привилось окно, в котором нужно задать форму и размеры будущей платы.

В правой части данного окна задается толщина линий прорисовки границы платы (Boundary Track Width) и размеров (Dimension Line Width), а также отступ от края платы (Keepout Distance From Board Edge).

Следующее окно предложит выбрать число сигнальных слоев, а также внутренних слоев питания и заземления. Наша плата будет иметь только два сигнальных слоя, поэтому в поле Signal Layers следует ввести число 2, а в поле Power Planes -- число 0. Для продолжения нажмем кнопку Next. Далее следует определить тип переходных отверстий. Так как мы проектируем простую двухстороннюю плату, то выберем тип Thru-hole Vias (сквозные переходные отверстия).

В следующем окне необходимо выбрать преобладающую технологию монтажа ЭРЭтов (поверхностный или монтаж в отверстия). При выборе опции Thru-hole components (преобладает монтаж в отверстия) ниже указывается допустимое число проводников между смежными контактными площадками. Если была выбрана опция Surface-mount components (преобладает поверхностный монтаж), ниже указывается разрешено или нет двустороннее размещение SMD-компонентов.

На следующем шаге от нас требуется задать минимально допустимые размеры объектов на печатной плате, которые будут преобразованы мастером в правила проектирования. Здесь задаются минимально допустимые: ширина проводника (Track Size), диаметр площадки переходного отверстия (Via Width), Диаметр переходного отверстия (Via Hole Size) и зазор между проводниками (Clearance). Для простоты, оставим эти значения заданными по умолчанию. Нажмем кнопку Next.

Последнее диалоговое окно сообщает, что создание заготовки платы завершено. Если необходимо внести какие-либо коррективы в заданные значения, то с помощью кнопки Back можно вернуться в нужное окно. В противном случае нажмем кнопку Finish.

Описание правил в ручном виде осуществляется через диалоговое окно Design Rules, которое вызывается с помощью команды меню Design > Rules.

После описанных действий откроется файл платы созданного шаблона с базовым числом настроек (рис.34). Этот файл необходимо сохранить и добавить в текущий проект.

Рис.34. Пустой файл печатной платы.

Процедура переноса информации из схемы в плату выполняется по команде Design > Import Changes From <Имя_проекта>... При запуске этой команды появляется окно (рис. 35), в котором представлен список отличий между схемой и платой.

Рис.35. Список отличий между схемой и платой.

Вначале командой Validate проверяется возможность внесения изменений. После того, как команда Validate подтверждает возможность внесения всех изменений, выполняется команда Execute, результатом которой будет загрузка всех данных из схемы в плату. В результате на пустом шаблоне будут размещены все ЭРЭ печатной платы (рис.36).

Рис.36. ЭРЭты на шаблоне платы.

Основным этапом разработки ПП, который, в общем-то, и определяет, какой будет эта ПП, является процедура расположения ЭРЭ на плате с учетом технического задания и формирование топологии печатных проводников. Несмотря на то, что в программе Altium Designer имеются автоматические инструменты размещения ЭРЭ на плате, разместим компоненты вручную, поскольку автоматическое размещение малоэффективно.

Разместим ЭРЭ в области, отведенной под разводку ПП, стремясь сократить число пересечений связей до минимума (рис.37).

Рис.37. Размещенные на плате ЭРЭты.

Трассировку печатных проводников произведем несколькими методами.

Рассмотрим режим интерактивной трассировки. Он включается командой меню Place > Interactive Routing или соответствующей пиктограммой из инструментов меню . По умолчанию в качестве режима интерактивной трассировки выбран Walkaround Obtacle - огибание препятствий. Изменить режим можно одновременным нажатием Shift +R. Трассировка ПП в интерактивном режиме представлена на рис.38.

Рис.38. ПП, разведенная в режиме интерактивной трассировки.

При необходимости трассировки одного проводника на разных слоях ПП используются переходные отверстия, которые размещаются по команде Place > Via.

Инструментарий автотрассировки расположен в меню Auto Route. Чтобы выполнить автоматическую трассировку, используем команду Auto Route > All, после чего появится окно Situs Routing Strategies (рис.39).

Данное окно служит для настройки стратегии трассировщика Situs. На вкладке Routing Strategy присутствуют пять заранее заданных эталонов стратегии трассировки:

Cleanup -- «чистка» топологии;

Default 2 Layer Board -- простая двухслойная плата;

Default 2 Layer With Edge Connectors -- двухслойная плата с торцевым разъемом;

Default Multilayer Board -- многослойная плата;

General Orthogonal -- преимущественно ортогональная трассировка;

Via Miser -- трассировка с минимизацией числа переходных отверстий.

Платы, разведенные по разным стратегиям трассировки, показаны на рис.40 и рис.41.

Рис.39. Окно Situs Routing Strategies.

Рис.40. ПП, разведенная по стратегии Default 2 Layer Board.

Рис.41. ПП, разведенная по стратегии General Orthogonal.

Вывод

Сравнивая полученные трассировки, можно сказать, что Стратегия Default 2 Layer Board, позволяет получить ПП с наименьшей общей длиной проводников, уменьшить до минимума число переходных отверстий по сравнению с интерактивной трассировкой и сократить время разводки проводников. Однако при каких-либо особых требованиях к ПП (например, ортогональное размещение проводников) следует изменить стратегию трассировки, либо задать правила автоматической трассировки вручную, либо использовать интерактивный режим трассировки.

Рис.42. 3D модель ПП РЭС.

Проверка правильности электрических соединений

Теперь проверим правильность электрических соединений с помощью модуля Signal Integrity. В этом модуле все проводники на ПП представляются в виде отрезков линий передачи и проводится расчет переходных процессов при воздействии на них импульсных сигналов. Модуль Signal Integrity запускается командой Tools > Signal Integrity из меню редактора ПП (рис.43).

Рис.35. Окно модуля Signal Integrity.

Выбирая Details из контекстного меню, мы получаем отчет для выбранного проводника (рис. 44). В нём отражены длина проводника, порядковый номер, полное сопротивление (мин., макс и среднее), входящие цепи и другие параметры. Здесь же указаны все входящие в схему цепи. Из этого списка последовательно выбирается интересующая цепь для анализа, при этом она перемещается в правое окно.

Рис.44. Окно свойств проводника.

Выбирая Model Assignements… , получаем все параметры ЭРЭ: наименование, описание на ПП, его значение, а также УГО и посадочное место на ПП.

Формирование Gerber-файлов

Gerber -- файловый формат, представляющий собой способ описания проекта печатной платы для изготовления фотошаблонов на самом разнообразном оборудовании. Практи-чески все современные системы автоматизации проектных работ позволяют генерировать выходные файлы в формате Gerber. С другой стороны почти всё современное оборудо-вание позволяет считывать данные в этом формате.

Для генерации Gerber файлов необходимо выполнить команду File > Fabrication Outputs > Gerber Files. На экране появится диалоговое окно Gerber Setup (рис.45).

Рис.45. Диалоговое окно Gerber Setup.

На вкладке General укажем формат численных данных для вывода в Gerber файлы: в поле Unit выберем опцию Millimeters, что соответствует метрической системе измерения, а в поле Format укажем формат численных данных для вывода в Gerber файлы. Выберем опцию 4:4, что соответствует записи координат объектов в формате 0000.0000.

На вкладке Layers, в списке Plot/Mirror Layers необходимо выбрать слои, которые будут выведены в Gerber файлы. Каждый слой выводится в отдельный файл с именем совпадающим с именем чертежа платы и уникальным расширением. Таблица соответствия слоев будет приведена в итоговом отчете. Чтобы выбрать все используемые слои, нужно нажать на кнопку Plot Layer и выбрать Used On.

Нажатием кнопки ОК завершим процесс настройки и запустим процесс генерации Gerber файлов. Система автоматически создаст три набора файлов, размешенных в разные категории. Отчет о том, что представляет собой каждый из этих файлов, приведен в файле *.REP из категории текстовых файлов. В документе *.RUL представлен сокращенный список установленных в проекте правил, необходимый для дальнейшей обработки Gerber файлов.

В категории Generated Documents будут созданы файлы в формате Gerber с уникальны-ми расширениями, каждый из которых соответствует своему слою. В некоторые из файлов добавлена информация из слоя Multi-Layer, в котором содержатся изображения кон-тактных площадок. Но главным будет файл CAMtasticl.CAM из категории Documents, представляющий собой проект встроенного в Altium Designer модуля подготовки плат к производству CAMtastic. Именно этот файл будет автоматически открыт на рабочем столе системы (рис. 38). Производителю для изготовления платы можно передать набор одиночных gerber-файлов, которые расположены в папке Out внутри директории проекта или один файл САМ, который в себе имеет всю информацию о слоях.

Рис.38. Рабочее окно файла CAMtastiv.cam.

Выходные файлы в формате САМ не воспринимаются программой технологической подготовки к производству печатных плат САМ350, поэтому производителю, который использует данную программу следует передавать файлы в формате Gerber.

11. Составление УП для сверления отверстий в ПП на станке с ЦУ

Другая важная операция, которую требуется выполнить в процессе подготовки проекта платы для производства -- это генерация УП для сверлильного станка с ЦУ (NC Drill).

Процесс генерации файлов сверления предельно упрощен, а дальнейшая их доработка выполняется в редакторе CAMtastic. В редакторе печатных плат системы Altium Designer выполним команду меню File > Fabrication Outputs>NC Drill Files. На экране появится диалоговое окно NC Drill Setup (рис.39). Аналогично созданию Gerber-файлов в поле Unit выберем опцию Millimeters, что соответствует метрической системе измерения, а поле Format укажем формат численных данных 4:4. Остальные настройки оставим без изменения и нажмем кнопку ОК.

Рис.39. Диалоговое окно NC Drill Setup.

Система автоматически создаст несколько файлов, которые будут добавлены в папку Out к ранее созданным Gerber файлам. В категорию Generated Documents добавится би-нарный файл *.DRL (рис.50), здесь же будет расположен файл *.LDP (рис.51), содержащий информацию о назначенных парах слоев сверления, что необходимо для изготовления многослойных печатных плат с глухими и слепыми переходными отверстиями. Файл *.ТХТ содержит собственно файл сверления в текстовом формате Excellon (рис.42). Именно этот файл будет импортирован в новый проект CAMtastic2.CAM, автоматически созданный системой.

Рис.50. Файл DRR.

Рис.51. Файл LDP.

При импорте файла в САМ проект появится диалоговое окно Import Drill Data. Нажмем кнопку Units и в окне NC Drill Import Setting, укажем метрическую систему единиц и формат численных данных 4:4, после чего нажатием кнопки ОК закроем окно. Нажатием кнопки ОК запустим процедуру импорта. На рабочем столе системы Altium Designer откроется редактор CAMtastic в режиме редактирования NC Drill файлов, о чем свидетельствует вид его панели управления.

На основании этих двух файлов будет сформирована УП для сверлильного станка с ЦУ. В ней отражены координаты отверстий и контактных площадок для нанесения их на ПП, сгруппированных под каждые элементы отдельно (рис.42). Останется только с помощью соответствующей постпроцессорной программы транслировать эту УП в контроллер конкретного сверлильного станка с ЦУ.

Общий вывод о работе. Таким образом, была составлена конструкторско-технологическая документация, которая может быть передана в технический отдел для подготовки производства данного РЭС

Список использованных источников информации

Сабунин А.Е. Altium Designer. Новые решения в проектировании электронных устройств. - М.: СОЛОН-ПРЕСС, 2009. - 432 с.: ил.

Суходольский В.Ю. Сквозное проектирование функциональных узлов РЭС на печатных платах в САПР Altium Designer 6. Часть 1.: Учебное пособие. СПб.: Изд-во СПбГЭТУ “ЛЭТИ”, 2008. 148 с.

Размещено на Allbest.ru


Подобные документы

  • Анализ деятельности Объединённого института ядерных исследований. Функции программы Altium Designer. Разводка печатной платы, электрическая схема. Отпечатка ламинированного зеркального рисунка печатной платы на текстолите, пайка электрических элементов.

    отчет по практике [3,9 M], добавлен 04.08.2015

  • Процесс автоматизированного проектирования в системе P-CAD для проектирования печатной платы усилителя мощности. Упаковка схемы на плату. Процедура автоматической трассировки печатной платы. Текстовое описание схемы электрической принципиальной.

    курсовая работа [935,9 K], добавлен 18.01.2014

  • Проектирование печатной платы для электрической схемы высокочастотного генератора. Порядок создания библиотеки радиоэлектронных компонентов в системе DipTrace. Условно-графическое обозначение резистора. Порядок размещения ЭРЭ на печатной плате в системе.

    курсовая работа [1,1 M], добавлен 19.06.2015

  • Описание схемы электрической принципиальной и принципа работы узла. Обоснование выбора класса точности и способа пайки печатной платы. Элементы внешней коммуникации узла. Способы обеспечения влагозащиты платы. Расчет проводников по постоянному току.

    курсовая работа [989,4 K], добавлен 21.03.2013

  • Описание схемы электрической принципиальной приёмника для радиоуправляемой игрушки. Этап проектирования и расчет надежности микросхемы. Обоснование выбора элементов: резисторов, конденсаторов. Трассировка печатной платы и компоновка печатной платы.

    курсовая работа [29,8 K], добавлен 27.01.2009

  • Анализ электрической принципиальной схемы. Конструктивный расчет платы: исходные данные для расчета шага размещения, размеров зоны расположения интегральной схемы и платы. Интерактивное размещение и трассировка. Создание графического начертания элементов.

    курсовая работа [1,7 M], добавлен 11.12.2012

  • Разработка структурной и принципиальной схемы, проектирование изготовления печатной платы. Расчёт потребляемой мощности и температурного режима блока, проектирование его корпуса. Чертёж основания блока устройства и сборочный чертёж блока устройства.

    курсовая работа [1,6 M], добавлен 19.11.2012

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.