Многотабличные базы данных

Информационная система: понятие, задачи. Создание связей между таблицами. Работа с данными при помощи запросов. Включение полей в запрос. Построение и применение форм. Работа с текстовым процессором MS Excel, построение диаграммы. Работа с СУБД MS Access.

Рубрика Программирование, компьютеры и кибернетика
Вид контрольная работа
Язык русский
Дата добавления 30.03.2013
Размер файла 5,0 M

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru/

Многотабличные базы данных. Виды связей между таблицами. Создание запросов, форм, отчетов

Одной из важнейших областей применения компьютеров является переработка и хранение больших объемов информации в различных сферах деятельности человека: в экономике, банковском деле, торговле, транспорте, медицине, науке и т. д.

Существующие современные информационные системы характеризуются огромными объемами хранимых и обрабатываемых данных, сложной организацией, необходимостью удовлетворять разнообразные требования многочисленных пользователей.

Информационная система - это система, которая реализует автоматизированный сбор, обработку и манипулирование данными и включает технические средства обработки данных, программное обеспечение и обслуживающий персонал.

Цель любой информационной системы - обработка данных об объектах реального мира. Основой информационной системы является база данных. В широком смысле слова база данных - это совокупность сведений о конкретных объектах реального мира в какой-либо предметной области. Под предметной областью принято понимать часть реального мира, подлежаще11го изучению для организации управления его объектами и, в конечном счете, автоматизации, например предприятие, вуз и т. д.

Создавая базу данных, пользователь стремится упорядочить информацию по различным признакам и быстро производить выборку с произвольным сочетанием признаков. При этом очень важно выбрать правильную модель данных. Модель данных - это формализованное представление основных категорий восприятия реального мира, представленных его объектами, связями, свойствами, а также их взаимодействиями.

База данных - это информационная модель, позволяющая упорядоченно хранить данные о группе объектов, обладающих одинаковым набором свойств.

Информация в базах данных хранится в упорядоченном виде. Так, в записной книжке все записи упорядочены по алфавиту, а в библиотечном каталоге либо по алфавиту (алфавитный каталог), либо в соответствии с областью знания (предметный каталог).

Система программ, позволяющая создавать БД, обновлять хранимую в ней информацию, обеспечивающая удобный доступ к ней с целью просмотра и поиска, называется системой управления базами данных (СУБД).

Реляционные базы данных состоят из нескольких таблиц, связь между которыми устанавливается с помощью совпадающих полей. Каждая запись в таблицах идентифицирует один объект. Отношение между объектами определяет отношение между таблицами. Существует 3 типа отношений:

1. Отношение «один к одному» означает, что каждая запись в одной таблице соответствует только одной записи в другой таблице. Одному гражданину страны соответствует только один номер паспорта, в то же время как один номер паспорта соответствует только одному человеку.

2. Отношение «один ко многим» означает, что каждой записи в одной таблице соответствует одна или несколько записей в другой таблице. Один абитуриент может поступать во многие вузы и в тоже время в один вуз может поступать много абитуриентов.

3. Отношение «многие ко многим» возникает между двумя таблицами в тех случаях, когда:

* одна запись из первой таблицы может быть связана более чем с одной записью из второй таблицы;

* одна запись из второй таблицы может быть связана более чем с одной записью из первой таблицы.

Например, связь между преподавателями и группами студентов. Несколько преподавателей ведут занятия в нескольких группах, и несколько групп занимаются у нескольких преподавателей.

В большинстве случаев любые две таблицы связаны отношением «один - ко многим».

Создание связей между таблицами

Для того чтобы рассмотреть создание связей между таблицами построим в базе данных «Профконсультант» еще две таблицы:

Таблица Абитуриенты:

Таблица пересечения Связь

Первые два поля являются ключевыми, причем для таблицы тСвязь-Абвузы они являются чужими ключами.

Рисунок 1 - Схема данных

Чтобы определить связи, необходимо использовать команду Сервис->Схема данных. Если связь определяется впервые в базе данных, то Access откроет пустое окно Схема данных, а затем выведет на экран окно диалога Добавление таблицы. В этом окне необходимо выделить нужные таблицы и нажать кнопку Добавить. В нашем случае в окно схемы данных надо добавить все три таблицы. Чтобы установить связь между таблицами твузы и тСвязьАбвуз, надо выделить поле Кодвуза в таблице твузы (щелкнуть левой кнопкой «мыши»), перетащить и опустить его на поле Кодвуза в таблице тСвязьАбвуз. Аналогично устанавливается связь между двумя другими таблицами.

Когда вы отпустите кнопку мыши, Microsoft Access откроет окно диалога Связи, представленное на рис. 2.

Рисунок 2- Настройка связей между полями таблиц

После установки флажка Обеспечение целостности данных, Access делает доступными еще два флажка: Каскадное обновление связанных полей и Каскадное удаление связанных записей. При установленном флажке Каскадное обновление связанных полей Microsoft Access обновляет все значения чужих ключей в дочерних таблицах (то есть в таблицах на стороне отношения «многие» при связи «один ко многим») при изменении значения первичного ключа в родительской таблице, которая находится на стороне отношения «один» при связи «один ко многим». Если же вы установите флажок Каскадное удаление связанных записей, Microsoft Access удалит дочерние строки (связанные строки в дочерних таблицах) при удалении родительской строки (связанная строка в родительской таблице). Установите флажок Каскадное обновление связанных полей, чтобы при изменении кода вуза Access автоматически обновлял записи в таблице тСвязьАбвуз.

После нажатия кнопки Создать Access создаст связь и нарисует линию между двумя таблицами, указывающую на наличие связи между ними. Заметьте: когда вы просите обеспечить целостность данных, Access изображает на конце линии у таблицы, находящейся на стороне отношения «один», цифру 1, а на другом конце у таблицы со стороны отношения «многие» - символ бесконечности. Чтобы удалить связь, щелкните по ее линии и нажмите клавишу Del. Если вы хотите отредактировать или изменить существующую связь, дважды щелкните по соответствующей линии, чтобы снова открыть окно диалога Связи.

Работа с данными при помощи запросов

В режиме таблицы доступны самые разные операции с данными - просмотр, сортировка, фильтрация, обновление и печать. Однако очень часто приходится проводить вычисления или просматривать данные из нескольких таблиц. Отобрать нужные данные можно с помощью запросов.

После выполнения запроса на выборку (который отбирает информацию из таблиц и других запросов базы данных, в то время как при выполнении запросов на изменение данные вставляются, обновляются или удаляются) Access создает набор записей, содержащий отобранные данные. Однако в отличие от реальной таблицы, этот набор записей физически не существует в базе данных. Access создает набор записей из данных таблицы только во время выполнения запроса.

Выбор данных из одной таблицы

Одним из преимуществ запросов является то, что они позволяют достаточно быстро отобрать необходимые данные из нескольких связанных таблиц. Но запросы полезны и при работе с одной таблицей. Все приемы, используемые при работе с единственной таблицей, годятся и для сложных многотабличных запросов, поэтому мы начнем с запросов на выборку данных одной таблицы.

На рис. 3 показан запрос в режиме конструктора. Окно конструктора запросов разделено на две части. В верхней находятся списки полей таблиц или запросов, на основе которых создается новый запрос. В нижней располагается бланк QBE (Query By Example - запрос по образцу), в котором выполняется вся работа по созданию запроса. Каждый столбец бланка представляет одно поле, используемое в запросе. Поле может просто принадлежать одной из таблиц, быть вычисляемым (иными словами, его значение рассчитывается на основе одного или нескольких полей таблицы) или итоговым, то есть использующим одну из встроенных функций Microsoft Access.

Рисунок 3 - Запрос в режиме Конструктор

Первая строка бланка запроса служит для выбора полей, которые должны присутствовать в наборе записей, используется для сортировки данных или для выбора информации из таблицы. Полям запроса можно присвоить имена, которые будут отображаться в заголовках столбцов при выводе набора записей запроса, а для генерации вычисляемых полей можно использовать выражения любой степени сложности.

Если была выполнена команда Вид->Имена таблиц, во второй строке бланка запроса Access выведет имя таблицы, из которой выбрано поле. В третьей строке бланка можно задать сортировку по возрастанию или по убыванию.

Флажки в строке бланка Вывод на экран отвечают за вывод полей в наборе записей. По умолчанию выводятся все поля, включенные в бланк Запроса.

Для ввода условия отбора записей используется строка Условие отбора и строки или. На рис. 3 показан запрос на выборку фамилий тех студентов, которые имеют оценки от 4 до 5 баллов.

Включение полей в запрос

Первым шагом при создании запроса является выбор полей, включаемых в набор записей. Можно просто перетащить поле с помощью мыши в нужный столбец бланка из списка полей верхней части окна. При перетаскивании поля указатель мыши превращается в маленький прямоугольник.

Вычисляемые поля

С любыми полями таблицы можно выполнять вычисления и сделать вычисляемое выражение новым полем в наборе записей, при этом можно использовать любые из встроенных функций Access. Кроме того, поля запроса могут содержать данные, получаемые с помощью арифметических операций над полями таблицы. Например ЦенаТовара*Количество.

На рис. 4 показан пример вычисляемого поля для таблицы тАттестат. Вычисляемое поле Среднее выводит средний балл по трем предметам: Русский, Математика, Физика.

Рисунок 4 - Вычисляемое поле

Итоговые запросы

Для вычисления итоговых значений надо нажать кнопку Групповые операции, чтобы в бланке QBE появилась строка Групповые операции.

Access предоставляет девять функций, обеспечивающих выполнение групповых операций. Вы можете задать нужную вам функцию, введя ее имя с клавиатуры в строке Групповая операция бланка запроса или выбрав ее в раскрывающемся списке.

Итоговые функции Access:

Sum - вычисляет сумму всех значений заданного поля в каждой группе.

Avg - вычисляет среднее арифметическое всех значений данного поля в каждой группе.

Min - возвращает наименьшее значение, найденное в этом поле внутри каждой группы.

Max - возвращает наибольшее значение, найденное в этом поле внутри каждой группы.

Count - возвращает число записей, в которых значения данного поля отличны от Null.

StDev - стандартное отклонение всех значений данного поля в каждой группе.

Var - вычисляет дисперсию значений данного поля в каждой группе.

First - возвращает первое значение этого поля в группе.

Last - возвращает последнее значение этого поля в группе.

На рис. 5 показан пример запроса с применением групповой операции Sum. Данный запрос является многотабличным и позволяет определить сумму выплат, сделанных каждым абитуриентом.

Рисунок 5 - Окно запроса с применением групповой операции

Построение и применение форм

Формы являются основным средством организации интерфейса пользователя в приложениях Microsoft Access.

Обзор форм

Рассмотрим основные виды форм, которые можно построить в Access.

Простые формы. В простой форме показывается только одна запись таблицы, причем все необходимые поля отображаются на одной странице.

Многостраничные формы. При необходимости вывести на экран записи, каждая из которых содержит большой объем информации, можно создать многостраничную форму.

Ленточные формы. Существует еще один тип форм, удобный для просмотра списка записей с небольшим числом полей данных. Это ленточная форма. В отличие от простой формы, которая показывает только одну запись, в ленточной форме отформатированные записи выводятся на экран одна за другой, как в таблице.

Подчиненные формы. Подчиненные формы используются для представления данных, находящихся на стороне «многие» отношения «один - ко многим». Например, форма фАбитуриент показывает одного студента и несколько вузов, в которые студент поступает (рис. 6).

Рисунок 6 - Окно Формы в обычном режиме

Конструктор форм

Чтобы начать создание формы, необходимо в окне базы данных выбрать таблицу или запрос, выполнить команду Вставка->Форма или выбрать Новая форма в раскрывающемся списке кнопки Новый объект на панели инструментов. Access откроет окно диалога Новая форма. В поле со списком, расположенном в нижней части диалога, Access выводит имя таблицы или запроса, выбранного в окне базы данных. При необходимости можно выбрать другую таблицу или запрос, раскрыв список этого поля, содержащий перечень всех таблиц и запросов в текущей базе данных.

Выберите Конструктор в этом окне диалога и нажмите кнопку Ok. Access откроет окно формы в режиме конструктора и выведет на экран несколько инструментов конструктора форм (рис. 7). В нашем примере окно формы находится на заднем плане, панель элементов располагается третьей в панели инструментов, список полей - в верхней части окна, окно свойств формы - в правом нижнем углу. В новой форме будет присутствовать только область данных (с серой сеткой). Для добавления в форму областей заголовка и примечания используется команда Вид-> Заголовок/примечание формы, для добавления колонтитулов - Вид-> Колонтитулы. Увеличить или уменьшить размер любой области можно, если установить указатель мыши на краю этой области и перетащить его. Удаление сетки выполняется командой Вид-> Сетка.

Рисунок 7 - Создание формы в режиме Конструктор

Основные сведения об отчетах

Отчеты представляют собой наилучшее средство для представления информации из базы данных в виде печатного документа. По сравнению с другими средствами вывода данных на печать отчеты обладают двумя принципиальными преимуществами:

1. Предоставляют широкие возможности для группировки и вычисления промежуточных и общих итогов для больших наборов данных.

2. Могут быть использованы для получения красиво оформленных счетов, заказов на покупку, почтовых наклеек, материалов для презентаций и других документов.

Создание отчета

В окне диалога Новый отчет можно выбрать один из шести вариантов.

Конструктор. Используется для создания отчета «с нуля» или для редактирования ранее созданного отчета.

Мастер отчетов. Запускает основного мастера по разработке отчетов, позволяющего выбрать поля для отчета, задать форматы, условия группировки и итоговые функции.

Автоотчет: в столбец. Этот мастер создает отчет, в котором каждая запись базового запроса или таблицы представлена в виде простого списка, содержащего названия и значение полей.

Автоотчет: ленточный. В отчете этого типа записи базового запроса или таблицы выводятся в одной строке.

Диаграмма. Этот мастер помогает построить диаграмму и создает в отчете свободную рамку объекта OLE с внедренной диаграммой Microsoft Graph.

Почтовая наклейка. Этот мастер позволяет выбрать поля с именами и адресами, отформатировать их и создать отчет для печати почтовых наклеек.

Разработка отчета в режиме конструктора

Окно отчета в режиме Конструктора идентично окну формы в этом режиме, т. е. присутствует такая же Панель элементов, окно со списком полей и окно со списком свойств. Пустой макет отчета содержит разделы Верхний колонтитул, Нижний колонтитул, между которыми находится Область данных. Как и при работе с формами, можно изменить размер любого раздела, перетащив его границу.

Верхний и нижний колонтитулы будут печататься соответственно вверху и внизу каждой страницы отчета. Добавить или удалить верхний и нижний колонтитулы можно с помощью команды Вид->Колонтитулы. Можно задать заголовок отчета, который будет печататься только в самом начале отчета, и примечание отчета, печатающееся в конце отчета. Чтобы добавить в отчет эти разделы, выберите Формат->Заголовок/примечание отчета.

Работа с текстовым процессором MS Excel

Постановка задачи

Создать таблицу и заполнить ее соответствующими расчетами

Ведомость выдачи зарплаты

ФИО

Всего начислено

Сумма аванса

Налог, %

Сумма к выдаче

1

Иванов И.И.

500000

 

 

 

2

Петров П.П.

200000

 

 

 

3

Сидоров С.С.

1170000

 

 

 

4

Грибов В.В.

1215000

 

 

 

5

Дубов А.А.

627000

 

 

 

6

Мохов Е.В.

453000

 

 

 

Начислено всей бригаде

?

 

 

 

Аванса выдано всей бригаде

?

 

 

Сумма налога по всей бригаде

?

 

Общая сумма к выдаче

?

Сумма аванса вычисляется по формуле и составляет 40% от всей начисленной суммы. Подоходный налог составляет 12% от всей зарплаты.

Заполнить итоговые строки, используя функцию суммирования.

Построить диаграмму, иллюстрирующую долю каждого работника в общей сумме заработной плате.

Решение

Начислено всей бригаде: поставим курсор в ячейку C9 и воспользуемся функцией Сумма()

Рис. 8

Рис. 9

Расчет суммы аванса для каждого работника. В ячейку D3 введем формулу: =C3*0,4 и растиражируем эту формулу для диапазона ячеек D3:D8. Для подсчета общей суммы аванса воспользуемся функцией СУММ().

Рис. 10

Расчитаем сумму подоходного налога для каждого сотрудника, а также общую сумму налога по бригаде.

Рис. 11

Рассчитаем сумму к выдаче. Для этого в ячейку F3 введем формулу: =C3-D3-E3 и растиражируем эту формулу для диапазона ячеек F3:F8.

Рис. 12

Все формулы:

Рис. 13

Алгоритм построения диаграммы

Вставка -> Круговая диаграмма

Рис. 14

Правая кнопки мыши -> Выбрать данные

Рис. 15

Работа с СУБД MS Access

access excel диаграмма таблица

Постановка задачи

Создать в MS Access базу данных заданной структуры. Заполнить таблицу информацией (не менее 7-10 записей) и выполнить над ней указанные действия:

Структура:

Наименование изделия

Количество изделия

Дата поступления в продажу

Сорт

Создать запрос на вывод наименования и сорта изделий, дата поступления в продажу которых

Не позднее 01.01.98

Количество > 1000

Создать с помощью конструктора отчет для вывода значений всех полей и суммарное количество изделий в примечании отчета.

Решение

Создадим новую базу данных под именем Tovar

Рис. 16

Создание таблицы в режиме конструктора

Рис. 17

Заполнение таблицы данными

Рис. 18

Запрос на вывод наименования и сорта изделий, дата поступления в продажу которых

Не позднее 20.11.2012

Количество > 100

Конструктор запроса

Рис. 19

Выполнение запроса

Рис. 20

Отчет для вывода значений всех полей и суммарное количество изделий в примечании отчета

Рис. 21

Рис. 22

Список использованных источников

1. Гончаров А. Ю., Access 2003. Самоучитель с примерами/ Кудиц-образ - Москва, 2004.

2. Информатика. Word, Excel: методическое пособие/ Гришин М. П./ МГИУ - Москва, 2011.

3. Информатика. Word, Excel, Eccess/ Рубальская О.Н., Рубальский Г.Б/ ФиС - Минск, 2008.

4. Практикум по информатике. Word - Excel - Eccess/ Ф. Г. Богатов/ Щит-М, МосУ МВД России - Москва, 2010.

Размещено на Allbest.ru


Подобные документы

  • Многотабличные базы данных. Виды связей между таблицами. Создание запросов, форм и отчетов. Работа с текстовым процессором MS Excel, создание таблиц и заполнение их соответствующими расчетами. Создание в MS Access базы данных заданной структуры.

    контрольная работа [3,0 M], добавлен 25.03.2014

  • Понятие и основные функции СУБД "Access". Алгоритм создания базы данных сотрудников: создание таблиц с помощью конструктора, ключевые поля, установление связей между таблицами. Создание форм для поиска и ввода данных. Работа с запросами и отчетами.

    контрольная работа [827,5 K], добавлен 01.06.2010

  • Особенности СУБД Microsoft Access, ее ориентация на рядовых потребителей, возможность легко выполнять основные операции с БД: создание, редактирование и обработка данных. Информационная модель задачи, работа с конструктором запросов и отчетов базы данных.

    курсовая работа [758,6 K], добавлен 30.06.2015

  • Характеристика программных продуктов ERwin, Microsoft Excel и Access. Создание сущностей и связей, преобразование логической модели в физическую в среде ERWin. Создание таблиц в MS Access, работа с запросами и отчетами. Построение диаграмм в MS Excel.

    курсовая работа [2,5 M], добавлен 09.12.2013

  • Изучение работы с реляционной СУБД "Access", основные этапы проектирования базы данных: создание таблицы в режиме конструктора, заполнение ее данными, проектирование связей между ними. Создание форм и запросов, выбор сортировки, заполнение отчетов.

    контрольная работа [4,5 M], добавлен 17.01.2011

  • Проектирование базы данных "Общежитие" в СУБД Microsoft Access. Создание запросов, состоящих из комбинаций разных типов данных. Создание форм и полей таблицы в режиме конструктора. Ввод и просмотр данных в режиме таблицы, создание связей между ними.

    курсовая работа [4,3 M], добавлен 24.06.2019

  • Основные этапы проектирования базы данных. Access как система управления базами данных (СУБД), ее предназначение, отличительные возможности. Работа с таблицами, их создание и редактирование. Порядок создания запросов. Способы защиты баз данных.

    лабораторная работа [3,1 M], добавлен 18.08.2009

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.