Проект локальної мережі зі списками контролю доступу за протоколами TFTPта NETBIOS з використанням статичної маршрутизації та технології NAT

Розрахунок адресного простору мережі центрального офісу. Розподіл адресного простору між під мережами віддаленого офісу. Налаштування динамічного присвоєння адрес на маршрутизаторах з використанням протоколу DHCP. Налаштування маршрутизації в мережах.

Рубрика Программирование, компьютеры и кибернетика
Вид курсовая работа
Язык украинский
Дата добавления 12.04.2017
Размер файла 245,4 K

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru/

ВОЛИНСЬКИЙ КОЛЕДЖ

НАЦІОНАЛЬНОГО УНІВЕРСИТЕТУ ХАРЧОВИХ ТЕХНОЛОГІЙ

ЦИКЛОВА ВИПУСКОВА КОМІСІЯ ІНФОРМАЦІЙНИХ ТЕХНОЛОГІЙ

КУРСОВА РОБОТА

з дисципліни «Комп'ютерні системи та мережі»

на тему: «Проект локальної мережі зі списками контролю доступу за протоколами TFTPта NETBIOS з використанням статичної маршрутизації та технології NAT»

Зміст

  • Вступ
  • 1. Аналітична частина
    • 1.1 Характеристика та аналіз протоколів взаємодії підмереж
    • 1.2 Опис технологій маршрутизації
  • 2. Практична частина
    • 2.1 Розрахунок адресного простору мережі центрального офісу
    • 2.2 Розрахунок адресного простору мережі віддаленого офісу
    • 2.3 Налаштування динамічної адресації.
    • 2.4 Налаштування маршрутизації
    • 2.5 Конфігурування функцій безпеки
    • 2.6 Налаштування трансляції адрес
  • Висновки
  • Література
  • Додатки

Вступ

Сучасні технології передачі даних надають своїм користувачам широкіможливості по організації різних видів послуг і сервісів:

- організація електронного документообігу й ведення загальних архівів документів;

- організація корпоративної телефонної мережі з єдиним планом нумерації; організація систем конференц-зв'язку, у тому числі відеоконференц-

- зв'язку; побудова розподілених систем відеоспостереження з єдиним центром

- зберігання даних; організація дистанційного доступу до файлів і серверів з базами даних;

- підключення до мережі Інтернет з можливістю організації єдиної корпоративної політики інформаційної безпеки і т. ін.

Перераховані можливості дозволяють спростити процедури по керуванню внутрішніми бізнес-процесами й надають компанії ряд конкурентних переваг, а саме забезпечуються: простота керування компанією,прозорість роботи компанії, оперативний контроль діяльності всіх служб і структурних підрозділів, доступ до всіх інформаційних ресурсів підприємства в реальному часі, оперативний зв'язок; економія засобів на міжнародних й міжміських дзвінках.

Більшість інформаційних рішень, що застосовуються сьогодні, носить розподілений характер і вимагає наявності на підприємстві або в організації високопродуктивної корпоративної мережі передачі даних.

Основним завданням корпоративної мережі є забезпечення взаємодії системних додатків та організація доступу до них віддалених користувачів.

Тому корпоративна мережа, як правило, є територіально розподіленою, тобто такою, що об'єднує офіси, підрозділи й інші структури, що перебувають на значному віддаленні одні від одних. Часто вузли корпоративної мережі виявляються розташованими в різних містах, а іноді й країнах.

Таким чином, корпоративна мережа - це складна система, що включає тисячі найрізноманітніших компонентів: комп'ютери різних типів, системне й прикладне програмне забезпечення, мережеві адаптери, концентратори,комутатори й маршрутизатори, кабельна система. Основне завдання полягає в тому, щоб ця громіздка й досить дорога система якнайкраще справлялася з обробкою потоків інформації, що циркулюють між співробітниками підприємства й дозволяла приймати їм своєчасні й раціональні рішення, що забезпечують виживання підприємства у жорсткій конкурентній боротьбі.

Оскільки широке застосування комп'ютерних мереж у наш час є незаперечним фактом, тому тема даної роботи є актуальною.

Метою роботи є проектування мереж центрального та віддаленогоофісів підприємства з використанням списків контролю доступу та налаштуванням динамічної маршрутизації.

В процесі виконання роботи потрібно вирішити наступні завдання:

1. Розрахувати адресний простір мережі центрального офісу.

2. Розподілити адресний простір між під мережами віддаленого офісу.

3. Налаштувати динамічне присвоєння адрес на маршрутизаторах з використанням протоколу DHCP.

4. Налаштувати маршрутизацію в мережах.

5. Реалізувати заходи безпеки шляхом застосування списків контролю доступу в мережі центрального офісу.

1. Аналітична частина

мережа протокол маршрутизація

1.1 Характеристика та аналіз протоколів взаємодії підмереж

Згідно із завданням до курсової роботи в локальній мережі центрального офісу передбачено контроль доступу за протоколами: TFTP іNETBIOS.

TFTPце - простий протокол, який покроково синхронізований протокол передачі файлів, який дозволяє клієнтам зчитувати або записувати файли сервера. Одним із основних використань протоколу є первинне завантаження бездискових робочих станцій у локальній мережі. Найчастіше TFTP використовується саме через простоту його реалізації. Протокол працює поверх протоколу UDP.

TFTP уперше було стандартизовано у 1981 році[1], поточний стандарт протоколу -- RFC 1350.

Протокол TFTP створений з розрахунку на невеликий розмір і простоту реалізації. Через це він позбавлений більшості можливостей, які мають більш серйозні протоколи на кшталт FTP. Єдине, на що здатний цей протокол -- це записувати та зчитувати файли на сервер та з нього. Він не може виводити список файлів та наразі не підтримує автентифікацію. Основне призначення TFTP -- забезпечення простоти реалізації клієнта. У зв'язку з цим він використовується для завантаження бездискових робочих станцій, завантаження оновлень і конфігурацій в «розумні» мережеві пристрої, записи статистики з міні-АТС (CDR) та апаратних маршрутизаторів файрволів.TFTP, на відміну від FTP, не містить можливостей аутентифікації і єдиний метод ідентифікації клієнта -- це його мережева адреса (яка може бути підробленою). Зазвичай в Unix-системах TFTPD доступний тільки каталог / TFTPboot. Проте в старих TFTP-серверах було можливим отримати файл паролів командою RRQ ../[…]/шлях_до_файлу_паролів. Це було використано багатьма хакерами, щоб отримати копії файлу паролів з Unix і потім розшифрувати паролі. Щоб запобігти подібному, більшість сучасних TFTP-серверів регламентують, які файли можуть бути отримані з використанням TFTP (як правило, файли з директорії /tftpboot в Unix системах). Ця директорія містить тільки завантажувальні файли, необхідні бездисковим системам.Демон TFTPD (одна з реалізацій TFTP-сервера) відмовляється обробляти файли, що містять в своєму імені комбінацію «/../» або починається з «../». Запис дозволяється тільки у файли, які вже існують (будь-якого розміру, наприклад нульового), і доступні для публічного запису (права доступу:-RW-RW-RW-).Для додаткової безпеки TFTP-сервер на Unix-системах зазвичай встановлює свій користувацький ідентифікатор (UID) і ідентифікатор групи (GID) у значення, які не можуть бути призначені реальному користувачеві. Це забезпечує доступ тільки до файлів, які доступні для читання і запису всім.У TFTP існує 3 режими передачі: netascii, octet і mail:Netascii є модифікованою формою ASCII, визначений у RFC 764. Вона складається з 8-бітного розширення 7-бітних ASCII-символів з кодами від 0x20 до 0x7F (друкованих символів і пробілу) і восьми керуючих символів. Допустимі керуючі символи включають нуль-символ (код 0x00), новий рядок (LF, код 0x0A) і повернення каретки (CR, код 0x0D). Netascii також вимагає, щоб маркер кінця рядка був замінений на пари символів CR LF для передачі, і щоб за кожним символом CR слідував або символ LF, або нуль-символ.

Octet використовується для передачі довільних необроблених 8-бітних байтів, причому отриманий файл в результаті побайтово ідентичний посланому.

Режим передачі mail використовує передачу netascii, але файл відправляється одержувачу електронною поштою на адресу, яка вказується замість імені файлу. RFC 1350 визначає цей режим передачі застарілим і таким, що не повинен бути реалізованим.

Для початку передачі даних клієнт повинен послати серверу WRQ або RRQ-пакет. В обох пакетів формат однаковий:Після отримання RRQ-пакета сервером, він відразу починає передачу даних. У випадку з WRQ-запитом -- сервер має надіслати ACK-пакет із номером пакета 0. Пакет надсилається із динамічного порту сервера, усе подальше спілкування з сервером відбувається через цей порт.Сторона-відравник файла надсилає пронумеровані пакети даних (DATA) сталого розміру (за замовчуванням це 512 байт), а сторона-отримувач надсилає відповідні підтвердження (ACK). Якщо пакет даних або підтвердження було втрачено, то через певний час (таймаут) сторона, яка не отримала очікуваного пакета, повторно надсилає останній надісланий нею пакет. Така схема дозволяє тримати в пам'яті тільки останній надісланий пакет, у той час як підтвердження протилежної сторони гарантує, що всі попередні пакети було отримано і вони прийняті саме в тому порядку, в якому були надіслані. Така схема передбачає, що кожна зі сторін є і відправником, і одержувачем. Одна сторона надсилає дані й отримує підтвердження, інша -- отримує дані й відправляє підтвердження.

Останній пакет даних має розмір менше 512 байт. Якщо розмір файлу кратний 512, то останній пакет DATA повинен мати нульовий розмір.

Протокол NETBIOSбуврозробленийфірмоюSytekCorporationзазамовленнямIBMв 1983 році. Вінміститьусобіінтерфейссеансовогорівня (NetBIOSinterface) моделіOSI. Транспортніпротоколи -- цеNetBEUI, TCP/IP, IPX/SPX. NetBIOSoverTCP/IPназиваєтьсяNetBT.

Мережа Windows не живе без NetBIOS. Неважливо, що написано у властивостях мережевого оточення -- якщо є це оточення, значить є і NetBIOS. Він відповідає за логічні імена комп'ютерів у мережі і передачу даних між двома комп'ютерами, що встановили між собою сесію.

Інтерфейс NetBIOS являє собою стандартний інтерфейс розробки програм (API) для забезпечення мережних операцій вводу/виводу й керування транспортним протоколом нижчого рівня. Програми, що використають NetBIOS API інтерфейс, можуть працювати тільки при наявності протоколу, що допускає використання такого інтерфейсу.

NetBIOS також визначає протокол, що функціонує на сеансовому/транспортному рівнях моделі OSI. Цей протокол використовується поверх інших протоколів (таких як IPX, NetBEUI, NetBT - поверх стеку протоколів TCP/IP) для виконання мережевих запитів вводу/виводу й операцій, описаних у стандартному интерфейсному наборі команд NetBIOS. Тобто NetBIOS сам не підтримує виконання файлових операцій. Ця функція покладається на протоколи нижележащих рівнів, а сам NetBIOS забезпечує тільки зв'язок із цими протоколами та NetBIOS API інтерфейс.

NetBIOS забезпечує:

1. Реєстрацію й перевірку мережних імен.

2. Встановлення й розрив з'єднань.

3. Зв'язок із гарантованою доставкою інформації.

4. Зв'язок з негарантованою доставкою інформації.

5. Підтримку керування й моніторингу драйвера й мережевої карти.

1.2 Опис технологій маршрутизації

Статична маршрутизація - вид маршрутизації, при якому маршрути вказуються в явному вигляді при конфігурації маршрутизатора. Вся маршрутизація при цьому відбувається без участі будь-яких протоколів маршрутизації.

При заданні статичного маршруту вказується:

- адреса мережі (на яку маршрутизируется трафік), маска мережі;

- адреса шлюзу (вузла), який сприяє подальшій маршрутизації (або підключений до маршрутизуються мережі безпосередньо);

- опціонально метрика (іноді іменується також "ціною") маршруту. При наявності декількох маршрутів на одну і ту ж мережу деякі маршрутизатори вибирають маршрут з мінімальною метрикою.

Статичні маршрути не змінюються маршрутизатором. Динамічні маршрути змінюються маршрутизатором автоматично в разі одержання інформації про зміну маршрутів від сусідніх маршрутизаторів. Статична маршрутизація потребує мало обчислювальних ресурсів і використовується в мережах, які не мають декількох шляхів до адресата призначення. Якщо від маршрутизатора до маршрутизатора є тільки один шлях, то звичайно використовують статичну маршрутизацію.

Для конфігурації статичної маршрутизації в маршрутизаторах Cisco використовують дві версії команди ip route .Команда вказує маршрутизатору, що усі пакети, призначені для Адрес МережіПризначення - МаскаМережіПризначення слід надсилати на свій інтерфейс Інтерфейс. Якщо інтерфейс Інтерфейс - інтерфейс типу Ethernet, то фізичні (MAC) адреси вихідних пакетів будуть широкомовними.Команда вказує маршрутизатору, що усі пакети, призначені для Адрес Мережі Призначення - МаскаМережіПризначення, слід надсилати на той свій інтерфейс, з якого досяжна IP-адреса Адрес. Як правило, Адреса це адреса наступного хопа по шляху до АдресМережіПризначення. Вихідний інтерфейс і фізичні адреси вихідних пакетів визначаються маршрутизатором пза своїми ARP-таблицям на підставі IP-адреси Адрес. Наприклад:

Ip route 10.6.0.0 255.255.0.0 Serial1 (1)

Ip route 10.7.0.0 255.255.0.0 10.4.0.2 (2)

Приклад (1)відображає мережний префікс 10.6.0.0/16 на локальний інтерфейс маршрутизатора Serial1. Приклад (2)відображає мережний префікс 10.7.0.0/16 на IP-адресу 10.4.0.2 наступного хопа на шляху до 10.7.0.0/16. Обидві команди додають статичні маршрути в таблицю маршрутизації (мітка S):

S 10.6.0.0 via Serial1

S 10.7.0.0 [1/0] via 10.4.0.2

У разі падіння інтерфейсу, усі статичні маршрути, відображені на цей інтерфейс, видаляються з таблиці маршрутів. Якщо маршрутизатор не може більше знайти адресу наступного хопа на шляху до адреси, вказаному у статичному маршруті, то маршрут видаляється з таблиці.

2. Практична частина

2.1 Розрахунок адресного простору мережі центрального офісу

Вихідні дані до завдання наведені в табл. 1 та рис. 1.

Таблиця 1

Вихідні дані до розрахунку адресного простору мережі центрального офісу

№ вар.

IP-адреса

Кількість вузлів

Net1

Net2

Net3

Net4

Net5

4

192.168.13.0

15

7

11

48

50

Рисунок 1 -- Структурна схема мережі

Як видно з рисунку, мережа центрального офісу складається з шести підмереж та чотирьох маршрутизаторів. Спочатку присвоїмо адреси маршрутизаторам.

Відповідно до схеми, між маршрутизаторами є три мережі. Присвоїмо адреси портам маршрутизаторів, обравши префікс /30. Це дозволить утворити мережі тільки з двома адресами вузлів. Параметри мереж між маршрутизаторами показані в таблиці.

Таблиця 2

Параметри мереж між маршрутизаторами

Мережа

Маршрутизатор

Номер порту

Адреса

Маска підмережі

Rt1-Rt2

Rt1

1

192.168.13.5

255.255.255.252

Rt1-Rt2

Rt2

1

192.168.13.2

255.255.255.252

Rt1-Rt3

Rt1

2

192.168.13.17

255.255.255.252

Rt1-Rt3

Rt3

1

192.168.13.6

255.255.255.252

Rt1-Rt4

Rt1

3

192.168.13.9

255.255.255.252

Rt1-Rt4

Rt4

1

192.168.13.10

255.255.255.252

Порти №0 маршрутизаторів направлені у внутрішні мережі. Мережа маршрутизаторів займає адресний пул 192.168.13.1-192.168.13.20. Всі інші адреси можуть бути віддані для підмереж вузлів.

Підмережа сервера Net6 складається з одного вузла. Разом із тим потрібно врахувати те, що два значення адрес повинно відводитись на адресу підмережі та широкомовну адресу. Також потрібно врахувати, що одну із адрес повинен зайняти порт маршрутизатора, який направлений в дану мережу. Тому для адресації вузлів потрібно відвести як мінімум (заокругливши до більшого цілого)

log 2 4?2 біт.

Це означає, що префікс під мережі має бути 32-2=30. Зважаючи на це, одержимо наступні параметри мережі Net6.

Таблиця 3

Параметри мережі Net6

Назва мережі

Net6

Адреса мережі

192.168.13.16

Маска мережі

255.255.255.252

Префікс мережі

/30

Адреса першого вузла

192.168.13.17

Адреса останнього вузла

192.168.13.18

Широкомовна адреса

192.168.13.19

Кількість вузлів мережі

2

Кількість зайнятих адрес

2

Кількість вільних адрес

0

Мережа Net1 складається з 15 вузлів. Враховуючи адресу мережі та широкомовну адресу, отримуємо, що для адресації потрібно (заокругливши до більшого цілого) log2 30+3=5 біт.

Таке значення відповідає префіксу мережі /27, маска 255.255.255.224. Параметри мережі наведено в таблиці.

Таблиця 4

Параметри мережі Net1

Назва мережі

Net1

Адреса мережі

192.168.13.32

Маска мережі

255.255.255.224

Префікс мережі

/27

Адреса першого вузла

192.168.13.33

Адреса останнього вузла

192.168.13.62

Широкомовна адреса

192.168.13.63

Кількість вузлів мережі

15

Кількість зайнятих адрес

29

Кількість вільних адрес

19

Мережа Net2 складається з 7 вузлів. Враховуючи адресу мережі та широкомовну адресу, отримуємо, що для адресації потрібно (заокругливши до більшого цілого) log2 10?4біт.

Таке значення відповідає префіксу мережі /28, маска 255.255.255.240. Параметри мережі наведено в таблиці.

Таблиця 5

Параметри мережі Net2

Назва мережі

Net2

Адреса мережі

192.168.13.64

Маска мережі

255.255.255.240

Префікс мережі

/28

Адреса першого вузла

192.168.13.65

Адреса останнього вузла

192.168.13.78

Широкомовна адреса

192.168.13.79

Кількість вузлів мережі

14

Кількість зайнятих адрес

8

Кількість вільних адрес

6

Мережа Net3 складається з 11 вузлів. Враховуючи адресу мережі та широкомовну адресу, отримуємо, що для адресації потрібно (заокругливши до більшого цілого) log2 14+3?4

Таке значення відповідає префіксу мережі /28, маска 255.255.255.240. Параметри мережі наведено в таблиці.

Таблиця 6

Параметри мережі Net3

Назва мережі

Net3

Адреса мережі

192.168.13.80

Маска мережі

255.255.255.240

Префікс мережі

/28

Адреса першого вузла

192.168.13.81

Адреса останнього вузла

192.168.13.94

Широкомовна адреса

192.168.13.95

Кількість вузлів мережі

14

Кількість зайнятих адрес

12

Кількість вільних адрес

2

Мережа Net4 складається з 48 вузлів. Враховуючи адресу мережі та широкомовну адресу, отримуємо, що для адресації потрібно (заокругливши до більшого цілого) log2 62+3?6 біт.

Таке значення відповідає префіксу мережі /26, маска 255.255.255.192. Параметри мережі наведено в таблиці.

Таблиця 7

Параметри мережі Net4

Назва мережі

Net4

Адреса мережі

192.168.13.128

Маска мережі

255.255.255.192

Префікс мережі

/26

Адреса першого вузла

192.168.13.129

Адреса останнього вузла

192.168.13.190

Широкомовна адреса

192.168.13.191

Кількість вузлів мережі

62

Кількість зайнятих адрес

49

Кількість вільних адрес

13

Мережа Net5 складається з 62 вузлів. Враховуючи адресу мережі та широкомовну адресу, отримуємо, що для адресації потрібно (заокругливши до більшого цілого) log2 62+3?6біт.

Таке значення відповідає префіксу мережі /26, маска 255.255.255.192. Параметри мережі наведено в таблиці.

Таблиця 8

Параметри мережі Net5

Назва мережі

Net5

Адреса мережі

192.168.13.192

Маска мережі

255.255.255.192

Префікс мережі

/26

Адреса першого вузла

192.168.13.193

Адреса останнього вузла

192.168.13.254

Широкомовна адреса

192.168.13.255

Кількість вузлів мережі

62

Кількість зайнятих адрес

51

Кількість вільних адрес

11

Співвідношення між кількістю зайнятих та вільних адрес в підмережах показане на рис. 2.

Рисунок 2 -- Співвідношення між кількістю зайнятих та вільних адрес

2.2 Розрахунок адресного простору мережі віддаленого офісу

Вихідні дані до завдання наведені в табл. 9 та рис. 3.

Таблиця 9

Вихідні дані до розрахунку адресного простору мережі віддаленого офісу

№ вар.

IP-адреса

Шлюз

4

10.1.4.0/24

Rt4

Відповідно до завдання потрібно розподілити адресний простір між маршрутизаторами так, щоб відповідні підмережі мали префікс /30. Такий префікс обмежує кількість вузлів значенням 2. Параметри мереж між маршрутизаторами показані в таблиці.

Рисунок 3 -- Структурна схема мережі

Таблиця 10

Параметри мереж між маршрутизаторами

Мережа

Маршрутизатор

Номер порту

Адреса

Маска підмережі

Rt1-Rt2

Rt1

1

10.1.4.1

255.255.255.252

Rt1-Rt2

Rt2

2

10.1.4.2

255.255.255. 252

Rt2-Rt4

Rt2

3

10.1.4.13

255.255.255. 252

Rt2-Rt4

Rt4

4

10.1.4.14

255.255.255. 252

Rt4-Rt3

Rt4

1

10.1.4.18

255.255.255. 252

Rt4-Rt3

Rt3

2

10.1.4.17

255.255.255. 252

Rt4-Rt5

Rt4

1

10.1.4.25

255.255.255. 252

Rt4-Rt5

Rt5

2

10.1.4.26

255.255.255. 252

Rt5-Rt3

Rt5

1

10.1.4.22

255.255.255. 252

Rt5-Rt3

Rt3

2

10.1.4.21

255.255.255.252

Rt3-Rt1

Rt3

1

10.1.4.6

255.255.255.252

Rt3-Rt1

Rt1

2

10.1.4.5

255.255.255.252

Rt1-Rt5

Rt1

3

10.1.4.9

255.255.255.252

Rt1-Rt5

Rt5

2

10.1.4.10

255.255.255.252

Порти №0 маршрутизаторів направлені у внутрішні мережі. Мережа маршрутизаторів займає адресний пул 192.168.13.1-192.168.13.30.

Розподілимо адреси, що залишилися між п'ятьма мережами. Для заданої кількості мереж на їх адресацію потрібно відвести (заокругливши до більшого цілого) log2 5?3біт.

Таким чином префікс мереж становитиме 24+3=27 біт.Параметри мереж наведено в таблиці.

Таблиця 11

Параметри підмережвіддаленого офісу

PC1

Адреса мережі

10.1.4.32

Маска мережі

255.255.255.224

Адреса першого вузла

10.1.4.33

Адреса останнього вузла

10.1.4.62

Широкомовна адреса

10.1.4.63

PC2

Адреса мережі

10.1.4.64

Маска мережі

255.255.255.224

Адреса першого вузла

10.1.4.65

Адреса останнього вузла

10.1.4.78

Широкомовна адреса

10.1.4.79

PC3

Адреса мережі

10.1.4.80

Маска мережі

255.255.255.224

Адреса першого вузла

10.1.4.81

Адреса останнього вузла

10.1.4.94

Широкомовна адреса

10.1.4.95

PC4

Адреса мережі

10.1.4.128

Маска мережі

255.255.255.224

Адреса першого вузла

10.1.4.129

Адреса останнього вузла

10.1.4.190

Широкомовна адреса

10.1.4.191

PC5

Адреса мережі

10.1.4.192

Маска мережі

255.255.255.192

Адреса першого вузла

10.1.4.193

Адреса останнього вузла

10.1.4.254

Широкомовна адреса

10.1.4.55

2.3 Налаштування динамічної адресації

Виконаємо налаштування DHCP мережі центрального офісу. Перед цим потрібно присвоїти адреси портам маршрутизаторів.

Налаштування адрес портів маршрутизатораRt1:

Router(config)#intfastEthernet 0/0

Router(config-if)#ip address 192.168.13.17 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int fastEthernet 1/0

Router(config-if)#ip address 192.168.13.5 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

Router(config-if)#exit

Router(config)#int fastEthernet 2/0

Router(config-if)#ip address 192.168.13.9 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet2/0, changed state to up

Router(config-if)#exit

Router(config)#int fastEthernet 3/0

Router(config-if)#ip address 192.168.13.1 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet3/0, changed state to up

Router(config-if)#exit

Router(config)#exit

Адреса сервера Srv1 залишається статичною, її значення 192.168.13.17/30.

Налаштування адрес портів маршрутизатора Rt2:

Router(config)#int fastEthernet 0/0

Router(config-if)#ip address 192.168.13.33 255.255.255.224

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int fastEthernet 0/1

Router(config-if)#ip address 192.168.13.65 255.255.255.240

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

Router(config-if)#exit

Router(config)#int fastEthernet 1/0

Router(config-if)#ip address 192.168.13.2 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet2/0, changed state to up

Router(config-if)#exit

Налаштування DHCP маршрутизатора Rt2:

Router(config)#ip dhcp pool net1

Router(dhcp-config)#network 192.168.13.32 255.255.255.224

Router(dhcp-config)#default-router 192.168.13.33

Router(config)#ip dhcp excluded-address 192.168.13.33

Router(config)#ip dhcp pool net2

Router(dhcp-config)#network 192.168.13.64 255.255.255.224

Router(dhcp-config)#default-router 192.168.13.65

Router(config)#ip dhcp excluded-address 192.168.13.65

Налаштування адрес портів маршрутизатора Rt3:

Router(config)#int fastEthernet 0/0

Router(config-if)#ip address 192.168.13.65 255.255.255.240

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int fastEthernet 1/0

Router(config-if)#ip address 192.168.13.81 255.255.255.240

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

Router(config-if)#exit

Налаштування DHCP маршрутизатора Rt3:

Router(config)#ip dhcp pool net3

Router(dhcp-config)#network 192.168.13.80 255.255.255.240

Router(dhcp-config)#default-router 192.168.13.81

Router(config)#ip dhcp excluded-address 192.168.13.81

Налаштування адрес портів маршрутизатора Rt4:

Router(config)#int fastEthernet 0/1

Router(config-if)#ip address 192.168.13.129 255.255.255.192

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int fastEthernet 1/0

Router(config-if)#ip address 192.168.13.10 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

Router(config-if)#exit

Router(config)#int fastEthernet 1/1

Router(config-if)#ip address 192.168.13.193 255.255.255.192

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet1/1, changed state to up

FastEthernet0/0, changed state to up

Router(config-if)#exit

Налаштування DHCP маршрутизатора Rt4:

Router(config)#ip dhcp pool net4

Router(dhcp-config)#network 192.168.13.128 255.255.255.192

Router(dhcp-config)#default-router 192.168.13.129

Router(config)#ip dhcp excluded-address 192.168.13.129

Router(config)#ip dhcp pool net5

Router(dhcp-config)#network 192.168.13.192 255.255.255.192

Router(dhcp-config)#default-router 192.168.13.193

Router(config)#ip dhcp excluded-address 192.168.13.193

Після налаштування адресації структура мережі центрального офісу має наступний вигляд (рис. 4).

Виконаємо налаштування динамічної адресації мережі віддаленого офісу. Налаштування адрес і DHCP маршрутизатора Rt1:

Router(config)#intfa0/0

Router(config-if)#ipaddress10.1.4.33 255.255.255.224

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Рисунок 4 -- Структура мережі центрального офісу

Router(config-if)#exit

Router(config)#int fa1/0

Router(config-if)#ip address 10.1.4.1 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

Router(config-if)#exit

Router(config)#int fa2/0

Router(config-if)#ip address 10.1.4.5 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet2/0, changed state to up

Router(config-if)#exit

Router(config)#ip dhcp pool pc1

Router(dhcp-config)#network 10.1.4.32 255.255.255.224

Router(dhcp-config)#default-router 10.1.4.33

Router(dhcp-config)#exit

Router(config)#ip dhcp excluded-address 10.1.4.33

Router(config)#end

Налаштування адрес і DHCP маршрутизатора Rt2:

Router(config)#int fa0/0

Router(config-if)#ip address 10.1.4.65 255.255.255.224

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int fa1/0

Router(config-if)#ip address 10.1.4.2 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

Router(config-if)#exit

Router(config)#int fa2/0

Router(config-if)#ip address 10.1.4.13 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet2/0, changed state to up

Router(config-if)#exit

Router(config)#ip dhcp pool pc2

Router(dhcp-config)#network 10.1.4.64 255.255.255.224

Router(dhcp-config)#default-router 10.1.4.65

Router(dhcp-config)#exit

Router(config)#ip dhcp excluded-address 10.1.4.65

Router(config)#end

Налаштування адрес і DHCP маршрутизатора Rt3:

Router(config)#int fa0/0

Router(config-if)#ip address 10.1.4.81 255.255.255.224

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int fa1/0

Router(config-if)#ip address 10.1.4.17 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

Router(config-if)#exit

Router(config)#int fa2/0

Router(config-if)#ip address 10.1.4.6 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet2/0, changed state to up

Router(config-if)#exit

Router(config)#int fa7/0

Router(config-if)#ip address 10.1.4.21 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet7/0, changed state to up

Router(config-if)#exit

Router(config)#ip dhcp pool pc3

Router(dhcp-config)#network 10.1.4.80 255.255.255.224

Router(dhcp-config)#default-router 10.1.4.81

Router(dhcp-config)#exit

Router(config)#ip dhcp excluded-address 10.1.4.81

Router(config)#end

Налаштування адрес і DHCP маршрутизатора Rt4:

Router(config)#int fa0/0

Router(config-if)#ip address 10.1.4.129 255.255.255.224

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int fa1/0

Router(config-if)#ip address 10.1.4.18 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

Router(config-if)#exit

Router(config)#int fa2/0

Router(config-if)#ip address 10.1.4.25 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet2/0, changed state to up

Router(config-if)#exit

Router(config)#int fa3/0

Router(config-if)#ip address 10.1.4.14 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet3/0, changed state to up

Router(config-if)#exit

Router(config)#int fa4/0

Router(config-if)#ip address 20.20.20.2255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet4/0, changed state to up

Router(config-if)#exit

Router(config)#ip dhcp pool pc4

Router(dhcp-config)#network 10.1.4.128 255.255.255.224

Router(dhcp-config)#default-router 10.1.4.129

Router(dhcp-config)#exit

Router(config)#ip dhcp excluded-address 10.1.4.129

Router(config)#end

Налаштування адрес і DHCP маршрутизатора Rt5:

Router(config)#int fa0/0

Router(config-if)#ip address 10.1.4.193 255.255.255.224

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int fa1/0

Router(config-if)#ip address 10.1.4.10 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

Router(config-if)#exit

Router(config)#int fa2/0

Router(config-if)#ip address 10.1.4.22 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet2/0, changed state to up

Router(config-if)#exit

Router(config)#int fa3/0

Router(config-if)#ip address 10.1.4.22 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet3/0, changed state to up

Router(config-if)#exit

Router(config)#int fa4/0

Router(config-if)#ip address 10.1.4.26 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet4/0, changed state to up

Router(config-if)#exit

Router(config)#ip dhcp pool pc5

Router(dhcp-config)#network 10.1.4.192 255.255.255.224

Router(dhcp-config)#default-router 10.1.4.193

Router(dhcp-config)#exit

Router(config)#ip dhcp excluded-address 10.1.4.193

Router(config)#end

Після налаштування адресації структура мережі центрального офісу має наступний вигляд (рис. 5).

Рисунок 5 -- Структурамережівіддаленого офісу

2.4 Налаштування маршрутизації

Відповідно до завдання у мережі центрального офісу потрібно налаштувати статичну маршрутизацію.

Додаємо статичні маршрути в маршрутизатор Rt1.

Router(config)#ip route 192.168.13.32 255.255.255.224 192.168.13.2

Router(config)#ip route 192.168.13.64 255.255.255.240 192.168.13.2

Router(config)#ip route 192.168.13.128 255.255.255.240 192.168.13.6

Router(config)#ip route 192.168.13.192 255.255.255.192 192.168.13.10

Router(config)#ip route 192.168.13.208 255.255.255.192 192.168.13.10

На Rt2, Rt3, Rt4 налаштуємо маршрутизацію таким чином, щоб весь трафік маршрутизувався через Rt1.

Додаємо статичний маршрут в Rt2.

Router(config)#iproute 192.168.13.0 255.255.255.0 192.168.13.1

Додаємо статичний маршрутв Rt3.

Router(config)#iproute 192.168.13.0 255.255.255.0 192.168.13.5

Додаємо статичний маршрутв Rt4.

Router(config)#iproute 192.168.13.0 255.255.255.0 192.168.13.9

Таким чином таблиці маршрутизації Rt2, Rt3, Rt4 будуть мати мінімальний обсяг.

Для мережі віддаленого офісу згідно завдання налаштовуємо статичну маршрутизацію

Налаштування статичної маршрутизації на маршрутизаторі Rt1.

Router(config)#ip route 10.1.4.64 255.255.255.224 10.1.4.2

Router(config)#ip route 10.1.4.96 255.255.255.224 10.1.4.6

Router(config)#ip route 10.1.4.128 255.255.255.224 10.1.4.18

Router(config)#iproute10.1.4.160 255.255.255.224 10.1.4.14

НалаштуваннястатичноїмаршрутизаціїнамаршрутизаторіRt2.

Router(config)#ip route 10.1.4.32 255.255.255.224 10.1.4.1

Router(config)#ip route 10.1.4.96 255.255.255.224 10.1.4.10

Router(config)#ip route 10.1.4.128 255.255.255.224 10.1.4.18

Router(config)#ip route 10.1.4.160 255.255.255.224 10.1.4.14

НалаштуваннястатичноїмаршрутизаціїнамаршрутизаторіRt3

Router(config)#ip route 10.1.4.32 255.255.255.224 10.1.4.5

Router(config)#ip route 10.1.4.64 255.255.255.224 10.1.4.9

Router(config)#ip route 10.1.4.128 255.255.255.0 10.1.4.18

Router(config)#ip route 10.1.4.160 255.255.255.0 10.1.4.22

Налштування статичної маршрутизації на маршрутизаторі Rt4.

Router(config)#ip route 10.1.4.32 255.255.255.224 10.1.4.5

Router(config)#ip 10.1.4.64 255.255.255.224 10.1.4.9

Router(config)#ip route 10.1.4.96 255.255.255.224 10.1.4.17

Router(config)#ip route 10.1.4.160 255.255.255.224 10.1.4.22

Нлаштування статичної маршрутизації на маршрутизаторі Rt5.

Router(config)#iproute 10.1.4.32 255.255.255.224 10.1.4.5.5

Router(config)#ip route 10.1.4.64 255.255.255.224 10.1.4.13

Router(config)#ip route 10.1.4.96 255.255.255.224 10.1.4.17

Router(config)#ip route 10.1.4.128 255.255.255.224 10.1.4.21

Router(config)#ip route 10.1.4.0 255.255.255.0 10.1.4.13

Router(config)#ip route 10.1.4.0 255.255.255.0 10.1.4.21

2.5 Конфігурування функцій безпеки

Відповідно до завдання потрібно налаштувати стандартні списки контролю доступу на заборону проходження трафіку в наступних напрямках:

- відправник NET4, одержувач NET2;

- відправник NET2, одержувач NET1;

- відправник NET4, одержувач NET6.

Розширені списки налаштовуються на заборону проходження трафіку в наступних напрямках:

- відправник NET2, одержувач NET5, протоколTFTP;

- відправник NET1, одержувач NET3, протоколNETBIOS.

Налаштуємо стандартний список контролю доступу на маршрутизаторі Rt4.

Router(config)#access-list 1 deny 192.168.13.128 0.0.0.63

Router(config)#access-list 1 permit 192.168.13.0 0.0.0.255

Застосуємо цей список до відповідного порту маршрутизатора у вихідному напрямку.

Router(config)#int fastEthernet 0/0

Router(config-if)#ip access-group 1 out

Налаштуємо стандартний список контролю доступу на маршрутизаторі Rt2.

Router(config)#access-list 1 deny 192.168.13.64 0.0.0.15

Router(config)#access-list 1 permit 192.168.13.0 0.0.0.255

Застосуємо цей список до відповідного порту маршрутизатора у вихідному напрямку.

Router(config)#int fastEthernet 2/0

Router(config-if)#ip access-group 1 out

Налаштуємо стандартний список контролю доступу на маршрутизаторі Rt1.

Router(config)#access-list 1 deny 192.168.13.128 0.0.0.63

Router(config)#access-list 1 permit 192.168.13.0 0.0.0.255

Застосуємо цей список до відповідного порту маршрутизатора у вихідному напрямку.

Router(config)#int fastEthernet 0/0

Router(config-if)#ip access-group 1 out

Налаштуємо розширений список контролю доступу на маршрутизаторі Rt2.(TFTP)

Router(config)# access-list 101 deny udp 192.168.13.64 0.0.0.15 192.168.13.192 0.0.0.63 eq 69

Router(config)#access-list 101 permit ip any any

Застосуємо цей список до відповідного порту маршрутизатора у вхідному напрямку.

Router(config)#int fastEthernet 2/0

Router(config-if)#ip access-group 1 in

Налаштуємо розширений список контролю доступу на маршрутизаторі Rt2.(NETBIOS)

Router(config)#access-list 101 deny tcp 192.168.13.32 0.0.0.31 192.168.13.80 0.0.0.15 eq 139

Router(config)#access-list 101 permit ip any any

Застосуємо цей список до відповідного порту маршрутизатора у вхідному напрямку.

Router(config)#int fastEthernet 0/0

Router(config-if)#ip access-group 1 in

Переглянемо списки контролю доступу на маршрутизаторах.

Списки контролю доступу маршрутизатора Rt2.

Router#show access-lists

Standard IP access list 1

10 deny 192.168.13.64 0.0.0.15 (21 match(es))

20 permit 192.168.13.0 0.0.0.255 (16 match(es))

Extended IP access list 101

10 deny udp 192.168.13.32 0.0.0.31 192.168.13.208 0.0.0.15 eq snmp (1 match(es))

20 permit ip any any (6 match(es))

Списки контролю доступу маршрутизатора Rt3.

Router#show access-lists

Standard IP access list 1

10 deny 192.168.13.80 0.0.0.15 (22 match(es))

20 permit 192.168.13.0 0.0.0.255 (4 match(es))

Extended IP access list 101

10 deny tcp 192.168.13.128 0.0.0.63 192.168.13.208 0.0.0.15 eq www (12 match(es))

20 permit ip any any (6 match(es))

Списки контролю доступу маршрутизатора Rt4.

Router#show access-lists

Standard IP access list 1

10 deny 192.168.13.192 0.0.0.63 (5 match(es))

20 permit 192.168.13.0 0.0.0.255 (23 match(es))

2.6 Налаштування трансляції адрес

З'єднуємо шлюзові маршрутизатори підмереж. Створимо мережу між маршрутизаторами, призначивши адреси портам. Адреси будемо брати з мережі 20.20.20.0/30.

Налаштування шлюзового маршрутизатора мережі центрального офісу:

Router(config)#int fastEthernet 4/0

Router(config-if)#ip address 20.20.20.1 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet4/0, changed state to up

FastEthernet4/0, changed state to up

Router(config-if)#exit

Налаштування шлюзового маршрутизатора мережі віддаленого офісу:

Router(config)#int fastEthernet 4/0

Router(config-if)#ip address 20.20.20.2 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet4/0, changed state to up

FastEthernet4/0, changed state to up

Router(config-if)#exit

Виконаємо конфігурування шлюзового маршрутизатора мережі центрального офісу для трансляції адрес.

Налаштовуємо статичний NATдля мережі центрального офісу, таким чином, щоб трансляція адрес виконувалась на сервер:

Router(config)#ip nat inside source static 192.168.13.17 20.20.20.1

Router(config)#int fa0/0

Router(config-if)#ip nat inside

Router(config-if)#exit

Router(config)#int fa4/0

Router(config-if)#ip nat outside

Router(config-if)#exit

Налаштовуємо динамічний NAT з перекриттям(PAT)для мережі центрального офісу:

Router(config)#access permit 192.168.13.0 0.0.0.255

Router(config)#ip nat source list 15 fastEthernet4/0 overload

Router(config)#int fa1/0

Router(config-if)#ip nat inside

Router(config-if)#exit

Router(config)#int fa2/0

Router(config-if)#ip nat inside

Router(config-if)#exit

Router(config)#int fa3/0

Router(config-if)#ip nat inside

Router(config-if)#exit

Router(config)#int fa4/0

Router(config-if)#ip nat outside

Router(config-if)#exit

Виконаємо конфігурування шлюзового маршрутизатора мережі віддаленого офісу для трансляції адрес.

Налаштовуємо динамічний NATдля мережі віддаленого офісу:

Router(config)#ip nat pool REM_OFF 20.20.20.2 20.20.20.2 netmask 255.255.255.252

Router(config)#access-list 16 permit 192.168.13.0 0.0.0.255

Router(config)#ip nat inside source list 16 pool REM_OFF

Router(config)#int fa0/0

Router(config-if)#ip nat inside

Router(config-if)#exit

Router(config)#int fa1/0

Router(config-if)#ip nat inside

Router(config-if)#exit

Router(config)#int fa2/0

Router(config-if)#ip nat inside

Router(config-if)#exit

Router(config)#int fa3/0

Router(config-if)#ip nat inside

Router(config-if)#exit

Router(config)#int fa4/0

Router(config-if)#ip nat outside

Router(config-if)#exit

Висновки

В даній курсовій роботі було розв'язано наступні завдання:

- спроектовано локальну мережу центрального офісу;

- розраховано адресний простір мереж центрального та віддаленого офісів;

- налаштовано функції безпеки за допомогою списків контролю доступу за протоколамиTFTP таNETBIOS;

- налаштовано динамічну адресацію в мережах за допомогою протоколу DHCP;

- здійснено конфігурацію маршрутизаторів мережі центрального офісу для статичної маршрутизації;

- на маршрутизаторах мережі віддаленого офісу налаштовано теж статичну маршрутизацію.

В результаті виконання даної курсової роботи були отримані навички проектування, розрахунку та налаштування корпоративної мережі. Дані комп'ютерні мережі стабільно функціонують, мають запас адресного простору для розширення та налаштовані для безпечного використання в корпоративному середовищі.

Література

1. Виснадул Б.Д. Основы компьютерных сетей: учебное пособие / Виснадул Б.Д., Лупин С.А., Сидоров С.В., Чумаченко П.Ю.; под ред. Гагариной Л.Г. - М.: ИД «Форум» : ИНФРА-М, 2007. - 272 с.

2. Олифер В.Г. Компьютерные сети. Принципы, технологии, протоколы: Учебник для вузов / Олифер В.Г., Олифер Н.А. - СПб.: Питер, 2010. - 944 с.

3. Олифер В.Г. Сетевые операционные системы : Учебник для вузов / Олифер В.Г., Олифер Н.А. - СПб. : Питер, 2009. - 672 с.

4. Сергеев А. Офисные локальные сети / Сергеев А. - М.: Диалектика, 2009.- 320 с.

5. Столингс В. Современные компьютерные сети / Столингс В. - СПб.: Питер, 208. - 784 с.

6. Таненбаум Э.С. Компьютерные сети / Таненбаум Э.С. - М.: Питер, 2003. - 992 с.

7. Stevens W. R. TCP/IP Illustrated, Volume 1: The Protocols [Текст] / W. Richard Stevens - Addison Wesley Professional, 1994. - 1021 с.

8. Stevens W. R. Unix Network Programming, Volume 1: The Sockets Networking API [Текст] / W. Richard Stevens, Bill Fenner, Andrew M. Rudoff. - Addison Wesley Professional, 2004. - 1004 c.

Додаток А

Конфігураційний файл маршрутизатора Rt1

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

no ip cef

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.13.17 255.255.255.252

ip nat inside

duplex auto

speed auto

!

interface FastEthernet1/0

ip address 192.168.13.5 255.255.255.252

ip nat inside

duplex auto

speed auto

!

interface FastEthernet2/0

ip address 192.168.13.9 255.255.255.252

ip nat inside

duplex auto

speed auto

!

interface FastEthernet3/0

ip address 192.168.13.1 255.255.255.252

ip nat inside

duplex auto

speed auto

!

interface FastEthernet4/0

ip address 20.20.20.1 255.255.255.252

ip nat outside

duplex auto

speed auto

!

interface FastEthernet5/0

no ip address

duplex auto

speed auto

shutdown

!

ip nat inside source static 192.168.13.17 20.20.20.1

ip classless

ip route 192.168.13.32 255.255.255.224 192.168.13.2

ip route 192.168.13.64 255.255.255.240 192.168.13.2

ip route 192.168.13.80 255.255.255.240 192.168.13.6

ip route 192.168.13.128 255.255.255.240 192.168.13.10

ip route 192.168.13.128 255.255.255.192 192.168.13.10

!

ip flow-export version 9

!

!

access-list 15 permit 192.168.13.0 0.0.0.255

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

Додаток Б

Конфігураційний файл маршрутизатора Rt2

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

ip dhcp excluded-address 192.168.13.32

ip dhcp excluded-address 192.168.13.1

ip dhcp excluded-address 192.168.13.33

ip dhcp excluded-address 192.168.13.65

!

ip dhcp pool TEST

network 192.168.13.0 255.255.255.0

default-router 192.168.13.32

dns-server 8.8.8.8

ip dhcp pool net1

network 192.168.13.32 255.255.255.224

default-router 192.168.13.33

ip dhcp pool net2

network 192.168.13.64 255.255.255.240

default-router 192.168.13.65

!

!

!

no ip cef

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.13.33 255.255.255.224

ip access-group 1 in

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.13.65 255.255.255.240

ip access-group 1 out

duplex auto

speed auto

!

interface FastEthernet1/0

ip address 192.168.13.2 255.255.255.252

ip access-group 1 out

duplex auto

speed auto

!

interface FastEthernet1/1

no ip address

duplex auto

speed auto

shutdown

!

router rip

!

ip classless

ip route 192.168.13.0 255.255.255.0 192.168.13.1

!

ip flow-export version 9

!

!

access-list 1 deny 192.168.13.2 0.0.0.224

access-list 1 permit 192.168.13.0 0.0.0.255

access-list 1 deny 192.168.13.64 0.0.0.15

access-list 1 deny 192.168.13.128 0.0.0.63

access-list 101 deny udp 192.168.13.64 0.0.0.15 192.168.13.192 0.0.0.63 eq tftp

access-list 101 permit ip any any

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

End

Додаток В

Конфігураційний файл маршрутизатора Rt3

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

ip dhcp excluded-address 192.168.13.64

ip dhcp excluded-address 192.168.13.81

!

ip dhcp pool net3

network 192.168.13.80 255.255.255.240

default-router 192.168.13.81

!

!

!

ip cef

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.13.65 255.255.255.240

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0

no ip address

clock rate 2000000

shutdown

!

interface Serial0/1

no ip address

clock rate 2000000

shutdown

!

interface FastEthernet1/0

ip address 192.168.13.81 255.255.255.240

duplex auto

speed auto

!

interface FastEthernet1/1

no ip address

duplex auto

speed auto

shutdown

!

router rip

!

ip classless

ip route 192.168.13.0 255.255.255.0 192.168.13.1

ip route 192.168.13.0 255.255.255.0 192.168.13.5

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

End

Додаток Г

Конфігураційний файл маршрутизатора Rt4

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

ip dhcp excluded-address 192.168.13.129

ip dhcp excluded-address 192.168.13.193

!

ip dhcp pool net4

network 192.168.13.128 255.255.255.192

default-router 192.168.13.129

ip dhcp pool net5

network 192.168.13.192 255.255.255.192

default-router 192.168.13.193

!

!

!

ip cef

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.13.193 255.255.255.192

ip access-group 1 out

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.13.10 255.255.255.252

ip access-group 1 in

duplex auto

speed auto

!

interface Serial0/0

no ip address

clock rate 2000000

shutdown

!

interface Serial0/1

no ip address

clock rate 2000000

shutdown

!

interface FastEthernet1/0

ip address 192.168.13.129 255.255.255.192

duplex auto

speed auto

!

interface FastEthernet1/1

no ip address

duplex auto

speed auto

shutdown

!

ip classless

ip route 192.168.13.0 255.255.255.0 192.168.13.9

!

ip flow-export version 9

!

!

access-list 1 deny 192.168.13.2 0.0.0.192

access-list 1 permit 192.168.13.0 0.0.0.255

access-list 1 deny 192.168.13.128 0.0.0.63

access-list 101 deny tcp 192.168.13.32 0.0.0.31 192.168.13.80 0.0.0.15 eq 139

access-list 101 permit ip any any

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

end

Размещено на Allbest.ru


Подобные документы

  • З’єднання компонентів мережі офісу на фізичному та канальному рівні, створення топології мережі, налаштування адресації та маршрутизації. Моделювання потоків трафіку і обміну пакетами між роутерами мережі, розрахунок подвоєної затримки поширення сигналу.

    курсовая работа [402,1 K], добавлен 23.12.2015

  • Розробки локальної обчислювальної мережі для підприємства з використанням обладнання Cisco. Її тестування та налагодження в програмі Packet Tracer. Визначення програмного забезпечення та обладнання. Топологічна схема мережі. Розподіл адресного простору.

    дипломная работа [2,3 M], добавлен 15.07.2015

  • Дослідження особливостей управління взаємодією вузлів мережі при обміні даними. Вивчення типів адрес, які використовуються у IP-мережі. Огляд алгоритмів гнучкого використання адресного простору, формування та обробки IP-адрес. Маршрутизація в ІР-мережах.

    контрольная работа [22,0 K], добавлен 25.04.2014

  • Поняття та завдання комп'ютерних мереж. Розгляд проекту реалізації корпоративної мережі Ethernet шляхом створення моделі бездротового зв’язку головного офісу, бухгалтерії, філій підприємства. Налаштування доступу інтернет та перевірка працездатності.

    курсовая работа [2,2 M], добавлен 20.03.2014

  • Налаштування інтернет-з’єднання за допомогою мобільного телефону. Проєктування і налаштування провідної мережі, бездротової мережі WiFi. Робота з BT. З’єднання пристроїв, сервіс, безпека. Робота з електронною поштою. Огляд технології 3G, 2.75G, 2.5G.

    контрольная работа [29,2 K], добавлен 08.02.2011

  • Порядок налагодження інтерфейсів маршрутизатора Cisco. Дослідження особливостей формування маршрутів у маршрутизаторі Cisco. Ознайомлення зі специфікою діагностики інтерфейсів маршрутизатора та маршрутів. Приклад налаштування ІР-адреси на робочій станції.

    лабораторная работа [352,8 K], добавлен 30.06.2012

  • Теоретичні основи технології віртуалізації як інструменту навчання, проектування мереж та системного адміністрування. Планування складу комп’ютерної мережі, вибір платформи та операційної системи, установка і налаштування програм. Питання охорони праці.

    дипломная работа [5,9 M], добавлен 24.04.2014

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.