Розробка об’єктно-орієнтованої надбудови в середовищі AutoCAD

Підстава для створення, найменування та область застосування програмного забезпечення. Дослідження теоретичних аспектів процесу проектування систем автоматизації розробки конструкторської документації. Інструкція по інсталяції програмного продукту.

Рубрика Программирование, компьютеры и кибернетика
Вид дипломная работа
Язык украинский
Дата добавления 26.10.2012
Размер файла 2,5 M

Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже

Студенты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны.

Размещено на http://www.allbest.ru/

Размещено на http://www.allbest.ru/

Міністерство освіти та науки України

Криворізький інститут

Кременчуцького університету економіки, інформаційних технологій та управління

Кафедра Технічної кібернетики

ДИПЛОМНА РОБОТА

зі спеціальності

7.091402 “Гнучкі комп'ютеризовані системи та робототехніка“

ПОЯСНЮВАЛЬНА ЗАПИСКА

«Розробка об'єктно-орієнтованої надбудови в середовищі AutoCAD»

Студента групи ГКС-03-з

Василенко Павло Вадимович підпис________

Керівник роботи проф., к.т.н.

Корнілов Георгій Іванович підпис________

Кривий Ріг

2008

АНОТАЦІЯ

Метою дипломної роботи є розробка програми на мові AutoLISP, яка призначена для автоматизації креслення кріпильних виробів. Також в роботі було виконано дослідження теоретичних аспектів і інструментів проектування систем автоматизації розробки конструкторської документації.

Розділів 6, схем та малюнків 46, таблиць 5, бібліографічних посилань 30, загальний обсяг - 98.

Аннотация

Целью дипломной работы является разработка программы на языке AutoLISP, которая предназначена для автоматизации прорисовки крепежных изделий. Также в работе было произведено исследование теоретических аспектов и инструментов проектирования систем автоматизации разработки конструкторской документации.

Разделов 6, схем и рисунков 46, таблиц 5, библиографических ссылок 30, общий объем - 98.

The summary

The purpose of this diploma|degree| work is development|elaboration| of the of the program in AutoLISP language, which is intended for automation of timbers wares drawing.

Research of theoretical aspects and instruments of planning of the automation systems for designer document was on the go made also.

Sections 6, circuits and figures 46, tables 5, bibliographic references 30, total amount - 98.

ЗМІСТ

  • Вступ
  • 1. Постановка завдання
    • 1.1 Найменування та область застосування
    • 1.2 Підстава для створення
    • 1.3 Характеристика розробленого програмного забезпечення
    • 1.4 Мета й призначення
    • 1.5 Загальні вимоги до розробки
    • 1.6 Джерела розробки
  • 2. Дослідження теоретичних аспектів процесу проектування систем автоматизації розробки конструкторської документації
    • 2.1 Призначення і основні характеристики систем АКД
    • 2.2 Методи створення графічних зображень й геометричних об'єктів
    • 2.3 Структура й основні принципи побудови систем АКД
    • 2.4 Технологія багатоваріантного конструювання
  • 3. Середовище проектування VISUAL LISP
    • 3.1 Огляд пунктів головного меню
    • 3.2 Огляд панелей інструментів
    • 2.3 Написання програм в текстовому редакторові середовища Visual LISP
  • 4. Опис програмної реалізації об'єктно-орієнтованої надбудови
    • 4.1 Функціональне призначення та технологічні особливості розробки
    • 4.2 Опис особливостей креслення геометричних об'єктів системи
    • 4.3 Розробка логіко-функціональной схеми надбудови
    • 4.4 Інструкція по інсталяції програмного продукту
    • 4.5 Опис інтерфейсу користувача
    • 4.6 Опис файлів, які є складовою частиною надбудови
    • 4.7 Розробка діалогового вікна системи
    • 4.8 Опис програмної реалізації головних функцій проектованої надбудови
  • 5. Економічне обґрунтування доцільності розробки програмного продукту
    • 5.1 Організаційно-економічна частина
    • 5.2 Розрахунок економічного ефекту по упровадженню програмного продукту
  • 6. Охорона праці
    • 6.1 Інженерна охорона праці
    • 6.2 Фізичні й психофізіологічні небезпечні та шкідливі виробничі фактори при роботі на комп'ютері й заходи по їх знищенню
      • 6.2.1 Електромагнітне випромінювання
      • 6.2.2 Рентгенівське випромінювання
      • 6.2.3 Підвищений рівень шуму
      • 6.2.4 Несприятливий мікроклімат
      • 6.2.5 Освітлення
      • 6.2.6 Психофізіологічні шкідливі і небезпечні виробничі чинники
    • 6.3 Організаційні і технічні заходи по зменшенню рівня шкідливих виробничих чинників
      • 6.3.1 Захист від електромагнітних випромінювань
      • 6.3.2 Захист від ураження електричним струмом
      • 6.3.3 Захист від статичної електрики
      • 6.3.4 Захист від шуму та вібрації
      • 6.3.5 Оздоровлення повітряного середовища
      • 6.3.6 Захист від рентгенівського випромінювання
      • 6.3.7 Забезпечення раціонального освітлення
    • 6.4 Пожежна безпека
      • 6.4.1 Пожежна і вибухова безпека в робочій зоні технічного обслуговування в приміщеннях з ПЕОМ
  • Висновки
  • Список літератури

Додаток А - Вихідний текст файлів надбудови

ВСТУП

програмний автоматизація конструкторський інсталяція

Автоматизація проектування -- напрям сучасної науки і техніки, що інтенсивно розвивається. Системи автоматизованого проектування (САПР) стають однією з складових частин гнучких виробничих систем і гнучких автоматизованих виробництв.

З появою технічних і програмних засобів графічної взаємодії проектувальника з ЕОМ завдання автоматизації проектування стало можливим вирішувати інтерактивно. Важливу роль при цьому грає графічне сприйняття і можливість маніпулювати графічними образами. Використання графічних засобів є одним з прийомів інженерної діяльності.

Системи автоматичного проектування дозволяють автоматизувати розробку конструкторської документації варіантів виробів залежно від заданих параметрів, наприклад, на основі базових або уніфікованих несучих конструкцій; модернізацію існуючих конструкцій; виконання креслень з великою кількістю однотипних графічних зображень; трудомісткий процес складання переліків елементів, специфікацій і інших текстових документів. Засобами ЕОМ можна автоматизувати рішення графічних задач: визначення габаритних розмірів конструкцій, їх площ, об'ємів, параметрів, умов їх взаємного розташування і т.п.

Система AutoCAD є однією з найпопулярнішої в світі систем автоматичного проектування. AutoCAD є могутнім графічним ядром, на якому базуються багато прикладних пакетів як і від самої фірми AutoDESK, так і від незалежних виробників.

Тепер використання AutoCAD вже не зводиться до відтворення роботи на креслярській дошці. Відносини і зв'язки між окремими тілами в тривимірному просторі можуть задаватися в структурі самих елементів конструкцій. Внутрішня форма опису кожного елементу геометричної моделі в AutoCAD передбачає можливість запису практично будь-якої супутньої інформації. Починаючи з версії 13, AutoCAD забезпечує функціональну структуризацію. Для кожної серйозної прикладної роботи, пов'язаної з проектуванням, існують різноманітні настройки, що розширюють базовий AutoCAD до функціонального інструменту, призначеного для роботи в конкретних умовах. Картографія, машинобудування, магістральні об'єкти, архітектура, промислове, цивільне будівництво і землеустрій, і багато що інше породили цілу гамму додатків до AutoCAD, що перетворюють його на налаштований на конкретну роботу інструмент. На більшості крупних проектно-конструкторських підприємств створені спеціальні відділи по підтримці процесу проектування - Відділи Інформаційних Технологій. У їх завдання входить підтримка в порядку «конструкторських » інструментів - комп'ютерів і програм. Їх роль підібрати необхідний інструмент, налогодити його на заданий режим роботи, стежити, щоб він працював правильно, і навчити основний персонал використовувати вибрані і «заточені» «пили і сокири » ефективно і безпечно.

Система AutoCAD в об'ємі базового постачання дозволяє виконувати креслярські і конструкторські роботи в об'ємі тільки штатних засобів. За допомогою стандартних примітивів (відрізків, кіл, дуг і т.д.) можна намалювати майже все, що завгодно. Але кінцевим користувачам (інженерам і конструкторам різних профілів) необхідно малювати не просто примітиви, а проектувати конкретні об'єкти (деталі устаткування, електричні і принципові схеми, будівельні плани і багато що інше). Робити це треба швидко і якісно відповідно до стандартів в тій або іншій країні або галузі.

Все що потрібно всім кінцевим користувачам включити до складу системи неможливо. Тому фірма AutoDESK забезпечила базову систему засобами розробки прикладних систем. Використовуючи ці засоби, можна створювати програми для автоматизації роботи в різних напрямах інженерної діяльності, не залежно від регіональних і галузевих стандартів.

1. ПОСТАНОВКА ЗАВДАННЯ

1.1 Найменування та область застосування

Найменування розробки: об'єктно орієнтована надбудова в середі AutoCAD. Система призначена для автоматизації креслення кріпильних виробів в середі AutoCAD і може бути використана інженерами та конструкторами при виконанні креслень.

1.2 Підстава для створення

Підставою для розробки є наказ № 65Са-01 від 29 жовтня 2007 р. по Криворізькому інституту КУЕІТУ.

Початок робіт: 31.10.07. Закінчення робіт: 01.06.08.

1.3 Характеристика розробленого програмного забезпечення

Проектована об'єктно-орієнтована надбудова реалізована засобами мов AutoLISP та DCL. Програмний продукт може функціонувати в середі AutoCAD 2000 та наступних версій. Зображення типових виробів створюються на основі державних стандартів та відвідають усім необхідним вимогам.

До складу надбудови входять:

- krpz.lsp - головний модуль завантажуваної надбудови;

- krpz.dcl - файл, що містить інформацію про діалогове вікно системи;

- blts.lsp, gks.lsp, vint.lsp, shb.lsp - файли, що містять алгоритми креслень виробів;

- файли з розширенням dat - містять табличну інформацію про параметри кріпильного виробу відповідної серії;

- файли з розширенням slb містять слайди (графічні зображення) параметричних типових креслень відповідних виробів.

1.4 Мета й призначення

Метою даної дипломної роботи є розробка об'єктно-орієнтованої надбудови на мові AutoLISP, яка призначена для автоматизації креслення різьбових кріпильних виробів. Система пройшла практичну апробацію і може бути використана інженерами та конструкторами при виконанні креслень.

1.5 Загальні вимоги до розробки

Вимоги до програмного забезпечення:

· Робота в середовищі операційних систем Windows 2000/XP;

· Простота й зрозумілість інтерфейсу.

Мінімальні вимоги до апаратного забезпечення:

· IBM-сумісний комп'ютер, не нижче Pentium IІ, RAM-128Mb, SVGA-800*600*16bit;

· Вільний простір на жорсткому диску не менш 600 Мб.

· Додаткове програмне забезпечення: інсталяція AutoCAD.

1.6 Джерела розробки

Джерелами розробки дипломної роботи є:

· довідкова література;

· наукова література;

· технічна література;

· програмна документація.

2. ДОСЛІДЖЕННЯ ТЕОРЕТИЧНИХ АСПЕКТІВ ПРОЦЕСУ ПРОЕКТУВАННЯ СИСТЕМ АВТОМАТИЗАЦІЇ РОЗРОБКИ КОНСТРУКТОРСЬКОЇ ДОКУМЕНТАЦІЇ

2.1 Призначення і основні характеристики систем АКД

Сучасний рівень програмних і технічних засобів електронної обчислювальної техніки дозволяє перейти до нових інформаційних комп'ютерних технологій, створювати системи автоматизації розробки і виконання конструкторської документації (АКД), що задовольняють стандартам ЄСКД як за якістю виконання документів, так і по дотриманню вимог стандартів. На комп'ютері можуть бути створені конструкторські документи (креслення і схеми) як з використанням, наприклад графічних примітивів типу відрізка, кола, полілінії та ін., так і фрагментів раніше створених конструктивних елементів: графічних зображень (ГЗ) стандартних виробів, типових і уніфікованих конструкцій, їх частин і т.д. При цьому моделі вищезгаданих фрагментів можуть бути параметрично заданими. За допомогою завдання різних значень параметрів конструктор може змінити їх розміри і геометричну форму, забезпечуючи багатоваріантність ГЗ і відповідно креслень і схем. При такому підході до конструювання використання комп'ютерної графіки не усуває креслення (рис. 2.1) як основу конструювання, комп'ютер використовується як «електронний кульман», що полегшує працю конструктора. Такий підхід базується на двовимірному геометричному моделюванні.

Рис. 2.1 Структура системи АКД, заснованої на двовимірному геометричному моделюванні

При розробці КД в цьому випадку ефективність застосування комп'ютерної графіки забезпечується наступними її можливостями:

· наявністю у всіх графічних редакторах засобів перетворень: повороту,

· перенесення, масштабування, побудови дзеркального зображення і др.;

· використання готових фрагментів креслень з бібліотеки слайду: конструктивних і геометричних елементів, уніфікованих і типових конструкцій, стандартних виробів;

· формуванням креслень з використанням об'єктно-орієнтованих інтерфейсів користувача, ведення діалогу з комп'ютером в звичних для конструктора (у вигляді піктограм) термінах і із звичними для нього об'єктами (ГЗ);

· наявністю пакетів програм опису типових моделей-представників креслень об'єктів, коли процес створення конкретного креслення виробу полягає в маніпулюванні розмірами, представленими у вигляді параметрів;

· отриманням креслень високої якості, оформлених за стандартами ЄСКД (формується на етапі конструювання) шляхом виводу на графічні пристрої, принтери і інші пристрої.

Для використання цих можливостей застосовуються системи-надбудови над базовою графічною системою (наприклад, над AutoCAD), що містять спеціалізовані для конкретного виробу моделі необхідних фрагментів ГЗ, інтерфейсів користувача, що є об'єктно-орієнтованими «падаючими» і піктографічними меню і відповідними бібліотеками слайду.

Існують і інші підходи до автоматизації конструкторської діяльності, наприклад на основі просторового геометричного моделювання, коли формується просторова модель геометричного об'єкту (ГО), що є наочнішим способом представлення оригіналу і могутнішим і зручнішим інструментом для вирішення геометричних завдань (рис. 2.2). Креслення тут грає допоміжну роль, а методи його створення засновані на методах комп'ютерної графіки, методах відображення просторової моделі (у AutoCAD - тривимірне моделювання). При першому підході - традиційному процесі конструювання - обмін інформацією здійснюється на основі конструкторської, нормативно-довідкової і технологічної документації; при другому - на основі внутрішньо-машинного представлення ГО, загальної бази даних, що сприяє ефективному функціонуванню програмного забезпечення систем автоматизованого проектування (САПР) конкретного виробу.

Рис. 2.2 Структура системи АКД, заснованої на використанні просторової моделі геометричного об'єкту

2.2 Методи створення графічних зображень й геометричних об'єктів

Обробка графічних даних на комп'ютері як область прикладної інформатики означає формування ГІ й ГО (створення цифрової моделі), їх зберігання, відображення й перетворення, що можливо представити в вигляді геометричного інформаційного потоку (рис. 2.3). На малюнку показані три способи створення моделі ГО й його обробки на комп'ютері в залежності від виду ГО й способу його вводу в комп'ютер.

Виділяють два основних вида ГО:

· постійний - з постійними розмірами й геометричною формою, на-приклад ГІ умовних графічних позначень радіовиробів електричних схем, графічне зображення стандартного радіоивироби (резистора, конденсатора й ін.) з постійними розмірами;

· параметрично заданий - зі змінними розмірами й геометричною формою, наприклад, графічне зображення радіовироби, що залежить від номіналу; типові й уніфіковані несучі конструкції радіоелектронних обладнань; конструктивні елементи типових деталей і ін.

Моделі постійних ГО можуть бути отримані за допомогою I і III способів. Способом I ГО вводяться в комп'ютер зі скануючих обладнань вводу, планшетних обладнань, що кодують, телекамери й ін. Способом III для інтерактивного вводу/виводу ГО застосовуються графічні системи (графічні редактори) опису й редагування ГО (наприклад, Autocad).

Формування моделі параметрично заданого ГО забезпечується способом II з використанням програм створення моделі або об'єктно-орієнтованих систем-надбудов (скажемо, за допомогою мови програмування Autolisp) над Autocad.

Методи створення моделей, параметрично керованих ГО, характеризуються більшими витратами на формування внутрімашинного розуміння. Щоб скоротити ці витрати, при описі деяких груп технічних об'єктів можна користуватися одним із двох принципово різних методів: варіантним або генерируючим.

Рис. 2.3 Способи створення й обробки моделі геометричного об'єкту

Рис. 2.4 Структурна схема елементів деталі

Варіантний метод заснований на тому, що для певного класу виробів виявляється модель-представник, за допомогою якої отримують всі геометричні форми цього класу виробів. Представника класу виробів називають типо-завивання, або комплексною моделлю, а отримані з неї форми - варіантами (виконань). Виконання виробу визначається заданими параметрами, обнулення яких приводить до виключення складових елементів ГО. У простому випадку змінюються тільки розміри, а конструкція окремих варіантів сімейства виробів залишається незмінною. Опис ГО, заданого параметрами, лежить в основі багатоваріантного конструювання. Витрати на опис типової моделі великі в порівнянні з витратами на отримання варіантів, тому багато систем використовують принцип вкладеності моделей: один раз описані типові моделі використовуються для опису інших типових моделей як макрокоманди.

Генеруючий метод заснований на розділенні ГО на конструктивні і геометричні елементи і створенні нових ГО з наявних елементів за допомогою вибору різних їх поєднань. На рис. 2.4 приведений приклад розділення деталі на елементи. Системи АКД, що працюють по генеруючому методу, володіють високою гнучкістю і ефективні, оскільки досвід показує, що більшість конструкторських розробок створюються шляхом поєднання елементів, що не використалося, раніше відомих, як за принципом функціонування, так і по виконанню.

2.3 Структура й основні принципи побудови систем АКД

Система АКД виконує введення, зберігання, обробку і виведення графічної інформації у вигляді конструкторських документів. Для реалізації системи необхідні: документи, що регламентують роботу системи АКД; початкова інформація для формування інформаційної бази; інформаційна база, що містить моделі ГО, ГІ, елементи оформлення креслення по ДОСТ ЕСКД; технічні і програмні засоби створення ГО і ГІ і їх виводу; інтерфейс користувача у вигляді діалогу з комп'ютером.

Всі перераховані складові утворюють методичне, інформаційне, технічне, програмне і організаційне забезпечення системи АКД (рис. 2.5).

Основними принципами побудови системи АКД є:

· мобільність - адаптується системи АКД до різних САПР. Шлях до цього - використання поширених базових графічних систем (наприклад, AUTOCAD) і мов програмування (наприклад, AUTOLISP);

· інформаційна єдність всіх частин АКД і САПР, яке передбачає єдність бази даних для різних призначень (скажімо, користування моделі ГО і ГІ як для формування креслень, так і для розрахунків і виготовлення виробу);

· інваріантність - максимальна незалежність складових частин і системи АКД в цілому по відношенню до орієнтованих систем АКД і САПР. Наприклад, система електронних пристроїв може бути використана як графічна підсистема в системі управління робототехнічним комплексом і як графічна підсистема в системі управління контрольно-вимірювальним пристроєм;

· можливість розширення системи АКД шляхом доповнення нових складових частин й розвиток старих.

Рис. 2.5 Методичне, інформаційне, технічне, програмне й організаційне забезпечення системи АКД

2.4 Технологія багатоваріантного конструювання

Існує безліч методів формування конструкторської документації в середовищі графічних систем. У цьому підрозділі описується метод післяопераційної обробки заготівки деталі. Його особливість полягає в тому, що способів механічної обробки заготівки для перетворення її на виріб відносно мало. Багато разів використовуючи цю технологічну операцію, можна отримувати в результаті креслення деталей дуже широкого класу. Більш того, якщо всі способи обробки незалежні один від одного, то додавши навіть одну нову операцію, значно розширюється різноманітність отримуваних креслень. Щоб отримати набір команд формування креслень певного класу деталей, спочатку потрібно вибрати з вже наявних креслень найбільш складні і такі, що повно відображають всі особливості даного класу. Далі на їх основі створюють креслення типової деталі. Всі розміри цього креслення повинні бути виражені в параметрах. З такого параметричного типового креслення деталі (рис. 2.6) і починається розробка програмного забезпечення. Але раніше необхідно виділити з цього креслення основу деталі і функціональні елементи. Основою для будь-якої деталі служить заготовка, з якої за допомогою наступної обробки (свердлення, точіння, фрезерування і ін.) отримують необхідний виріб. В принципі всі основи можна представити у вигляді заготівки у формі або циліндра, або паралелепіпеда без отворів. Проте на практиці заготовки бувають складнішими формою і в деяких випадках з крізними отворами. На рис. 2.7 зображено параметричне креслення основи комплексної деталі. Функціональний елемент, з погляду розробника програмного забезпечення, - це одна параметрична обробка заготовки. При обробці моделі заготовки необхідно коректно модифікувати важ креслення. Це обумовлює деяку подвійність терміну «функціональний елемент»: з одного боку, це технологічна операція над деталлю-заготовкою, а з іншої - програма, що модифікує креслення заготовки.

Рис. 2.6 Параметричне типове креслення деталі

Рис.2.7 Параметричне креслення основи комплексної деталі

Для користувача функціональний елемент - це програма або команда, що модифікує креслення заготівки в повній відповідності з деякою технологічною обробкою деталі заготівки. Якщо для параметричного прототипу, приведеного на рис.2.6, прийняти за основу рис. 2.7, то, окрім основи, можна виділити ще 3-4 функціональних елементу: кругову систему отворів, різьбовий отвір з проточкою, циліндрове розточування і ін. Всі функціональні елементи повинні бути незалежні один від одного, тобто виконуватися в будь-якій послідовності і будь-яка кількість разів, якщо це не суперечить коректного виконання відповідних їм технологічних операцій над деталлю заготівки. При розробці програм, що формують функціональні елементи, слід мати на увазі, що вони обов'язково прив'язані до базових точок заготівки. Вони вибираються зазвичай або на перетині осей проекції, або на перетині осі і якої-небудь поверхні, але не більш за одну на кожній проекції заготівки. На рис. 2.8 показані деякі функціональні елементи для комплексної деталі, зображеної на рис.2.6.

На AUTOLISP виклик програми і введення вхідних параметрів можна оформити двома способами - або у вигляді функції, або у вигляді команди. У кожного способу є переваги і недоліки, але, з погляду користувача, зручніший виклик командою з введенням даних в процесі діалогу. Більш того, якщо програму формування основи ще можна описати у вигляді функції, то функціональний елемент - тільки у вигляді команди, що включає розвинений діалог з користувачем. Діалог необхідний по двох причинах: по-перше, введення координат базових крапок в більшості випадків можливе тільки за допомогою об'єктних прив'язок в інтерактивному режимі; по-друге, введення значень параметрів функціональних елементів, визначуваних елементами заготівки, вимагає вимірювання безпосередньо на кресленні.

При створенні сценарію діалогу треба дотримуватися деяких правил:

· необхідно здійснювати ввід лише мінімально-достатньої інформації.

Наприклад, на рис. 2.7 розмір функціонального елементу визначений через різницю двох розмірів прототипу. Помилково вимагати від користувача введення обох розмірів, щоб отримати їх різницю; правильніше відразу запитати цю різницю (L-L8). Окрім введення значень параметрів, що визначають геометрію функціонального елементу, необхідне введення не менше однієї базової точки. У мові AUTOLISP це здійснюється або шляхом введення координат точки в параметрах функції, що розробляється, або за допомогою функції GETPOINT з подальшим витяганням даних координат. Для основи необхідна одна базова точка, що визначає її місцеположення на кресленні. Для функціонального елементу - стільки, а скількох проекціях модифікується зображення заготовки;

· ввід інформації повинен здійснюватися, по можливості, різними способами.

У AUTOLISP це означає, що, наприклад, введення значення параметра D краще здійснювати за допомогою функції GETDIST. На відміну від функції GETREAL, GETDIST дозволяє вводити значення і з клавіатури (введення числа), і за допомогою миші (введення відстані між двома вибраними на екрані крапками). Різноманітність способів введення даних значно полегшує роботу користувача з будь-якою програмою.

· не слід запрошувати і вводити інформацію, яку можна отримати з креслення, наприклад, при формуванні циліндрового розточування по отвору (рис. 2.9).

Даний функціональний елемент визначають значення параметрів L8, D2 і базової крапки. Для видалення частини лінії отвору програмістові необхідно також знати його діаметр D. Здається спокусливим просто запитати це значення у користувача, але воно не відноситься до даного функціонального елементу. Рішення проблеми - в скануванні певної області креслення і аналізі тих об'єктів, які потрапили в цю область. У AUTOLISP сканування здійснюється за допомогою функції SSGET, зазвичай з ключем Crossing.

Рис.2.8 Функціональні елементи комплексної деталі

Рис.2.9 Формування циліндричного розточування по отвору

Розробник програмного забезпечення повинен дотримувати незалежність функціональних елементів. Для команд редагування AUTOCAD, незалежність означає, що при виконанні будь-якої розробленої команди не грає ролі, яким чином і в якій послідовності обробляється графічне зображення. Для функціональних елементів незалежність означає, що вони повинні модифікувати будь-яке креслення заготівки, при цьому неважливо, в якій послідовності і якими засобами креслення формувалося. Якщо розробник не підтримувався даного принципу, то функціональний елемент розроблений некоректно. Нижчеприведені функції, що формують основу комплексної деталі і функціональний елемент, розробці і нагоджені в середовищі мови AUTOLISP.

; Очищення поля креслення формату А4 (зручно використовувати при наладці програми).

(COMMAND "ERASE" "С" "0,0" "210,297)

;

; Функція формування параметрично керованої основи комплексної деталі. За базову точкуузятий лівийнижній кут горизонтальної проекції (х, у)

(DEFUN OSN (X У DDlL LI L2 L3 / L2PLIP Rl R XI Y1 )

(SETQ

L2P(/L2 2.0);Визначення

LIP(/L1 2.0);локальних

Rl(/Dl 2.0);змінних.

R(/D 2.0)

; Формування контура і кіл горизонтальної проекції. Зображення розміщується в заздалегідь створеному шарі Osn.

(COMMAND "LAYER" "Set" "Osn" ""

"LINE" (LIST X Y ) (LIST (+ X L2) Y ) (LIST (+ X L2) (+ Y LI) ) (LIST X (+ Y LI) ) "C" "CIRCLE" (LIST (+ X L2p) (+ Y LIP)) Rl "CIRCLE" (LIST (+ X L2p) (+ Y LIP)) R

; Формування осьових ліній горизонтальної проекції. Зображення знаходиться в заздалегідь створеному шарі Osi, якому привласнений штріхпунктірний тип лінії.

"LAYER" "Set" "Osi" ""

"LINE" (LIST(+ X L2P) (- Y 5.0))

(LIST(+ X L2p) (+ Y LI 5.0))

"LINE" (LIST(- X 5.0) (+ Y LIP))

(LIST(+ X L2 5,0) (+ Y LIP))

; Формування фронтальної проекції в шарі Osn.

(SETQ XI X Yl (+ LI 20.0)

; Визначення координат локальної базової точки для фронтальної проекції.(COMMAND "LAYER" "Set" "Оsn"

"LINE"

(LIST (+ XI L2P) (LIST XI

(LISTXI

(LIST(+XI L2)

(LIST(+XI L2)

(LIST(+XI L2P Rl)(+ (LIST(+XI L2P Rl)( +

(LIST(-(+ XI L2P)Rl)

(LIST(-(+ XI L2P)Rl)

LINE" (LIST (+ XI L2P R) (LIST (+ XI L2P R)

(+ Yl L3)) (+ Yl L3))

Yl )

Yl ) (+ Yl L3))

Yl L3)) Yl L )) (+ Yl L )) (+ Yl L3))

Yl ) (+ Yl L)) ""

; Формування осьової лінії фронтальної проекції.

; Зображення знаходиться в шарі Osi.

"LAYER" "Set" "Osi

"LINE" (LIST (+ XI L2P) (- Yl 5.0))

(LIST (+ XI L2P) (+ Yl L 5.0)) ""

)

; Звернення до функції OSN з різноманітними параметрами.

; Результат роботи функції наведений на мал. 2.10.

; Штрихування сформоване засобами AutoCAD.

(OSN 20 20 15 45 40 45 80 10) (OSN 140 10 б 15 120 20 30 50) (OSN 20 200 25 35 20 35 180 5)

; Команда FUN1 формує прямокутну проточку.

; Основа комплексної деталі модифікується автоматично.

; Результати роботи команди FUN1 показані на мал. 2.11.

(DEFUN C:FUN1 (/ ВР1 ХВ1 YB1 L2P L4P L6P ВР2 ХВ2 YB2 L3)

; Ввід базової точки 1, що знаходиться в центрі горизонтальної

; проекції, з об'єктною прив'язкою Intersection (Пересечение).

(COMMAND "OSNAP" "Int")

(SETQ BP1 (GETPOINT "\nEnter base point 1 :")

XB1 (CAR BP1) ; Обчислення координат

УВ1 (CADR BP1) ; базової точки 1.

; Ввід параметрів проточки на горизонтальної проекції.

; Використовується ефект "гумової нитки" від базової точки 1.

(COMMAND "OSNAP" "Perpend")

(SETQ L2P (GETDIST BP1 "\nEnter L2/2 :") )

(COMMAND "OSNAP" "None")

(SETQ L4P(GETDIST BP1 "\nEnter L4/2 :")

L6P (GETDIST (LIST (+ XB1 L2P) YB1) "\nEnter L2/2 :")

; Формування проточки на горизонтальній проекції

(COMMAND "LAYER" "Set" "Osn" ""

"PLINE" (LIST (+ XB1 L2P)(- YB1 L6P))

(LIST (+ XB1 L4P)(- YB1 L6P))

(LIST (+ XB1 L4P)(+ YB1 L6P))

(LIST (+ XB1 L2P)(+ YB1 L6P)) ""

)

(SETQ PPP1 (ENTLAST) )

)

(COMMAND

"PLINE" (LIST (- XB1 L2P)(- YBl L6P))

(LIST (- XB1 L4P)(- YBl L6P))

(LIST (- XB1 L4P)(+ YBl L6P))

(LIST (- XB1 L2P)(+ YBl L6P))

(SETQ PPP2 (ENTLAST))

; Модернізація контуру горизонтальної проекції основи деталі.

(COMMAND "TRIM" PPPl ""

(LIST (+ XB1 L2P) (+ УВ1 (/ L6P 2.0))) "TRIM" PPP2 ""

(LIST (- XB1 L2P) (+ YB1 (/ L6P 2.0)))

Рис.2.10 Результат виконання функції OSN

Рис.2.11 Результат виконання функції FUN1

; Введення базової крапки 2, розташованою внизу в центрі фронтальної ; проекції, з об'єктною прив'язкою Intersection (Перетин)

(COMMAND "OSNAP" "Int")

(SETQ BP2 (GETPOINT "\nEnter base point 2 :"}

XB2 (CAR BP2)

;Обчислення координатYB2 (CADR BP2);--базової точки 2.

; Ввід параметрів проточки на фронтальної проекції.

; Використовується ефект "гумової нитки" від базової точки 2

(COMMAND "OSNAP" "Perpend")

(SETQ L3 (GETDIST BP2 "\nEnter L3 :") )

; Формування проточки на фронтальній проекції.

(COMMAND "OSNAP" "None"

"LINE" (LIST (+ XB2 L4P) YB2 }

(LIST (+ XB2 L4P) (+ YB2 L3 }} ""

; Команда запускається з командної строки AutoCAD вказанням

; її ім'я - FUN1.

3. СЕРЕДОВИЩЕ ПРОЕКТУВАННЯ VISUAL LISP

Середовище Visual LISP введене в систему AUTOCAD для спрощення процесу написання і відладки програм на мові AUTOLISP. На рис. 3.1 показано діалогове вікно Visual LISP для AUTOCAD (Visual LISP for AUTOCAD), яке з'являється на екрані, якщо користувач вводить в командному рядку команду VLISP (таке ж найменування застосовується і в англомовній версії AUTOCAD). Іншою формою цієї команди є VLIDE. До аналогічного результату приводить використання пункту AUTOLISP, редактор Visual LISP (Visual LISP Editor) падаючого меню Сервіс (Tools).

Діалогове вікно Visual LISP для AUTOCAD (Visual LISP for AUTOCAD) є самостійною оболонкою усередині системи AUTOCAD, з своїми падаючими меню і панелями інструментів. Панелі інструментів можуть знаходитися не тільки у фіксованому положенні (див. рис. 3.1), але і в плаваючому (див. рис. 3.2).

Усередині робочої зони розташовуються вікна для відкритих текстових файлів (можуть редагуватися файли LISP-програм, DCL-файли діалогових вікон, SQL-файли операцій з базами даних, файли програм на мові С), вікно Консоль Visual LISP (Visual LISP Console) (використовується для зв'язку з системою AUTOCAD), вікно Трасування (Trace) (використовується для відладки програм).

3.1 Огляд пунктів головного меню

До складу середовища Visual LISP входять дев'ять падаючих меню: Файл (File), Правка (Edit), Пошук (Search), Вигляд (View), Проект (Project), Відладка (Debug), Сервіс (Tools), Вікно (Window), Довідка (Help). У всіх падаючих меню є і постійні пункти, і пункти, які міняють свій стан або зникають залежно від конкретного етапу розробки програми.

Меню Правка (Edit) (рис. 3.4) містить наступні пункти:

· Відмінити (Undo)

· Повторити (Redo)

· Вирізати (Cut)

· Копіювати (Copy)

· Вставити (Paste)

· Видалити (Delete)

· Виділити все (Select All)

· Перевірка дужок (Parantheses Matching)

· Додаткові функції (Extra Commands)

Перші сім пунктів меню відповідають аналогічним пунктам меню Правка (Edit) інших додатків Windows. Пункт Перевірка дужок (Parantheses Matching) містить підпункти операцій для контролю редагованого тексту:

· Знайти закриваючу (Match Forward)

· Знайти відкриваючу (Match Backward)

· Виділити до кінця (Select Forward)

· Виділити до початку (Select Backward)

Два перші підпункти дозволяють знаходити в тексті що парну закриває або парну відкриває дужки для дужки, що знаходиться у поточної позиції курсора. Два останні підпункти виконують аналогічні операції, але при цьому ще і виділяють потрібні ділянки тексту.

Меню Пошук (Search) (рис. 3.5) призначено для операцій текстового редактора Visual LISP (зокрема, операцій пошуку і заміни). Пояснимо призначення деяких з цих пунктів (сенс решти пунктів ясний з найменувань). Пункт Дописати словом з вікна (Complete Word by Match) дає можливість редакторові Visual LISP дописати (закінчити) почате вами слово аналогічно попередньому слову з таким же початком в поточному вікні редагованої програми. Пункт Дописати словом із списку (Complete Word by Apropos) дозволяє отримувати варіанти дописування слова із списку символів AUTOLISP, куди входять імена вбудованих функцій (рис. 3.6).

За допомогою закладок можна позначати потрібні місця в тексті для швидкого переміщення між ними надалі. Операції установки, видалення закладок і переходів між закладками виконуються за допомогою підпунктів Закладка Вкл / Викл (Toggle Bookmark), Наступна закладка (Next Bookmark), Попередня закладка (Previous Bookmark), Прибрати всі закладки (Clear All Bookmarks) пункту Закладки (Bookmarks). Ще два підпункти - Виділити до наступної закладки (Select to Next Bookmark) і Виділити до попередньої закладки (Select to Previous Bookmark) - того ж пункту меню дозволяють полегшити операції виділення великих ділянок тексту.

Падаюче меню Вигляд (View) (див. рис. 3.7) призначено для операцій проглядання різної допоміжної інформації під час роботи L1SP-программы, а також для роботи з панелями інструментів діалогового вікна Visual LISP для AutoCAD (Visual LISP for AutoCAD).

Пункт Вивчити (Inspect) дозволяє викликати спеціальні вікна Вивчення (Inspect), в яких можна подивитися стан змінних, списків, наборовши, примітивів, а також виразів AUTOLISP. Ім'я об'єкту, що вивчається, або вираз повинні бути заздалегідь виділені в тексті програми; якщо нічого не було виділено, то перед відкриттям чергового вікна Вивчення (Inspect) видається запит імені. Пункт Стек трасування (Trace Stack) виводить на екран однойменне вікно. У цьому вікні приводиться перелік останніх виконаних операцій (рис. 3.8).

У верхній частині вікна розташовані кнопки:

· Освіжити (Refresh) -- очищує вміст вікна;

· Копіювати у вікно трассировки/журнал (Copy to Trace/Log) - копіює текст в спеціальне вікно Трасування (Trace).

Якщо у вікні Стек трасування (Trace Stack) виділити який-небудь рядок, то за допомогою правої кнопки миші можна викликати контекстне меню з дополні-тельнимі операціями над елементами стека трасування (об'єм контекстного ме-ню може мінятися): Вивчити (Inspect), Друк (Print), Символ функції (Function Symbol), Копіювати (Copy), Локальні змінні (Local Variables), Положення в тексті (Source Position), Позиція виклику функції (Call Point Source).

Пункт Пошук помилок (Error Trace) падаючого меню Вигляд (View) викликає однойменне вікно з інформацією про помилки, що виникли при виконанні програми.

Якщо виділити в цьому вікні рядок, то натисненням правої кнопки миші можна викликати контекстне меню для отримання додаткових відомостей про елемент вікна Пошук помилок (Error Trace). Контекстне меню має ті ж пункти, що і контекстне меню вікна Стек трасування (Trace Stack). На мал. 3.9 показаний приклад додаткового вікна, викликаного за допомогою пункту Показати повідомлення (Show Message), яке з'являється в контекстному меню для рядка SYNTAX-ERROR.

Пункт Інспектор символів (Symbol Service) падаючого меню Вигляд (View) відкриває однойменне вікно, яке виконує функції, схожі на функції вікна Вивчення (Inspect), але тільки для символів AUTOLISP.

Вікно має три поля: Ім'я (Name), Значення (Value) і Прапори (Flags). Призначення перших два полий очевидно (ім'я символу і значення символу), а поле Прапори (Flags) містить чотири прапорці, які можуть бути встановлені або скинуті для вибраного символу:

· Трасування (Trace) - відстежування за допомогою трасування;

· Відладка на вході (Debug on Entry) - відладка при вході у функцію;

· Захист від присвоєння (Protect Assign) - захист спеціальних символів від випадкового привласнення (наприклад, т, pi і ін.);

· Експорт в AUTOCAD (Export to AUTOCAD) - експорт функції в AUTOCAD, щоб зробити її доступною для додатків OBJECTARX.

Вікно Інспектор символів (Symbol Service) у верхній частині має чотири кнопки (зліва направо):

· Контрольне значення (Watch) - добавляє символ до вікна Контрольне значення (Watch);

· Вивчить (Inspect) - відкриває вікно Вивчення (Inspect) для даного символу;

· Показати опис (Show Definition) - викликає вікно текстового редактора і виділяє в нім текст символу, що є призначеною для користувача функцією;

· Довідка (Help) - викликає довідку по Visual LISP з описом символу, що є вбудованою функцією.

Пункт Вікно контрольних значень (Watch Window) падаючого меню Вигляд (View) виводить на екран вікно Контрольне значення (Watch). Вікно відображує значення вибраних символів в ході виконання програми. Додавання символів до цього вікна проводиться або за допомогою вікна Інспектор символів (Symbol Service) (кнопкою Контрольне значення (Watch)), або за допомогою першої (лівою) з чотирьох кнопок (Додати контрольне значення (Add Watch)), розташованих у верхній частині вікна Контрольне значення (Watch). Перерахуємо ці кнопки:

· Додати контрольне значення (Add Watch)

· Очистити вікно (Clear Window)

· Сортувати вираз (Sort Expressions)

· Копіювати у вікно трасировки/журнал (Сору to Trace/Log)

Пункт Параметри довідкового списку (Apropos Window) падаючого меню Вигляд (View) виводить на екран вікно Параметри довідкового списку (Apropos).

Дане вікно дозволяє переглядати список зарезервованих символів (насамперед, імен вбудованих функцій). Введена у верхньому полі послідовність букв є основним критерієм формування списку імен, що виводяться (ці букви мають бути обов'язково присутніми в іменах всіх символів списку). Користувач може за допомогою прапорців вказати, чи повинна ця послідовність обов'язково бути присутнім на початку імені або може встре-тіться в іншій частині символу, а також чи можливе використання спеціальних знаків типа "*" або "#", як у функції wcmatch.

Пункт Вікно точок останову (Breakpoints Window) падаючого меню Вигляд (View) відкриває вікно Точки останову (Breakpoints), використовуване у відладці програм. Пункт Вікно виводу (Output Window) дозволяє відкрити вікно <Повідомлення збірки> < Builder Ouput> для виведення повідомлень, що генеруються в процесі розробки додатків.

Пункт Консоль LISP (LISP Console) падаючого меню Вигляд (View) викликає дуже важливе вікно, зване Консоль Visual LISP (Visual LISP Console) (рис. 2.19), яке в середі Visual LISP є аналогом зони командних рядків системи AUTOCAD. У нім можна вводити вирази AUTOLISP, завантажувати і виконувати функції, а також читати значення змінних. Сюди ж Visual LISP виводить свої повідомлення.

Пункт Огляд бази даних малюнка (Browse Drawing Database) падаючого меню Вигляд (View) має підпункти Всі об'єкти (Browse All Entities), Таблиці (Browse Tables), Блоки (Browse Blocks), Набір (Browse Selection) і Розширені дані (Inquire Extended Data...), при виборі яких викликаються відповідні вікна для перегляду бази даних графічних примітивів і неграфічеських об'єктів поточного малюнка (рис.3.11).

Пункт Панелі інструментів (Toolbars) падаючого меню Вигляд (View) викликає діалогове вікно Панелі інструментів (Toolbars) (рис. 3.12), яке управляє видимістю п'яти панелей середи Visual LISP.

Прапорці цього вікна мають бути встановлені біля імен тих з п'яти панелей (Стандартна (Standard), Пошук (Search), Сервіс (Tools), Відладка (Debug), Вигляд (View)), які необхідно вивести на екран. Зміни вносяться за допомогою кнопок Приховати все (Hide All), Показати все (Show All), Застосувати (Apply). Кнопка Закрити (Close) закриває діалогове вікно Панелі інструментів (Toolbars).

Падаюче меню Проект (Project) дає можливість працювати з проектами. Проект - це об'єднання групи Lisp-программ в додаток, що працює в середі системи AUTOCAD і компілює в один файл з розширенням fas (можливий варіант, коли кожною з програм створюється свій Fas-файл, хоча це менш зручно). Меню Проект (Project) має наступні пункти:

· Новий проект (New Project)

· Відкрити проект (Open Project)

· Закрити проект (Close Project)

· Властивості проекту (Project Properties)

· Завантажити Fas-файл проекту (Load Project FAS File)

· Завантажити початкові файли проекту (Load Project Source Files)

· Зібрати Fas-файл проекту (Build Project FAS)

· Перекомпілювати Fas-файл проекту (Rebuild Project FAS)

Останні (додаткові) рядки в меню показують імена відкритих проектів. Активний проект помічений прапорцем. Падаюче меню Відладка (Debug) (рис. 3.13) дозволяє відладжувати програми в середі Visual LISP.

Падаюче меню Сервіс (Tools) (рис. 3.15) призначено для допоміжних операцій.

Підпункт Кольору синтаксичних елементів (Syntax Coloring) доступний лише в тому випадку, якщо в активному вікні знаходиться текст файлу, що має розширення, відмінне від Isp. Тоді викликається вікно Колірний стиль (Color Style) (на рис. 3.16 показано вікно, відкрите при роботі з Dcl-файлом), в якому можна вибрати колірну гамму текстового редактора, що відповідає одному з пропонованих варіантів.

Підпункт Набудувати поточне (Configure Current) відкриває вікно Оформлення вікна (Window Attributes) (рис. 3.17), в якому можна підкоригувати колірні установки різних елементів тексту, що діють. Елементи, що оформляються, перераховані в списку, що розкривається.

Підпункт Оформлення поточного вікна по прототипу (Set Current Window to Prototype) міняє установки активного вікна на установки прототипу, а підпункт Оформлення всіх вікон по прототипу (Set All Windows to Prototype) виконує ту ж операцію над всіма вікнами.

Підпункт Шрифти (Fonts) викликає стандартне діалогове вікно Вибір шрифту (Select Font) (рис. 2.27) для вибору використовуваних у вікнах шрифтів. Пункт Параметри середи (Environment Options) падаючого меню Сервіс (Tools) має три підпункти:

· Спільні параметри (General Options)

· Параметри форматування Visual LISP (Visual LISP Format Options)

· Параметри розмітки сторінки (Page Setup Options)

Підпункт Спільні параметри (General Options) викликає діалогове вікно Спільні параметри (General Options), що має вкладки Спільна (General) і Діагностична (Diagnostic), дозволяюча міняти різні налаштування середа Visual LISP. Підпункт Параметри форматування Visual LISP (Visual LISP Format Options) розкриває діалогове вікно Опції форматування (Format options), що управляє установками форматування для текстового редактора Visual LISP. Третій підпункт - Параметри розмітки сторінки (Page Setup Options) пункту Параметри середи (Environment Options) викликає діалогове вікно Параметри (Page Setup (рис.3.19) для операцій виведення текстів на друк з середи Visual LISP.

Пункт Зберегти параметри (Save Settings) падаючого меню Сервіс (Tools) дозволяє зберігати налаштування робочого столу Visual LISP (останні відкриті вікна, їх параметри і т. п.). Падаюче меню Вікно (Window) по структурі аналогічно меню з аналогічним найменуванням інших додатків Windows.

3.2 Огляд панелей інструментів

У оболонку Visual LISP входять п'ять панелей інструментів:

* Стандартна (Standard)

* Пошук (Search)

* Сервіс (Tools) (у плаваючому положенні вона називається Інструменти (Tools))

* Відладка (Debug)

* Вигляд (View)

Як видно з даного переліку, найменування панелей схожі на найменування падаючих меню, що розгледіли вище. Призначення панелей також аналогічно призначенню відповідних падаючих меню.

У панель інструментів Стандартна (Standard) (рис. 3.22) входять наступні кнопки (зліва направо):

· Новий файл (New file)

· Відкрити файл (Open file)

· Зберегти файл (Save file)

· Друк (Print)

· Вирізувати (Cut)

· Копіювати (Сміттю)

· Вставити (Paste)

· Відмінити (Undo)

· Повторити (Redo)

· Дописати слово (Complete word)

Дев'ять перших кнопок цієї панелі аналогічні однойменним кнопкам панелі інструментів Стандартна (Standard) системи AUTOCAD. Остання кнопка Дописати слово (Complete word) відповідає пункту Дописати словом із списку (Complete Word by Apropos) падаючого меню Пошук (Search), що дозволяє закінчити почате слово елементом списку стандартних символів. Панель інструментів.

Пошук (Search) (рис. 3.23) виконує функції, аналогічні функціям падаючого меню Пошук (Search).

У неї входять сім наступних кнопок:

*Знайти (Find)

*Замінити (Replace)

*Пошук рядка на панелі інструментів (Find toolbar string)

*Закладка Вкл/Откл (Toggle bookmark)

*Наступна закладка (Next bookmark)

*Попередня закладка (Previous bookmark)

*Видалення всіх закладок (Clear all bookmarks)

Призначення всіх цих кнопок, окрім третьої, аналогічно призначенню відповідних пунктів і підпунктів падаючого меню Пошук (Search). Кнопка Пошук рядки на панелі інструментів (Find toolbar string) працює разом із списком, що розкривається, знаходиться в панелі інструментів Пошук (Search) і виконує пошук символу, ім'я якого вибране в цьому списку або введене в список з клавіатури.

Панель інструментів Сервіс (Tools) (рис. 3.24) має дев'ять наступних кнопок:

*Завантаження активного вікна редагування (Load active edit window)

*Завантаження виділеного фрагмента (Load selection)

*Перевірка вмісту вікна редактора (Check edit window)

*Перевірка виділеного фрагмента (Check selection)

*Форматування вмісту вікна редагування (Format edit window)

*Форматування виділеного фрагмента (Format selection)

*Закоментувати блок (Comment block)

*Раськомментіровать блок (Uncomment block)

*Довідка (Help)

Перші шість пунктів панелі аналогічні першим шести пунктам падаючого меню Сервіс (Tools), якщо користувач за допомогою редактора працює з текстом програми або її фрагментом.

Кнопки Закоментувати блок (Comment block) і Раськомментувати блок (Uncomment block) дозволяють легко вставляти (за допомогою крапок з комою) або знімати коментарі у виділених рядках тексту програми. Пункт Довідка (Help) служить для отримання довідкової інформації.

Панель інструментів Відладка (Debug) (рис. 3.25) має наступні кнопки:

*Крок із заходом (Step into)

*Крок з обходом (Step over)

*Крок з виходом (Step out)

*Продовжити (Continue)

*Вийти (Quit)

*Скидання (Reset)

*Точка останову Вкл/Откл (Toggle breakpoint)

*Додати контрольне значення (Add watch)

*Останній останов (Last break)

Крім того, в процесі виконання програми в налагоджувальному режимі, з точками остановов, в панелі з'являється остання кнопка. Кнопка показує, де знаходиться курсор під час поточного останову (перед дужками або після).

У панель інструментів Вигляд (View) (рис. 3.26) входять наступні кнопки:

· Активізація AUTOCAD (Activate AUTOCAD)

· Вибрати вікно (Select window)

· Консоль Visual LISP (Visual LISP Console)

· Вивчити (Inspect)

· Трасування (Trace)

· Вікно відладки символів (Symbol service)

· Довідковий список (Apropos)

· Вікно контрольних значень (Watch window)

Найменування кнопок говорять про те, що вони виконують операції, закріплені за розглянутими вище різними пунктами падаючих меню: Режим AUTOCAD (AUTOCAD Mode) меню Сервіс (Tools), вибір вікна за допомогою списку вікон меню Вікно (Window), Консоль LISP (LISP Console) меню Вигляд (View), Вивчити (Inspect) меню Вигляд (View), Стек трасування (Trace Stack) меню Вигляд (View), Інспектор символів (Symbol Service) меню Вигляд (View), Параметри довідкового списку (Apropos Window) меню Вигляд (View), Вікно контрольних зна-ченій (Watch Window) меню Вигляд (View).

2.3 Написання програм в текстовому редакторові середовища Visual LISP

У середовищі Visual LISP можна відкривати в своєму вікні і редагувати текстові файли наступних типів: LISP-програм (з розширенням Isp), DCL-фаилы діалогових вікон (з розширенням del), SQL-файли операцій з базами даних (з розширенням sql), файли програм на мові C++ (з розширенням з). Включений до складу середовища текстовий редактор надає істотну допомогу в написанні файлів цих типів, оскільки вже в процесі введення тексту виконує синтаксичний аналіз, виділяючи символи, відповідні дужкам, операторам, операндам, коментарям і т.д. Результати свого синтаксичного аналізу редактор відображає кольором букв набраного тексту. Вибір настройки редактора відповідно до типу файлу можна зробити за допомогою пункту Оформлення вікна (Window Attributes), Кольори синтаксичних елементів (Syntax Coloring) падаючого меню Сервіс (Tools). За умовчанням редактор налаштований на роботу з текстами LISP-програм.

Кольорова гамма, зазвичай використовувана для синтаксичного аналізу програм на мові LISP, наступна:

· синій - зарезервовані символи AUTOLISP (імена вбудованих функцій і т. п.);

· фіолетовий - текстові рядки, обрамлені подвійними лапками;

· зелений - цілі і речовинні числа;

· фіолетовий (на сірому фоні) - коментарі;

· червоний - відкриваючі і закриваючі дужки;

· чорний - інші символи (змінні користувача і ін.).

За бажання можна внести зміни до колірної палітри за допомогою пункту Оформлення вікна (Window Attributes), Набудувати поточне (Configure Current) падаючого меню Сервіс (Tools). Пункт Параметри середовища (Environment Options) падаючого меню Сервіс (Tools) теж може допомогти у встановленні великої кількості зручностей для конкретного користувача. Незамінним засобом швидкого коментування виділеної ділянки тексту і зняття коментарів є кнопки Закоментувати блок (Comment block) і Разкоментувати блок (Uncomment block) панелі інструментів Сервіс (Tools). Синтаксична перевірка тексту всього відкритого файлу або виділеного фрагмента може бути виконана за допомогою пунктів Перевірити виділений фрагмент (Check Selection) і Перевірити текст в редакторові (Check Text in Editor) падаючого меню Сервіс (Tools) або аналогічних кнопок в панелі Сервіс (Tools). Для перевірки відповідності закриваючих і відкриваючих дужок добре користуватися пунктом Перевірка дужок (Parantheses Matching) падаючего меню Правка (Edit).

За бажання можна внести зміни до колірної палітри за допомогою пункту Оформлення вікна (Window Attributes), Набудувати поточне (Configure Current) При перезаписі файлу з розширенням lsp Visual LISP створює копію попереднього стану файлу (копії привласнюється розширення _ls).

4. ОПИС ПРОГРАМНОЇ РЕАЛІЗАЦІЇ ОБ'ЄКТНО-ОРІЄНТОВАНОЇ НАДБУДОВИ


Подобные документы

  • Підстава для створення системи Компас-3D. Характеристика розробленого програмного забезпечення. Призначення і характеристики систем автоматизації конструкторської документації. Дослідження методів створення динамічних бібліотек в середовищі Delphi.

    дипломная работа [3,3 M], добавлен 22.10.2012

  • Проблеми розробки компонентного програмного забезпечення автоматизованих систем управління. Сучасні компонентні технології обробки інформації. Аналіз вибраного середовища проектування програмного забезпечення: мова програмування PHP та Apache HTTP-сервер.

    дипломная работа [2,8 M], добавлен 11.05.2012

  • Цілі та головні задачі систем метаданих, їх структура та елементи, опис словників та класифікаторів. Розробка логіко-функціональної схеми надбудови, її функціональне призначення. Економічне обґрунтування доцільності розробки програмного продукту.

    дипломная работа [1,7 M], добавлен 26.10.2012

  • Проектування і реалізація навчального програмного продукту "Побудова геометричних фігур". Використання C++ Builder 6 у якості програмного середовища для реалізації даної навчальної програми. Інструкція з використання розробленого програмного забезпечення.

    курсовая работа [2,2 M], добавлен 05.05.2014

  • Основні завдання синоптичної метеорології. Призначення та область застосування програмного продукту "Статистика метеоспостережень", функціональні вимоги до нього. Інформаційне забезпечення, структура, опис інтерфейсу. Тестування програмного продукту.

    курсовая работа [3,6 M], добавлен 30.04.2016

  • Характеристика об’єкта автоматизації, вимоги до системи, склад та зміст системи. Розробка функціональної схеми програмного продукту. Тестування підпрограми програмного продукту. Розробка бази даних та налаштування ECO компонент в Borland Developer Studio.

    практическая работа [1,8 M], добавлен 05.06.2014

  • Приклади рішень від провідних компаній-розробників, що працюють у сфері автоматизації роботи з документами. Основні можливості систем електронного документообігу. Вибір програмного забезпечення для створення програмного продукту. Опис програмної системи.

    курсовая работа [45,8 K], добавлен 06.06.2011

Работы в архивах красиво оформлены согласно требованиям ВУЗов и содержат рисунки, диаграммы, формулы и т.д.
PPT, PPTX и PDF-файлы представлены только в архивах.
Рекомендуем скачать работу.